Jump to content

[1.3.1 - 1.12.x] Outer Planets Mod [v2.2.10] [3rd Jan 2022]


Poodmund
 Share

Recommended Posts

2 hours ago, OhioBob said:

You should be able to add in OPM at any time without it disrupting anything you were doing in the stock system.  The only exception is Eeloo, which OPM moves.  So it you have a spacecraft in route to Eeloo, it will be headed to nowhere once OPM is installed.

 

Link to comment
Share on other sites

9 hours ago, OhioBob said:

You should be able to add in OPM at any time without it disrupting anything you were doing in the stock system.  The only exception is Eeloo, which OPM moves.  So it you have a spacecraft in route to Eeloo, it will be headed to nowhere once OPM is installed.

I tested it and all the planets show up fine, I used Alt+F12 to explore them a bit. But whenever I go back to the space center, the screen is all glitched out, only happens about 50% of the time though.

I only tried it on my sandbox save that I use for testing, I think the problem might be it.

Link to comment
Share on other sites

I don't understand it...why does having OPM installed, even all by itself, cause a massive lag spike/freeze when entering map view. In 1.6.x and before, there used to be a bit of a speed bump in loading, but not nearly as huge as now/1.7.x.

F12 log in 1.6 showed this right as entering map mode: imgur.com/hh0DIiQ.png

While in 1.7, it has quite a lot more to report (everything above the red line): imgur.com/SJP05d9.png 

Surely deleting all the biome maps isn't the only way to mend this issue

Sorry if already brought up, but i guess in my time away from KSP (again) the forums broke even more, taking down old posts with it, and the search function is still as garbage as ever

Link to comment
Share on other sites

2 hours ago, StickyScissors said:

I don't understand it...why does having OPM installed, even all by itself, cause a massive lag spike/freeze when entering map view. In 1.6.x and before, there used to be a bit of a speed bump in loading, but not nearly as huge as now/1.7.x.

 

 

Experiencing this issue now and narrowed it down to OPM. Perhaps Kopernicus issues?

 

This is about a 2 - 5 second freeze between scene transitions and renders the mod unusable for now at least for me, I switch between map view a lot and a 5 second freeze is just too much.

Link to comment
Share on other sites

Kopernicus changed the way it deals with (some) textures in the more recent releases which I would guess it causing the difference in behaviour. 

I would go to the Kopernicus thread and see if there is discussion about this issue there, and if not, raise an issue about it.

Link to comment
Share on other sites

8 hours ago, StickyScissors said:

I don't understand it...why does having OPM installed, even all by itself, cause a massive lag spike/freeze when entering map view. In 1.6.x and before, there used to be a bit of a speed bump in loading, but not nearly as huge as now/1.7.x.

Try this...  Find the file OPM_KopernicusSetting.cfg and edit it by adding the line shown in red below.  This solved a lag problem in JNSQ.  Might not work for OPM but it's worth a try.

@Kopernicus:FOR[OPM]
{
    useManualMemoryManagement = True
    useOnDemandBiomes = False
}

Edited by OhioBob
Link to comment
Share on other sites

5 hours ago, OhioBob said:

Try this...  Find the file OPM_KopernicusSetting.cfg and edit it by adding the line shown in red below.  This solved a lag problem in JNSQ.  Might not work for OPM but it's worth a try.

@Kopernicus:FOR[OPM]
{
    useManualMemoryManagement = True
    useOnDemandBiomes = False
}

This works! 

 

You have just given me so much happiness in one forum post 

Link to comment
Share on other sites

Spoiler

{
            "name": "KerbalEngineerRedux"
        },
        {
            "name": "KerbalJointReinforcementNext"
        },
        {
            "name": "KerbalAlarmClock"
        },
        {
            "name": "StageRecovery"
        },
        {
            "name": "Toolbar"
        },
        {
            "name": "ToolbarController"
        },
        {
            "name": "ClickThroughBlocker"
        },
        {
            "name": "DMagicOrbitalScience"
        },
        {
            "name": "ContractRewardModifier"
        },
        {
            "name": "OuterPlanetsMod"
        },
        {
            "name": "UniversalStorage2"
        },
        {
            "name": "ScienceAlert"
        },
        {
            "name": "SCANsat"
        },
        {
            "name": "CommunityTechTree"
        },
        {
            "name": "ModuleManager"
        },
        {
            "name": "Kopernicus"
        },
        {
            "name": "ModularFlightIntegrator"
        },
        {
            "name": "CommunityTerrainTexturePack"
        },
        {
            "name": "CommunityResourcePack"
        },
        {
            "name": "KSPInterstellarExtended"
        },
        {
            "name": "PatchManager"
        },
        {
            "name": "InterstellarFuelSwitch"
        },
        {
            "name": "BetterBurnTime"
        },
        {
            "name": "HideEmptyTechNodes"
        },
        {
            "name": "HeatControl"
        },
        {
            "name": "TexturesUnlimited"
        },
        {
            "name": "InterstellarFuelSwitch-Core"
        },
        {
            "name": "TweakScale"
        },
        {
            "name": "DistantObject"
        },
        {
            "name": "DistantObject-default"
        },
        {
            "name": "Strategia"
        },
        {
            "name": "CustomBarnKit"
        },
        {
            "name": "ContractConfigurator"
        },
        {
            "name": "WaypointManager"
        },
        {
            "name": "StockVisualEnhancements"
        },
        {
            "name": "Scatterer"
        },
        {
            "name": "SVE-LowResolution"
        },
        {
            "name": "KabramsSunFlaresPack-White-Low"
        },
        {
            "name": "EnvironmentalVisualEnhancements"
        },
        {
            "name": "Scatterer-config"
        },
        {
            "name": "RemoteTech"
        },
        {
            "name": "Chatterer"
        },
        {
            "name": "ProceduralFairings"
        },
        {
            "name": "ProceduralFairings-ForEverything"
        },
        {
            "name": "ContractsWindowPlus"
        },
        {
            "name": "CapCom"
        },
        {
            "name": "ProgressParser"
        },
        {
            "name": "ContractParser"
        },
        {
            "name": "FinalFrontier"
        },
        {
            "name": "RealPlume"
        },
        {
            "name": "RealPlume-StockConfigs"
        },
        {
            "name": "SmokeScreen"
        },
        {
            "name": "KSP-AVC"
        },
        {
            "name": "RealChute"
        },
        {
            "name": "FerramAerospaceResearchContinued"
        },
        {
            "name": "InfernalRoboticsNext"
        },
        {
            "name": "KAS"
        },
        {
            "name": "KIS"
        },
        {
            "name": "EasyVesselSwitch"
        },
        {
            "name": "AmpYearPowerManager"
        },
        {
            "name": "REPOSoftTech-Agencies"
        },
        {
            "name": "USI-LS"
        },
        {
            "name": "USITools"
        },
        {
            "name": "CommunityCategoryKit"
        },
        {
            "name": "TransferWindowPlanner"
        },
        {
            "name": "TriggerAu-Flags"
        },
        {
            "name": "UKS"
        },
        {
            "name": "FirespitterCore"
        },
        {
            "name": "USI-Core"
        },
        {
            "name": "Konstruction"
        },
        {
            "name": "GroundConstruction-Core"
        },
        {
            "name": "AT-Utils"
        },
        {
            "name": "ConfigurableContainers-Core"
        },
        {
            "name": "CraftManager"
        },
        {
            "name": "KXAPI"
        },
        {
            "name": "ContractConfigurator-KerbinSpaceStation"
        },
        {
            "name": "ContractConfigurator-FieldResearch"
        },
        {
            "name": "ContractConfigurator-RemoteTech"
        },
        {
            "name": "ContractConfigurator-Tourism"
        },
        {
            "name": "KeepItStraight"
        },
        {
            "name": "ManeuverNodeEvolved"
        },
        {
            "name": "TrackingStationEvolved"
        },
        {
            "name": "TacFuelBalancer"
        }

2 hours ago, Poodmund said:

@scottadges, @StickyScissors and @Velve666, were any of you using any other mods that interact with Kopernicus at all? i.e. Planet Packs, Terrain mods etc.

The issue is known but trying to isolate causation cases to identify the best solution.

Perhaps

See spoiler ^

Edited by Velve666
Link to comment
Share on other sites

I came here looking for help with the map mode lag issue.  Very happy to report that OhioBob's suggested fix seems to work perfectly!  If it helps diagnose the issue at all, I am using no other mods besides those required to install OPM.  I'd be happy to provide any additional debug information that would be helpful, just let me know if there's anything I can collect.

Link to comment
Share on other sites

5 hours ago, Poodmund said:

were any of you using any other mods that interact with Kopernicus at all? i.e. Planet Packs, Terrain mods etc.

The issue is known but trying to isolate causation cases to identify the best solution.

The only thing I was using was OPM. Otherwise, I use Realistic Atmospheres along with Astronomer's Visual Pack. And PlanetShine, Scatterer, TextureReplacer. Trying to think of any other graphics-related mods that I have in my modlist. (I honestly don't know if any of those other ones interact with Kopernicus.)

Let me know if there's anything else I can help with the troubleshooting! Thanks for all your awesome work on the mod!

Edited by scottadges
Link to comment
Share on other sites

Thanks for the info guys. I tested this myself too and confirmed even with OPM's .dds biome maps the delay was still occurring. For the time being, if you want to remove that few seconds of delay when entering map mode please use the band-aid config patch as discussed previously on this page but in time, if/when a new version of Kopernicus is released this issue will resolve itself as Thomas P has reverted the default behaviour of the OnDemand biome loading: https://github.com/Kopernicus/Kopernicus/commit/449bad8920c0ff5f523354ddb34ca5bc949e5bd9

Thanks for your interest and help in this. :D

Link to comment
Share on other sites

  • 2 weeks later...

If there's a better place to ask this please direct me there. Now, to the root of my question-

I'm looking for asteroid moonlets around Neidon. This is kind of important because I accepted contracts to bring D and E asteroids into orbit there and I reasoned I could be clever and find them already orbiting the planet before sending a little probe to dock with them. I assumed they would be there because every other gas giant has asteroid moonlets that show up in the tracking station. I was really counting on this behavior!

Things I think are important- I have a probe around Neidon and I do not have CustomAsteroids installed, but that doesn't seem to matter because other gas gaints have moonlets for god's sake.

I actually do see unknown objects pop up from time to time but they appear directly over my probe's icon and vanish instantly. This might be a bug.

What would you advise?

Edited by darwinpatrick
Link to comment
Share on other sites

I would also like to report that the usage of "useOnDemandBiomes = False" usage has fixed my issue completely. I also narrowed the issue down to OPM (having excess of 40 mods was a pain and time consuming).

Thank you for providing a solution to this problem I have been having for several days.

FV -

 

Note - I don't follow the forums much; don't expect a reply.

On 9/25/2019 at 7:27 AM, OhioBob said:

Try this...  Find the file OPM_KopernicusSetting.cfg and edit it by adding the line shown in red below.  This solved a lag problem in JNSQ.  Might not work for OPM but it's worth a try.

@Kopernicus:FOR[OPM]
{
    useManualMemoryManagement = True
    useOnDemandBiomes = False
}

Please see my above post.

Link to comment
Share on other sites

I've been wanting to get into some heavily modded game play for awhile now, and this mod is the first one I went for.

I've installed this mod before, but ages ago. When I install the mod now everything works, but I could never get the textures of things like the new moons to be right, and they all just turn into Moho clones.

With this (and all of its required prerequisites) being the only mods in my GameData folder,  I only managed to get the textures of the gas giants to be correct when I add in things like EVE and SVE.

There is probably something very simple I'm missing here, but my ape brain seems to not be able to figure it out so I am here now for help from people who know more about this lol 

(Should also note I've been trying to install this through ckan, which might be a factor)

eaa4ea48505a67b685f5db8fbccb4717.png

Edited by fantttt
Link to comment
Share on other sites

I have something developers might be interested to see. Look at the rotation periods for Plock and Karen.

U9qxFhs.png

ik4LGJM.png

Yes, they're one minute off. I actually noticed this on my mission, where I chose my Plock landing site such that Karen was on the horizon. I came back to it a while later (while it was mining) and discovered that Karen was gone. It had slowly slipped over the western horizon. So I checked in the tracking station and came up with this. Does Plock intentionally rotate 0.05% faster than Karen?

Link to comment
Share on other sites

On 10/16/2019 at 10:11 PM, fantttt said:

I've been wanting to get into some heavily modded game play for awhile now, and this mod is the first one I went for.

I've installed this mod before, but ages ago. When I install the mod now everything works, but I could never get the textures of things like the new moons to be right, and they all just turn into Moho clones.

With this (and all of its required prerequisites) being the only mods in my GameData folder,  I only managed to get the textures of the gas giants to be correct when I add in things like EVE and SVE.

There is probably something very simple I'm missing here, but my ape brain seems to not be able to figure it out so I am here now for help from people who know more about this lol 

(Should also note I've been trying to install this through ckan, which might be a factor)

eaa4ea48505a67b685f5db8fbccb4717.png

You should have the CTTP file in your GameData. You can download it manually somewhere around these forums, I think.

Link to comment
Share on other sites

  • 3 weeks later...
3 hours ago, jbarry39 said:

Any G2 as to 1.8.x Compatibility?

A peek at the Restock thread may give a clue as to why this one might not have an immediate update ;) -- also, waiting on Kopernicus to be brought up to 1.8* spec.

Edited by Beetlecat
Link to comment
Share on other sites

@Poodmund, I installed the Custom Barn Kit for my existing career with OPM installed to get that 4th level of Tracking Station, but I still cannot upgrade. I checked the Custom Barn Kit config, and it doesn't seem to have the 4th level for Tracking Station. Was this feature removed? What should I do? I am using KSP 1.7.2, and all the mods are updated for that version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...