St4rdust

KSP Loading... Preview: Breaking Ground - Robotics - KAL-1000 Controller

Recommended Posts

Posted (edited)

I wonder if they could make SAS work If they allowed us to bind parts to pitch/roll/yaw directly?

EDIT: Wait it looks like you CAN do that in the action groups. Too bad you can’t enable/disable SAS via a checkbox if you wanted. 

Edited by MechBFP

Share this post


Link to post
Share on other sites
Posted (edited)

I've managed to build up a Prometheus style of ship using the Servos and the KAL-1000 system. While the editor works flawlessly in the VAB / SPH, once on the tarmac only the 1st field actuates. (Can ping-pong the play loop and see it)

The other fields that are "attached" don't appear to move despite working correctly before launch. Being that this is a NEW feature, I am not sure if this is a bug or just something I've missed.

Please be aware that just like the Prometheus, the motor-mount "arms" rotate and the attached engines pods rotate separately but simultaneously. This allows the engines to be vectored, going from VTOL to SSTO. There are two arms (one on either side of the ship) with two pods per cross arm.

 

Any help or advice is welcome!

Cheers!

-Redacted

Edited by Redacted

Share this post


Link to post
Share on other sites
Posted (edited)

Thus far all the variants i have tried fail to function on the Tarmac but work great in the VAB. I have even removed the "Arms" to mount the pods directly to the fuselage when no change in performance.

Have even tried using the typical twin engine setup and the Servos don't respond outside the editor.

Looks like the hope of having a viable VTOL or some form of vector control with these things is dead.

Edited by Redacted

Share this post


Link to post
Share on other sites
2 hours ago, Redacted said:

Thus far all the variants i have tried fail to function on the Tarmac but work great in the VAB. I have even removed the "Arms" to mount the pods directly to the fuselage when no change in performance.

Have even tried using the typical twin engine setup and the Servos don't respond outside the editor.

Looks like the hope of having a viable VTOL or some form of vector control with these things is dead.

Are you using KerbalJointReinforcement?

Share this post


Link to post
Share on other sites
Posted (edited)

No

 


    "kind": "metapackage",
    "abstract": "A list of modules installed on the auto KSP instance",
    "name": "installed-auto",
    "license": "unknown",
    "version": "2019.06.08.04.28.37",
    "identifier": "installed-auto",
    "spec_version": "v1.6",
    "recommends": [

            "name": "ModuleManager"
            "name": "CommunityTerrainTexturePack"
            "name": "TextureReplacer"
            "name": "PlanetWiki"
            "name": "Mk3Expansion"
            "name": "DMagicOrbitalScience"
            "name": "SCANsat"
            "name": "DynamicBatteryStorage"
            "name": "EasyVesselSwitch"
            "name": "ClickThroughBlocker"
            "name": "B9PartSwitch"
            "name": "KerbalEngineerRedux"
            "name": "DraggableNavball"
            "name": "AlcubierreStandalone"
            "name": "NearFutureSolar"
            "name": "StationPartsExpansionRedux"
            "name": "NearFutureSolar-Core"
            "name": "MarkIVSpaceplaneSystem"
            "name": "CryoTanks-Core"
            "name": "NearFutureLaunchVehicles"
            "name": "FlatBtmShtlSys"
            "name": "xScienceContinued"
            "name": "ModularFlightIntegrator"
            "name": "Astrogator"
            "name": "RasterPropMonitor"
            "name": "CommunityResourcePack"
            "name": "NearFutureProps"
            "name": "RasterPropMonitor-Core"
            "name": "BetterBurnTime"
            "name": "NearFuturePropulsion"
            "name": "NearFutureConstruction"
            "name": "PreciseNode"
            "name": "DistantObject"
            "name": "DistantObject-default"
            "name": "HideEmptyTechNodes"
            "name": "KIS"
            "name": "CommunityCategoryKit"
            "name": "CommunityTraitIcons"
            "name": "NearFutureElectrical"
            "name": "MemGraph"
            "name": "NearFutureSpacecraft"
            "name": "DeployableEngines"
            "name": "CommunityTechTree"
            "name": "BetterScienceLabsContinued"
            "name": "SpacetuxSA"
            "name": "BetterSRBs"
            "name": "KSP-AVC"
            "name": "NearFutureSpacecraft-OrbitalLFOEngines"
            "name": "MakingLessHistory"
            "name": "ScienceRelay"
            "name": "TrackingStationEvolved"
            "name": "PWBFuelBalancerRestored"
            "name": "DockingPortAlignmentIndicator"
            "name": "RealChute"
            "name": "HeatControl"
            "name": "PortraitStats"
            "name": "AblativeAirbrake"
            "name": "ToolbarController"
            "name": "AttitudeAdjuster"
            "name": "CryoEngines"
            "name": "Mk2Expansion"
            "name": "CryoTanks"
            "name": "PartOverhauls"
            "name": "BetterTimeWarpCont"
            "name": "KerbalAlarmClock"
            "name": "NearFutureElectrical-Core"
            "name": "TriggerAu-Flags"
            "name": "KerbalAtomics"
 

Edited by Redacted

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/8/2019 at 6:20 PM, HebaruSan said:

Are you using KerbalJointReinforcement?

Ok, figured out why... Auto struts between moving parts.

Removed the struts and the craft was able to fly. However it was rather poorly due to the limited strenght of the joints.

Looks like rotatable engine pods are a no go with the stresses of flight. Even the smallest change in the engine position,  due to aero-dynamic flex, can cause the entire ship to oscillate and explode.

Edited by Redacted

Share this post


Link to post
Share on other sites
1 hour ago, Redacted said:

Ok, figured out why... Auto struts between moving parts.

Removed the struts and the craft was able to fly. However it was rather poorly due to the limited strenght of the joints.

Looks like rotatable engine pods are a no go with the stresses of flight. Even the smallest change in the engine position,  due to aero-dynamic flex, can cause the entire ship to oscillate and explode.

I guess it'd be good to be able to toggle autostrut with action/axis groups. Then you'd be able to hit a button and autostruts would be automatically set/disabled, rather than having to click on every part and cycle through the autostrut settings to turn them off.

Maybe there's already a mod that does that? I don't know.

Share this post


Link to post
Share on other sites
2 hours ago, RealKerbal3x said:

I guess it'd be good to be able to toggle autostrut with action/axis groups. Then you'd be able to hit a button and autostruts would be automatically set/disabled, rather than having to click on every part and cycle through the autostrut settings to turn them off.

Maybe there's already a mod that does that? I don't know.

Problem comes during changes that are made during dynamic flight. Turning the struts On / Off could cause parts to shift position. This change will alter both the CG and the point of thrust in an unexpected or controllable way. (Boom)

Share this post


Link to post
Share on other sites

Oscillating and exploding craft... I had to deal with one of those last night in my attempt to learn how to use the new parts. I was trying to build an "Osprey" like craft.

I finally got things to work by not using any symmetry related functions on any of the servos and rotors I used. That also meant building each engine assembly individually instead of using Alt-LMB to copy stuff. And yes, no autostruts.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.