Jump to content

[1.12.1] JNSQ [0.10.0] [23 Sept 2021]


Galileo
 Share

Recommended Posts

17 minutes ago, RKunze said:

I am trying to install that combination through CKAN by choosing "JNSQ", (version 0.10.0), "Grannus Expansion Pack Rescale" (version 1.2.4) and "GPP Secondary" (version 1.6.6.0). But CKAN tells me JNSQ 0.10.0 conflicts with GPP secondary (or rather, with its depency "GPP") version 1.6.6.0. Also, I don't see any GPP rescale package on CKAN.

Is CKAN telling the truth here (if so, which version of GPP secondary is compatible with JNSQ 0.10.0?) or should I just install GPP secondary and GPP_rescale version 1.6.6.0 manually?

I don't know anything about how CKAN works, never used it.  I know that JNSQ 0.10.0, GPP 1.6.6.0, and GEP 1.2.4 are compatible, along with the optional mods that come with them.  If installed manually everything should work.  CKAN may not be set up correctly, or perhaps there's a bug in one of our mods that is preventing it from working.  Either way, it's beyond my current knowledge to fix.  I recommend you install manually whatever CKAN is not allowing you to install.

Link to comment
Share on other sites

The conflict with GPP is set here, maybe another member of the Galileo team can speak to whether it still applies:

EDIT: I think this is slowly coming back to me now. If I recall correctly, GPP and GEP are structured differently; GEP installs as secondary by default and requires a special "primary" patch to use it as the main solar system, whereas GPP installs as primary by default and requires a special "secondary" patch to use it as a secondary solar system. So GEP (without the patch) is intrinsically compatible with other solar systems, while GPP is not.

Edited by HebaruSan
Link to comment
Share on other sites

15 minutes ago, OhioBob said:

I know that JNSQ 0.10.0, GPP 1.6.6.0, and GEP 1.2.4 are compatible, along with the optional mods that come with them.  [...]  I recommend you install manually whatever CKAN is not allowing you to install.

Thanks, will do that.

Link to comment
Share on other sites

1 hour ago, HebaruSan said:

EDIT: I think this is slowly coming back to me now. If I recall correctly, GPP and GEP are structured differently; GEP installs as secondary by default and requires a special "primary" patch to use it as the main solar system, whereas GPP installs as primary by default and requires a special "secondary" patch to use it as a secondary solar system. So GEP (without the patch) is intrinsically compatible with other solar systems, while GPP is not.

What you describe is exactly true.  So it makes sense that JNSQ and GPP might show as incompatible.

Link to comment
Share on other sites

On 9/23/2021 at 6:34 PM, RyanRising said:

However, is it intentional that the extinctionThickness in scatterer configurations is set to 0? This means there are no sunset colours in the lighting or clouds.

Yes this was intentional when I created the cfgs. At the the time, that effect was not functioning correctly. I have not gone back to check recent scattered releases.

Link to comment
Share on other sites

On 9/23/2021 at 5:32 PM, OhioBob said:

We want to install all three planet packs sized to 2.5x scale.  Since JNSQ already exists at 2.5x, it does not require resizing.  However, GPP and GEP are both natively 1x, therefore we must install the 2.5x version of GPP_Rescale and GEP_Rescale to match the size of JNSQ.  We install the following mods:

JNSQ + GPP + GPP_Secondary + GPP_Rescale (2.5x) + GEP + GEP_Rescale (2.5x)

Ok, so going from this, if I want to add GPP to an existing JNSQ, I would do this:

GPP needs to install the 2.5x version of GPP_Rescale to match the size of JNSQ.  We install the following mods:

JNSQ + GPP + GPP_Secondary + GPP_Rescale (2.5x) 

I'm not sure about adding GEP yet, I assume that it can be added later?

And kudos to you, @Galileo and the rest of the team for this wonderful update

Link to comment
Share on other sites

37 minutes ago, Bombaatu said:

Yay, update! One thing, though - all of the icons for Strategia strategies are upside-down now...

@OhioBob I can confirm this.

IM8hKrw.png

Why this should be true is a complete mystery to me, but there it is. My game has roughly six thousand mods installed though, so I'm not sure how helpful I can be at troubleshooting.

Link to comment
Share on other sites

17 minutes ago, linuxgurugamer said:

Ok, so going from this, if I want to add GPP to an existing JNSQ, I would do this:

GPP needs to install the 2.5x version of GPP_Rescale to match the size of JNSQ.  We install the following mods:

JNSQ + GPP + GPP_Secondary + GPP_Rescale (2.5x) 

I'm not sure about adding GEP yet, I assume that it can be added later?

That's correct.  I noted that adding Rescale to an existing save is not recommended, but in this case you shouldn't have any problem since you're not changing the size of JNSQ.  And, yes, you should be able to add GEP at a later time, using GEP + GEP_Rescale (2.5x).

Link to comment
Share on other sites

@OhioBob

The CKAN stuff needs a bit of work.  GPP 1.6.6.0 is listed as not compatible with JNSQ.

Frankly, given the plethora of options you give, I have no idea how to deal with it, but @HebaruSan is the one to ask for help

2 minutes ago, OhioBob said:

That's correct.  I noted that adding Rescale to an existing save is not recommended, but in this case you shouldn't have any problem since you're not changing the size of JNSQ.  And, yes, you should be able to add GEP at a later time, using GEP + GEP_Rescale (2.5x).

Ok, and what about the GPP clouds, and GPP textures, are they needed as well?

Link to comment
Share on other sites

On 9/25/2021 at 11:36 AM, Bombaatu said:

Yay, update! One thing, though - all of the icons for Strategia strategies are upside-down now...

23 hours ago, jefferyharrell said:

Why this should be true is a complete mystery to me, but there it is. My game has roughly six thousand mods installed though, so I'm not sure how helpful I can be at troubleshooting.

LOL.  All the icons were converted from .dds to .png.  But .dds must be flipped vertically, while .png does not.  So whoever did the conversion apparently forgot to flip them.

23 hours ago, linuxgurugamer said:

The CKAN stuff needs a bit of work.  GPP 1.6.6.0 is listed as not compatible with JNSQ.

Frankly, given the plethora of options you give, I have no idea how to deal with it, but @HebaruSan is the one to ask for help

We know about the non-compatibility thing, though I'm not sure if there's a solution.  The problem is that both JNSQ and GPP are natively primary star systems that replace the stock system.  Thus, as far as CKAN is concerned, they can't co-exist with each other.  They are only compatible with the addition of GPP_Secondary.

When all the options were set up, I only considered manual installation.  Never gave any thought to CKAN because, quite honestly, I have no idea how it works.

Quote

Ok, and what about the GPP clouds, and GPP textures, are they needed as well?

Yes, those are needed as well.

Edited by OhioBob
Link to comment
Share on other sites

@Bombaatu, @jefferyharrell

Can either of you guys confirm for me whether the icons are flipped vertically, or rotated 180 degrees?  In other words, are the I, II and III markings suppose to be on the bottom-left or the bottom-right?

(edit)  Can one of you guys check these in game?  Just replace the ones in your install with the following.  They are located in the folder JNSQ/JNSQ_Textures/Icons.  I might have done them incorrectly.  They should be right-side-up now, but I might have to flip them again horizontally.

https://www.dropbox.com/s/a53s8bysvzp9nyj/Icons.zip?dl=0

(edit2)  I just found some screenshots from Strategia and I'm pretty sure I have them all backwards.

(edit3)  I think they're correct now, but if anyone can check them for me it's appreciated.

Edited by OhioBob
Link to comment
Share on other sites

1 hour ago, OhioBob said:

LOL.  All the icons were converted from .dds to .png.  But .dds must be flipped vertically, while .png does not.  So whoever did the conversion apparently forgot to flip them.

Or maybe that person lives in Australia.

Link to comment
Share on other sites

1 hour ago, OhioBob said:

We know about the not compatibility thing, though I'm not sure if there's a solution.  The problem is that both JNSQ and GPP are natively primary star systems that replace the stock system.  Thus, as far as CKAN is concerned, they can't co-exit with each other.  They are only compatible with the addition of GPP_Secondary.

Given that GPP_Secondary is only some very small ModuleManager patches, how about this:

  • bundle a copy of GPP_Secondary with JNSQ that only activates when GPP is installed (i.e. tack a NEEDS[GPP] to each patch).
  • Declare GPP compatible with JNSQ. The integrated GPP_Secondary version automatically converts GPP to a secondary system if it is installed and does no harm if not.

This would force JNSQ to always be the primary system when GPP and JNSQ are both installed, but given that I did not find anything that makes JNSQ a secondary system that would probably be no problem.

As a side note, installing GPP and GPP_Secondary manually on my otherwise mostly (apart from Principia) CKAN install worked like a charm. But the combination of JNSQ, GEP and GPP (plus a zillion other mods) made KSP gobble up 16GB of RAM, 32GB of swap, and finally get itself exploded by the OOM killer  when both RAM and swap ran out (on Linux).

So for now I'm back to JNSQ+GEP only (accompanied by a zillion other mods), which (barely) fits into 16 GB RAM. And arguing with myself if this justifies buying a new PC...

Link to comment
Share on other sites

2 hours ago, Pepethecat said:

what this square crater thing is and Im trying to find out how to get rid of it

This is the Kerbal Konstructs map-decal for the Boneyard Airbase. It uses the "ColorMapName = color__Crater1" which seems to display quite differently in v0.10.0 than it did on v0.9.0.
A quick fix would be to fly to Boneyard and land, then do a KK edit with CTL-K and then change the Map-Decal "AirBaseBoneyard" and set ColorMapName to None. Save and exit.

It should then just be the colour of the surrounding terrain.

Link to comment
Share on other sites

@OhioBob  @Galileo

See this log.  Lots of mods, all updated.  1.12.2

Got to 50 gig memory before crash.  JNSQ, GPP.  Deleted settings.cfg, never got to main menu

https://www.dropbox.com/s/8nwwwxjw5vrf0aw/Player-JNSQ-GPP-50gmem.log?dl=0

 

Edit: game with JNSQ only loads ok

 

I examined the GPP stuff again, turned out I installed it all incorrectly.  Fixed and testing again

Edited by linuxgurugamer
Link to comment
Share on other sites

On 9/24/2021 at 2:50 PM, Pepethecat said:

Is it normal for the kerbal konstruct sites to have the wrong grass color on some of modules/buildings?

unknown.png

No, that's not normal...but I haven't gotten around to fixing that up.

Link to comment
Share on other sites

On 9/24/2021 at 6:25 PM, RKunze said:

I am trying to install that combination through CKAN by choosing "JNSQ", (version 0.10.0), "Grannus Expansion Pack Rescale" (version 1.2.4) and "GPP Secondary" (version 1.6.6.0). But CKAN tells me JNSQ 0.10.0 conflicts with GPP secondary (or rather, with its depency "GPP") version 1.6.6.0. Also, I don't see any GPP rescale package on CKAN.

Is CKAN telling the truth here (if so, which version of GPP secondary is compatible with JNSQ 0.10.0?) or should I just install GPP secondary and GPP_rescale version 1.6.6.0 manually?

Read back, CKAN isn't support for this configuration yet

Link to comment
Share on other sites

I have found that when in a KSP 1.12.2, with both JNSQ and GPP installed, KerbalKonstructs along with it's dependency, Custom Pre Launch Checks, causes the game to get into an endless loop and eventually run out of memory.

I have posted in the KK thread, posting here in case anyone else comes across this problem

Log file here if anyone is interested:

https://www.dropbox.com/s/2jztpdijqsr62md/Player-JNSQ-GPP-KK-CPLC.log?dl=0

Edited by linuxgurugamer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...