• 0
Milesy

Action groups showing #Autoloc

Question

Posted (edited)

Whenever I go into action groups it has the normal  ones then #Autoloc_ followed by a number then below loads of things like pitch, yaw, translate L/R etc.

Running 1.7.1 (latest version).  I've tried reinstalling the whole game (without mods) but the issue is still there, I didn't remove any of the files that the uninstall didn't remove (settings, logs, old saves that kind of thing).  Also the issue is still there with newly created craft and newly created games.  What on earth could be going on?

Edit: I've just noticed an autoloc (which was off) in the settings as well, is this all a very strangely done feature in 1.7.1?

Edited by Milesy

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1
Posted (edited)
32 minutes ago, Milesy said:

I don't have any DLC it just started happening after the update to 1.7.1

Ok, so I tried it as well and I can confirm, that the missing autoloc strings are in the wrong dictionary. It's easy to fix though :)

Open the GameData folder of your KSP install "YOUR_INSTALL_PATH/Kerbal SPace Programm/GameData" and create a new textfile there. Call it however you like (for example "DictionaryFix") and put the .cfg file extension on it. Open the file, copy and paste the following lines into it:

Localization
{
	en-us
	{
		#autoLOC_8003261 = Axis Group
		#autoLOC_6012031 = Celestial bodies cast shadows
	}
}

and save the file. On the next game launch, the correct strings should appear in your game. If you need them for a different language than English, I can look them up for you, just tell me which language you need ;)

I'll also create a bugreport on the bugtracker  so it can be fixed soon :) 

edit: Apparently, someone reported this issue already so I just updated it: #22685

Edited by 4x4cheesecake

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

This isn't an answer to the OP but I am experiencing the same problem and have researched it a little... the error is happening in the action grouping inside the build building... the autoloc # is 8003261 which when searching the up-to-date dictionary.cfg file, this entry does not exist and the number falls firmly in line with entries for the new expansion, "Breaking Ground".

I have not bought this expansion, would love to, but haven't... I do not know if the OP does not have the xpack either and if this is an entry that does exist in the file for people who do have the xpack... I just know I don't have the xpack and the entry doesn't exist in my config.

I have to believe this error happened in the latest patches for the xpack that came out in the last 48 hours... because that's when the error showed up.

 

EDIT TO ADD: I'm toying with it... I only have the first upgrade to the VAB and to the Ground Control Building... yet, this is allowing me full access to all the custom buttons which shouldn't be unlocked yet... I simply click on the abort button to add actions to it, which is what I use for science actions to quickly do them before I upgrade fully... and this opens all the custom action slots which I can now use... even though as I have said, I do not have the upgraded facilities to do this... my save file is actually called "LEGIT" so I am not going to use this exploit... but it breaks the whole mechanic of leveling up buildings.

 

AND A BIT MORE: Actually... it just allows you to assign things to the custom tabs, but when going to the launch pad, custom action buttons that have been assigned do not work... so it's not saving the custom actions inside the VAB with this exploit... so it's not really an exploit... just a graphical bug... the basic actions still save and work in mission.

Edited by apelikejay
more information

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, apelikejay said:

This isn't an answer to the OP but I am experiencing the same problem and have researched it a little... the error is happening in the action grouping inside the build building... the autoloc # is 8003261 which when searching the up-to-date dictionary.cfg file, this entry does not exist and the number falls firmly in line with entries for the new expansion, "Breaking Ground".

Which dictionary did you look at? I can find the string in the DLC dictionary:

Quote

PS D:\KSP\KSP 1.7.1\GameData> findstr /S "8003261" *.cfg
SquadExpansion\Serenity\Localization\dictionary.cfg:            #autoLOC_8003261 = Axis Groups

Do both of you got the DLC or did you just update to 1.7.1? In the latter case, it's probably a bug and the string is put into the wrong dictionary but if you actually got the DLC as well, I would suggest to reinstall the DLC (on steam, you can verify the file integrity. Right click the game in your library -> properties -> local files -> verify integrity of game files).

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, 4x4cheesecake said:

Do both of you got the DLC or did you just update to 1.7.1?

I don't have any DLC it just started happening after the update to 1.7.1

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, Milesy said:

I don't have any DLC it just started happening after the update to 1.7.1

Interesting. I'll do a little test and come back to you in a few minutes :)

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, apelikejay said:

This isn't an answer to the OP

On the contrary you've convinced me that this is a cock up with 1.7.1 patch (which seems to be an excellent patch, squad have almost nailed it)

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
35 minutes ago, Milesy said:

I don't have any DLC it just started happening after the update to 1.7.1

Same... do not have the DLC... appears to be not in the config for those without the DLC.

 

EDIT TO ADD: Did the trick of updating with a separate file that 4x4cheesecake recommends and this does fix the language (removes the autoloc dialog) on the screen but the behavior of added custom buttons and pitch/yaw and all that is still the same. Thanks for looking into this... I'm with Milesy... this is a quirk that doesn't affect the overall greatness of the game... not at all... I'm sure it will be fixed. Thanks again.

Edited by apelikejay

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, apelikejay said:

Same... do not have the DLC... appears to be not in the config for those without the DLC.

Trust me, these are good news because it's easy to fix ;) Just look at my post above and of course, if you need the strings in a different language, just tell me and I'll give you the correct translation (of course, you can translate it on your own if you want so but I just need to switch to a different language in steam and get the correct DLC dictionary in just a few seconds^^ )

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, 4x4cheesecake said:

It's easy to fix though :)

You sir/madam are a genius and fixed the problem.  It now says axis group instead of #autoLOC_8003261. I've no idea what all the options are below that but frankly don't care.

Many thanks for your help, I really didn't think it'd be fixable without waiting for a patch, especially after reading Apelikejay's post.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.