Jump to content
  • 1

"Screen Message" spam in Breaking Ground


Go to solution Solved by Solune,

Question

I've put a DeployedCentralStation on the dark side of the mun.

It has no CommNet connection to kerbin, so I get a message telling me so.

The problem is when I start timewarping: I get spammed with 100+ messages saying the same thing, with no way to clear them all easily

Save and screenshots

https://www.dropbox.com/sh/u6rjhyx27bd4xde/AAARY2zZaxXzPKHO2mQ40-5Ra?dl=0

 

I initially found the bug when I was on minmus: since minmus is rotating, my station is sometimes is in line of sight of kerbin, but it is hidden often enough that I still get spammed.

 

KSP (not steam) Version:

[config]
build id = 02539
2019.05.29 at 07:00:13 PDT
Branch: master
language = en-us

Running on windows 7 64bit

Breaking Ground 1.0.0

Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 1

Found a possible fix over here

Go to post #19.

To quote:
In "\saves\default\persistent.sfs" (your main save) and in "\GameData\SquadExpansion\Serenity\Resources\DeployedScience.cfg", change the line
"ScienceTimeDelay = 60" to "ScienceTimeDelay = 6000000".

This makes it generate science about once every 50 ingame days, which would be about 8.8 science each time, (as measured with Minmus).

Link to post
Share on other sites
  • 0

Had the same issue, hunderes of messages when timewarping for other misions with an outpost on minmus. Completly drowns out anything that might be of use. Maybe just have max 1 message about it and have a counter for how often it triggered?

Link to post
Share on other sites
  • 0

Yep, same issue. Deployed a few surface stations on Minmus and now I get a couple hundred messages whenever I do long time warps for interplanetary transfers.

Going to toss out my suggestion for a fix (this is the first thing I checked to see if it existed ingame when I hit the problem): put a tweakable on the central station to enable/disable all messages from all of the attached components. Since people can access the central stations from the tracking center, that would let people turn on and off the messages whenever they want for whichever stations they want (unless the stations are out of power, I suppose).

Link to post
Share on other sites
  • 0

I found a solution works for me..

My game had over 5000 messages, and performance was a crawl / slow..

I was not going to sit there and click delete one at a time..

1. Save your game. 

2. (Go to each location where you have active ground experiments.  - disable or recover the units for now)

3. exit game and go to settings.

4. In Settings / Look for advanced messaging app - disable it..

5. restart game, see message window may have one or zero messages..  delete those..

6. Save again, exit and restart messaging app if desired then restart game..

 

 

Link to post
Share on other sites
  • 0

I also noticed this issue after installing Breaking Ground when I put up a ground science station by the KSP monolith. After time warping, I can see the the counter for screen messages in the upper right corner of the screen just start to climb and the game performance takes a nosedive--since I'm on older hardware, it is really noticeable.

The only mods I have installed at the moment are Missing History (1.7.3) and Module Manager (4.0.2).

  • KSP 1.7.2594 (WindowsPlayer 64) en-us
  • Making History 1.7.1
  • Breaking Ground 1.2.0
  • Running Windows 10 on a Dell N5110 with 8GB of RAM instead of the original 4GB.
Link to post
Share on other sites
  • 0
2 hours ago, DJWyre said:

Found a possible fix over here

Go to post #19.

To quote:
In "\saves\default\persistent.sfs" (your main save) and in "\GameData\SquadExpansion\Serenity\Resources\DeployedScience.cfg", change the line
"ScienceTimeDelay = 60" to "ScienceTimeDelay = 6000000".

This makes it generate science about once every 50 ingame days, which would be about 8.8 science each time, (as measured with Minmus).

Excellent, thanks, I'll try that. I also added a zero to "DataSendFailedTimeDelay" although that isn't really an issue in 1.7.3

Link to post
Share on other sites
  • 0
On 8/17/2019 at 5:21 PM, DJWyre said:

Found a possible fix over here

Go to post #19.

To quote:
In "\saves\default\persistent.sfs" (your main save) and in "\GameData\SquadExpansion\Serenity\Resources\DeployedScience.cfg", change the line
"ScienceTimeDelay = 60" to "ScienceTimeDelay = 6000000".

This makes it generate science about once every 50 ingame days, which would be about 8.8 science each time, (as measured with Minmus).

Hi,

 

first of all thanks for this workaround. I made the proposed changes and the screen messages did indeed stop spamming my message log. However, I've now warped forward over 100 days and haven't received any notification anymore, which is a problem because I accepted the "collect 50% surface deployed science" contract.

Can this have happened because the probe had no connection at the time it was supposed to transmit or did I maybe break sth?

 

Thanks in advance.

Link to post
Share on other sites
  • 0
On 9/4/2019 at 11:06 AM, ICYHOT said:

Hi,

 

first of all thanks for this workaround. I made the proposed changes and the screen messages did indeed stop spamming my message log. However, I've now warped forward over 100 days and haven't received any notification anymore, which is a problem because I accepted the "collect 50% surface deployed science" contract.

Can this have happened because the probe had no connection at the time it was supposed to transmit or did I maybe break sth?

 

Thanks in advance.

I too had this issue. I think the original poster assumed the number to be seconds, but it's not.

I had to wait until about 120-150 days, rather than the expected ~60.

But it does work.

Edited by DJWyre
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...