UomoCapra

Kerbal Space Program 1.7.2 is live!

Recommended Posts

33 minutes ago, Dash8466 said:

I just wish we could turn the rotors faster or more efficient

They are apparently working on it. The issue is that Unity has a rotational limit. Any fixes will have to fake a faster rotation somehow. Likely a separate propeller part that blurs the rotations and simulates the effect.

Share this post


Link to post
Share on other sites
9 hours ago, UomoCapra said:

Now you’ll be able to tie the main throttle to an axis group.

Hey this is GOOD! Easier to control craft like jumpjets etc.

Share this post


Link to post
Share on other sites

I've been waiting for this exact hotfix (plus the docking port bug/craft assembly bug but I'm guessing it's a more challenging fix). I will be buying the DLC today, thanks x a million to the devs for their work

Share this post


Link to post
Share on other sites
11 hours ago, UomoCapra said:

* Fix shadow casting string not displaying correctly if player doesn’t have the Breaking Ground Expansion.

But what does it do? It enables eclipses or what? Since the release of Breaking Ground this option remains a mystery.

Share this post


Link to post
Share on other sites
7 hours ago, RealKerbal3x said:

Thanks a lot guys!

The suit LED colour switch means that now I’ll be able to tell between my Kerbals at a glance :D

hmmm... when will someone post a MM patch that changes suit color based upon class and rank? :P

Share this post


Link to post
Share on other sites
6 hours ago, mindstalker said:

They are apparently working on it. The issue is that Unity has a rotational limit. Any fixes will have to fake a faster rotation somehow. Likely a separate propeller part that blurs the rotations and simulates the effect.

Thank you!!

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, UomoCapra said:

MainThrottle axis can be bound, but only in absolute mode.

[Edit: On new craft binding MainThrottle works just fine.

For those of us with existing craft, ... ]

Throttle control, as indicated by the slider next to the nav-ball,  might control the rate of change of what throttle was set to control.

Using the U.I. in the editor to bind MainThrottle [to a robotic part on an existing craft] gives me only one of the two changes described in the workaround (link) in the bug-tracker.  If I make the second change by hand, I get the desired behavior : throttle position as indicated on the slider corresponds to the controlled variable of the part.

Or, just replace the motor with a new one in the VAB.

Edited by OHara
only existing craft have the MainThrottle entry under incremental

Share this post


Link to post
Share on other sites

Have a quick question about the Making History Download pack .. was wondering if that is updated to 1.72, or do we use the 1.7.1 version and that's not going to break anything is it? Cause I found the Breaking Ground and the new version but no, makiing history Update..

 

Or is that one coming out soon?

 

Space_Coyote

Share this post


Link to post
Share on other sites
2 minutes ago, Space_Coyote said:

Have a quick question about the Making History Download pack .. was wondering if that is updated to 1.72, or do we use the 1.7.1 version and that's not going to break anything is it? Cause I found the Breaking Ground and the new version but no, makiing history Update..

 

Or is that one coming out soon?

 

Space_Coyote

@nestor said on the previous page that MH 1.7.1 is still fine for KSP 1.7.2.

Share this post


Link to post
Share on other sites

I don't know which one it was but something fixed my #1 irritation with 1.7.1, namely Missions failing to start with any of my helicopters. It works now and opens up all kinds of possibilities! 

Thank you!

7 hours ago, Dash8466 said:

I just wish we could turn the rotors faster or more efficient

OT for the thread, but if you're building helicopters or propeller aircraft, DM me and I'll help troubleshoot; there's nothing wrong with the motors, they're super powerful. A single heavy motor can lift 70 tons or more. That's a lot of power!

Share this post


Link to post
Share on other sites

I got another update today, seems like a really small update, maybe a hotfix. What was it?

Share this post


Link to post
Share on other sites
1 hour ago, scimas said:

I got another update today, seems like a really small update, maybe a hotfix. What was it?

There was a problem with build 2555 for those that don’t have Breaking Ground expansion installed. If you don’t have Breaking Ground you should ensure you have build 2556 showing at the. Orrin right corner when you start the game. For those that do have Breaking Ground it won’t matter if you have either. 

Details of the problem that was fixed can be found here. 

 

Share this post


Link to post
Share on other sites
Posted (edited)

I did have a thought when looking at binding robotic parts to axis.

Could we add a number of auxiliary axis?

so if I had say a 2nd joystick I could use it to control 'other' robotic functions.. for example a 2nd throttle axis on joystick 2 could control thrust vectoring.. or an arm position (or multiple joint positions), or flap extension, or wing folding, etc, etc, etc..

Edited by bunjatec
more examples..

Share this post


Link to post
Share on other sites
1 hour ago, JPLRepo said:

There was a problem with build 2555 for those that don’t have Breaking Ground expansion installed. If you don’t have Breaking Ground you should ensure you have build 2556 showing at the. Orrin right corner when you start the game. For those that do have Breaking Ground it won’t matter if you have either. 

Details of the problem that was fixed can be found here. 

 

Downloading from store on linux, what exactly changed. If I have 1.7.2.2555, what files exactly do I need to replace to patch to 2556. So I don't have to run all the dlc scripts again, and copy over settings, and copy over saves. etc. I mean I can do it the hard way if needed, would be nice though if all I have to do is replace a couple files to patch to 2556 instead of making whole new install.

Share this post


Link to post
Share on other sites
3 hours ago, JPLRepo said:

There was a problem with build 2555 for those that don’t have Breaking Ground expansion installed. If you don’t have Breaking Ground you should ensure you have build 2556 showing at the. Orrin right corner when you start the game. For those that do have Breaking Ground it won’t matter if you have either. 

Details of the problem that was fixed can be found here.

I haven't updated yet (mods...) but in the KSP settings menu for GOG Galaxy the latest version is 1.7.2.02555 (2 days ago), is that latest, non-Breaking Ground patch?

Share this post


Link to post
Share on other sites

The only Mod I'm experiencing difficulty with is Kopernicus...others seem to work ok.  I would imagine Kopernicus will get an update to take 1.7.2 into account.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Black-Two- said:

I haven't updated yet (mods...) but in the KSP settings menu for GOG Galaxy the latest version is 1.7.2.02555 (2 days ago), is that latest, non-Breaking Ground patch?

No, you want build 1.7.2.02556... it was a little late, sorry. But GOG should be updated now

Edited by Just Jim

Share this post


Link to post
Share on other sites
Posted (edited)

Looks like the Game Data file got duplicated and that's what caused all the wonkyness...too many late evenings

Edited by jbarry39

Share this post


Link to post
Share on other sites
Posted (edited)
9 minutes ago, jbarry39 said:

KSP 1.7.2 is a total piece of garbage!  Try to start a new game/save and ALL THE MENUS ARE DUPLICATED.  When you right-click on a Kerbal...the menu is DUPLICATED.  Utter TRASH.  KSP 1.7.3 Anyone???  Joke.

Woah there! Calm down! Could you give us screenshot in a dedicated thread so people can help you out with this problem?

Edited by lapis

Share this post


Link to post
Share on other sites
1 hour ago, jbarry39 said:

KSP 1.7.2 is a total piece of garbage!  Try to start a new game/save and ALL THE MENUS ARE DUPLICATED.  When you right-click on a Kerbal...the menu is DUPLICATED.  Utter TRASH.  KSP 1.7.3 Anyone???  Joke.

No one else has this issue... so not a bug. Probably a mod incompatibility. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.