FahmiRBLXian

Startup Loading Duration Thread - Post How Long Your Install Takes To Load!

Recommended Posts

Posted (edited)

My main install took around 20 30 minutes to load the whole game.

How about yours?

Spoiler

My Specs (As what I remembered and knew about my laptop)

HP Pavillion g4, 7 years old ('After-market' upgraded RAM)

  • RAM 4GB, Unsure of DDR
  • CPU : Intel Core i5-2450M, 2.5GHz
  • GPU : AMD Radeon (HD) 2450M
  • Storage : 500GB HDD
  • OS Windows 7 Professional

(Will be upgrading to Windows 10 via Media Creation Tool by the end of this year)

My Modlist (I'll list whenever I have time) - Total, 58, as of what AVC logged. Excluding (some) dependencies & MM

  • Making History DLC
  • Breaking Ground DLC
  • Airplane Plus
  • KAX/L
  • SXT Continued
  • APUS
  • Mk2 Expansion
  • Mk3 Mini Expansion
  • Firespitter
  • Stockalike Mk1 Open Cockpit
  • Aviation Lights
  • Grounded - Modular Vehicles
  • ReDirect
  • Tundra Exploration
  • Kerbal Reusability Expansion
  • Station Parts Expansion Redux
  • Tundra Exploration
  • Heisenberg Airships
  • Hooligan Labs
  • Aircraft Carrier Accessories
  • Kerbal Foundries
  • MOLE
  • TAC Life Support
  • BDArmory
  • North Kerbin Division
  • B9 Aerospace (Legacy & Current)
  • B9 Procedural Wings
  • BD Mk22
  • AARS Continued
  • Tweakscale
  • MechJeb
  • Kerbal Engineer Redux
  • Burn Together
  • Kramax Autopilot Continued
  • Kronal Vessel Viewer
  • Janitor's Closet
  • KerbinSide Remastered
  • Kerbal Konstructs
  • Omega's Stockalike Structures
  • Tundra Space Center
  • Crew Light
  • CameraTools
  • Vessel Mover
  • KS3P (Can someone help me to set this up (i.e Getting the visual effect on) pls?)
  • Craft Manager & / KerbalX Mod

It can be among the record-breaking longest to the lightning-SSD shortest ones. Feel free to post yours here.

Edited by FahmiRBLXian

Share this post


Link to post
Share on other sites
38 minutes ago, FahmiRBLXian said:

My main install took around 20 minutes to load.

How about yours?

Wow! You must have a pretty big mod list? Or a mechanical hard drive?

Share this post


Link to post
Share on other sites
52 minutes ago, RealKerbal3x said:

@FahmiRBLXian Same as you, around 20 mins.

Ouch... mine takes 2-3 minutes and I'm putting together a new machine this week, so that time's going to drop a bit.

Share this post


Link to post
Share on other sites
1 minute ago, purpleivan said:

Ouch... mine takes 2-3 minutes and I'm putting together a new machine this week, so that time's going to drop a bit.

It takes so long because I run quite a few big mods and have a mechanical hard drive. Having a lot of mods is always a really conflicted experience because you want to get rid of as many as possible to improve performance, but also want to keep them all because they're all so nice, you know? :sticktongue:

Share this post


Link to post
Share on other sites

25 minutes.  SSD, computer less than a year old - all the mods.  ;)

Share this post


Link to post
Share on other sites

Didn't clock it, but seems like around 3-4 minutes?  Definitely not 20+.

Still running an older Mac Mini ( SSD & 16GB RAM helps a lot ), but have a good list of mods ( mostly part mods like Near Future, Planetary Base Sys, etc. ).

Share this post


Link to post
Share on other sites

Mine is about 4 minutes, ssd, just over 60 mods (some large like rssve).

20+ minutes is absurd, ksp has terrible loading code.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, DStaal said:

25 minutes.  SSD, computer less than a year old - all the mods.  ;)

15-20 minutes for me depending on how many mods in that instance. SSD, 1 year old gaming laptop, 60-85 mods.

Edited by panarchist

Share this post


Link to post
Share on other sites
14 minutes ago, coredumpster said:

Didn't clock it, but seems like around 3-4 minutes?  Definitely not 20+.

Still running an older Mac Mini ( SSD & 16GB RAM helps a lot ), but have a good list of mods ( mostly part mods like Near Future, Planetary Base Sys, etc. ).

I grabbed times from the KSP.log.  It logs when you start, and when you get to the menu.

I'll admit loading KSP wasn't all it was doing - I was browsing the web and watching videos while it loaded.  AVC lists a bit over 200 mods for me, for reference.

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/17/2019 at 11:38 PM, Tekaoh said:

Wow! You must have a pretty big mod list? Or a mechanical hard drive?

Yes, 500GB Storage HDD, 4GB RAM, Intel Core i5-2450M, AMD Radeon HD 7450M. HP Pavillion G4.

Approx. 50 mods; around 9 13 of them are part mods, including dependencies.

Edited by FahmiRBLXian

Share this post


Link to post
Share on other sites

Four minute load time for me.

I'm running 36 mods, nine of which are part mods, on a four year old HP laptop.

I'm bumping up against my memory limits so I will be purchasing a new laptop as a Christmas gift to me, just to run KSP.

To paraphrase JFK, ich bin ein Kerbal.

MM

Share this post


Link to post
Share on other sites

Intel i5 4570, 24GB DDR3 RAM, SanDisk 480GB SSD, NVIDIA GeForce GTX 970 STRIX, probably 4 - 5 years old. Original motherboard, processor and 8GB original RAM, the rest was upgraded later on.

AVC lists 142 mods, which includes 32 part mods, 7 visual mods, and JNSQ. (2.7x Scaled System) Also have Making History and Breaking Ground installed.

Load Time is 10 minutes, 1 second according to KSP.log

 

Share this post


Link to post
Share on other sites

54 seconds from double click on the icon to working menu (it would be less but the game hiccups right after the green menu text first appears). This is with 13 extra folders in GameData, off of an NVMe SSD.

Share this post


Link to post
Share on other sites

I'm also around 20 min or so. About 6 parts mod packs (OPT, OPT Legacy, MKIV, MK2X, MK3X, KPBS). 2 extra planet packs excluding stock (OPM & GEP). The rest are quality-of-life and life support with extra contract packs. I'm on a mechanical hard-drive as well. 

Share this post


Link to post
Share on other sites

Anything more than 3 mins , and i'd chuck  PC off a high cliff 

Share this post


Link to post
Share on other sites

Startup loading, about 5 minutes for the main menu to appear and another 3-4 for it to become responsive.

Exit loading, around 15-20 minutes from KSC to desktop.

Share this post


Link to post
Share on other sites

How much time it takes you to load the game? Would be nice to hear. Mine with all my mods 1 minute.

Share this post


Link to post
Share on other sites

Overlapping threads have been merged

Share this post


Link to post
Share on other sites

Just discovered that my loading duration became longer with waiting to get a functional main menu.

30 Minutes.

Share this post


Link to post
Share on other sites
Posted (edited)

If you want to add more mods but get better performance, enable DX11 in your shortcut. (It does add a few barely noticeable graphical glitches though)

explorer201907281536.png

Edited by RocketSimplicity

Share this post


Link to post
Share on other sites
2 hours ago, RocketSimplicity said:

If you want to add more mods but get better performance, enable DX11 in your shortcut. (It does add a few barely noticeable graphical glitches though)

explorer201907281536.png

I remember tryna do the same thing; adding "-force-d3d11" but without spacing from the location, which resulted in an unsuccessful attempt to apply that. :/

Anyway, thanks for shading light on the correct way.

Share this post


Link to post
Share on other sites
Posted (edited)

1.7.0 w/JNSQ, Scatterer EVE

About [1m] and 45 seconds. Another 5sec pause to menu. Full screen 1080p, all settings maxed.

1.7.3 / MH+BG

About 35 seconds, same pause, also maxed settings. 

1.6.1 RO 

About 5 mins.

All from an SSD on an MSI laptop w/8th Gen I5, 1080ti and 16gRAM.

Edited by Ratwerke_Actual
Edited [ ]

Share this post


Link to post
Share on other sites
Posted (edited)

Maybe 1 or 2? Fast enough I regularly restart to keep it fresh if I'm kerbaling for a long time. 
I've only got about a dozen mods, and I'm running it on a very powerful laptop I set up for CAD work.  SSD, 8th Gen i7, 32GB ram.

Edited by Tw1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.