Jump to content

[1.12.x] Shuttle Orbiter Construction Kit | Stockalike Space Shuttle Orbiter! | (Tubes!) | v1.1.8


benjee10
 Share

Recommended Posts

Fantastic modeling! I do have a question about the manual, however. I'm trying to figure out the mechjeb profile for the shuttle ascent,  but the described parameters either don't exist in mechjeb, or more likely, I am unfamiliar with them. For example, I am not aware of any setting that allows you to establish an orbit without coasting, or even an eccentric orbit for that matter (without extra maneuvers). Additionally, which setting relates to pitch rate? Would it be possible to send a screenshot of the proper mechjeb settings? Finally, whenever I try using my mechjeb profile, the SRBs end up just destroying the orange fuel tank because the boosters separate while the shuttle is rolled on its back during the ascent.

Thanks!

Link to comment
Share on other sites

6 minutes ago, MaxLak said:

Fantastic modeling! I do have a question about the manual, however. I'm trying to figure out the mechjeb profile for the shuttle ascent,  but the described parameters either don't exist in mechjeb, or more likely, I am unfamiliar with them. For example, I am not aware of any setting that allows you to establish an orbit without coasting, or even an eccentric orbit for that matter (without extra maneuvers). Additionally, which setting relates to pitch rate? Would it be possible to send a screenshot of the proper mechjeb settings? Finally, whenever I try using my mechjeb profile, the SRBs end up just destroying the orange fuel tank because the boosters separate while the shuttle is rolled on its back during the ascent.

Thanks!

I'm not able to grab a screenshot right now, but most of the parameters you are looking for are accessed by switching from 'Classic ascent profile' to 'Primer vector guidance' in the ascent autopilot window. 

The SRBs should indeed separate while the shuttle is inverted. Make sure you have the separation motors angles correctly - the nose cone motors should be rolled at about a 45 degree angle between the ET and the orbiter, so that they push out and down away from the shuttle. Like this:

screenshot995.png

You may need to manually place some additional separators at the bottom of the boosters too to ensure a clean separation. 

Link to comment
Share on other sites

I just found this (I know what rock were you under) an dit is awesome looking. But I can use it (sadface) I saw above where the OMS has a new model, the one in the current download disappears when you attach it to anything and that part is now locked and can't be recycled.  Is there a quick fix for this, or will I have to wait for the new one to be released. If that is the case, is there a good substitute in KSP? I'm kinda on a  FAM kick and trying to recreate the Shuttle/Skylab thingy. On the other side I am tearing my hair out trying to recreate the LSAM and Jtown...

Link to comment
Share on other sites

On 8/30/2022 at 8:30 AM, benjee10 said:

I'm not able to grab a screenshot right now, but most of the parameters you are looking for are accessed by switching from 'Classic ascent profile' to 'Primer vector guidance' in the ascent autopilot window. 

The SRBs should indeed separate while the shuttle is inverted. Make sure you have the separation motors angles correctly - the nose cone motors should be rolled at about a 45 degree angle between the ET and the orbiter, so that they push out and down away from the shuttle. Like this:

screenshot995.png

You may need to manually place some additional separators at the bottom of the boosters too to ensure a clean separation. 

Thanks for the help, I see what happened. The part mirroring automatically misaligned one of the nose cone motors in the included craft file, leading one of them to launch an SRB directly into the external tank. 

Sorry for all of the questions, but any tips on making sure the mechanical arm doesn't flop all over the place during flight?

Link to comment
Share on other sites

13 minutes ago, bjbeardse said:

I just found this (I know what rock were you under) an dit is awesome looking. But I can use it (sadface) I saw above where the OMS has a new model, the one in the current download disappears when you attach it to anything and that part is now locked and can't be recycled.  Is there a quick fix for this, or will I have to wait for the new one to be released. If that is the case, is there a good substitute in KSP? I'm kinda on a  FAM kick and trying to recreate the Shuttle/Skylab thingy. On the other side I am tearing my hair out trying to recreate the LSAM and Jtown...

As OrbitalManeuvers said updating SharedAssets should fix it - the new OMS engine is included in that! Shuttle & the rest of my mods bundle the latest version except for reDIRECT - I guess you may have installed this last in which case the old version of SharedAssets would overwrite the new one? 

If you're looking for planetary base parts, my other mod Planetside includes some parts inspired by Jamestown. 

4 minutes ago, MaxLak said:

Thanks for the help, I see what happened. The part mirroring automatically misaligned one of the nose cone motors in the included craft file, leading one of them to launch an SRB directly into the external tank. 

Sorry for all of the questions, but any tips on making sure the mechanical arm doesn't flop all over the place during flight?

Glad you got it figured out! 

If you are using Breaking Ground for the robotics you should be able to lock each joint in the VAB before flight, then turn on autostrut to heaviest on the arm end effector. You can bind the joint lock/unlock to an action group for when you need to move it, but I think you will need to toggle the autostrut manually. That should keep it locked in place during launch. Make sure you have all of the joints locked or the autostrut won't be able to run through them. It can be a bit finicky trying to get them all locked at the same time when in flight as if there's any movement the game refuses to lock them. 

Link to comment
Share on other sites

@benjee10I have noticed an odd artifact when building the shuttle. It depends on the camera angle, but I can see a flipped ghost of the orbiter wings in the VAB. It's like a shadow of the wing, but flipped. I won't be able to get you a screenshot until the weekend, so I apologize if my info is a little limited.

Link to comment
Share on other sites

4 minutes ago, DJ Reonic said:

@benjee10I have noticed an odd artifact when building the shuttle. It depends on the camera angle, but I can see a flipped ghost of the orbiter wings in the VAB. It's like a shadow of the wing, but flipped. I won't be able to get you a screenshot until the weekend, so I apologize if my info is a little limited.

The way the wing part is set up is that it has two models of the wing, each a mirror of each other, then B9 is used to disable one at a time. It is probably just an artefact of this - I haven't seen it myself but so long as it's not visible in flight I wouldn't be too concerned. Do you have TU or anything like that installed? 

Link to comment
Share on other sites

5 hours ago, benjee10 said:

The way the wing part is set up is that it has two models of the wing, each a mirror of each other, then B9 is used to disable one at a time. It is probably just an artefact of this - I haven't seen it myself but so long as it's not visible in flight I wouldn't be too concerned. Do you have TU or anything like that installed? 

Yes. TU and TUFX. No configs for SOCK (at least none that I'm aware of.)

Link to comment
Share on other sites

  • 2 weeks later...

is there any tutorial on how i can successfully rondevu and dock with this thing? tried going manual but that was a mistake, decided to try and use MechJeb but it makes the shuttle act crazy with super short burns that if i let it sit there it will waste monopropellant. apart from that the shuttle looks amazing  i dont think i can ever play KSP without this mod!

Link to comment
Share on other sites

5 minutes ago, Just John said:

is there any tutorial on how i can successfully rondevu and dock with this thing? tried going manual but that was a mistake, decided to try and use MechJeb but it makes the shuttle act crazy with super short burns that if i let it sit there it will waste monopropellant. apart from that the shuttle looks amazing  i dont think i can ever play KSP without this mod!

I am guilty of this myself but for you you should try and learn how to rendezvous and dock manually. Also when on orbit change the control point to -15 in the cockpit.

 

Edited by cfopcuber2
Link to comment
Share on other sites

24 minutes ago, Just John said:

is there any tutorial on how i can successfully rondevu and dock with this thing? tried going manual but that was a mistake, decided to try and use MechJeb but it makes the shuttle act crazy with super short burns that if i let it sit there it will waste monopropellant. apart from that the shuttle looks amazing  i dont think i can ever play KSP without this mod!

1) As said above, change the control point to -15 after SRB separation (as said in manual) - this helps when thrust is low.

2) MJ works for rendezvous... most of the time. Sometimes it can glitch and do these short burns in quick succession. Save before starting your Hohmann transfer. Also, perform all the stuff with RCS disabled, using only SAS (this will be slower, but hopefully more precise)

3) Docking with MJ is currently next-to-impossible due to RCS placement (which confuses MJ). Your best bet is to use a docking tug (or even station module, like Kristall) which would dock with the orbiter and bring it to station using its own powerful RCS. (Disable orbiter RCS for the duration)

Edited by biohazard15
Link to comment
Share on other sites

15 hours ago, biohazard15 said:

1) As said above, change the control point to -15 after SRB separation (as said in manual) - this helps when thrust is low.

2) MJ works for rendezvous... most of the time. Sometimes it can glitch and do these short burns in quick succession. Save before starting your Hohmann transfer. Also, perform all the stuff with RCS disabled, using only SAS (this will be slower, but hopefully more precise)

3) Docking with MJ is currently next-to-impossible due to RCS placement (which confuses MJ). Your best bet is to use a docking tug (or even station module, like Kristall) which would dock with the orbiter and bring it to station using its own powerful RCS. (Disable orbiter RCS for the duration)

Or... just set docking port as control point :D

Link to comment
Share on other sites

47 minutes ago, hugoraider said:

Or... just set docking port as control point :D

This doesn't work due to the arrangement of the RCS & actuation toggles, you need to rebind all the RCS axes to match the control direction of the docking port. 

I think I have a solution to this which should come in the next update. Consolidating all the RCS transforms into a single module and giving them cardinal directions (rather than the off-angles that cause them to activate for multiple control inputs & make the RCS unbalanced) and using dummy FX transforms in the visually correct locations should make things a lot simpler and allow control from other points on the craft. 

Link to comment
Share on other sites

21 minutes ago, benjee10 said:

This doesn't work due to the arrangement of the RCS & actuation toggles, you need to rebind all the RCS axes to match the control direction of the docking port. 

I think I have a solution to this which should come in the next update. Consolidating all the RCS transforms into a single module and giving them cardinal directions (rather than the off-angles that cause them to activate for multiple control inputs & make the RCS unbalanced) and using dummy FX transforms in the visually correct locations should make things a lot simpler and allow control from other points on the craft. 

WDYM? it works perfectly for me :huh:

Link to comment
Share on other sites

5 minutes ago, hugoraider said:

WDYM? it works perfectly for me :huh:

The shuttle's thrusters can't all point in cardinal directions (which would be most efficient) due to the heat shield, aerodynamic shape, avoiding firing directly into the wings etc. so they are at multiple slightly weird angles. Without limiting the RCS actuation toggles, KSP picks some of these thrusters up as belonging to multiple RCS axes, which means you will get thrusters firing which shouldn't be firing, which gives you unintended translations while rotating in certain directions & induces rotation while trying to translate.

To avoid this the mod splits the RCS up into multiple modules which you can configure the RCS axes for separately. There is a guide on how to do this in the manual, or the craft files provided have it already set up. 

A limitation of this is that the actuation toggles are set *relative to the control point*, so having done this you will end up with RCS dead zones if you control from anywhere but the cockpit. I'm guessing you don't have the RCS toggles set as intended, and MechJeb is just compensating for the bad thruster firings. This is fine, but the shuttle will be harder to control and it will drain your monoprop pretty quickly, since many more thrusters are firing than should be *and* MechJeb is having to perform additional firings to correct for the induced translation.

I have tested the fix above and it not only removes this issue but also makes the Shuttle a bit easier to fly in general. 

Link to comment
Share on other sites

34 minutes ago, The Dressian Exploder said:

Now that Artemis Construction Kit has been more or less done for the time being, could we be seeing a completion of the Buran?

 

Have break first though, you've contributed so much to the KSP modding scene, a rest is definitely deserved.

ACK is far from done. Benjee just released a teaser for EUS.

Link to comment
Share on other sites

Love this mod. It's the only shuttle mod I actually use. The only problem I have. The viking engines. I can't right click them in the VAB to modify them, nor do they appear in the staging until on the launch pad.

I opened up the debug menu. And whenever I place them into the build it says "Exception: NullReferenceException: Object reference not set in an instance of an object"

I reinstalled the mod a few times. Aswell as making it my only mod installed in hopes of finding out what happens. To no luck. Any help would be appreciated!

Link to comment
Share on other sites

2 hours ago, TigerBea5t said:

Love this mod. It's the only shuttle mod I actually use. The only problem I have. The viking engines. I can't right click them in the VAB to modify them, nor do they appear in the staging until on the launch pad.

I opened up the debug menu. And whenever I place them into the build it says "Exception: NullReferenceException: Object reference not set in an instance of an object"

I reinstalled the mod a few times. Aswell as making it my only mod installed in hopes of finding out what happens. To no luck. Any help would be appreciated!

Delete Benjee10_SharedAssets and make sure you have the latest version of that. It is included with the release or available separately on GitHub. You may need to rebuild craft files.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...