benjee10

[1.7.X] Shuttle Orbiter Construction Kit | Stockalike Space Shuttle Orbiter! | (Initial Release!) | v1.0.0

Recommended Posts

@benjee10 I appear to be having an issue with the AJ10/Viking engine, even though I have all four of your mods installed (including Shared Assets) the engine part is missing from the game and craft files containing it don't load, yet its' config files exist in one of Shared Assets' folders. As I'm also having a seemingly identical issue with one of BDB's parts, this might be an error on my side, though I'll keep tinkering with it.

Share this post


Link to post
Share on other sites
Posted (edited)

So I decided to find an unorthodox way of assembling a space station:  Giant Space Claw.

HjRWS3i.png

Robotic arms?  Pffft.  Just load up some dangerous fuel in a 50 year old Moon lander and attach a giant scary claw to it.

 

Space shuttles are great for testing giant space claws.

Edited by Deltac

Share this post


Link to post
Share on other sites

Hi, does anyone have advice about reentry and landing, im playing on JNSQ so its about 2.7x.

I can't figure out a entry profile that doesnt cause something to explode from overheating, usually its the nose landing gear or the payload adapter.

Other than that the mod is amazing

Thanks 

Share this post


Link to post
Share on other sites
On 7/16/2019 at 3:24 AM, shdwlrd said:

After playing around with the shuttle for awhile last weekend, I have to say, nice job balancing it. I was able to bring it back to Kerban in one piece after several failed orbital attempts. (Some on purpose, some not.) Once I was able to get it orbital, orbital maneuvers were executed with minimal fuss, the reentry was easy and the flight to the ground was uneventful. (I still can't hit the KSC, yet alone the runway, but I landed it in one piece.)

My only real issues are these. The wings and the nodes need to be stronger. If the boosters don't clear properly after separation and bounce off the wings, either the wings would be knocked off or go kaboom. The included OMS engines either need more thrust or better ISP. Outside of it was taking forever to do orbital insertion and maneuver burns, the burns was using a lot more of my onboard fuel than expected. (Burns was done with 41 tonnes of ore ballast. I play stock system size, and test with the maximum amount of weight I can get to orbit without going crazy with the ET and booster stack.)

The only part I would like to see is an external tank mount for the stock tanks sizes. I was using the mount from the Cormorant because it looked better than any stock parts.

Many thanks, glad you're finding the balance generally good! 

The issues you're having with the OMS come from using a stock scale system. The shuttle is designed to work best in a 2.5-2.7x scale solar system, where the payload the complete stack can put in orbit is much smaller (I recommend no more than around 15t). Because the shuttle can get a great deal more into orbit at stock scale, its OMS is consequentially under powered here when flying with a heavy payload. Bear in mind that IRL the shuttle's max payload was around 25t, so 41t is way outside of operational margins for the real STS, let alone a sub-scale version for KSP. Flying with a 15t payload you will find OMS burns a lot more manageable. At may payload the shuttle has around 360m/s delta-V which is more than adequate for rendezvous ops & deorbit. 

In terms of the wing strength, I don't believe there's much I can do here config-wise but applying autostrut to the wings makes them pretty rigid. 

On 7/17/2019 at 10:32 PM, sslaptnhablhat said:

@benjee10 I appear to be having an issue with the AJ10/Viking engine, even though I have all four of your mods installed (including Shared Assets) the engine part is missing from the game and craft files containing it don't load, yet its' config files exist in one of Shared Assets' folders. As I'm also having a seemingly identical issue with one of BDB's parts, this might be an error on my side, though I'll keep tinkering with it.

Afraid I can't be of much help here apart from suggesting a clean reinstall of the mods (making sure to delete them first, not simply overwriting them). It could be that if you've jsut been overwriting the mod folders older config files could be sticking around and causing errors. 

Share this post


Link to post
Share on other sites

@benjee10 so the robotics the HTrobotics must have contain the robotic parts but i launched the game (as usual) the robotics are not showing up is their a way of enabling them???

 

Share this post


Link to post
Share on other sites

Amazing mod, @benjee10, all of your mods are something else!

With regards to the robotic arm, I was attempting to remove a payload from the orbiter, but as the module moves out of the cargo bay, the orbiter starts to swing violently, essentially trying to pivot around the Orbiter.  I've tried both increasing and decreasing the damping on the robotic joints, but neither mid, high, or low damping has been able to stop this shuddering and wavering.  Is there a method to using this arm that I am missing?

Share this post


Link to post
Share on other sites
Posted (edited)

I just learnt about "Orbiter-derived station", a non-NASA proposal to turn Columbia into a mother ship during the 1990 round of Space Station Freedom (SSF) redesign. (https://www.wired.com/2012/03/space-station-columbia-1991/ , written by David S. F. Portree). Tried to build it with benjee's amazing parts!

(In short, it takes the 3,600kg-heavier-than-usual Columbia out of the fleet, than utilize the modules and solar array being built for SSF. It focuses on having more pressurized volume for micro-gravity research by diverting Earth-sensing and space-observation experiments into other unmanned spacecrafts.)

 

ODSb.gif

vXMnofV.png

station-ODS2.gif

KoekBVF.png

ODSd.gif

yN0DxQd.png

station-ODS.gif

CdCkTJw.png

More pics:

Spoiler

 

Launch:

bx5S29z.png

Zsne3UO.png

doIRW42.png

GQZBzRH.png

t4UK9y6.png

Initial configuration: (The belly should be white instead)

yVi42aK.png

MrCPUUC.png

Assembly complete: (CST-100 to act as a "Apollo derived ACRV". All SSF designs have cupola so I guess it should be in here as well)

CmJs1XV.png

dg71nOx.png

ZMvORCr.png

Further expansion based on the description: (50% more solar power from module attached to nose, docking port at belly. Also I believe extra radiator would be helpful)

GesGI8J.png

EFqPOWC.png

nV3LAr4.png

 

 

Edited by MangoRises
fix expression

Share this post


Link to post
Share on other sites
1 hour ago, MangoRises said:

I just learnt about "Orbiter-derived station", a non-NASA proposal to turn Columbia into a mother ship during the 1990 round of Space Station Freedom (SSF) redesign. (https://www.wired.com/2012/03/space-station-columbia-1991/ , written by David S. F. Portree). Tried to build it with benjee's amazing parts!

This is insane! I love it!

Share this post


Link to post
Share on other sites
4 hours ago, JediRangerkendor said:

Is there anyway to get the Canadarm as a stand alone mod? 

Download it and delete the Folders Benjee10_sharedAssets and Benjee_shuttleOrbiter. Now you have only the robotic parts.

Share this post


Link to post
Share on other sites
18 hours ago, Cheesecake said:

Download it and delete the Folders Benjee10_sharedAssets and Benjee_shuttleOrbiter. Now you have only the robotic parts.

O.O

Share this post


Link to post
Share on other sites

Hey , I was wondering where do people learn to make mods for KSP? all tutorials are very out dated 

Share this post


Link to post
Share on other sites

Hello, i am curious of how you created the Front Page of the Shuttle Manual

i am somewhat interested in Graphics

Share this post


Link to post
Share on other sites

Modular Launch Pads v2.0, with the new shuttle pad, is now out

The shuttle pad was designed for the Comorant Aeronology shuttle, as it was made long before SOCK appeared, but it will work with SOCK with some "do it yourself" adjustment work, until I get v2.1 out with proper support for SOCK. 

Share this post


Link to post
Share on other sites
On 8/3/2019 at 9:24 AM, Adam-Kerman said:

is there a specific Mechjeb Ascent need for the SOCK Shuttle?

If you read the manual for the SOCK, it suggests a Primer Vector Guidance for the ascent:

Shuttlesnip.png

Share this post


Link to post
Share on other sites
4 hours ago, Gunslinger1 said:

Any idea how to solve the arm parts flopping around in flight?

You need to lock the arm when you launching, and if the object your arm grab have pod, need to turn torque down to zero.

Share this post


Link to post
Share on other sites
On 8/5/2019 at 9:48 PM, rogerwang86 said:

You need to lock the arm when you launching, and if the object your arm grab have pod, need to turn torque down to zero.

How does one lock the arm?

Share this post


Link to post
Share on other sites
8 hours ago, Gunslinger1 said:

How does one lock the arm?

I'm Having a similar issue but its different, Ive successfully "Locked the parts" in the VAB but after SRB Separation the arm starts flopping around and wont stop.

Is there something I dont know? Ive increased the damping, increased the motor power,  Any solution? 

Share this post


Link to post
Share on other sites
8 hours ago, Gunslinger1 said:

How does one lock the arm?

 

18 minutes ago, Thomas Edison said:

I'm Having a similar issue but its different, Ive successfully "Locked the parts" in the VAB but after SRB Separation the arm starts flopping around and wont stop.

Is there something I dont know? Ive increased the damping, increased the motor power,  Any solution? 

Locking the arm parts either in flight or in the VAB basically allows autostrut to run past the robotic joints, so you also need to turn autostrut on on the end effector part, otherwise it doesn’t have any effect other than to prevent the robotic parts actuating actively. When the parts are unlocked autostrut is ignored.

Share this post


Link to post
Share on other sites
Posted (edited)
10 minutes ago, benjee10 said:

 

Locking the arm parts either in flight or in the VAB basically allows autostrut to run past the robotic joints, so you also need to turn autostrut on on the end effector part, otherwise it doesn’t have any effect other than to prevent the robotic parts actuating actively. When the parts are unlocked autostrut is ignored.

Thanks for the speedy reply!

Just tried re-doing all of that, Still moves for me. I Tried all the different autostrut settings and tried locking in VAB and On the Pad. Still no fix. Seems to be rooted in the servo pitch joint.

Edited by Thomas Edison

Share this post


Link to post
Share on other sites
51 minutes ago, Thomas Edison said:

Thanks for the speedy reply!

Just tried re-doing all of that, Still moves for me. I Tried all the different autostrut settings and tried locking in VAB and On the Pad. Still no fix. Seems to be rooted in the servo pitch joint.

Make sure you have every single joint in the arm locked. If even one is unlocked, the autostrut won’t be able to run past it. You might want to try adding autostrut to multiple parts of the arm too, for instance the booms or longeron attach point.

Share this post


Link to post
Share on other sites
Posted (edited)
17 minutes ago, benjee10 said:

Make sure you have every single joint in the arm locked. If even one is unlocked, the autostrut won’t be able to run past it. You might want to try adding autostrut to multiple parts of the arm too, for instance the booms or longeron attach point.

Just tried that, No success. Any suggestions? Im going to try maybe something like KJR.

(UPDATE)

Kerbal Joint reinforcement- Next, Has fixed the problem as I can see. 

Edited by Thomas Edison

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.