benjee10

[1.7.X] Shuttle Orbiter Construction Kit | Stockalike Space Shuttle Orbiter! | (Initial Release!) | v1.0.0

Recommended Posts

30 minutes ago, slaintemaith said:

Still getting complete aerodynamic wipe-out at 30km.
No matter how much fuel I xfer.

What other mods do you have installed? The only thing I can think of is some conflict changing either the atmosphere or fuel density. The shuttle is balanced so that it’s far more likely to suffer over-stability (i.e. inability to pitch up) over loss of control.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm using FAR and a Rescale for KSRSS.

And it's odd, since the balance was off when I loaded just the orbiter in to the SPH, but upon doing it again, seems fine.
So my install is most likely borked.

Is there a pretty version of SSRSS that I can bump up to 2.5x for 1.7.3?

I hate Kerbal.  =P
 

Edited by slaintemaith

Share this post


Link to post
Share on other sites
34 minutes ago, slaintemaith said:

I'm using FAR and a Rescale for KSRSS.

And it's odd, since the balance was off when I loaded just the orbiter in to the SPH, but upon doing it again, seems fine.
So my install is most likely borked.

Is there a pretty version of SSRSS that I can bump up to 2.5x for 1.7.3?

I hate Kerbal.  =P
 

FAR is almost certainly the cause of this - I haven’t tested it with FAR, but given the magnitude of the changes it makes to aero I’d expect that to cause major performance changes both on ascent and reentry. 

I don’t know much about SSRSS, but if you’re looking for an alternative, more realistic system to play in JNSQ is beautiful and plays really well with the shuttle. 

Share this post


Link to post
Share on other sites

Anyone have a problem with the shuttle stack going wacko and spinning out of control when rolling heads up?

Share this post


Link to post
Share on other sites
19 minutes ago, DJ Reonic said:

Anyone have a problem with the shuttle stack going wacko and spinning out of control when rolling heads up?

Doable roll on the SSMEs, control point set to -15 degrees, and take it slow. SSMEs having roll control can cause instability for some reason.

Share this post


Link to post
Share on other sites

hey @benjee10 when i load the craft file i get this error...
[EXC 18:19:01.480] Exception: Conflict found between ModuleB9PartSwitch (moduleID='wingTexture') on part benjee10.shuttle.deltaWing and ModuleB9PartSwitch (moduleID='wingTexture') on part benjee10.shuttle.deltaWing:
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()

can you help?

Share this post


Link to post
Share on other sites
1 hour ago, Insanity_BK said:

hey @benjee10 when i load the craft file i get this error...
[EXC 18:19:01.480] Exception: Conflict found between ModuleB9PartSwitch (moduleID='wingTexture') on part benjee10.shuttle.deltaWing and ModuleB9PartSwitch (moduleID='wingTexture') on part benjee10.shuttle.deltaWing:
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()

can you help?

There are known B9-errors. But you can ignore them, they are not gamebreaking.

Share this post


Link to post
Share on other sites
7 minutes ago, Cheesecake said:

There are known B9-errors. But you can ignore them, they are not gamebreaking.

actually it cant ignore it.... when i get the error it forces me to close KSP

Share this post


Link to post
Share on other sites

Brilliant work.  That said....I still think the IRL space shuttle was a dumb idea.

Share this post


Link to post
Share on other sites
2 hours ago, Insanity_BK said:

hey @benjee10 when i load the craft file i get this error...
[EXC 18:19:01.480] Exception: Conflict found between ModuleB9PartSwitch (moduleID='wingTexture') on part benjee10.shuttle.deltaWing and ModuleB9PartSwitch (moduleID='wingTexture') on part benjee10.shuttle.deltaWing:
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
  Two modules cannot manage the same material: shuttleUV2 (Instance) (Instance)
    B9PartSwitch.ModuleB9PartSwitch.CheckOtherSwitchers ()
    B9PartSwitch.ModuleB9PartSwitch.Start ()

can you help?

Not sure I’m afraid. Do you have module manager installed? Looks like it could be an issue with the optional extra for the Columbia-style wing strake texture.

Share this post


Link to post
Share on other sites
Just now, benjee10 said:

Not sure I’m afraid. Do you have module manager installed? Looks like it could be an issue with the optional extra for the Columbia-style wing strake texture.

should i uninstall the Columbia wing texture?

also i do have module manager installed

Share this post


Link to post
Share on other sites
3 hours ago, Thomas Edison said:

Any plans to create more launchers benjee?

Which launchers do you mean? There was only one space shuttle yet.

Share this post


Link to post
Share on other sites

When watching some youtube channels, you get the guy saying things like, "Hey you gotta smash that like button" in the tone of a 5 year old with enough volume to jump your headphones off your ears.  I was wishing I could smash the like button for this pack and its advertisement value.  Nice job and thank you, hope it plays well.  Been missing one since Bobcat days.

Share this post


Link to post
Share on other sites

Here's the shuttle launch segment for my trailer/demo/short of version 2 of Modular Launch Pads, using SOCK (it's timestamped):

 

Share this post


Link to post
Share on other sites
On 8/16/2019 at 12:57 PM, benjee10 said:

FAR is almost certainly the cause of this - I haven’t tested it with FAR, but given the magnitude of the changes it makes to aero I’d expect that to cause major performance changes both on ascent and reentry. 

I don’t know much about SSRSS, but if you’re looking for an alternative, more realistic system to play in JNSQ is beautiful and plays really well with the shuttle. 

Here's the thing: without FAR, the shuttle's cross-range on reentry is almost nil.  Trajectories or MechJeb Landing Predictions need to basically be dead on the money because nothing you do in atmo is going to affect where you land that much after deorbit burn.  You also get the nose-down attitude issues at lower altitudes, where it's difficult to pull up to land, and your speed bleeds off insanely--I can lose speed with my nose pointed down 20 degrees.

WITH FAR, you can skim in and out of the higher atmosphere to prolong your reentry and S-turn to correct for inclination shifts (these actually work in conjunction with one another.)  You don't have the "soupy" kerbal atmosphere, so speed control becomes an issue because you have to slow down when you're getting near the runway.  The only issue with FAR is the transitions from super sonic to subsonic around 20000-10000 meters.  For some reason all yaw seems to give way, and the ship just flat-spins until the atmo gets dense enough for the control surfaces to work.

Now I'm not saying it's your design.  Chances are it's actually how the atmosphere is set up in my world.  I'm using this, but 2.5x.

But I'd love to get all the things working well.  I'm just not sure where to look.  I'm using this mod, FAR, Kopernicus, KSRSS, Sigma, and Rescale.

Share this post


Link to post
Share on other sites

Hey! This might be a little much but, I'd like to ask if you might could quit using plume party for the plumes? There is no way to turn off stock configs that I know of for plume party and i'd like to just have the stock engines have the stock plume. Might be too hard. Just a request!

Share this post


Link to post
Share on other sites

Hey man, great mod! i don't mean to sound demanding but i have a suggestion, would it be possible to add some sort of Camera in the kerboarm end effector? that would definitely help with attaching it to the grapple fixtures!

Share this post


Link to post
Share on other sites
1 hour ago, tmccreight651 said:

Hey man, great mod! i don't mean to sound demanding but i have a suggestion, would it be possible to add some sort of Camera in the kerboarm end effector? that would definitely help with attaching it to the grapple fixtures!

Yes, it's possible with hullcam vds. Just needs a cfg patch for that

Share this post


Link to post
Share on other sites
6 hours ago, Marcelo Silveira said:

Yes, it's possible with hullcam vds. Just needs a cfg patch for that

Awesome! how would i go about doing that? im not very cfg savvy and i dont wanna break my game *sweatdrop*

Share this post


Link to post
Share on other sites
On 8/25/2019 at 6:49 PM, Thomas Edison said:

Hey! This might be a little much but, I'd like to ask if you might could quit using plume party for the plumes? There is no way to turn off stock configs that I know of for plume party and i'd like to just have the stock engines have the stock plume. Might be too hard. Just a request!

Can't you just uninstall Plume Party?

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/26/2019 at 1:49 AM, Thomas Edison said:

Hey! This might be a little much but, I'd like to ask if you might could quit using plume party for the plumes? There is no way to turn off stock configs that I know of for plume party and i'd like to just have the stock engines have the stock plume. Might be too hard. Just a request!

 

54 minutes ago, sslaptnhablhat said:

Can't you just uninstall Plume Party?

Deleting Plume Party entirely would break the plumes for the reDirect/SOCK engines as they use Plume Party FX in the main part CFG. 

If you didn't want to use Plume Party for the stock engines  you can just delete PlumeParty/Configs. Note that reDirect/SOCK engines will still have PlumeParty FX. The only way around that would be for you to personally patch them with standard stock plumes.

:/ I think Plume party is way better than stock plumes but hey everyone is entitled to their opinion)

Edited by Zorg

Share this post


Link to post
Share on other sites
Posted (edited)
17 hours ago, Zorg said:

 

Deleting Plume Party entirely would break the plumes for the reDirect/SOCK engines as they use Plume Party FX in the main part CFG. 

If you didn't want to use Plume Party for the stock engines  you can just delete PlumeParty/Configs. Note that reDirect/SOCK engines will still have PlumeParty FX. The only way around that would be for you to personally patch them with standard stock plumes.

:/ I think Plume party is way better than stock plumes but hey everyone is entitled to their opinion)

Hello @Zorg,

Is this the solution to the problems with "Restock", too?

--------------------------

Many Answers, thanks to @Zorg:

 

 

Edited by N3N

Share this post


Link to post
Share on other sites
On 8/30/2019 at 11:07 AM, Zorg said:

 

Deleting Plume Party entirely would break the plumes for the reDirect/SOCK engines as they use Plume Party FX in the main part CFG. 

If you didn't want to use Plume Party for the stock engines  you can just delete PlumeParty/Configs. Note that reDirect/SOCK engines will still have PlumeParty FX. The only way around that would be for you to personally patch them with standard stock plumes.

:/ I think Plume party is way better than stock plumes but hey everyone is entitled to their opinion)

I tried that earlier today. Is there a certain folder I need to delete? Sorry I'm not great with configs and stuff.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.