Sign in to follow this  
GrinchWSLG

Unity Reducing Texture Quality

Recommended Posts

I've created at part with a 1024x diffuse and normal map. In Unity it looks right but when I write it for game and look at in KSP, I'm seeing a pretty drastic drop in resolution on both the normal and the diffuse, almost like its halved the resolution. Is this to be expected? Is some settings in Unity I'm missing? I've played with most of the settings but nothing seems to increase the quality.

This isn't a debate about appropriate texture sizes for parts, just trying to figure out how to get a good quality texture in the game through Unity.

EDIT: I'd add pics but my pic account is in maintenance...

Edited by GrinchWSLG

Share this post


Link to post
Share on other sites

After you import a texture in unity if you click it some options should appear in the inspector tab. There are option for reducing resolution and changing compression. If you do change the compression look at for the file size because "true color" and "16 bit" compression options make the file size large.

http://grab.by/fRAE

Share this post


Link to post
Share on other sites

I played with all the options, including trilinear. It always looks like its just dumping the resolution. Here's some examples of what I'm seeing.

unityexample.jpg

kspexample.jpg

Share this post


Link to post
Share on other sites

Okay my last guess at the problem is the engine is mip mapping the texture. In case you don't know what that is the engine pretty much creates versions of your textures with lower resolutions. when you are far away from the object it will switch to a lower resolution mip map to save ram.

Figure%20-%20Mipmap%20Selection.jpg

Try maxing out your game and playing around with the settings in the settings.cfg file.

Share this post


Link to post
Share on other sites
Okay my last guess at the problem is the engine is mip mapping the texture. In case you don't know what that is the engine pretty much creates versions of your textures with lower resolutions. when you are far away from the object it will switch to a lower resolution mip map to save ram.

Try maxing out your game and playing around with the settings in the settings.cfg file.

This is what I'm thinking its doing, unless the conversion is just really terrible. Is there a settings.cfg guide somewhere for increasing graphics settings?

Does your part have a normal map? Invert the green channel on your normal.

That has pretty much nothing to do with this problem.

Share this post


Link to post
Share on other sites

From what I can tell, your game's settings are lower than normal. At least, going by the background in that screenshot - the floor looks low resolution (well, lower than normal), as does the mk1pod atop it.

Share this post


Link to post
Share on other sites

Trick I learned from C7 himself:

- Go to Unity and click your texture

- You will see option on the right and it stands currently on compressed.

- Change it to Truecolor

- ???

- Win

Share this post


Link to post
Share on other sites

I can only suggest this:

1. Try to reinstall game.

2. Try to force game's graphics setting using registry (this helped me).

3. Check your video drivers settings, maybe they overwrite game parameters.

Share this post


Link to post
Share on other sites

Your graphics card might be overriding the texture filtering, possibly...

Edit: basically what quadro's point 3. said.

Share this post


Link to post
Share on other sites

Heh, I finally fixed it with the regedit. Had to force the graphics setting. There's still some blockiness on my normal map, but I think that's a result of the unity conversion, the textures look much more acceptable now.

Thanks for your help guys.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this