linuxgurugamer

[1.5.1, 1.6.1, 1.7.2] TAC Fuel Balancer

Recommended Posts

Posted (edited)

Forum user @Z-Key Aerospace turned this mod over to me, original thread is here: https://forum.kerbalspaceprogram.com/index.php?/topic/139223-ksp-v145-tac-fuel-balancer-v220/

tac-splash.jpg

TAC Fuel Balancer

  • Easily refuel from space stations.
  • Keep your spaceplane or VTOL balanced.
  • Dump spare fuel before re-entry.
  • Lock and unlock tanks

This mod can transfer fuel, or other resources, between parts on the same vessel (including docked vehicles) from a simple GUI.

New Dependencies

Features

  • Transfer a resource into a part, drawing an equal amount from each other part.
  • Transfer a resource out of a part, transferring an equal amount into each other part.
  • Enable balance mode to transfer a resource such that all parts are the same percentage full.
  • Dump a resource out of a part. Note that the resource is lost, never to be found.
  • Lock a part, so that none of the resource will be transferred into or out of the part.
  • When still Pre launch (or Landed): edit the amount of a resource loaded in a part. Works on all resources, even solid rocket fuel.

Useful when you are flying along and need to quickly, and easily, transfer fuel from one tank to another. Or re-balance your fuel distribution to keep your centre of mass from getting too far out of whack.

Availability

 

 

This release had 4 betas, changes in each shown below:

2.21

  • Adoption by Linuxgurugamer
  • Rebuilt for 1.5.1, 1.6.1, 1.7.0
  • Removed all old toolbar code, about 1500 lines
  • Added support for the ToolbarController
  • Added support for the ClickThroughBlocker
  • Added fast toggles to fuel balance window
  • Added new settings:
    • ShowToggles
    • ShowTooltips
  • Make text in menu button yellow
  • Added settings option to make tooltips optional
  • Made edit mode only available when in sandbox mode (beginning of integrating career modes)
  • Added a stock settings page, works alongside current settings page
  • Added option to not use the KSP skin A
  • dded option to disable old settings window

2.21.1

  • Fixed InstallChecker to look for mod in PluginData directory
  • Fixed UI opening by default
  • Made the option to not show the Dump option only apply to the popup menu
  • Made the positioning of the toggles configurable and display optional of each
  • Made the pop-up menu optional
  • Added option to not show non-transferable resources
  • Changed location of saved config file from TacFuelBalancer\Plugins/PluginData/TacFuelBalancer\FuelBalancer.cfg to TacFuelBalancer\PluginData\FuelBalancer.cfg

2.21.2

  • Fixed build issue with embedded icon resources
  • Added info to help screens
  • Moved settings around a little bit
  • Added code to create the PluginData directory if it doesn't exist
  • Fixed tooltip not hiding when showing the popup-menu

2.21.3

  • Updated InstallChecker slightly
  • Disabled the old settings screen

2.21.4

  • Adjusted position of reset resource lists button
  • Added code to load images from disk if unable to load from resource
Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

This is great news! Thank you for all you do! To bring so many old-yet-useful mods forward to work with the current revisions of KSP must be a stupendous task.

Share this post


Link to post
Share on other sites
Posted (edited)

I don't know if you're adding functionality, but I'd like to request a "x0" (or paused) button for the resource transfer speed so that I can set up multiple ins and outs without it transferring to unrelated tanks?

Edited by Erzengel

Share this post


Link to post
Share on other sites

I'm not entirely sure which addon is having a problem here, but when I install TAC I don't get a toolbar, when I install Toolbar I don't get the old popup toolbar at all, but when I do install toolbar Controller I at least get the TAC image on the right KSP looking toolbar. Unfortunately when I click on it, I don't get the TAC menu popping up at all. This is all using CKAN and ensuring that I have updated the repositories.

 

Log file and debug keeps scrolling '
[EXC 21:11:16.171] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.2, Culture=neutral, PublicKeyToken=null' or one of its dependencies.'

Full log here: https://www.dropbox.com/s/5p7xxtqn6v574t8/KSP.log?dl=0

Share this post


Link to post
Share on other sites
1 hour ago, nullscan said:

I'm not entirely sure which addon is having a problem here, but when I install TAC I don't get a toolbar, when I install Toolbar I don't get the old popup toolbar at all, but when I do install toolbar Controller I at least get the TAC image on the right KSP looking toolbar. Unfortunately when I click on it, I don't get the TAC menu popping up at all. This is all using CKAN and ensuring that I have updated the repositories.

 

Log file and debug keeps scrolling '
[EXC 21:11:16.171] FileNotFoundException: Could not load file or assembly 'ClickThroughBlocker, Version=0.1.7.2, Culture=neutral, PublicKeyToken=null' or one of its dependencies.'

Full log here: https://www.dropbox.com/s/5p7xxtqn6v574t8/KSP.log?dl=0

I don't use CKAN, so I can't confirm the setup - but do you have ClickThroughBlocker installed?  It's a dependency.

Share this post


Link to post
Share on other sites
9 hours ago, DStaal said:

I don't use CKAN, so I can't confirm the setup - but do you have ClickThroughBlocker installed?  It's a dependency.

Sorry, should have confirmed it. Yes I do have it installed. If I don't have toolbar controller installed I don't get the scroll of errors in the dubugger though. 

Share this post


Link to post
Share on other sites

Nowhere in the mod description does it list ClickThrough or anything else as a "Dependency" I think that needs to be changed with a link to that mod for people installing it for the first time or doing it manually. 

Share this post


Link to post
Share on other sites
17 minutes ago, HGGundamReviews said:

Nowhere in the mod description does it list ClickThrough or anything else as a "Dependency" I think that needs to be changed with a link to that mod for people installing it for the first time or doing it manually. 

It's a dependency of Toolbar Controller and Toolbar - so it's not a direct dependency of this mod.  It is listed as a dependency of those mods.

Share this post


Link to post
Share on other sites

OK now that I read this thread I am starting to understand why I am having an issue.

I am back playing KSP after taking about a year off.  I was glad to see this mod pop up as compatible in CKAN recently.

I have downloaded this through CKAN and it does not require click through as a dependency.  Knowing this is a linuxgurugamer  maintained mod I had CKAN add ClickThrough and the toolbar.  Every time I added ClickThrough with CKAN it always told me the ClickThrough was old and it would ask to update.

End of the day, this is what I have tried:

1.  Download Tac Fuel Balancer on its own through CKAN.  This does not work

2.  Using CKAN install the Blizy Toolbar, ClickThrough, and Tac Fuel Balancer.  This does not work

3.  Download ClickThrough manually and then using CKAN install the Toolbar and Tac Fuel Balancer.  This also does not work.

I have been trying this for a bit now.  No big deal.

Does anyone have the trick to getting this to work?  I have not tried manually downloading Tac Fuel Balancer on its own yet.

 

Share this post


Link to post
Share on other sites
35 minutes ago, Craig D said:

OK now that I read this thread I am starting to understand why I am having an issue.

I am back playing KSP after taking about a year off.  I was glad to see this mod pop up as compatible in CKAN recently.

I have downloaded this through CKAN and it does not require click through as a dependency.  Knowing this is a linuxgurugamer  maintained mod I had CKAN add ClickThrough and the toolbar.  Every time I added ClickThrough with CKAN it always told me the ClickThrough was old and it would ask to update.

End of the day, this is what I have tried:

1.  Download Tac Fuel Balancer on its own through CKAN.  This does not work

2.  Using CKAN install the Blizy Toolbar, ClickThrough, and Tac Fuel Balancer.  This does not work

3.  Download ClickThrough manually and then using CKAN install the Toolbar and Tac Fuel Balancer.  This also does not work.

I have been trying this for a bit now.  No big deal.

Does anyone have the trick to getting this to work?  I have not tried manually downloading Tac Fuel Balancer on its own yet.

 

Do you have the Toolbar Controller in addition to Blizzy's Toolbar? I've installed all my mods with CKAN and don't have probllens. You could post a log so we could see what's going wrong.

Share this post


Link to post
Share on other sites

Hello Tonka,

TLDR - the Toolbar Controller fixed it once I manually downloaded Click Through Blocker and put it in the game folder.

I have been reading these forums for a couple of years and have been fearing the day I needed to find my "log" for something like this.  It took me a while and it was in the last place suggested %USERPROFILE%\AppData\LocalLow\Squad\Kerbal Space Program\output_log.txt.

So you are using CKAN.  Does it load the correct version of Click Through Blocker?  Mine always loads the old version and during booting it ask if I want to download a newer version.  When using the old file, I see a lot of errors in KSP.log showing a Click Through Blocker error.

Here is my fix:

Manually install latest version of Click Through Blocker.  Then launch CKAN and load Toolbar Controller and Tac Fuel Balancer.  Now the mod works as I remember it.

Do you still want to see my log?  I have now found it but I don't think it will be helpful now.

Thanks for the help,

-Craig

Share this post


Link to post
Share on other sites
Posted (edited)

@Craig D If you have everything working I don't need to see a log.

I prefer to stick to CKAN for almost all of my mods. I know @linuxgurugamer sometimes will put out pre-release or beta updates of mods that will trigger the notice that updates are available, but these won't be listed in CKAN. Unless the beta version fixes a problem I've noticed I usually just wait until it becomes the mainstream release and CKAN lists it.

I'm also pretty strict about checking the mod threads before I install ANY update, just to get a feel if it might be a game breaker and need to do a full game backup before updating. 

Edited by Tonka Crash

Share this post


Link to post
Share on other sites
50 minutes ago, Tonka Crash said:

I know @linuxgurugamer sometimes will put out pre-release or beta updates of mods that will trigger the notice that updates are available, but these won't be listed in CKAN.

I try to avoid that, but sometimes it's unavoidable

Share this post


Link to post
Share on other sites
Posted (edited)

Ah, well I guess I'll manually install Click Through and see if it fixes the problem. My issues are the same as @Tonka Crashs

 

EDIT: Yup, that did it. Guess it's more of a toolbar problem as I got the floating toolbar back after manually installing click through 

Edited by nullscan

Share this post


Link to post
Share on other sites

@linuxgurugamer I checked and CKAN does not have ClickThroughBlocker or Toolbar Controller defined as dependencies for this mod. It might cut down on some of the questions if this were corrected.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Tonka Crash said:

@linuxgurugamer I checked and CKAN does not have ClickThroughBlocker or Toolbar Controller defined as dependencies for this mod. It might cut down on some of the questions if this were corrected.

Oops (fixing it now)

CKAN updated

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

I launched CKAN and it told me I should update the TAC fuel Balancer so I thought maybe this has been fixed.  I removed both the balancer and the (manually deleted) Click Through Blocker.  I should have left it alone.

I don't need this mod where I am at currently.  I will do what I did above tomorrow to fix this.  I then launched CKAN and loaded Click Through Block and TAC fuel Balancer (trying to avoid having manually installed mods).  Now when launching the game it told me both TAC fuel balancer and Click Through Blocker are out of date and suggested I update those mods.  Which I would only be able to do manually so I will skip it for now.

I don't know where the CKAN forums are, maybe I should move my discussion to where that thread is.  I know they have an old and new forum but did not spend enough time after that looking for the correct one.  Maybe I will figure it out tomorrow at work.

So just a heads up, thanks,

-Craig

Share this post


Link to post
Share on other sites

@Craig D Maybe it's time to share a log. This morning I got the notice from CKAN that the metadata for TacFuelBalancer had changed, so I reinstalled it today.

What versions of things are you getting? I installed with CKAN for KSP 1.7.3 and get the following:

  • Click Through Blocker 1.7.2
  • Toolbar Controller 1.8.2
  • Toolbar 1.7.22.1
  • TacFuelBalancer 2.21.4

I'm not seeing messages about being out of date.

Share this post


Link to post
Share on other sites

Hello Tonka Crash,

I really hate to ask this next question.  For adding the file to DropBox it will only let me invite someone through email.  I know DropBox change a bit last year but I have not used it for a while.  Am I supposed to know an email address to invite?

With that said, I am wondering if this is a CKAN issue.

Here are my versions.

  • KSP 1.7.3
  • CKAN 1.26.2 (says that is the latest version)
  • Click Through Blocker 0.1.6.10  - It says it is the latest version.  It also says Max KSP using mod version 0.1.7.2    -   interesting
  • Toolbar Controller 0.1.8.2
  • Toolbar 1.7.22.1
  • TacFuelBalancer 2.21.4 

Today I am only getting a message about updating Click Through Blocker when launching the program.

Thanks again for the help,

-Craig

Share this post


Link to post
Share on other sites

@Craig D I think I found your problem. What versions of KSP do you have set as compatible versions in CKAN

68747470733a2f2f692e696d6775722e636f6d2f

The latest version of ClickThroughBlocker is restricted to 1.5.1-1.7.2, but the older version you have is listed for 1.5.1 and later with no upper limit. You need set CKAN to see mods released for older releases of KSP as compatible or you run into problems like what you are seeing. I have 1.4, 1.5, 1.6, 1.7 all set. If you haven't set these CKAN will only install mods explicitly listed as compatible with only 1.7.3. Please don't make me go through spiel about how most mods for 1.4 or later work fine in later versions of KSP.

 

Share this post


Link to post
Share on other sites

Hello Tonka Crash,

You are a rock star!  That fixed it.  Honestly I don't know how long I would have gone before figuring something like that out.

I did not have any of them clicked.  Once I clicked on 1.4, 1.5, 1.6, and 1.7 I then saw the correct Click Through Blocker in CKAN.  

Thank you very much for the help!

-Craig

Share this post


Link to post
Share on other sites

Hi @linuxgurugamer, is there a way to allow fuel editing after launch? I'm not trying to cheat or anything, it's just that I'm experiencing a really nasty bug that causes fuel tanks to instantly empty when locking and unlocking them. I was hoping to use your mod to refill the tanks when that happens, but unfortunately there doesn't seem to be an option to allow fuel editing at any point after launch. Thanks!

Share this post


Link to post
Share on other sites
2 hours ago, cosekantphi said:

Hi @linuxgurugamer, is there a way to allow fuel editing after launch? I'm not trying to cheat or anything, it's just that I'm experiencing a really nasty bug that causes fuel tanks to instantly empty when locking and unlocking them. I was hoping to use your mod to refill the tanks when that happens, but unfortunately there doesn't seem to be an option to allow fuel editing at any point after launch. Thanks!

You have to enable that in the settings

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

You have to enable that in the settings

That'd be under difficulty settings, right? I can't seem to find the setting for this.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.