Jump to content

[1.8.x] DE_IVAExtension - For All the Stock Pod IVAs!


Recommended Posts

1 hour ago, kennyboy said:

I would love to..... how would I go about doing that?  

ps.... Every update that is available is thru CKAN and I'm running the latest version of Kerbal

 

 

Gawd,  I'm so ignorant regarding these issues and the how to's....... anyway, thank you for walking me through all of this.  Steep learning curve on my end.

I've copied the Player txt and output_log txt. Should I just email them to you?

Edited by kennyboy
Link to post
Share on other sites
1 hour ago, kennyboy said:

Here you gooooooo

 

Thanks.  Doesn't look like it's what I thought it might be....but you do have a number of mods that interact with RPM.  I'll try to reproduce the issue later on, but you might want to try removing some of these:

  • NearFutureProps
  • Astrogator
  • DockingPortAlignmentIndicator

Posting the log file from after you reproduce the issue might be more useful too, if something is going wrong in the code instead of part loading.

Also, can you post a screenshot of what isn't working specifically?  And which part specifically you're trying to use?  There are a lot of cockpits named "mk"

Edited by JonnyOThan
Link to post
Share on other sites

removed the items listed above..... no change to the game issues

took several screen shotsF2C2D474A74B28332024A3CE57625E20EE8A1C6B44108BEA2954FC3490DC92D8422E95E2352767D0

top image is the Mk1-3 the push buttons on the three screens do not work

The bottom image is the ALCOR pd b..... All the buttons on the screens work

link to files just after I tried the mods.... moments before.

https://drive.google.com/drive/folders/1ylYX_iqiNiiskOpGdTaivXNP_JpJ_ia-?usp=sharing

 

Thank YOU again for looking into all of this......  : )

Link to post
Share on other sites
10 hours ago, kennyboy said:

The bottom image is the ALCOR pd b

I don't think that's correct...it looks like the stock RPM mk1pod IVA.  Notably, the MFDs there are the RPM defaults and the ones that aren't working are the ASET/ALCOR ones.

Your logs indicate the error:

[RasterPropMonitor]: Failed loading font texture "ASET/ASET_Props/MFDs/Fonts/mainfont" - missing texture?
[RasterPropMonitor]: INITIALIZATION ERROR, CHECK CONFIGURATION.
DirectoryNotFoundException: Could not find a part of the path "C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ASET\ASET_Props\MFDs\Fonts\fontDefinition.txt".

So it seems like your ASET props are somehow not installed correctly.  That file exists in the rar file here: https://spacedock.info/mod/1204/ASET Props . How did you go about installing the ASET props?

Link to post
Share on other sites

https://drive.google.com/drive/folders/1ylYX_iqiNiiskOpGdTaivXNP_JpJ_ia-?usp=sharing

 

The Link above includes some images of the files loaded into my Game Data within KSP

I checked: 

The top image, Manufacturer MK1-3 Command Pod, Kerlington Model Rocket and Paper Products Inc

The bottom image, Manufacturer A.S.E.T. Alcor Pod (b)

Other Information:

Below are the dependent Mods for the ED_IVAExetention Mod, The ED mod and the below mods are also installed

ASET Props Pack V. 1.5.0

Mod Manager V. 4.1.3

Toolbar Controller V. 1.9.4

Click Through Blocker V. 1.9.5

RPM V. 31.2

RPM Cor 31.2

 

 

Also have 

ASET Agency V. 1.0

Link to post
Share on other sites

HOUSTON....

We Have Lift OFFFFFFFFF

That seems to have worked....

All of this exchange for that? I cant thank you enough for your time regarding this matter....I love this game and the IVA aspect takes it to a whole new level.

I'll be testing it all out and I'll let you know how its working....    :)

Ken

Link to post
Share on other sites
1 hour ago, kennyboy said:

Well,

Real Close,   the Mk-2 pod by C7 Aerospace division doesn't have the updated screen. But the Mk-1 does..... so thats good!

The mk2 is a making history pod, and DE_IVAExtensions only includes the non-DLC pods.  Try here for the MH ones: 

 

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
8 hours ago, Flo94 said:

I get stuck at Loading Expansions. The pictures shift (I am not getting Not Responding), but it won't load. Worked just fine before adding these mods. 1.9.0 , using Linux. Any suggestions will be greatly appreciated! 

Try adding the mod dependencies one at a time to figure out which one breaks the game. Log files are also useful.

Link to post
Share on other sites

First of all, awesome work! I have been waiting for a proper IVA experience for a long time. It adds a completely another dimension to the game.

 

However, for some reason all the glowing text on the panel and displays are unreadable. Some of the text (for example on SAS buttons) is readable until I turn on the panel lights.

Screenshots:

https://imgur.com/a/r8FaIsx

Also whenever I enter into an IVA, I get this message spammed in my Player.log
 

OpenGL Error: Invalid texture unit!

(Filename: ./Runtime/GfxDevice/opengles/DeviceStateGLES.cpp Line: 72)

Player.log:

https://drive.google.com/open?id=1pQAFRvLxBcK7ggnp9dmf6NY8cNQjRRDH

 

I tested it with minimal install. I installed DE_IVAExtension and its dependencies through CKAN. KSP 1.8.1 with both DLSs, running on Linux.

 

Thanks in advance for any help or information which might help me to fix the problem!

Link to post
Share on other sites
On 2/23/2020 at 7:38 AM, Hyperr said:

When I use this I the cameras dont work, could someone help?

 

To use cameras, you need a camera mod such as Hullcam VDS. Are you using a particular camera mod?

2 hours ago, banditsan said:

Why ToolbarController and ClickThroughBlocker listed as dependencies if they are not used by mod?

They are dependencies of dependencies.

Link to post
Share on other sites
19 hours ago, EscapeVelocity said:

However, for some reason all the glowing text on the panel and displays are unreadable. Some of the text (for example on SAS buttons) is readable until I turn on the panel lights.

In case anyone else has the problem, I was able to "fix" the issue I had by setting OpenGL context level to 4.2 with following command line option for KSP:

-force-glcore42

Anything above 4.2 will not work.

Also, it seems to be related to a Unity bug for Linux https://issuetracker.unity3d.com/issues/linux-3d-with-extras-projects-will-throw-constant-opengl-error-invalid-texture-unit-errors

 

Now I can finally enjoy my IVAs :)

8 minutes ago, KriLL3 said:

Any plans on expanding this to the making history pods?

For Making History pods there this mod available which does that:

 

Link to post
Share on other sites

Hey folks,

Without elaborating too, too much - because my head is about to overheat from frustration - I can't get well anything to work, at all really. Been fighting with GameData folder all afternoon (see img links).

What in the H could i be doing wrong?

https://drive.google.com/file/d/10qH_lpxyuIEy6z04NDTFCgrq237czAXZ/view

https://drive.google.com/open?id=1RQOcptwZVJqIXOhv1as9dBMbmh9lvpuX

https://drive.google.com/open?id=1XlZeN4cShoy3GXV0wtHK8kFz-5zndkzO

https://drive.google.com/open?id=1uXcXtUHhjstsntkareIk3m5Tz5b_r5pW

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...