Jump to content

[1.9.x] Orbital Utility Vehicle aka Orbital Tug


Recommended Posts

Just now, zer0Kerbal said:

short range operation yes, but a tug for intrasolar operation? say from Kerbin to Mun? or further. Am currently too busy to do such, but just thoughts. :)

Then it's not for this.  This is a utility vehicle, for short range operations, IMHO

I am open to discussion about this

Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

Then it's not for this.  This is a utility vehicle, for short range operations, IMHO

I am open to discussion about this

as am I - not a high priority, maybe if requested (allot) will do - found a great little mod that allows for 4 or more modes on a single engine - :P but that is for the possible future.

Link to post
Share on other sites
On 8/8/2019 at 9:36 PM, Targus said:

It's a 1.0 hyper engine from hyper drive mod https://www.curseforge.com/kerbal/ksp-mods/hyper-drive made by @Exodus_Solis  

Interesting.  I just took a look at that mod.  It's listed on Curse a public domain, but he claims that these are all stock which he's modified.  Unfortunately, I believe the mod consists of copyrighted Squad part files and slightly modified

Link to post
Share on other sites
On 8/4/2019 at 10:52 PM, kerbalx75 said:

could you continue my mod Kerbal Traits 

I could, but other than it being a MM config, and having a class which makes no sense (Ranger), what sort of support do you expect it to need?

5 hours ago, FreeThinker said:

@zer0Kerbal I created a pull request with the fix for KSPIE compatibility

I'm glad I saw this.  @FreeThinker Next time, please ping me as well, otherwise email can get lost 

Link to post
Share on other sites
3 hours ago, madindehead said:

This looks really interesting. Going to keep an eye on this! The only annoyance...the textures :0.0: I'm very picky with things looking stockalike :blush: Ah well. I can live with it I'm sure!

Stock alike colors are for rockets, planes, etc.  this is a construction vehicle, makes sense for it to be yellow, easier to see, etc.

that being said, if someone were to reskin it in stockalike colors, I’d be willing to include them as a varient.  At this point, I thing the colors would need to match the new stock colors, not the old ones

16 hours ago, FreeThinker said:

@zer0Kerbal I created a pull request with the fix for KSPIE compatibility

I’ll do a release of this later today.

See the first part of this  message above, wondering if you would be interested?

Edited by linuxgurugamer
Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

Stock alike colors are for rockets, planes, etc.  this is a construction vehicle, makes sense for it to be yellow, easier to see, etc.

that being said, if someone were to reskin it in stockalike colors, I’d be willing to include them as a varient.  At this point, I thing the colors would need to match the new stock colors, not the old ones

See the first part of this  message above, wondering if you would be interested?

Retexturing is not my thing, but perhaps  @silversliver is intrested in doing retexture job?

Edited by FreeThinker
Link to post
Share on other sites
  • 1 month later...

Linux,

Quick question, I noticed there are RCS on the tugs grappler body however they do not appear to be operational. I have also right clicked on the part outside the VAB to see if they needed to be activated but there does not appear to be an option. Am I missing anything?

Syrius

Link to post
Share on other sites
16 hours ago, Syrius said:

Linux,

Quick question, I noticed there are RCS on the tugs grappler body however they do not appear to be operational. I have also right clicked on the part outside the VAB to see if they needed to be activated but there does not appear to be an option. Am I missing anything?

Syrius

do you mean the core?

(the part with all the fuel, and 4 grappler arms)

if so - it has a thruster power of 15 (internally scaled to 10%) using ModuleRCSFX.

have you turned on RCS while in flight?

 

Edited by zer0Kerbal
Link to post
Share on other sites
2 hours ago, zer0Kerbal said:

do you mean the core?

(the part with all the fuel, and 4 grappler arms)

if so - it has a thruster power of 15 (internally scaled to 10%) using ModuleRCSFX.

have you turned on RCS while in flight?

 

Yes that would  be the part and yes I have. As a matter of fact the craft was using the RCS on the crew module (from a different mod) just fine but those on the tug were non-op.

I will see if I can get some more information as it seems to be working for you, yes?

 

Syrius

Link to post
Share on other sites
1 hour ago, Syrius said:

Yes that would  be the part and yes I have. As a matter of fact the craft was using the RCS on the crew module (from a different mod) just fine but those on the tug were non-op.

I will see if I can get some more information as it seems to be working for you, yes?

 

Syrius

just tried it. works. reason you might not be seeing effects is that by default the RCS is turned down to 10% - try using the RMB/PAW to turn up the RCS - and you should see the effects.

Link to post
Share on other sites
  • 2 months later...

Slight issue;
Installed via CKAN, textures aren't loading for any part save the cockpit. B9 part switch says it can't find them on load. 

What have I done wrong? 

EDIT: Manual install from Spacedock worked fine. Missing texture files in the version listed on CKAN

Edited by Dep_Opt
update
Link to post
Share on other sites
1 hour ago, Dep_Opt said:

Slight issue;
Installed via CKAN, textures aren't loading for any part save the cockpit. B9 part switch says it can't find them on load. 

What have I done wrong? 

EDIT: Manual install from Spacedock worked fine. Missing texture files in the version listed on CKAN

hi, i don t  think so, i installed this mod few days ago via ckan and all was fine.

Link to post
Share on other sites
1 hour ago, Dep_Opt said:

Slight issue;
Installed via CKAN, textures aren't loading for any part save the cockpit. B9 part switch says it can't find them on load. 

What have I done wrong? 

EDIT: Manual install from Spacedock worked fine. Missing texture files in the version listed on CKAN

Sounds like you got it before the textures were updated.  Refresh it and try again

Link to post
Share on other sites
  • 4 months later...
3 hours ago, RainDreamer said:

Digging up this old thread here for a question: The antenna doesn't work with remote tech for some reason.

Any one know a reason why?

neither @linuxgurugamer or myself play with RemoteTech (IIRC).

So neither one of us (or anybody else it seems, until now) have tested the patch that is there. Shocking I know. :D

SO if you want to supply the fix (or anybody), I am confident that @linuxgurugamer will include it in this mod. :)

Edited by zer0Kerbal
Link to post
Share on other sites
3 hours ago, zer0Kerbal said:

neither @linuxgurugamer or myself play with RemoteTech (IIRC).

So neither one of us (or anybody else it seems, until now) have tested the patch that is there. Shocking I know. :D

SO if you want to supply the fix (or anybody), I am confident that @linuxgurugamer will include it in this mod. :)

I actually wrote a patch that somehow works despite basically being a copy of your patch, so it was weird... and might be just interaction with some other mods and/or load order.

That said I have been trying to remove the antenna model you added for the drone pod (why disable the super useful service bay for the antenna when you have a separate antenna part already?) to no avail. I am not that good with MM patch and I haven't dare touch the main RT patch in the mod since it is managed by CKAN, so I have been writing a patch for a patch lol.

I will now try messing a little bit with the MM patch you have and see if it somehow works and let you know.

Link to post
Share on other sites

@linuxgurugamer & @zer0Kerbal

So I rewrote the MM patch for Remote Tech, restoring the service bay to the drone pod while removing the antenna & giving it passive antenna of 1Mm, also included the drone antenna part in the patch as that has been missing (which is why it didn't work). 

Module Data Transmitter also have to be removed apparently, and module SPU should be SPU passive (I have no idea why since I copy from another remote tech patch, but it works).

//DronePod
@PART[DronePod]:NEEDS[RemoteTech]:FOR[OrbitalTug]
{
	!MODULE[ModuleDataTransmitter] {}
	
	%MODULE[ModuleSPUPassive] {}
	
	%MODULE[ModuleRTAntennaPassive] {
	%OmniRange = 1000000
	
	%TRANSMITTER {
			%PacketInterval = 0.3
			%PacketSize = 2
			%PacketResourceCost = 15.0
		}	
	}
}

//////////////////////////////////////////////////////
//DroneAntenna
@PART[droneAntenna]:FOR[OrbitalTug]:NEEDS[RemoteTech]
{
	
	!MODULE[ModuleDataTransmitter] {}

      	%MODULE[ModuleRTAntenna] {
		%Mode0DishRange = 0
		%Mode1DishRange = 90000000
		%EnergyCost = 0.82
		%DishAngle = 25.0
		
		%TRANSMITTER {
			%PacketInterval = 0.2
			%PacketSize = 2
			%PacketResourceCost = 12.0
            }
        }

        %MODULE[ModuleSPUPassive] {}
}

/////////////////////////////////////////////////////
//demolitionDroneKIS,impactDrone
@PART[helperDrone,demolitionDroneTAC,demolitionDroneKIS]:NEEDS[RemoteTech]:FOR[OrbitalTug]
{
	!MODULE[ModuleDataTransmitter] {}	

	%MODULE[ModuleSPUPassive] {}
	
	%MODULE[ModuleRTAntennaPassive]	{
		%OmniRange = 500000
		
		%TRANSMITTER {
			%PacketInterval = 0.15
			%PacketSize = 2
			%PacketResourceCost = 12.0
		}
	}
}

Also off topic, but you guys think you can make a stand alone carrier module without the push tug? That is way more than what I can do.

Edited by RainDreamer
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...