Jump to content

[1.12.x] ShipEffects Continued


linuxgurugamer
 Share

Recommended Posts

JlqFcXq.jpg

ShipEffects Continued is a continuation of @ensou04's ShipEffects mod.  Originally continued by @Galileo, he asked me to take it over since he didn't have time for it. 

Original thread here:  https://forum.kerbalspaceprogram.com/index.php?/topic/103113-wip-shipeffects-sound-mod-dynamic-ship-sound-effects-now-released/

Previous thread here:  https://forum.kerbalspaceprogram.com/index.php?/topic/161673-ksp-142-shipeffects-continued-1084/

 

 

So, what does this mod do? Let me quote the original developer:
 

 

  Quote

We all wished we could hear our spaceship cry while entering Eve, or accelerating with a bunch of Mainsails. This mod fills in the remaining gap in the sound effects part. This adds rattles, vibrations, stress sounds to your ship depending on how much thrust, gravitational and atmospheric forces is your ship enduring.

 

Availability

Creating your Own SoundPack:

Simply replace the sound files in the sounds folder with your own, using the same file names. Format used for the sound files is .wav
.OGG might work. Does not support other formats though.

Loops are the best used for this. Make sure your peak db is around -6db, this ensures we don't clip the speakers.

 

These are the default settings. Volume controls for this are of the same name.  Please note that these settings have been moved from a config file into the stock settings page


	OnlyInIVA			= 	true
	
	masterVolume 			= 	1.0
	rattleVolume 			= 	1.0
	vibrationVolume 		= 	1.0
	rumbleVolume 			=	1.0
	thumpVolume 			= 	1.0
	stressVolume			= 	0.6
	atmosphereVolume 		= 	0.6
	
	// Default is 1.0, exaggerates or eases the value that controls the sound. a higher number means Sounds will play sooner, lower means later.
	ResistMultiplier		=	1.75	
	
	// Default is 8.0, how much g-force to simulate during re-entry
	ReEntryMultiplier		=	8.0

 

 

Edited by linuxgurugamer
Link to comment
Share on other sites

Hey @linuxgurugamer,

Just installed on a fresh (but modded) install and received the following message:


Incorrect Haystack Continued Installation: Haystack Continued has been installed incorrectly and will not function properly. All files should be located in KSP/GameData/HaystackContinued/Plugins. Do not move any files from inside that folder.

Incorrect path(s):
GameData\ShipEffectsContinued\Plugins\ShipEffectsContinued.dll

 

Note that I do not have Haystack Continued installed at all. 

Logs: https://1drv.ms/u/s!AoyHZiRU1jT-zbdPmwwoaYTI2u38dg?e=43GpUG

 

Thanks!

Link to comment
Share on other sites

10 minutes ago, eightiesboi said:

Hey @linuxgurugamer,

Just installed on a fresh (but modded) install and received the following message:


Incorrect Haystack Continued Installation: Haystack Continued has been installed incorrectly and will not function properly. All files should be located in KSP/GameData/HaystackContinued/Plugins. Do not move any files from inside that folder.

Incorrect path(s):
GameData\ShipEffectsContinued\Plugins\ShipEffectsContinued.dll

 

Note that I do not have Haystack Continued installed at all. 

Logs: https://1drv.ms/u/s!AoyHZiRU1jT-zbdPmwwoaYTI2u38dg?e=43GpUG

 

Thanks!

Oops.

that's the InstallChecker, looks like I forgot to change  a string.  You can ignore it until I get an update out

New release, 1.0.9.1

  • Fixed Installchecker string
Edited by linuxgurugamer
Link to comment
Share on other sites

No worries. With all the mods you maintain and develop, it's amazing that everything generally works so well! Squad (er, Star Theory) should have already made you an offer you can't refuse!

 

And by the time I had said "no worries" you had already fixed it. Lol. Thank you!

Edited by eightiesboi
Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Hello @HiDeN_GS,

It is really hard to diagnose problems with modded installs without the log files. This post explains where they are but please remember to use a service like dropbox or google drive to host the files and then link to them here in the forum. The reason for this is that posting complete log files into the forum cause loading issues for some threads and make it hard to read on mobile devices.

 

Link to comment
Share on other sites

  • 3 months later...

First I also didn't think the mod wouldn't work - I didn't realize it only plays the sounds in IVA, which I don't use very often. Now I tried it, and it's frikkin' terrifying - I love it :D

Would it be possible to enable it also in external view?

One thing that irritated me though was a constant (i.e. every second or so) staging sound - is that normal?

EDIT: seemed to be a temporary issue...

Edited by infinite_monkey
Link to comment
Share on other sites

New release, 1.0.11

  • Moved settings from cfg file to settings page
16 hours ago, infinite_monkey said:

Staging sound is back :( I'm not quite sure, but I think it happens when launching the vessel from VAB, but not when it's reloaded.

Please post a log file, it didn't have it happen when I was testing the config changes

Edited by linuxgurugamer
Link to comment
Share on other sites

Wow, that update was fast :D

19 hours ago, linuxgurugamer said:

Please post a log file, it didn't have it happen when I was testing the config changes

I did some further tests. It happens with the Onion command module (from Making History), but not with the Mk1. Maybe it has nothing to do with ShipEffects and comes from Stock?

I don't think it'll be of much help, but here is a logfile. Launch happens near the end with the SoundFXTest vehicle.

Link to comment
Share on other sites

2 hours ago, infinite_monkey said:

Wow, that update was fast :D

I did some further tests. It happens with the Onion command module (from Making History), but not with the Mk1. Maybe it has nothing to do with ShipEffects and comes from Stock?

I don't think it'll be of much help, but here is a logfile. Launch happens near the end with the SoundFXTest vehicle.

If it's the Onion, then it's probably a stock bug.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...