Jump to content

[KSP1.12.x] RealPlume - Stock v4.0.8 & RealPlume v13.3.2 [25/JUN/2021]


Zorg
 Share

Recommended Posts

On 10/19/2021 at 6:31 AM, bigboibru said:

Will realplume-stock also defer to Waterfall if Waterfall sounds are defected on an engine?

Realplume does not defer to waterfall configs automatically. The deconflicting patches need to be written on a case by case basis.

6 hours ago, Dakitess said:

Wether i'm using Waterfall or without it, I don't feel like Realplume is working, what do you think based on theses images, one from the ground and the other one in orbit ? 

It seems to me that RealPlume used to make a wider plume in the vacuum.

 

 

 

Any idea ?

Everything looks correct at a glance to be honest. Can you post your modulemanager.log and modulemanager.configcache files?

Though might be a good idea to make sure Smokescreen, RealPlume and RP-stock were installed correctly (maybe missing files in a copy paste). Try reinstalling and if still no luck please post the files above.

Link to comment
Share on other sites

I did reinstall, first was from Github and next from SpaceDock, had the same doubt, but same result. Not looking ugly by any mean, but I thought to recall some plus more different from stock than this, hence my questions :)

Don't have a ModuleManager.log, only ConfigCache, ConfigSHA, Physics, TechTree. How can I send to you ?

If it seems okay to your eyes, then fair enough :)

 

Link to comment
Share on other sites

11 minutes ago, Dakitess said:

I did reinstall, first was from Github and next from SpaceDock, had the same doubt, but same result. Not looking ugly by any mean, but I thought to recall some plus more different from stock than this, hence my questions :)

Don't have a ModuleManager.log, only ConfigCache, ConfigSHA, Physics, TechTree. How can I send to you ?

If it seems okay to your eyes, then fair enough :)

 

Sorry I meant your install folders looked correct, the plumes are definitely wrong, they are stock plumes. 

Modulemanager.log is inside Kerbal Space Program/Logs/ModuleManager

can share via dropbox, google drive (public link), wetransfer etc. 

Link to comment
Share on other sites

Thanks for your help :) i've now reinstalled WaterFall + WaterFall Stock as I needed it for some footage, so don't be suprised if they show somewhere :p

KSP.log (might help as well ?) https://drive.google.com/file/d/19cepoNmqqHYGJ23WwTdoxu0ruM834YnD/view?usp=sharing

ModuleManager.log : https://drive.google.com/file/d/1wyQGfZeudWMgltAS-3J-PN-0HdPe4QUg/view?usp=sharing

ModuleManager.configCache https://drive.google.com/file/d/1swMG_mSTRMPm7wa9z5Zry_tMeUpADN_z/view?usp=sharing

Link to comment
Share on other sites

Do you have any news about my issue ?

Just to know, don't want to be rude or anything, no rush, your time of course :)

Edit : Okay ! So, someone from Reddit (thanks :p) told me remove !stockwaterfalleffect in the first line of rapier cfg in realplume-stock fodler and it did the trick.

But unfortunately, it also deeply impact performance and i'm about the same amount of FPS than with the Rapiers Waterfall Config, barely more... I'll have to pass on specific Rapiers plume then, have too much of them haha

Thanks again ;)

Edited by Dakitess
Link to comment
Share on other sites

4 hours ago, Dakitess said:

Do you have any news about my issue ?

Just to know, don't want to be rude or anything, no rush, your time of course :)

Edit : Okay ! So, someone from Reddit (thanks :p) told me remove !stockwaterfalleffect in the first line of rapier cfg in realplume-stock fodler and it did the trick.

But unfortunately, it also deeply impact performance and i'm about the same amount of FPS than with the Rapiers Waterfall Config, barely more... I'll have to pass on specific Rapiers plume then, have too much of them haha

Thanks again ;)

Oh sorry I got a bit busy and didn't have a chance to look.

unfortunately the realplume config for the rapier is quite a heavy effect. I never really dealt with atmo engines and this config was provided by a kind community member. Its very impressive but demanding.

You could also try going to RealPlume-Stock/Squad and deleting RAPIER.cfg and changing  RAPIER_OLD.txt to RAPIER_OLD.cfg

RAPIER_OLD does not look as impressive but its an older config from before my time and will be less demanding on fps. I'm not sure how it compares with waterfall-stock's rapier config. But worth a try perhaps?

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
  • 4 weeks later...

I have a question regarding this mod and Waterfall.  I downloaded Waterfall as it was a requirement for Far Future Technologies, but I actually prefer the RealPlume plumes.  Is there a way that I can make RealPlume take priority over Waterfall, rather than vice versa? 

Link to comment
Share on other sites

On 1/19/2022 at 5:38 AM, ble210 said:

I have a question regarding this mod and Waterfall.  I downloaded Waterfall as it was a requirement for Far Future Technologies, but I actually prefer the RealPlume plumes.  Is there a way that I can make RealPlume take priority over Waterfall, rather than vice versa? 

if you play with stock make sure you don't install install the mod "stock waterfall effects". That should be all I think.

if you play with restock make sure you dont install "waterfall restock". In addition go to realplume-stockConfigs/Restock and remove !WaterfallRestock from the NEEDS lines for all engines. eg:

@PART[liquidEngine3_v2]:NEEDS[ReStock,!WaterfallRestock]:AFTER[ReStock]

to 

@PART[liquidEngine3_v2]:NEEDS[ReStock]:AFTER[ReStock]

You need to do the same for any other mods you might have that have waterfall deconflicting syntax like this. For examples Knes, Tantares etc.

Edited by Zorg
Link to comment
Share on other sites

  • 3 weeks later...

Hi @ZorgOld issue... hope there's a fix for the loud bang sound when a ship loads

UPDATE:  I figured it out... it was some interaction with Ship Effects Continued. I think Smokescreen was triggering the sound effects of SEC, at least the engine enable sounds. I just removed SEC.

Edited by Krazy1
Link to comment
Share on other sites

  • 1 month later...

Hey, was just wondering about the license for this, I made a mod that uses realplume configs and I was just wondering if that’s fine or if I need to change anything

 

Link to comment
Share on other sites

  • 4 weeks later...

I'm Still Troubleshooting this and haven't been able to get the plumes to work. Starting to second guess my self on if I installed this correctly.
Here's is the Player Log https://www.dropbox.com/s/njy6gwybm8rf3t7/Player.log?dl=0
ModuleManager.Log https://www.dropbox.com/s/uh6xgbtyvf1iy8t/ModuleManager.log?dl=0
ModuleManager.ConfigCache https://www.dropbox.com/s/cbsoek1ol3uhjvo/ModuleManager.ConfigCache?dl=0
KSP.Log https://www.dropbox.com/s/jv9osu3wee5swdt/KSP.log?dl=0

unknown.png

unknown.png

Edited by xD-FireStriker
Link to comment
Share on other sites

  • 4 weeks later...
  • 4 weeks later...

Hey! I ran into a wee bug so thought I'd report here. When adding a waterfall config to the USI sounding rocket aerospike the real plume remains and they overlap.

GameData\RealPlume-Stock\UmbraSpaceIndustries\Sounding_Rockets.cfg uses :FINAL meaning it can't be overridden by the waterfall patch

Link to comment
Share on other sites

23 minutes ago, ROCKETGOOSE said:

Hey! I ran into a wee bug so thought I'd report here. When adding a waterfall config to the USI sounding rocket aerospike the real plume remains and they overlap.

GameData\RealPlume-Stock\UmbraSpaceIndustries\Sounding_Rockets.cfg uses :FINAL meaning it can't be overridden by the waterfall patch

Well, :FINAL patches are applied in alphabetic order by filename (and path) so if you want to override another mods FINAL patch just make sure that it's in a folder that comes after it alphabetically (which is why all my personal patches are in ZZZ_Custom)

Link to comment
Share on other sites

3 hours ago, Aelfhe1m said:

Well, :FINAL patches are applied in alphabetic order by filename (and path) so if you want to override another mods FINAL patch just make sure that it's in a folder that comes after it alphabetically (which is why all my personal patches are in ZZZ_Custom)

I haven't encountered this same problem before, but putting personal patches in a zzz_* folder is a very useful tip that I'll start doing just to be sure. Thanks!

Link to comment
Share on other sites

7 hours ago, Aelfhe1m said:

Well, :FINAL patches are applied in alphabetic order by filename (and path) so if you want to override another mods FINAL patch just make sure that it's in a folder that comes after it alphabetically (which is why all my personal patches are in ZZZ_Custom)

That's a really useful tip I'll be using that! thanks!

I still think that :FINAL shouldn't be used in the mod though, right?

Link to comment
Share on other sites

Posted (edited)
29 minutes ago, ROCKETGOOSE said:

That's a really useful tip I'll be using that! thanks!

I still think that :FINAL shouldn't be used in the mod though, right?

Agreed. The only reason a mod should use FINAL (in my opinion) is if it's trying to override another mod that is already using FINAL.

A combination of patches with FOR[zModName], AFTER[zModName] or even LAST[zModName] usually suffices in all other situations.

Although that does lead to an arms race among patches to see how many z's they can throw into the prefix to guarantee they're last! ;p

e.g. from my RP-1 MMpatch.log:

Spoiler

zRORescaleDragCubes
zROWaterfall_10_Initialize
zROWaterfall_15_AutoConfig
zROWaterfall_18_LateInitialize
zROWaterfall_19_ValidateRequiredKeys
zROWaterfall_20_MainEffect
zROWaterfall_30_Audio
zROWaterfall_38_GlowPreprocess
zROWaterfall_39_GlowResize
zROWaterfall_40_Glow
zROWaterfall_50_ExtraTemplates
zROWaterfall_80_MainPlumeVariants
zROWaterfall_85_HybridPlumes
zROWaterfall_90_Controllers
zROWaterfall_99_Finalize
zROWaterfall_Post
zRP-0
zRealAntennas
zRealFuelsVolumes
zRealPlume
zTestFlight
zzPostRealPlumeROEngines
zzReStockPlus
zzRealPlume
zzzAfterUniversalStorage
zzzElectricityUnits
zzzKerbalism
zzzRP-0
zzzRealFuels
zzzRealismOverhaul
zzzRealismOverhaul_RAPatch
zzzTagCleanup
ZZZZZ-RP0Tree
zzzzzROEngines
zzzzzz-B9PartSwitch
zzzzzz_RemoteTech
zzzzzzzzzzzzzzzzzzzzzzzRP0

and that's a very mod light install!

Edited by Aelfhe1m
added example
Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
On 4/7/2022 at 10:45 AM, xD-FireStriker said:

I'm Still Troubleshooting this and haven't been able to get the plumes to work. Starting to second guess my self on if I installed this correctly.
Here's is the Player Log https://www.dropbox.com/s/njy6gwybm8rf3t7/Player.log?dl=0
ModuleManager.Log https://www.dropbox.com/s/uh6xgbtyvf1iy8t/ModuleManager.log?dl=0
ModuleManager.ConfigCache https://www.dropbox.com/s/cbsoek1ol3uhjvo/ModuleManager.ConfigCache?dl=0
KSP.Log https://www.dropbox.com/s/jv9osu3wee5swdt/KSP.log?dl=0

unknown.png

unknown.png

I had the same issue, solution if anyone needs was to add ModuleManager version 4.1.4 to my GameData folder.

Link to comment
Share on other sites

  • 3 weeks later...

This mod is great, but I've noticed something thats been bugging me for the past few days. The plume for the RAPIER engine seems to have a gap between the actual engine bells and where the plume starts. Could the creator of the mod fix this possibly?

unknown.pngunknown.png
unknown.png

 

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...