Jump to content
  • 6

Settings reset at every game launch 1.8


Jahnus
 Share

Question

Hi guys,

 

With a clean installation version 1.8, without mods, The settings reset at each launch of the game. I tried to delete the .cfg file, nothing works. When I return the game in 1.7.3 beta in steam, no problem. The game keeps my settings, but when I go back to 1.8 settings reset each time ... 

Link to comment
Share on other sites

Recommended Posts

  • 3

Hello guys,

The work around is about Regional Format of Windows. You can still play in your language if you want.
This will change your date and hour format in Windows only.

 

To do that:

  1. Open your Windows tab (completely left in the taskbar)
  2. Open Settings (notched wheel)
  3. Click on Time & Language
  4. Click on Region
  5. Under the “Regional format” section, use the drop-down menu to set it to "English (United States)"

Ofcourse, the words in bold and underline will be in your language ...

 

I hope this will help someone while waiting for the fix.

Edited by Vandest
Link to comment
Share on other sites

  • 0
1 hour ago, Jahnus said:

Hi guys,

 

With a clean installation version 1.8, without mods, The settings reset at each launch of the game. I tried to delete the .cfg file, nothing works. When I return the game in 1.7.3 beta in steam, no problem. The game keeps my settings, but when I go back to 1.8 settings reset each time ... 

Do you have steam cloud saving enabled?

Do you use controllers?

Link to comment
Share on other sites

  • 0
3 hours ago, Jahnus said:

Hi guys,

 

With a clean installation version 1.8, without mods, The settings reset at each launch of the game. I tried to delete the .cfg file, nothing works. When I return the game in 1.7.3 beta in steam, no problem. The game keeps my settings, but when I go back to 1.8 settings reset each time ... 

Same problem.

I have have steam cloud saving enabled.

And each time a update my setting, the game quit the "full screen mode". I have to use alt + enter to restore it.

Link to comment
Share on other sites

  • 0
6 hours ago, Boyster said:

Do you have steam cloud saving enabled?

Do you use controllers?

I copied the KSP folder on the desk, to put steam out of action.  but same way ...

No controller use in KSP, I deleted my xbox 360 controller from windows, same way...

Link to comment
Share on other sites

  • 0

The problem is the same (Steam version). delete all modifications. No manipulations help! Reinstalled several times. Deleted the folder with the rest of the game. Nothing helps.

My system:
Windows 10
Processor - AMD Ryzen 5 2600
RAM - 16 GB
Video card - GeForce GTX 1050 2 GB

Link to comment
Share on other sites

  • 0
1 minute ago, BezKartuza said:

Yes I know.
But I want to play in my native language.
If the game did not have support for the Russian language, I would not buy it.

That is why it is called a work around. Also that was meant for other people looking at this thread, not you. 

Link to comment
Share on other sites

  • 0
5 minutes ago, MechBFP said:

That is why it is called a work around. Also that was meant for other people looking at this thread, not you. 

And I have the right to say my word. I paid my money and I want everything to work. In my opinion this is a normal desire. And I think I'm not the only one.

And I'm damn angry at developers today!

Link to comment
Share on other sites

  • 0
Just now, BezKartuza said:

And I have the right to say my word. I paid my money and I want everything to work. In my opinion this is a normal desire. And I think I'm not the only one.

And I'm damn angry at developers today!

Uh huh. You will notice I didn’t say otherwise. 

Link to comment
Share on other sites

  • 0
7 hours ago, Vandest said:

Hello guys,

The work around is about Regional Format of Windows. You can still play in your language if you want.
This will change your date and hour format in Windows only.

 

To do that:

  1. Open your Windows tab (completely left in the taskbar)
  2. Open Settings (notched wheel)
  3. Click on Time & Language
  4. Click on Region
  5. Under the “Regional format” section, use the drop-down menu to set it to "English (United States)"

Ofcourse, the words in bold and underline will be in your language ...

 

I hope this will help someone while waiting for the fix.

it works for me ! THX ;)

Link to comment
Share on other sites

  • 0
22 hours ago, Vandest said:

Hello guys,

The work around is about Regional Format of Windows. You can still play in your language if you want.
This will change your date and hour format in Windows only.

 

To do that:

  1. Open your Windows tab (completely left in the taskbar)
  2. Open Settings (notched wheel)
  3. Click on Time & Language
  4. Click on Region
  5. Under the “Regional format” section, use the drop-down menu to set it to "English (United States)"

Ofcourse, the words in bold and underline will be in your language ...

 

I hope this will help someone while waiting for the fix.

Thanks for this. I was slowly losing my mind trying to find from which Kraken-infested hole the settings were pulled out.

P.S.

This should not happen in released software, but this is KSP so I'm learning of weird new ways for software to fail as well as about orbital mechanics. :sticktongue: 

Link to comment
Share on other sites

  • 0
3 hours ago, AggressiveYoghurt said:

Having the same issue, i would rather not set my entire system as a US format as it changes the date format to the wrong MM/DD/YYYY which drives me up the wall. Stock game, persists out of steam and tried rebuilding settings.cfg and setting to read-only, never happened before.

Cant you pick a different format even if you choose US? not sure never tried it :P

Link to comment
Share on other sites

  • 0
Just now, Boyster said:

Cant you pick a different format even if you choose US? not sure never tried it :P

Actually yeah, it was just hidden in the old control panel behind a hundred menus and i had to manually input DD/MM/YYYY in there as it wasnt an option in a US layout. It sill looks a bit different and some parts are in english but i think ill live.

Link to comment
Share on other sites

  • 0

Same problem. Game just deletes settings.cfg and creates default everytime it launches. Really annoying bug.

KSP 1.8 pluses and minuses? 

+ ducted fans
+ new loading screens

- not working disengaging of servos
- resetting settings
- deleting all mods
- bugs again
- game reinstall
- waste of time
- need to remake many crafts

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...