Jump to content

[1.8 - 1.11.x] Distant Object Enhancement Continued v2.0.2.0 (27 December 2020)


Recommended Posts

  • 2 weeks later...
15 hours ago, captinjoehenry said:

I love this mod and it works great.  Except for the distant object rendering.  That consistently does not work.  The only thing that shows up is a small white dot instead of the station.  I do make use of a lot of mod parts if that effects anything.

Just had a look back at the previous versions, seems that a previous version of KSP broke that feature a while ago, back when it was managed by MOARdv. I'll see if i can track down what broke and and see if i can fix it

 

*Edit*

Ok, seems that this feature does work - at least on my test build for the newest version of KSP. Could you check your settings?
ytPbRGU.png

Edited by TheDarkBadger
Link to post
Share on other sites

As I'm trying to pinpoint this issue
https://forum.kerbalspaceprogram.com/index.php?/topic/197120-halo-like-visual-issue-ksp-1101/

I stumpled upon this in the log:

Uploading Crash Report
NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Component.get_transform(UnityEngine.Component)
  at DistantObject.FlareDraw.GenerateBodyFlares () [0x0032f] in <a3a15caa52954c7b93cbff005f15659c>:0 
  at DistantObject.FlareDraw.Awake () [0x00184] in <a3a15caa52954c7b93cbff005f15659c>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
UnityEngine.GameObject:Internal_AddComponentWithType(Type)
UnityEngine.GameObject:AddComponent(Type)
AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
AddonLoader:StartAddons(Startup)
AddonLoader:OnLevelLoaded(GameScenes)
AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

KSP just continues, so a hidden "crash" occured with that mod.

Could that have anything to do with my issue?

Link to post
Share on other sites
11 minutes ago, Gordon Dry said:

As I'm trying to pinpoint this issue
https://forum.kerbalspaceprogram.com/index.php?/topic/197120-halo-like-visual-issue-ksp-1101/

I stumpled upon this in the log:

Uploading Crash Report
NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Component.get_transform(UnityEngine.Component)
  at DistantObject.FlareDraw.GenerateBodyFlares () [0x0032f] in <a3a15caa52954c7b93cbff005f15659c>:0 
  at DistantObject.FlareDraw.Awake () [0x00184] in <a3a15caa52954c7b93cbff005f15659c>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
UnityEngine.GameObject:Internal_AddComponentWithType(Type)
UnityEngine.GameObject:AddComponent(Type)
AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
AddonLoader:StartAddons(Startup)
AddonLoader:OnLevelLoaded(GameScenes)
AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

KSP just continues, so a hidden "crash" occured with that mod.

Could that have anything to do with my issue?

 I wouldn't call that a hidden crass, just something which had an exception and stopped running at that point.  Was it repeating continously?

Link to post
Share on other sites

Just after my last post above a new build of DOE for KSP 1.10.1 was released, so instead of removing it I decided to update it instead.
But the issue retained.

Now I removed DOE and I don't see the "halo" anymore on the vessel (in orbit) which had it prior removing the mod.
I will investigate this a little more until my assumption gets fixated that indeed DOE is the culprit.

Edit:

toggling the features of DOE did not help

Edited by Gordon Dry
Link to post
Share on other sites
5 hours ago, Gordon Dry said:

Just after my last post above a new build of DOE for KSP 1.10.1 was released, so instead of removing it I decided to update it instead.
But the issue retained.

Now I removed DOE and I don't see the "halo" anymore on the vessel (in orbit) which had it prior removing the mod.
I will investigate this a little more until my assumption gets fixated that indeed DOE is the culprit.

Edit:

toggling the features of DOE did not help

Could you please PM me your modlist? It might be DOE not liking some other mod

Thanks

Link to post
Share on other sites
On 9/27/2020 at 8:38 AM, TheDarkBadger said:

Just had a look back at the previous versions, seems that a previous version of KSP broke that feature a while ago, back when it was managed by MOARdv. I'll see if i can track down what broke and and see if i can fix it

 

*Edit*

Ok, seems that this feature does work - at least on my test build for the newest version of KSP. Could you check your settings?
ytPbRGU.png

Yep I have those settings set.  But still when I'm out of physics range it just renders as a white dot.  I think I recall at one point this was caused by mod added parts...?

Link to post
Share on other sites
19 hours ago, captinjoehenry said:

Yep I have those settings set.  But still when I'm out of physics range it just renders as a white dot.  I think I recall at one point this was caused by mod added parts...?

Yeah it seems to be modded parts, Stock vessels load fine (At least from my testing) i'll have a look into why modded parts break the vessel rendering.

Link to post
Share on other sites
  • 5 weeks later...

So I've run into an issue where there is a small white circle with a blue center that shows up on my rockets.

After searching around trying to figure it out, I found out that it's an issue between Sigma Binary and DOE, that has been previously resolved by @Sigma88 with the help of another user.

Here is the issue:

https://github.com/Sigma88/Sigma-Dimensions/issues/90

https://github.com/Sigma88/Sigma-Binary/issues/52

 

And here is the fix by Sigma88:

https://github.com/Sigma88/DistantObject/releases

 

Now I'm assuming the version of DOE you took over doesn't include this fix since it looks like you took 1.9.1.1 and Sigma fixed it in 1.9.1.2 and 1.9.2.0

Is there anyway you can look at this and see if it's something that could be added to this version?

 

Thank You.

Edited by Spike88
Link to post
Share on other sites
  • 4 weeks later...

Thanks for this mod. I'm using it in 1.10.1 with scatterer and I've also got both DLC.

I had a question, I'm seeing comets showing up as dark smudges in the sky during the day. Just wondering if that's how they are supposed to look?

Link to post
Share on other sites
19 hours ago, cyberKerb said:

Thanks for this mod. I'm using it in 1.10.1 with scatterer and I've also got both DLC.

I had a question, I'm seeing comets showing up as dark smudges in the sky during the day. Just wondering if that's how they are supposed to look?

Could you please post a picture of what you are seeing and i'll take a look? :) 
On my end it comets look the same as in vanilla.

5 hours ago, infinite_monkey said:

Does everybody see planets flickering? Can that be reduced/eliminated?

Cant replicate this issue myself, could you PM me your mod list and i'll take a more in depth look :)
 

Link to post
Share on other sites
1 hour ago, TheDarkBadger said:

Could you please post a picture of what you are seeing and i'll take a look? :) 
On my end it comets look the same as in vanilla.

Sorry! Clearly I didn't know what they looked like in Vanilla. :blush: I removed the mod to check and I guess that's how a normal comet looks. It's on the far side of Kerbol and around Eve Orbit at the moment. I was expecting it to be a little more subtle for that distance. Hmmm... just wondering if I should log a KSP bug report for the comet being rendered in front of the  sun-flares. (I'm now doing a check without Scatterer to see if that might be related)  It's scatterer, I'll post over there.

oHs3GxZl.pngsEs1EeCl.png

without Scatterer
OQFyScAl.png

 

Edited by cyberKerb
Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...