Jump to content

RP-1 Realistic Progression One for KSP 1.10


Recommended Posts

On 9/26/2021 at 3:19 PM, siimav said:

Only KSP 1.10.1 works properly right now. Please follow the install guide here: https://github.com/KSP-RO/RP-0/wiki/RO-&-RP-1-Installation-for-1.10.1

Thanks for the answer, I went with the express guide with a squeaky clean install of 1.10.1
one thing i did different is added this mods(which looked online like they should be compatible) before the 1st run:

"name": "EasyVesselSwitch","version": "2.1"
"name": "KerbalEngineerRedux","version": ""
"name": "Trajectories","version": "v2.4.2"
"name": "KIS","version": "1.26"
"name": "KAS","version": "1.7"

i ran but when i saw that all the example craft files in sandbox are missing parts from bdb it seemed fishy 

so i closed the game properly(making cache) then uninstalled the  aforementioned mods and ran it again, but it changed nothing.
am i right to be worried or is that normal?
related question, does RP-1 require the making history expansion to work?

Edited by alien_wind
Link to comment
Share on other sites

  • 2 weeks later...

Requires RO v14.7.0 or newer.

New Features

  • Adjust research rate per-node based on how much the node is ahead or behind the current date (#1560)
  • Add vessel merging and engine refurbishment cost (#1551)
  • Reset Kerbalism experiment samples on KCT-recover
  • Add various tooltips to KCT and RP-1 (#1545)
  • Add tooltips with part titles to courses (#1562)
  • Allow using the highest under-research airlaunch level in sims


  • Deprecate XLR43 and move the engine configs to NAA-75 and LR89 engines. The XLR43, aka NAA75, was North American Aviation (Rocketdyne)'s development of the earlier XLR41, itself an improved US copy of the A-4 engine. Due to confusion on our part, its configs were originally split between an XLR43 part, the NAA75-110 part (aka Redstone/Jupiter-C/Juno I engine), and the Atlas booster engine part (LR43/LR89). This has been rectified where the two NAA75s (XLR43-NA-1 aka NAA75-65, and NAA75-110) share the same model, and the spaghetti-tube improved version (XLR43-NA-3, then LR43, then LR89) share the LR89 model. If you are using the XLR43 part, you should swap it out for the correct non-deprecated part. Doing so will be free. (See #1552 for the ECM changes related to this.)
  • Adjust ECMs for mid-late capsules
  • Fuel Cells now have an appreciable entry cost
  • Star 13E now has sane ECM
  • Fix AJ260s not having ECMs
  • Pods, landers, and service modules no longer have their costs inflated by their batteries.
  • Make the Mk1-3 pod ECM not much cheaper than Apollo (200k vs 250k, where Apollo's pays for other stuff too)
  • Move Apollo heatshield back from lunar landing to lunar HS
  • Support more kerbalEVA part variants
  • Adjust Soyuz ECMs, configure RN Soyuz (#1554)
  • Adjust some engine and solid ECMs (#1552) - in addition to the XLR43 changes, the LR87 series now shares some development cost with the Navaho (XLR43/LR79/LR89/etc) line; a typo was corrected for early RD107/108 config upgrades; and the STAR shared entry cost was fixed to eliminate the spurious STARComposite ECM.
  • Configure NFExploration dishes #1563


  • Add optional reward to XPL and XPSS contracts for horizontal landings with <10° descent angle (#1555)
  • All Return Home contracts require the vessel to stop before completing the contract
  • Fix the last tier commsat contract rewards being lower than intended
  • Adjust reputation reward for early contracts (#1559)


  • Add aniline mix to KCT resource multipliers (#1550)
  • Ease jump to simulation UT in 1d steps when Principia is installed. This alleviates extreme memory usage. (#1549)
  • Add a more descriptive stuck-in-sim error message
  • Disable Kerbalism vessel-wide uniform EC consumption by default
  • Log the facility the vessel was built at for launch events


Thank you to everyone who contributed to this release: @Capkirk123, @siimav, @NathanKell, @StonesmileGit, @bongotastic, @al2me6, @ryanc55, @lpgagnon


Edited by siimav
Link to comment
Share on other sites


I've been absent from RP-1 for a while, and rather than picking up my old 1.7.3 install and continuing to play that I figured I'd start fresh.
Followed the installation instructions (like always) and once I had everything set up the way I like (with a couple of extra mods that I like such as Warp Everywhere) I started my career playthrough.

I noticed right off of the bat that there were some changes with Kerbalism science and I wanted to check and make sure that this was indented behavior. Basically, I can't collect any science from low atmosphere for any experiment (all worth 0.0) except for supersonic flight analysis (which I hadn't gotten around to trying yet). Also, planetary photography (which was a big science boost early for my older install, if I remember correctly) wouldn't run and was considered to be in an invalid situation.

Was this a balance change, or do I have something set up incorrectly?

EDIT: Also, I've noticed that KCT isn't differentiating between the SPH and VAB construction anymore (all craft go into the same build queue.) Is this intentional as well? Seems like that makes building aircraft in the early game entirely not worth it due to the huge construction time compared to sounding rockets.

Edited by itsthatguy
Link to comment
Share on other sites

Hello all, one small issue I am having with the new version is that after a plane has deployed chutes it is too big to airlaunch without going into the editor to reset them.  Unfortunately, this forces a refurbish (at least I am guessing that is what is happening) and it takes nearly a 1/3 of the build time.


Link to comment
Share on other sites

Requires RO v14.7.0 or newer.


  • Add ServiceModule tags to ROTanks SM parts
  • Add NoResourceCostMult tag to ROCapsules CST SM
  • Add missing comms tech nodes to the year mapping file that controls year-based research rates
  • Fix getting tech research rate bonus for 1 more year than intended
  • Possible fix for avionics getting momentarily locked on launch pad
  • Write research rate and year-based multiplier for completed tech to career log
  • Prevent maintenance adding funds when subsidies are higher than costs
Link to comment
Share on other sites

A couple questions for any RP-1 experts:

A) If I try to start a science-only game, I can't unlock the starting node tech (the one costing 999 points) because it is unlocked automatically after visiting the mission control, but mission control is locked in non-career games. Is there any way around this?

B) is it at all possible (with the current RP1 version) to build a supersonic plane with only the starting tech, or do you need by necessity to unlock at least the first nodes?


(BTW: come back after a few years, installation was a breeze, everything working... a huge thank you to all the people making this wonder possible!) 

Link to comment
Share on other sites

7 hours ago, MagnusLL said:

A couple questions for any RP-1 experts:

A) If I try to start a science-only game...

RP-1 isn't really designed for science-only.  That said, I've heard people say that starting a career game then cheating yourself several million funds as needed during play does a pretty good approximation of a science game.

Link to comment
Share on other sites

On 10/12/2021 at 10:25 PM, spacebaby said:

Hello all, one small issue I am having with the new version is that after a plane has deployed chutes it is too big to airlaunch without going into the editor to reset them.  Unfortunately, this forces a refurbish (at least I am guessing that is what is happening) and it takes nearly a 1/3 of the build time.


You don't have to refurbish it, just going into Edit > Save Changes without changing anything (0 construction time) should allow you to airlaunch. At least it has been my workaround for this. I've also noticed that the aircraft also gets pushed to the top of the SPH, which probably has something to do with the whole "too big to airlaunch" bug.

Link to comment
Share on other sites

4 hours ago, obnox twin said:

Just a quick question will you able to have update this to 1.12.2? Like keep the 1.10.X and update but like a new download file so people can play RP-1 in 1.12.2.

Not yet.  Keep in mind that RP-1 is more than a mod - it's a complex and fragile creation, dependent on a suite of other mods, all of which need to interact in very specific ways.  Some of those dependencies only work on KSP 1.10.1 or earlier at this time.  The great thing with KSP is that you can have multiple installs, using different versions with different mixes of mods.

See here for instructions on how to get started: https://github.com/KSP-RO/RP-0/wiki/RO-&-RP-1-Installation-for-1.10.1

Link to comment
Share on other sites

Does anyone have any smart idea how to achieve early orbit with the latest releases?

I ask because many of the tricks used in previous versions are no longer available (e.g.: getting to the point where you can build small sounding rockets every few days to gain lots of money and speed up your research is not feasible anymore due to the time-dependant nature of the new SR contracts; spaceplanes are not "free" anymore due to the unified build queue; many trick builds used in "caveman orbits" aren't possible anymore due to first stage engines now only being startable on the ground; etc.)

I'm trying to achieve first orbit by the end of 1953 or first half of 1954 at the latest, but i'm finding it a whole lot more difficult than before... which I guess is a testament to the good work of the modders ;)

Link to comment
Share on other sites

I find that it makes a lot more sense to just keep milking sounding rocket contracts than trying to strive for early orbit.
You're going to end up wasting a lot of time and resources testing and stretching the capabilities of your early tech (especially if you're using TestLite, and I mean *ACTUALLY* using it, not just reverting every time you have an engine failure).
Remember, first orbit wasn't achieved until 10/57 IRL.

Really, I find that it's a mistake to strive for any big milestone before your technology level is really ready for it, but this is a good example.

Link to comment
Share on other sites

Thanks for the replies, everyone.

Another question: is there any way of recreating the post-war fighter planes? Was thinking of trying my luck at the supersonic jet-powered flight contracts, but apart from the fact that the J57 engine is in the third plane research node, making it relatively "late"... there's no fighter cockpit available! The only one is the Stuka...

Link to comment
Share on other sites

There's always the ol' reliable X-1 cockpit. It won't make for a convincing looking fighter, more of a high speed research plane of sorts.

That being said, the Stuka cockpit is close enough to make some sleek looking high performance prop fighters, or early transonic jets. You can push a Stuka cockpit and a J-47/J-48 just over the sound barrier in level flight if you area rule well and find the right altitude. There are plenty of accounts of F-86 Sabre pilots pushing "factory new" planes just over Mach one in a slight dive at high altitude, and they weren't area ruled at all AFAIK.

However, again, there's no need to rush it. There are other contracts you can complete until you unlock the J57. Rocket plane contracts are much simpler and easier to make happen early on. Also, the F-100 was introduced into service in September of '54 and the MiG-19 was introduced in '55 (really is a shame we don't have more soviet jet engines) so it wouldn't really make sense if you were able to build a supersonic jet right off of the bat.

If you want a reference to a sound design, here is a picture of the "KF-1" which I'm currently building in my new save (October '44). It's the first non-rocket plane that I've bothered to build on this save. On older RP-1 builds it made sense to build early planes, but with the changes to science (specifically that you can't collect any when "Flying Low") there's basically no point to build non-rocket planes until you are ready to complete the jet-powered supersonic contracts. IMO this is a good change because the old way made early progression very slow and grindy, especially because plane design takes much longer than rocket design (at least it does for me).


Edited by itsthatguy
Link to comment
Share on other sites

  • 2 weeks later...

Sooo... I've met a weird technical problem.

I'm not sure exactly how this happened, but the "telemetry analysis" science option has disappeared from ALL my ships (both saved crafts in the VAB editor and those in orbit) except for a single one, which has it still present both in the VAB and in the one probe I've in orbit for that type. And it's not the most recent ship I designed or orbited.

As far as I can tell, the procedural avionics used in that ship isn't any different from the ones used in all the other ships.

Also, if I edit one of the other ship types, and replace the "saved" procedural avionic with a new one (by adding it, re-rooting, and removing the old one) configured in the exact same way, the telemetry comes back.

I've also tried to copy the .craft file in a save for another career and the problem is still the same. So it's not in either the .craft file or the .save file, but it has to be in some kind of persistent cache and / or the configuration of the executable and the mods themselves. As far as I can tell, the only significant recent change is that I downloaded the latest RP-1 update a couple days ago.

Any idea what this could be? The weird thing is that by placing a new avionic the problem goes away, so it's almost like the part has somehow changed and the old one, while still recognized, is missing some needed info for the game engine.

Link to comment
Share on other sites

I'm on v1.11.2 and have a weird problem. My avionic units don't stack. e.g if I have a 2 ton upper stage and set the avionics to be able to control 2 ton, all is good. I add a decoupler and a 20 ton second stage. Now as far as I understand it I now have a 22 ton vehicle with 2 tons of avionics control, so if I set the second stage avionics to control 20 tons then I should be able to control the whole vehicle of 22 tons. But when I look at the RP1 avionics is says only 20 tons of avionics controls, it seems like only the largest unit counts.

This seems weird, am I missing something, do I have a corrupt install ? Anyone got any ideas ? Thanks

Link to comment
Share on other sites

9 hours ago, Fihnakis said:

Last I played RP-1, if my memory hasn't totally failed, there is an option in settings you have to check to enable avionics stacking. If you didn't enable it, they won't stack.

Ah, I WAS missing something. I never knew that option existed. Thanks so much. Looks like the wiki needs to be updated, because that option is unchecked at all difficulty levels but the wiki makes no mention of it an says that avionics stack.

Link to comment
Share on other sites

Hey guys!

First of all thank you for this awesome mod! I have enjoyed myself tremendously for the past two years. I just restarted a career game, and I have an issue I never encountered before. I'm trying to build my first orbital rocket, a caveman rocket that need to be 138 tons in order to reach orbital speed. I have a 150t launchpad currently in the making, but it's not done yet. In previous versions of the mod, you could build a rocket that exceeded your pad capabilities. In my case, when I try to build my caveman orbital rocket, the game tells me that it failed to pass the editor check because the rocket was too big, that it was going to build it but that I wasn't going to be able to launch it. Fair enough, except that when I press "OK", nothing happens, money is not spent and the rocket is not added to my queue. The issue is the same whether I order the rocket from inside the VAB, or using plans when i'm in the space center screen. Has anyone else encountered the same problem? Thanks  a lot!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...