Jump to content

[Linux] [GoG] Download old version

Recommended Posts

Hi everyone,

I know that this question has already been asked for Windows users, but I know how to download older version of the game on windows, both with Steam and the launcher of Galaxy of Gaming.

The problem is that on Linux there is no Launcher for GoG and on the website I have not managed to download the 1.7.3. (I like to play RP-1)

I could do it on Steam, but on steam I do not own the extensions.

I tried with Lutris, and the website. No luck so far. I asked this question on the Lutris forum last week, no answer. I just asked this question on the customer support of GoG, and still no answer.

I have the feeling that this forum might be my best chance.


Link to comment
Share on other sites

I think you'll need to use GoG support to get the previous version.  I've looked around and don't see any way to do it yourself.  If they don't get back to you soon, keep getting at them.  If they won't do it, they need to at least tell you "no".

Let me know if they do provide them, though.  I have all the GoG installers from 1.3.0 to 1.8.1 except 1.4.4... that dropped when I was on a KSP hiatus.  I'll never play it, but I'd like to complete the collection..

Link to comment
Share on other sites

Ya... one reason i am glad I bought it on the KSP Store. I had *every* .zip for *all three* OS's, from ~0.17 to 1.8.1... Started running out of HDD space, so I dumped all the "interim" releases, and just kept the final minor releases of each major... :cry:
And at least the KSP Store still has all the final minors up for all three OS's, from 1.0.5 to 1.8.1, that can still be downloaded...

Edited by Stone Blue
Link to comment
Share on other sites

Well, I just tried to install the game with the files they sent me, and I get some error. Impossible to install the game. I tried with the 1.8.1, and there everything goes well.
I tried writing them, and they try to pin this on the distros I'm using, Manjaro and RebornOS, which are both Arch based.

I will keep this up to date.

Link to comment
Share on other sites

Once I did:

chmod +x

on the install .sh file.

I tried those two:

(base) [[email protected] Desktop]$ sudo bash kerbal_space_program_1_7_3_02594_30887.sh
[sudo] password for thomot512: 
kerbal_space_program_1_7_3_02594_30887.sh: line 14: $'\r': command not found
: octal number out of range02594_30887.sh: line 15: umask: 077
kerbal_space_program_1_7_3_02594_30887.sh: line 16: $'\r': command not found
kerbal_space_program_1_7_3_02594_30887.sh: line 20: $'\r': command not found
kerbal_space_program_1_7_3_02594_30887.sh: line 29: $'\r': command not found
kerbal_space_program_1_7_3_02594_30887.sh: line 32: $'\r': command not found
kerbal_space_program_1_7_3_02594_30887.sh: line 36: syntax error near unexpected token `elif'
'erbal_space_program_1_7_3_02594_30887.sh: line 36: `elif test -x /usr/ucb/echo; then
(base) [[email protected] Desktop]$ sudo ./kerbal_space_program_1_7_3_02594_30887.sh
[sudo] password for thomot512: 
sudo: unable to execute ./kerbal_space_program_1_7_3_02594_30887.sh: No such file or directory

Edit: I noted something weird on the last line of the first error: the name of the file is: 'erbal_space_program_1_7_3_02594_30887.sh, instead of: kerbal_space_program_1_7_3_02594_30887.sh

Edited by Thomot512
Link to comment
Share on other sites

  • 2 weeks later...

I just received a last mail from them advising me to use the following command: 

dos2unix -f *.sh

This finally worked.

I really had to insist in order to get them (three different person) to admit that the issue is probably not the fact that I'm using an Arch based install.

To summarize, if you need to install an old KSP version from GoG, write to the support, and, if needed, use the command on top of this post.

This is due to the fact that the file might be uploaded from a windows machine which can cause some incompatibility issue. (I'm no specialist so if someone is willing to explain it in more detail, he/she is more than welcome)

Link to comment
Share on other sites

I'm not sure why their older versions would be any different than when they were released.  I've always had to do a chmod +x on the installers, but that's it.

I've never used Arch.  I'm curious how the file they gave you would behave on a different distro, like Mint(which is what I use).  Should be easy enough to test in a live environment just to see if the installer would run.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...