Jump to content

[1.5 - 1.10] Kerbalism 3.11


Sir Mortimer
 Share

Recommended Posts

The 'gear' icon in the kerbalism menu does nothing when I click it.  I am under the impression this is the config menu.  Any reason its not coming up for me?

Also, how do I get the radiation belts to show up in my map screen, like in the second video linked in the OP?  Do I need some special sensor for it?  I've looked in the tracking station and the in-flight map screen for such a display, to no avail.  I particularly want to know since I'm using a custom solar system (Galileo) and I want to make sure they are present and proper.  One of my earliest satellites got a radiation warning, but none since.  Not even the one that reached solar orbit.

Edited by IonMage
Link to comment
Share on other sites

4 hours ago, IonMage said:

Also, how do I get the radiation belts to show up in my map screen, like in the second video linked in the OP?  Do I need some special sensor for it?  I've looked in the tracking station and the in-flight map screen for such a display, to no avail.  I particularly want to know since I'm using a custom solar system (Kopernicus) and I want to make sure they are present and proper.  One of my earliest satellites got a radiation warning, but none since.  Not even the one that reached solar orbit.

you need to press B while in map view or in the tracking station.

But if you are using a custom solar system, it may not be supported with kerbalism radiation belts compatibility.

Link to comment
Share on other sites

Alternatively in map view, [numpad] 1 shows the inner belt, 2 the middle, 3 the outer belt. 0 hides the radiation belts again. Just in case you don't want to go through the B-button menu.

Link to comment
Share on other sites

Thanks, seems that there are in fact radiation belts appearing around the planets, so its working well enough.

 

Any idea why my config menu isnt showing though?

Edited by IonMage
Link to comment
Share on other sites

9 minutes ago, IonMage said:

Thanks, seems that there are in fact radiation belts appearing around the planets, so its working well enough.

 

Any idea why my config menu isnt showing though?

The config menu uses a couple of pages in the stock settings -> difficulty options available from the pause menu.

The cog symbol in the row of icons next to a vessels name in the flight UI is a status indicator for part failures (white if none, yellow for warnings and red for failures) - see wiki for details.

Link to comment
Share on other sites

18 minutes ago, Aelfhe1m said:

The config menu uses a couple of pages in the stock settings -> difficulty options available from the pause menu.

The cog symbol in the row of icons next to a vessels name in the flight UI is a status indicator for part failures (white if none, yellow for warnings and red for failures) - see wiki for details.

Ah, that explains it.  Thanks!

Link to comment
Share on other sites

Question: how can I run a fuel cell and sabatier on one ship, without draining my hydrogen tanks dry?

I'm running fuel cell + electrolysis to generate power while in the shadow of an orbit, and I'm also running electrolysis to generate oxygen for breathing. Since I now have spare CO2 and Hydrogen, I'd like to run sabatier on them, but I don't want the sabatier to take all the hydrogen from my fuel cells, or all the CO2 from my greenhouse.

I don't have any incoming sources of additional hydrogen or CO2 to my space station.

So far the best solution I've found is to only run sabatier during the shadow part of the orbit so that it only runs for a percentage of the time in orbit, but it feels risky, inefficient and dangerous. (I also haven't checked if it actually limits the sabatier enough to keep my tanks from running dry.) Is there a way I can limit sabatier to only take "spare" resources? Perhaps only from specific tanks?

(FYI i'm not playing with solar storms or reliability, so in my case I'm not at risk of a life support machine breaking down.)

Link to comment
Share on other sites

1 hour ago, lacunar said:

Question: how can I run a fuel cell and sabatier on one ship, without draining my hydrogen tanks dry?

I'm running fuel cell + electrolysis to generate power while in the shadow of an orbit, and I'm also running electrolysis to generate oxygen for breathing. Since I now have spare CO2 and Hydrogen, I'd like to run sabatier on them, but I don't want the sabatier to take all the hydrogen from my fuel cells, or all the CO2 from my greenhouse.

I don't have any incoming sources of additional hydrogen or CO2 to my space station.

So far the best solution I've found is to only run sabatier during the shadow part of the orbit so that it only runs for a percentage of the time in orbit, but it feels risky, inefficient and dangerous. (I also haven't checked if it actually limits the sabatier enough to keep my tanks from running dry.) Is there a way I can limit sabatier to only take "spare" resources? Perhaps only from specific tanks?

(FYI i'm not playing with solar storms or reliability, so in my case I'm not at risk of a life support machine breaking down.)

one thing to account is that those processes are not 100% efficient, so your tanks will run dry eventually. but you can get away with limited supplies - though the greenhouse do consume a relatively large amount of water, something like 30 kg per year after all the recycling is taken into account.

as for avoiding drying your tanks, unfortunately the automatization of processes does not have the option of start/stop something when a resource is close to depletion.

I had similar problems myself, and the only way I found to tackle them relied on some processes stopping because some tanks were full.

Link to comment
Share on other sites

13 minutes ago, Gotmachine said:

Make sure you don't have special characters in your KSP folder name / install path, there is a KSP bug that make everything go haywire when URI special characters are used in the path.
Usually, "+" is the culprit.

Checked. folder is

Quote

C:\Users\luigi\Desktop\Kerbal Space Program rss\GameData

no special characters.

Link to comment
Share on other sites

the mystery thickens.

I took a new, completely unmodded ksp. i added to it only kerbalism and its dependencies: kerbalism, kerbalism core, community resource pack, module manager. for each one of those I made sure to track and download the latest stable version.

I still get an error message, but a slightly different one

BwNbZdD.png

what is this harmonyksp? the kerbalism page doesn't even mention it

Link to comment
Share on other sites

8 minutes ago, king of nowhere said:

the mystery thickens.

I took a new, completely unmodded ksp. i added to it only kerbalism and its dependencies: kerbalism, kerbalism core, community resource pack, module manager. for each one of those I made sure to track and download the latest stable version.

I still get an error message, but a slightly different one

BwNbZdD.png

what is this harmonyksp? the kerbalism page doesn't even mention it

How did you install it? 

‘Harmony is a library that patches the KSP code directly.  It is listed as a dependency in CKAN, but not listed on the OP at all, although it might be embedded in the zip file

Edited by linuxgurugamer
Link to comment
Share on other sites

27 minutes ago, linuxgurugamer said:

How did you install it? 

‘Harmony is a library that patches the KSP code directly.  It is listed as a dependency in CKAN, but not listed on the OP at all, although it might be embedded in the zip file

i downloaded the mods and copied it into the gamedata folder. i did not use ckan.

i was told to get this harmonyksp, which i did. there was an harmony embedded into the kerbalism already, but it's an older version. now it seems to work. i see if it still works after i put in rss and the half dozen other mods

Link to comment
Share on other sites

1 hour ago, king of nowhere said:

what is this harmonyksp? the kerbalism page doesn't even mention it

The up-to-date "kerbalism page" is here.

This forum thread op is unmaintained as SirMortimer hasn't been around in a long time, and I have no intent of opening a new thread myself.

Link to comment
Share on other sites

So I've had a surface-deployed goo experiment running for 111 days on the Mun, and it's ONLY 2% COMPLETE. It has 4 power units available.

0.005625p/hr is the stated science gain rate.

This cannot be serious. Is this serious? This is pointless, it's going to take centuries for this stupid thing to finish, what is the point?

Link to comment
Share on other sites

26 minutes ago, Frostiken said:

So I've had a surface-deployed goo experiment running for 111 days on the Mun, and it's ONLY 2% COMPLETE. It has 4 power units available.

0.005625p/hr is the stated science gain rate.

This cannot be serious. Is this serious? This is pointless, it's going to take centuries for this stupid thing to finish, what is the point?

Did you use a scientist to deploy it, and if so, what rank?

Link to comment
Share on other sites

48 minutes ago, Frostiken said:

Even without a scientist the base flow of science is 0.05625.


It looks like there was a bug that makes Breaking Ground experiments take 10x longer than intended, which was fixed in July:

https://github.com/Kerbalism/Kerbalism/commit/f66d7865388cbcefd97e78bc5235e779dd891184 

However, the last release (3.14) was in July, so I guess it's not fixed yet. Thankfully, that's a tiny change that you should be able to make manually in your install.


I also think that using a scientist to deploy the experiment is supposed to help, but I can't find a reference to it in the config. 

Link to comment
Share on other sites

2 hours ago, lordcirth said:


It looks like there was a bug that makes Breaking Ground experiments take 10x longer than intended, which was fixed in July:

https://github.com/Kerbalism/Kerbalism/commit/f66d7865388cbcefd97e78bc5235e779dd891184 

However, the last release (3.14) was in July, so I guess it's not fixed yet. Thankfully, that's a tiny change that you should be able to make manually in your install.


I also think that using a scientist to deploy the experiment is supposed to help, but I can't find a reference to it in the config. 

lmao I knew I wasn't crazy, thanks.

Link to comment
Share on other sites

Does the EVA Science Experiment still use the vanilla science system? Or is there something I'm missing here? I ran the experiments, and the Kerbalism science tracker shows 1.0x for the regions I ran them in, but it still shows them otherwise marked as 'available science'. It also describes biomes the experiement is impossible in, like flying high / flying low.

Edited by Frostiken
Link to comment
Share on other sites

El 3/12/2022 a las 10:21, rey de la nada dijo:

Estoy tratando de instalar kerbalism+ rss , recibí este mensaje de error

J1RYaig.png

Esta es la lista de mods que instalar. no hay mucho además de kerbalism, rss y sus respectivas dependencias

Hkj99ls.png

¿cualquier sugerencia?

Tengo el mismo problema. although without the RSS

Edited by jaunco325
Link to comment
Share on other sites

1 hour ago, jaunco325 said:

Tengo el mismo problema. although without the RSS

the answer from @Gotmachine worked, it applies to you too

On 3/12/2022 at 11:40 PM, Gotmachine said:

The up-to-date "kerbalism page" is here.

This forum thread op is unmaintained as SirMortimer hasn't been around in a long time, and I have no intent of opening a new thread myself.

basically, you just have to get this harmonyksp (an updated version) and put it in gamedata too

Link to comment
Share on other sites

Any word on an official compatibility patch for SSPXR as the new parts are still not compatible? Still dont want to play with kerbalism if those parts are not going to work (with the telescope not even having any science experiments)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...