JonnyOThan

[1.8.x-1.9.x] - RasterPropMonitor (adopted)

Recommended Posts

Hello, I want to report an issue with this mod and the Mark IV Spaceplane System, I posted all information on that thread.

Link to my post

The mod author told me that the issue can be produced by this mod.

In the KSP.log there is just Null refence exceptions: Object not set of an instance of an object.

Share this post


Link to post
Share on other sites

Loading craft with ASET props gives these messages

Spoiler

[ERR 16:45:16.585] [RasterPropMonitorComputer]: Tried to look for method with propToUse still null?

[ERR 16:45:16.593] [RasterPropMonitorComputer]: Tried to look for method with propToUse still null?

[ERR 16:45:16.719] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.719] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeTarget

[ERR 16:45:16.719] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeTarget

[ERR 16:45:16.731] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.731] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeStabilityAssist

[ERR 16:45:16.731] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeStabilityAssist

[ERR 16:45:16.742] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.742] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeRetrograde

[ERR 16:45:16.742] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeRetrograde

[ERR 16:45:16.754] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.754] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModePrograde

[ERR 16:45:16.754] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModePrograde

[ERR 16:45:16.765] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.765] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeNormal

[ERR 16:45:16.765] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeNormal

[ERR 16:45:16.777] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.777] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeManeuver

[ERR 16:45:16.777] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeManeuver

[ERR 16:45:16.791] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.791] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiTarget

[ERR 16:45:16.791] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiTarget

[ERR 16:45:16.802] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.802] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiNormal

[ERR 16:45:16.802] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiNormal

[ERR 16:45:16.812] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.812] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiNormal

[ERR 16:45:16.812] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiNormal

[ERR 16:45:16.823] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.823] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiTarget

[ERR 16:45:16.823] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiTarget

[ERR 16:45:16.834] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.834] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeManeuver

[ERR 16:45:16.834] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeManeuver

[ERR 16:45:16.844] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.844] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeNormal

[ERR 16:45:16.845] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeNormal

[ERR 16:45:16.855] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.855] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModePrograde

[ERR 16:45:16.855] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModePrograde

[ERR 16:45:16.866] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.866] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeRetrograde

[ERR 16:45:16.866] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeRetrograde

[ERR 16:45:16.876] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.876] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeStabilityAssist

[ERR 16:45:16.876] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeStabilityAssist

[ERR 16:45:16.887] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.887] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeTarget

[ERR 16:45:16.887] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeTarget


Sometimes props work. Sometimes they don't.

Unloading craft results in some NREs

 

[LOG 16:45:45.130] [HighLogic]: =========================== Scene Change : From FLIGHT to EDITOR =====================
[EXC 16:45:45.329] NullReferenceException: Object reference not set to an instance of an object
    JSI.RasterPropMonitorComputer.Update () (at <77a8ebe46de443299cc7c3ff2e1917a5>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 16:45:45.331] NullReferenceException: Object reference not set to an instance of an object
    JSI.RasterPropMonitorComputer.Update () (at <77a8ebe46de443299cc7c3ff2e1917a5>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

Share this post


Link to post
Share on other sites
3 hours ago, Commodoregamer118 said:

Hello, I want to report an issue with this mod and the Mark IV Spaceplane System, I posted all information on that thread.

Link to my post

The mod author told me that the issue can be produced by this mod.

In the KSP.log there is just Null refence exceptions: Object not set of an instance of an object.

Interestingly, this is an issue with every single mod I've seen that tries to provide vessel recovery.  It will be fixed in the next release: https://github.com/JonnyOThan/RasterPropMonitor/commit/daabffa54b56a9ab26192ca1144fd9efce2baded

1 hour ago, Manul said:

Loading craft with ASET props gives these messages

I need your *entire* ksp.log.  I can’t do anything with just this snippet because I use IVAs with ASET props and don't hit this problem.  Also reporting which IVA you are using would help.

Edited by JonnyOThan

Share this post


Link to post
Share on other sites
3 hours ago, RW-1 said:

Hi Everyone,

I can confirm for me that it is fixed in Scansat 18.14:

https://www.curseforge.com/kerbal/ksp-mods/scansat

FYI

Hm, I was using 18.14 when I hit that trailMaterial issue.  It may be that you won't hit it in certain situations, like if you don't have a target or if it's not trying to draw a ground track.

Share this post


Link to post
Share on other sites
3 hours ago, JonnyOThan said:

I need your *entire* ksp.log

I'll try to reproduce this in a less modded install because this log is too huge, It took me about  1 hour to look through carefully. :confused:

Share this post


Link to post
Share on other sites

So can I use the CKAN installed scansat, vesselview, etc. for RPM? Or do I have to manually install them because they aren't wanting to work with RPM.

 

Share this post


Link to post
Share on other sites
11 minutes ago, Manul said:

I'll try to reproduce this in a less modded install because this log is too huge, It took me about  1 hour to look through carefully. :confused:

I really don’t mind huge logs - I have good tools for parsing and searching. If you want you can zip it; they usually compress really well.

8 minutes ago, ZZute said:

So can I use the CKAN installed scansat, vesselview, etc. for RPM? Or do I have to manually install them because they aren't wanting to work with RPM.

I don’t think there’s any reason CKAN wouldn’t work.  But there is a bug in scansat (see earlier posts in this thread).  And make sure you get “VesselViewerContinued” (not kronal vessel viewer) AND the RPM integration package for it.

If you’re still having problems, the log file will tell me exactly what you have installed and what might be going wrong.

Share this post


Link to post
Share on other sites
20 hours ago, Manul said:

Loading craft with ASET props gives these messages

  Reveal hidden contents

[ERR 16:45:16.585] [RasterPropMonitorComputer]: Tried to look for method with propToUse still null?

[ERR 16:45:16.593] [RasterPropMonitorComputer]: Tried to look for method with propToUse still null?

[ERR 16:45:16.719] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.719] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeTarget

[ERR 16:45:16.719] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeTarget

[ERR 16:45:16.731] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.731] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeStabilityAssist

[ERR 16:45:16.731] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeStabilityAssist

[ERR 16:45:16.742] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.742] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeRetrograde

[ERR 16:45:16.742] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeRetrograde

[ERR 16:45:16.754] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.754] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModePrograde

[ERR 16:45:16.754] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModePrograde

[ERR 16:45:16.765] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.765] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeNormal

[ERR 16:45:16.765] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeNormal

[ERR 16:45:16.777] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.777] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeManeuver

[ERR 16:45:16.777] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeManeuver

[ERR 16:45:16.791] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.791] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiTarget

[ERR 16:45:16.791] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiTarget

[ERR 16:45:16.802] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.802] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiNormal

[ERR 16:45:16.802] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiNormal

[ERR 16:45:16.812] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.812] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiNormal

[ERR 16:45:16.812] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiNormal

[ERR 16:45:16.823] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.823] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeAntiTarget

[ERR 16:45:16.823] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeAntiTarget

[ERR 16:45:16.834] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.834] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeManeuver

[ERR 16:45:16.834] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeManeuver

[ERR 16:45:16.844] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.844] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeNormal

[ERR 16:45:16.845] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeNormal

[ERR 16:45:16.855] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.855] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModePrograde

[ERR 16:45:16.855] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModePrograde

[ERR 16:45:16.866] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.866] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeRetrograde

[ERR 16:45:16.866] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeRetrograde

[ERR 16:45:16.876] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.876] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeStabilityAssist

[ERR 16:45:16.876] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeStabilityAssist

[ERR 16:45:16.887] Cannot find an InternalModule of typename 'JSIInternalRPMButtons'

[ERR 16:45:16.887] [InternalProp]: Failed finding module JSIInternalRPMButtons for method ButtonSASModeTarget

[ERR 16:45:16.887] [JSIActionGroupSwitch]: Failed to instantiate action handler JSIInternalRPMButtons:ButtonSASModeTarget


Sometimes props work. Sometimes they don't.

I solved this problem, RasterPropComputer module is missing in all cockpits from OPT Spaceplane, I have no idea how it used to work before (but it did).
NRE appears with any cocpit after scene change, here is a log.

https://drive.google.com/file/d/1rU1l5zKJH_YXZQeoQvcgnkIylkLQn4n7/view?usp=sharing

P.S. Ignore messages like this, NMB_RM prop is a mirror and it has no buttons:
[ERR 15:58:04.660] Could not register a button on transform named 'button-UP' in prop named 'NMB_RM'. Check your configuration.

 

Edited by Manul

Share this post


Link to post
Share on other sites
16 hours ago, Manul said:

I solved this problem, RasterPropComputer module is missing in all cockpits from OPT Spaceplane, I have no idea how it used to work before (but it did).

Many RPM props will create the RasterPropMonitorComputer module if it doesn't exist.  Did adding the module manually fix the problem?  Which cockpits were you using?  The message "Tried to look for method with propToUse still null?" is emitted by the RasterPropMonitorComputer itself, so I don't see how adding that could have fixed it.

EDIT: I've managed to repro this one.  It seems benign, but I'll try to figure it out.

16 hours ago, Manul said:

NRE appears with any cocpit after scene change, here is a log.

Fixed - this was benign, but good to clear out stuff that might look like a red herring: https://github.com/JonnyOThan/RasterPropMonitor/issues/9

Edited by JonnyOThan

Share this post


Link to post
Share on other sites
14 hours ago, JonnyOThan said:

Did adding the module manually fix the problem?

Yes, all buttons in OPT J cockpit work, no more error messages.

 

14 hours ago, JonnyOThan said:

The message "Tried to look for method with propToUse still null?" is emitted by the RasterPropMonitorComputer itself, so I don't see how adding that could have fixed it.

In 1.3-1.7 there used to be JSIAnimatorVariable errors (displayed on the screen with big green letters) due to missing RPMComputer module in some cockpits (not OPT, so I used to think that they don't lack this module). ASET HUD and a few other complicated props didn't work while others did, including MFDs. Adding a missing module always fixed this. Meanwhile cockpits from NMB work just perfect without RPMComputer module with their HUDs and other stuff, I have no idea why.

Edited by Manul

Share this post


Link to post
Share on other sites
On 1/14/2020 at 12:04 AM, Manul said:

Adding a missing module always fixed this.

This is quite interesting.  As I mentioned - many of the RPM props will try to add the RPMComputer if there isn’t one. But the way that it does it doesn’t quite work, which is why the error messages are emitted and the SAS hold buttons don’t work.  This has to do with what functions get called during object creation, so it might have changed in the unity upgrade in 1.8 - but that’s just speculation.  It also might vary by cockpit depending on the ordering of the props in the internal model.

I’ve also learned that its not a great idea to add part modules at runtime, so even though I think it would be possible to alter how the RPMComputer is created I don’t think that’s the best fix.  It should be the responsibility of the part mod to get their cfg files correct, but I don’t think OPT is getting updates anymore.  So I can provide a MM patch to fix this in the next release.  I could do it for all parts that have internal models, but that seems a little heavy-handed.  So I think I will narrowly scope it only to the mods that I know have this problem.

Finally, what’s NMB?

Share this post


Link to post
Share on other sites
6 hours ago, JonnyOThan said:

It should be the responsibility of the part mod to get their cfg files correct, but I don’t think OPT is getting updates anymore.

Half-correct... OPT Main itself is not getting updates anymore. However, OPT Legacy *is*. Also, OPT Reconfig, besides balancing and adding some "stuff" for OPT, is also a sort of a catch-all for patches and fixes for BOTH OPT Main and Legacy. Reconfig is required for one, not the other, but still can be used with the one that *doesnt* require it.

Basically, *ANYTHING* that is not model related in OPT Main, (and that might be worked around),  can be fixed/patched up in OPT Reconfig, if @JadeOfMaar is willing.
He's been releasing updates for Legacy, so any IVA fixes would just go right into a Legacy update (again, as long as Jade is willing to keep supporting *that* pack).

Edited by Stone Blue

Share this post


Link to post
Share on other sites

@JonnyOThan @Stone Blue If an IVA fix for OPT can exist entirely in a config then it would go into OPT Reconfig. If any files for models and textures need to be added then they go into OPT Legacy. It was the original OPT dev who created the IVA stuff but he has long since vanished from the KSP world, and IVAs are not my thing so I cannot make any decent changes to them.

Whoever is willing can and may create the config(s) such that it first strips out any offending non-RPM IVA stuff before applying the RPM stuff, and I will include it in my next OPT releases. (I often publish Legacy and Reconfig updates as a pair.) The restriction on Reconfig keeps it an easy download for folks who don't want or don't know of OPT Legacy.

Share this post


Link to post
Share on other sites
58 minutes ago, JadeOfMaar said:

@JonnyOThan @Stone Blue If an IVA fix for OPT can exist entirely in a config then it would go into OPT Reconfig. If any files for models and textures need to be added then they go into OPT Legacy. It was the original OPT dev who created the IVA stuff but he has long since vanished from the KSP world, and IVAs are not my thing so I cannot make any decent changes to them.

Whoever is willing can and may create the config(s) such that it first strips out any offending non-RPM IVA stuff before applying the RPM stuff, and I will include it in my next OPT releases. (I often publish Legacy and Reconfig updates as a pair.) The restriction on Reconfig keeps it an easy download for folks who don't want or don't know of OPT Legacy.

Eh, I’d just as soon include it as a patch within RPM itself.  There are IVAs provided for some other cockpit mods within the RPM package, so that kind of interconnection has a precedent.  There are probably other mods like NMB and more that have the same or similar problems and I’d prefer to just deal with them all the same way.  I can set this up in a way that it only applies to parts that are set up incorrectly, so that if you decide to provide a patch that fixes some or all of them it should just work.  One thing that a lot of people do, for example, is provide a custom boot screen for the MFD that shows the name & version of the IVA itself.

Share this post


Link to post
Share on other sites
41 minutes ago, JonnyOThan said:

Eh, I’d just as soon include it as a patch within RPM itself.

Heh. I hadn't fully caught on yet that you've taken over RPM. I'll leave all that to your discretion then. And I like the idea of the custom boot screen. When I wrote up Kerbalism compatibility for OPT I went to the trouble of describing a unique AI for its drone cores. I'd like to take the advantage to add a little imagery to represent it.

Share this post


Link to post
Share on other sites

I just released RPM v0.31.2.  You can get it here.  Changes:

  • CKAN is now officially supported. There are 2 CKAN packages, see the readme for details.
  • Fix KOSPropMonitor not refreshing the screen properly
  • Fix orbit display icon rendering
  • Fix vessel recovery prop soft-locking the game in some circumstances
  • Add missing vessel types to target menu
  • Fix some debug-only errors
  • Fix null reference exception on revert to editor
  • Add compatibility patches for incorrectly configured mods (NMB and OPT specifically)
  • Fix null reference exception when using internal light switch on incorrectly configured cockpits
  • External camera pages default to skip missing cameras, so the ALCOR MFD landing page will start on ExtCam1 if it exists
  • Move variable handler for plugins before builtins like it says in the docs
  • Fix line drawing on NAV pages due to broken shader reference in scansat

Share this post


Link to post
Share on other sites

Thank you so much for adopting this essential mod!  

I'm having issues updating the mod through CKAN.  It seems that VesselViewer Continued is dependent on JSIPartUtilities.  JSIPartUtilities owns the "GameData/JSI/LICENSE.md" file, and the update of your RPM mod is also trying to install this file.  CKAN throws an error and refuses to install your update.  

So, I uninstalled VesselViewer Continued and JSIPartUtilities and installed your update, but now I can't reinstall VesselViewer Continued because the JSIPartUtilities dependency throws an error when trying to install via CKAN!

I realize I can just do it all manually, but I know you worked hard to get the CKAN install officially supported, so I wanted to let you know it isn't working when installing alongside VesselViewer.

Thanks again for all your time and effort!

Matt

Edited by orionguy

Share this post


Link to post
Share on other sites
2 hours ago, orionguy said:

I'm having issues updating the mod through CKAN

Yep, my mistake...accidentally included a file that shouldn’t be there. Hopefully can get that cleaned up today.  Sorry about the inconvenience!!!

Share this post


Link to post
Share on other sites
2 hours ago, orionguy said:

I'm having issues updating the mod through CKAN

Can you try refreshing the CKAN data and installing it again?

Share this post


Link to post
Share on other sites
1 hour ago, JonnyOThan said:

Can you try refreshing the CKAN data and installing it again?

You're a genius!  Works like a charm.  Thanks.

Share this post


Link to post
Share on other sites

Thank you so much for taking this on. I was worried that I'd never have the map indicators again. Now I can finally start an IVA only playthrough on 1.8.1 like i'd been wanting to.

There's one thing I noticed though while testing it out, though. I used the built in docking camera (on the docking+ screen) on the smaller of the two MFDs from ASET props, 20x40 I think, to catch onto a space station with the grabber claw thing (stock part) and once connected, it switched my view to outside the craft, and attempting to switch back to IVA just locked the external camera movement. Switching to map view and back gave me the camera controls back, but still wouldn't let me go back to IVA. 

I'd never tried using the Docking+ button on the grabbing claw before, so it could very well have been present before you took the mod over, but I figured you might want to know about it.

Otherwise, it works great so far and i'm very greatful you took it upon yourself to maintain this mod. Thank you.

Share this post


Link to post
Share on other sites
5 hours ago, JonnyOThan said:

Confirmed: https://github.com/JonnyOThan/RasterPropMonitor/issues/11

Have you tested regular docking too?

 

EDIT- wow, I feel dumb. I figured i'd try to be thorough and try it on my unmodded install. It happens on that as well. Basically as far as I can tell, it happens any time you use the claw to catch a craft with docking ports in IVA.

It's nothing on your end. Sorry for bothering you with it.

Edited by Uhmattbravo
Correction

Share this post


Link to post
Share on other sites
2 hours ago, Uhmattbravo said:

 

EDIT- wow, I feel dumb. I figured i'd try to be thorough and try it on my unmodded install. It happens on that as well. Basically as far as I can tell, it happens any time you use the claw to catch a craft with docking ports in IVA.

It's nothing on your end. Sorry for bothering you with it.

That’s interesting, because there is definitely a crash inside RPM code when this happens. I had a sneaking suspicion that it might be a problem in the base game as well because I’ve seen weird behavior when docking with a claw and the internal camera, even without RPM installed.

Does regular docking have any issues when in IVA with (or without) RPM?

Share this post


Link to post
Share on other sites
1 hour ago, JonnyOThan said:

That’s interesting, because there is definitely a crash inside RPM code when this happens. I had a sneaking suspicion that it might be a problem in the base game as well because I’ve seen weird behavior when docking with a claw and the internal camera, even without RPM installed.

Does regular docking have any issues when in IVA with (or without) RPM?

 

I definitely did dock port to port in IVA with RPM earlier today. I used the Docking+ screen and everything if it makes a difference. Kicked me out to external view, but was able to switch right back to IVA, just like unmodded IVA docking. It didn't crash at all, even with the claw, just wouldn't let me back into IVA.

Both the claw and normal docking ports work fine in IVA unmodded, they just temporarily mess up the stock speed gauge.  It looks like tries to display current orbital speed and speed relative to the target at the same time. Switching to another vessel and back always fixes it.

Basically, aside from the minor inconvenience of the stock speed gauge, everything I tried worked the same with and without RPM. No actual crashing on either, just the hiccup with the view controls in that one specific situation both ways.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.