• 0
Arch3rAc3

[Xbox] Orbit changes during Time Warp in Vacuum

Question

Posted (edited)

Video link: (pay attention to the Apoapsis marker position and altitude)

I have no idea of what's causing this. It's happening to every craft I have in orbit, although not with the same intensity (smaller crafts seem to be affected less)

This issue is really messing up my game though. Not only Rendezvous/SOI Interceptions can be lost because the plotted course simply changes after the time warp; but in this specific example in the video, I need the AP/PE markers to stay in the same place as I'm deploying a satellite every time the main ship passed through it's AP, this way ensuring proper separation between each satellite.

 

Anyone has any idea on what's causing this? God, every day KSP has a new different bug that will probably take ages to be fixed...

Edit 1.: I'm not entirely sure, but I'm pretty confident I know what might be causing this issue, although I have no idea how it could be fixed.

The ship I'm using is quite tall as it has on the top 2 fairings with interstage nodes so I could fit 3 small satellites on top of each other.

Now, I'm not sure how the game takes into account where the "center" of the ship actually is during map view (if it's either the Center of Mass, the most central point regardless of the mass, the active "control from here" module or even something else entirely), but it seems like this center point is not really aligned with the orbit line center (let's say it's 10m below the orbit point for example).

This 10m offset therefore becomes the new center of the orbit when I switch from real time into warp mode. Therefore, as I switch, the game recalculates my orbit 10m below from where it actually was, causing bigger changes far away on my orbit.

Maybe if the Devs had/could implement a system in which the game takes my orbital values (AP / PE values) before I start the Warp and put them back in after the warp is done this problem would be fixed; instead of recalculating it as the warp is finished.

Edited by Arch3rAc3
Ideas

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
On 1/12/2020 at 4:15 AM, Anth12 said:

I recommend putting a bug report at the link supplied below if you want this fixed. though I cant promise they will

https://bugs.kerbalspaceprogram.com/projects/ksp

Might try, although I doubt anything will be done. There seems to be more bugs being added than they care about fixing it - especially on the xbox version.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.