Jump to content

[WIP][1.8.1] Epic Space Program - Beta 0.5


General Apocalypse
 Share

Recommended Posts

GA,

 

I am on "Zero Gravity Experiments" in the "The First Flights" section and I can not seem to get the "crewed" objective to check. I have launched manned missions utilizing both the mobile lab and the Mk1-3 Command Pod with a pilot and two scientist, done experiments in orbit and returned safely. Still, I can't get that "crewed" objective to get the check mark. Am I missing something?

 

Please help. I love the mod, by the way! Great work!

Link to comment
Share on other sites

On 2/14/2020 at 9:04 AM, FlashMcGaggins said:

GA,

 

I am on "Zero Gravity Experiments" in the "The First Flights" section and I can not seem to get the "crewed" objective to check. I have launched manned missions utilizing both the mobile lab and the Mk1-3 Command Pod with a pilot and two scientist, done experiments in orbit and returned safely. Still, I can't get that "crewed" objective to get the check mark. Am I missing something?

 

Please help. I love the mod, by the way! Great work!

That mission is supposed to be fully unmanned. You need to send a robotic vehicle into orbit then return it. The description is wrong.

Quick note : I can't update the mod to 1.9 until Contract Configurator and SCANsat are also updated to 1.9

Link to comment
Share on other sites

On 2/6/2020 at 12:46 AM, General Apocalypse said:


I'm not sure if it's technically possible at the moment. Also the FTL mods I have tried so far are quite heavy , maybe if there's wormhole/starge mod it might be feasible. My game loading time is about 4 minutes on a PCIE3.0 x4 SSD  so I'm not sure how many more mods I can add before the my PC becomes too bogged down by them.
 

 

Edited by ssd21345
Link to comment
Share on other sites

On 2/14/2020 at 9:04 AM, FlashMcGaggins said:

GA,

 

I am on "Zero Gravity Experiments" in the "The First Flights" section and I can not seem to get the "crewed" objective to check. I have launched manned missions utilizing both the mobile lab and the Mk1-3 Command Pod with a pilot and two scientist, done experiments in orbit and returned safely. Still, I can't get that "crewed" objective to get the check mark. Am I missing something?

 

Please help. I love the mod, by the way! Great work!

That should be fixed now.

Link to comment
Share on other sites

@General Apocalypse your mod is great! It sure provides a much more enjoyable path than the career mode 'explore this' and 'explore that' missions. 

Still, are you accepting suggestions? After going through like 1/3 of the way through most missions, starting a new savegame (for unrelated reasons), going 1/2 of the way yet again, creating a new savegame again (again for unrelated issues), it quickly becomes boring to go through the "first missions" part of the mission pack all over again. I loved it the first time; I think it was GREAT, nicely conceived, great to give this feel of progression... but after a while you just want to jump into the more meaty missions. 

I ended up just alt+12-ing my way out of the 'first missions' section. Maybe there could be a single mission right at the beginning where, when completed, unlocked the rest in the same way that the last mission in 'first missions' unlocks the others. Or something like that, perhaps a separate config which starts directly on the second section, or maybe even a separate download. 

Link to comment
Share on other sites

On 2/27/2020 at 12:53 AM, Daniel Prates said:

@General Apocalypse your mod is great! It sure provides a much more enjoyable path than the career mode 'explore this' and 'explore that' missions. 

Still, are you accepting suggestions? After going through like 1/3 of the way through most missions, starting a new savegame (for unrelated reasons), going 1/2 of the way yet again, creating a new savegame again (again for unrelated issues), it quickly becomes boring to go through the "first missions" part of the mission pack all over again. I loved it the first time; I think it was GREAT, nicely conceived, great to give this feel of progression... but after a while you just want to jump into the more meaty missions. 

I ended up just alt+12-ing my way out of the 'first missions' section. Maybe there could be a single mission right at the beginning where, when completed, unlocked the rest in the same way that the last mission in 'first missions' unlocks the others. Or something like that, perhaps a separate config which starts directly on the second section, or maybe even a separate download. 

Due to how the requirements are coded in that's not technically feasible right now. I would require a whole different mod. Maybe one day I'll do that but for an advanced player it only takes about an hour trough blast trough the initial missions.

Link to comment
Share on other sites

10 hours ago, General Apocalypse said:

but for an advanced player it only takes 

Yeah I actually have like +1500 hours in this game, and that is exactly the reason I went for the "first missions" part initially to enjoy your mod, but wouldn't ever do it again in a second time in another savegame.

What I am trying to say is, your mod has good potential to replace  the 'exploration' stock missions altogether, that is how good it is.  But it would be nice to have an option not to have to go through again, every time, the initial 'test this, test that' missions. 

Well, as I said, it's enough to autocomplete them all with alt+12.  I would sure redo all of this mod in every single new fresh career I start. 

Link to comment
Share on other sites

  • 1 month later...

I installed this a while ago, and am loving it so far.

 

Just some minor things I've noticed, I think it's the Fly By Minmus mission, the text in the requirements says fly by Mun. I think the same thing might happen elsewhere, but that one sticks out.

And the Friendship One mission, it says you need a crew of 4 Kerbals, but it will complete even if you have fewer than that.

 

Not game breakers by any means, but I thought I'd report them anyway.

 

But yeah, really good contract pack &)

Edited by WelshSteW
Typo
Link to comment
Share on other sites

  • 3 weeks later...

What do I need to do to pass the "Engine Calibration" contract?  I've tried several vessels, including 1 that used all the parts from the first one, and none are working right.

First issue - Has to have 2 staged to recognize that I'm flying over 200m for the science.  This is not in the description.

Second Issue - No "run test" button found anywhere and the "Engine Calibration" task never switches to a check box.

I am running a bunch of addons, including RemoteTech, but the first mission completed normally...

Link to comment
Share on other sites

Okay, finally passed it.  Here's the thing - it only completed when I used a liquid fueled rocket.  If this is a requirement, then it needs to be specified because I was trying to use Solid Fueled rockets since they are simple, cheap, and get the job done that is described.  Especially in conjunction with the Historical Missions pack which encourages use of sounding rockets for the early missions.

Link to comment
Share on other sites

23 hours ago, stk2008 said:

hmmm I cant even do the first mission I have installed all the parts this contract unlocks am I missing any thing? :( there is no sensor calibrate ?

 

EgU8RpW.png

'Sensor Calibration' is the overall objective of the contract, you do so by fullfilling the branched requirements. Based on the screenshot, you should just need to recover the vessel once you've checked the mystery goo. Just tested on my end, not having any issues.

Link to comment
Share on other sites

  • 1 month later...

I dont have any great suggestion for how to solve the issue, but I found that my big hangup on this mod is the requirements for a vehicle to be "New" and "Uncrewed".

I get the requirement of "Crewed" for some missions, but I only have so much time for gaming.  I dont want to deal with transfer windows for a probe to Jool in order to unlock the mission to send a crew to Jool.  

Maybe this mod isnt for me, and that is totally ok.  Just wanted to share my feedback.

Link to comment
Share on other sites

So, I was starting a new adventure with this (and about 312 of it's friends) when the game just froze up.

 

Went digging through the log file and found 15 versions (one for each planetary body) of this ...

[LOG 21:36:46.447] [INFO] ContractConfigurator.ContractType: Loading CONTRACT_TYPE: 'Survey Kerbin'
[EXC 21:36:46.467] ArgumentException: An invalid SCANtype name was provided.  Valid values are: Nothing, AltimetryLoRes, AltimetryHiRes, Altimetry, VisualLoRes, Biome, Anomaly, AnomalyDetail, VisualHiRes, ResourceLoRes, Science, ResourceHiRes, Everything_SCAN, Everything
System.ArgumentException: Requested value 'FuzzyResources' was not found.
  at System.Enum+EnumResult.SetFailure (System.Enum+ParseFailureKind failure, System.String failureMessageID, System.Object failureMessageFormatArgument) [0x00023] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
  at System.Enum.TryParseEnum (System.Type enumType, System.String value, System.Boolean ignoreCase, System.Enum+EnumResult& parseResult) [0x0017a] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
  at System.Enum.Parse (System.Type enumType, System.String value, System.Boolean ignoreCase) [0x00010] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
  at System.Enum.Parse (System.Type enumType, System.String value) [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
  at SCANsat.SCANUtil.GetSCANtype (System.String SCANname) [0x00000] in <9cf62b26bd1745c8ac93bcaa7703d75d>:0 
	SCANsat.SCANUtil.GetSCANtype (System.String SCANname) (at <9cf62b26bd1745c8ac93bcaa7703d75d>:0)
	System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0)
	Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
	System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0)
	System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0)
	ContractConfigurator.SCANsatUtil.GetSCANtype (System.String SCANname) (at <43a2e7cbd59545c6b9206fcd382ecb64>:0)
	ContractConfigurator.SCANsatUtil.ValidateSCANname (System.String SCANname) (at <43a2e7cbd59545c6b9206fcd382ecb64>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:LogException(Exception)
	ContractConfigurator.LoggingUtil:LogException(Exception)
	ContractConfigurator.SCANsatUtil:ValidateSCANname(String)
	ContractConfigurator.ConfigNodeUtil:ParseValue(ConfigNode, String, Action`1, IContractConfiguratorFactory, String, Func`2)
	ContractConfigurator.ConfigNodeUtil:ParseValue(ConfigNode, String, Action`1, IContractConfiguratorFactory, Func`2)
	ContractConfigurator.SCANsatCoverageFactory:Load(ConfigNode)
	ContractConfigurator.ParameterFactory:GenerateParameterFactory(ConfigNode, ContractType, ParameterFactory&, ParameterFactory)
	ContractConfigurator.ContractType:Load(ConfigNode)
	ContractConfigurator.<LoadContractTypeConfig>d__30:MoveNext()
	ContractConfigurator.<FinalizeContractTypeLoad>d__29:MoveNext()
	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[ERR 21:36:46.468] ContractConfigurator.SCANsatCoverageFactory: CONTRACT_TYPE 'Survey Kerbin', PARAMETER 'SCANsatCoverage' of type 'SCANsatCoverage': A validation error occured while loading the key 'scanType' with value 'FuzzyResources'.

[WRN 21:36:46.473] ContractConfigurator.ContractType: Errors encountered while trying to load CONTRACT_TYPE 'Survey Kerbin'

So, I switched over to my test install and installed just EPS (it selecting dependencies).  I ran it again.

This time there was no freeze and I was able to run the first contract and complete it with no problem.

But, being the curious one, I looked through that log as well.  When what to my surprise, the same 15 EXC errors remained. I dug to find something about FuzzyResources. Curiouser and curiouser. I dug more and found the calcuations for Kerbucks and that Kerbuck5 was assigned to these particular surveys. Okay, sure 60k.  Hey, I wonder ... back to the log and hmmm, it indicated only 12k.  Not on to not verfiy, I fired up the testRig. Huh, wadda ya know.. it really was only 12k added.

There is something going on with those Survey contracts that I don't think peeps be gettin' what they think they're getting.

 

Anywho, I've rolled up a few logs into THIS including: KSP_EPS.log & KSP_EPS (HeavyMod).log (those are the two KSP.logs), ModuleManager.ConfigCache, SurveyKerbin_EPS.log (ContractConfiguratorl log)

Link to comment
Share on other sites

I think that the first issue might be due to ScanSat removing some parts, so those types of scan don't exist anymore.

You could try installing an older version of ScanSat, and seeing if that fixes it.

Edited by WelshSteW
Link to comment
Share on other sites

On 6/25/2020 at 4:25 AM, WelshSteW said:

I think that the first issue might be due to ScanSat removing some parts, so those types of scan don't exist anymore.

You could try installing an older version of ScanSat, and seeing if that fixes it.

I think I figured it out.

There is an actual SCANsat parameter called 'FuzzyResources'.  After a bit of digging, it looks like that is the SCANsat version of a low resolution scan and corresponds to SCANtype =  ResourceLoRes.

 

Also, @General Apocalypse, all of the section header of lines in 9. TheEnterpriseProgram and 7.TheAscensionProgram that are missing the leading '//' to make them comment lines.

Link to comment
Share on other sites

On 6/27/2020 at 12:23 PM, TranceaddicT said:

I think I figured it out.

There is an actual SCANsat parameter called 'FuzzyResources'.  After a bit of digging, it looks like that is the SCANsat version of a low resolution scan and corresponds to SCANtype =  ResourceLoRes.

 

Also, @General Apocalypse, all of the section header of lines in 9. TheEnterpriseProgram and 7.TheAscensionProgram that are missing the leading '//' to make them comment lines.

@TranceaddicT  were you able to find a fix for this log. I am also trying to figure out by editind configs.

Link to comment
Share on other sites

24 minutes ago, HoneyBadger said:

@TranceaddicT  were you able to find a fix for this log. I am also trying to figure out by editind configs.

Right, so the offending exception is coming from GameData/EpicSpaceProgram/Contracts/4.TheExplorerProgram.cfg

Just open that and replace "FuzzyResources" with "ResourceLoRes"

That should net you 15 replacements.  It's safe to just do a blind replace as all 15 occurrences are what cause the exceptions.

 

For the missing  "//" just open those two files (9. TheEnterpriseProgram & 7.TheAscensionProgram) in the same folder and drop the double forward slash at 1,1. If you've got a syntax template, you'll see those lines grey-out.

Link to comment
Share on other sites

On 7/2/2020 at 11:15 AM, TranceaddicT said:

Right, so the offending exception is coming from GameData/EpicSpaceProgram/Contracts/4.TheExplorerProgram.cfg

Just open that and replace "FuzzyResources" with "ResourceLoRes"

That should net you 15 replacements.  It's safe to just do a blind replace as all 15 occurrences are what cause the exceptions.

 

For the missing  "//" just open those two files (9. TheEnterpriseProgram & 7.TheAscensionProgram) in the same folder and drop the double forward slash at 1,1. If you've got a syntax template, you'll see those lines grey-out.

@TranceaddicT Thanks i did those very helpful.

Edited by HoneyBadger
Link to comment
Share on other sites

  • 2 weeks later...
On 7/5/2020 at 5:46 AM, WelshSteW said:

The answer is in the posts above. ScanSat removed or renamed some stuff, and it broke the contracts. If you follow TranceaddicT's advice, you should be fine.

oh yeah sorry for not reading the previous posts. thanks!

Link to comment
Share on other sites

On 2/15/2020 at 1:33 PM, General Apocalypse said:

Quick note : I can't update the mod to 1.9 until Contract Configurator and SCANsat are also updated to 1.9

I'm willing to help test 1.9.1 or 1.10, but are you still around and working on this mod?

 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...