Jump to content

[1.7.3, 1.8.x, 1.9.x, 1.10.x] Soundtrack Editor Forked


Recommended Posts

On 2/7/2020 at 3:25 PM, linuxgurugamer said:

Due to the directories where files need to be installed, CKAN is unable to install this

Hi,

Just thinking out loud: Even if this kind of code isn't the funniest to write, can't we have a CKAN-aware addon acting as a kind of setup application and dedicated to handle the deployment/removal of the different sub-components spread across the game directory tree?

 

 

Link to post
Share on other sites
7 hours ago, DfA-DoM said:

Hi,

Just thinking out loud: Even if this kind of code isn't the funniest to write, can't we have a CKAN-aware addon acting as a kind of setup application and dedicated to handle the deployment/removal of the different sub-components spread across the game directory tree?

You don't want to open Pandora's box, especially for only a single mod

Link to post
Share on other sites
On 9/5/2020 at 8:11 PM, linuxgurugamer said:

You don't want to open Pandora's box, especially for only a single mod

Indeed.

BTW, I just saw that you already spotted the issue on the CKAN side several month ago.

Being myself programmer (but not a C# guru), I was also wondering, even if this could involve quite significant code rewriting, if it wouldn't be possible to dynamically load the offending dll such as what is done there: https://stackoverflow.com/a/13492645/4153864 ?

Link to post
Share on other sites
  • 3 weeks later...
1 hour ago, Entropian said:

1.9.x means any version with a 1.9 root, so 1.9.0, 1.9.1, 1.9.2, 1.9.3, etc.  This applies to pretty much any program with version numbers.

Most mods for 1.8 and 1.9 will work on 1.10.  I just dont have time to update everything everytime an update comes out

Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

Most mods for 1.8 and 1.9 will work on 1.10.  I just dont have time to update everything everytime an update comes out

Ok thank you.

In that case there is a problem with the mod.

When I install it (I think its installed correctly, just dropped everything into the KSP folder) it doesn't show a button at all and it won't play the songs.

My log file: https://drive.google.com/file/d/1YN1tBl_iFOn_Le3KMHiCRCp1Ao0xt0mb/view?usp=sharing

please let me know if the log file was shared wrong, I have never asked for mod support before.

Edited by Kerminator1000
Link to post
Share on other sites
5 minutes ago, Autolyzed Yeast Extract said:

this mod is still causing the game to hang during loading

unknown.png

using latest version

Let me consult my crystal ball.

Nope, not working today.

Let's check the log file, oh, that's right, there isn't a log file either.

Hmmm, what else can I do?

I know:

@Autolyzed Yeast Extract It's rather difficult to diagnose a problem without any information other than "it's broken".  Read the following and provide the necessary information:

Read this BEFORE asking for supporthttp://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

 

15 minutes ago, Kerminator1000 said:

Ok thank you.

In that case there is a problem with the mod.

When I install it (I think its installed correctly, just dropped everything into the KSP folder) it doesn't show a button at all and it won't play the songs.

My log file: https://drive.google.com/file/d/1YN1tBl_iFOn_Le3KMHiCRCp1Ao0xt0mb/view?usp=sharing

please let me know if the log file was shared wrong, I have never asked for mod support before.

@Kerminator1000 it's a private file, you need to grant access

Link to post
Share on other sites
19 minutes ago, Kerminator1000 said:

Ok thank you.

In that case there is a problem with the mod.

When I install it (I think its installed correctly, just dropped everything into the KSP folder) it doesn't show a button at all and it won't play the songs.

My log file: https://drive.google.com/file/d/1YN1tBl_iFOn_Le3KMHiCRCp1Ao0xt0mb/view?usp=sharing

please let me know if the log file was shared wrong, I have never asked for mod support before.

Check that you have the dependencies:

New Dependencies

 

Link to post
Share on other sites
5 minutes ago, Kerminator1000 said:

It won't show a button to adjust the playlists. Also I don't get any of the music.

My mod folder, in case you need it:

  Reveal hidden contents

9mzDaXo.pngAw5WcSX.png

 

Very odd.  I see that it is working in the log file.

Is it possible you disabled it somehow?  Click the yellow wrench in the toolbar, check to see if it is enabled.  If you changed it to be on the Blizzy toolbar, you also have to open the Blizzy toolbar and enable it there

Link to post
Share on other sites
5 minutes ago, linuxgurugamer said:

Very odd.  I see that it is working in the log file.

Is it possible you disabled it somehow?  Click the yellow wrench in the toolbar, check to see if it is enabled.  If you changed it to be on the Blizzy toolbar, you also have to open the Blizzy toolbar and enable it there

Ok, I will give this a try.

I am not at my KSP computer right now so I will let you know when I can.

Link to post
Share on other sites
16 minutes ago, Kerminator1000 said:

Ok, I will give this a try.

I am not at my KSP computer right now so I will let you know when I can.

also check to be sure that all the files in the downloaded zip file are put in the correct locations

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...