Jump to content

[1.8.X-1.10.X] Aurora Space Center: v1.1 "Kodiak Update" (NEW UPDATE !)


Recommended Posts

Posted (edited)
2 hours ago, Emilius73 said:

Congrats on this mod @Zoeille! How's the next release coming along?

The next update is coming soon! I only have some bugsfix left to do and modify some things that I did not like on v1.0 (because I am still a very big user of my own mod and I noticed that things could be improved)

In recent weeks I have been working on a light system for the shooting range (which you can place yourself) I still have to see if everything is good, I also have worked on the Kodiak LP-2 which is modeled but must be animated

 

Kodiak LP-2:

 

I'm really sorry for the time that Aurora is taking, with the pandemic and my personal life I put a lot this mod aside, I'm doing everything to get the v1.1 out quickly as possible!

You can also check the progression of the update here: https://trello.com/b/X0coCMIn/aurora-space-center

Edited by Zoeille
Link to post
Share on other sites
56 minutes ago, Zoeille said:

The next update is coming soon! I only have some bugsfix left to do and modify some things that I did not like on v1.0 (because I am still a very big user of my own mod and I noticed that things could be improved)

In recent weeks I have been working on a light system for the shooting range (which you can place yourself) I still have to see if everything is good, I also have worked on the Kodiak LP-2 which is modeled but must be animated

 

Kodiak LP-2:

 

I'm really sorry for the time that Aurora is taking, with the pandemic and my personal life I put a lot this mod aside, I'm doing everything to get the v1.1 out quickly as possible!

You can also check the progression of the update here: https://trello.com/b/X0coCMIn/aurora-space-center

Great! Don't worry about releasing soon, take your time!

Link to post
Share on other sites

Hello, thank you for this wonderful mod :cool: !

I just have one question about the animations : when I click on the building door, nothing happens. Did I forget to do something or it's a problem with my ksp ?

 

Thanks

 

Link to post
Share on other sites

When spawning one of the launch pads (tried LC-2 and LC-20), my framerate drops to 2 FPS and my log is flooded with this:

[EXC 20:11:21.671] NullReferenceException: Object reference not set to an instance of an object
	KerbalKonstructs.KKPadFX.LateUpdate () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

Am I missing a dependency or something? KSP version is 1.9.1

Link to post
Share on other sites
On 9/1/2020 at 11:19 AM, BobobXP said:

Hello, thank you for this wonderful mod :cool: !

I just have one question about the animations : when I click on the building door, nothing happens. Did I forget to do something or it's a problem with my ksp ?

 

Thanks

 

Thanks ! , did you try on the both doors ? (Right and left)

 

 

On 9/1/2020 at 8:14 PM, infinite_monkey said:

When spawning one of the launch pads (tried LC-2 and LC-20), my framerate drops to 2 FPS and my log is flooded with this:


[EXC 20:11:21.671] NullReferenceException: Object reference not set to an instance of an object
	KerbalKonstructs.KKPadFX.LateUpdate () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

Am I missing a dependency or something? KSP version is 1.9.1

Uh, I get the same bug on my RSS ksp, but i don't think it's a Aurora Space Center bug, could you try with an other mod like Tundra Space Center ?

You are playing on 1.0 and I have not made any bug fixes on it because there was none, and I (and my friends) have never had any problems playing with this version

 


By the way: The Aurora Space Center 1.1 release is ready, I just need to work on some bug fixes, 1.1 will be out soon (I can't wait to work on the 1.2)

Edited by Zoeille
Link to post
Share on other sites
3 hours ago, Zoeille said:

Uh, I get the same bug on my RSS ksp, but i don't think it's a Aurora Space Center bug, could you try with an other mod like Tundra Space Center ?

Since you said you have the same problem with RSS, I should mention that I'm using JNSQ. So maybe something with Kopernicus? I don't have this problem with Tundra Space Center, though.

I checked the log file again. The LateUpdate() only happens later on - before that, there are other errors, LateUpdate seems to be a follow-up error that then keeps repeating:

[EXC 22:47:15.105] NullReferenceException
	UnityEngine.Object.Internal_InstantiateSingleWithParent (UnityEngine.Object data, UnityEngine.Transform parent, UnityEngine.Vector3 pos, UnityEngine.Quaternion rot) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate (UnityEngine.Object original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate[T] (T original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	KerbalKonstructs.KKPadFX.Setup (System.Collections.Generic.List`1[T] emitterTransformNames, UnityEngine.GameObject baseObject, System.String smokeName) (at <d148da5d5d9249218e63843d11b290e5>:0)
	KerbalKonstructs.PadSmoke.Start () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 22:47:15.546] NullReferenceException
	UnityEngine.Object.Internal_InstantiateSingleWithParent (UnityEngine.Object data, UnityEngine.Transform parent, UnityEngine.Vector3 pos, UnityEngine.Quaternion rot) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate (UnityEngine.Object original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate[T] (T original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	KerbalKonstructs.KKPadFX.Setup (System.Collections.Generic.List`1[T] emitterTransformNames, UnityEngine.GameObject baseObject, System.String smokeName) (at <d148da5d5d9249218e63843d11b290e5>:0)
	KerbalKonstructs.PadSmoke.Start () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 22:47:15.980] NullReferenceException: Object reference not set to an instance of an object
	LaunchPadFX.Start () (at <ac04291822974a138f007b85091a10d0>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 22:47:16.422] NullReferenceException: Object reference not set to an instance of an object
	KerbalKonstructs.KKPadFX.LateUpdate () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

4 hours ago, Zoeille said:

By the way: The Aurora Space Center 1.1 release is ready, I just need to work on some bug fixes, 1.1 will be out soon (I can't wait to work on the 1.2)

That's great to hear :) 

Link to post
Share on other sites
2 minutes ago, infinite_monkey said:

Since you said you have the same problem with RSS, I should mention that I'm using JNSQ. So maybe something with Kopernicus? I don't have this problem with Tundra Space Center, though.

I checked the log file again. The LateUpdate() only happens later on - before that, there are other errors, LateUpdate seems to be a follow-up error that then keeps repeating:


[EXC 22:47:15.105] NullReferenceException
	UnityEngine.Object.Internal_InstantiateSingleWithParent (UnityEngine.Object data, UnityEngine.Transform parent, UnityEngine.Vector3 pos, UnityEngine.Quaternion rot) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate (UnityEngine.Object original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate[T] (T original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	KerbalKonstructs.KKPadFX.Setup (System.Collections.Generic.List`1[T] emitterTransformNames, UnityEngine.GameObject baseObject, System.String smokeName) (at <d148da5d5d9249218e63843d11b290e5>:0)
	KerbalKonstructs.PadSmoke.Start () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 22:47:15.546] NullReferenceException
	UnityEngine.Object.Internal_InstantiateSingleWithParent (UnityEngine.Object data, UnityEngine.Transform parent, UnityEngine.Vector3 pos, UnityEngine.Quaternion rot) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate (UnityEngine.Object original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.Object.Instantiate[T] (T original, UnityEngine.Vector3 position, UnityEngine.Quaternion rotation, UnityEngine.Transform parent) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	KerbalKonstructs.KKPadFX.Setup (System.Collections.Generic.List`1[T] emitterTransformNames, UnityEngine.GameObject baseObject, System.String smokeName) (at <d148da5d5d9249218e63843d11b290e5>:0)
	KerbalKonstructs.PadSmoke.Start () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 22:47:15.980] NullReferenceException: Object reference not set to an instance of an object
	LaunchPadFX.Start () (at <ac04291822974a138f007b85091a10d0>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 22:47:16.422] NullReferenceException: Object reference not set to an instance of an object
	KerbalKonstructs.KKPadFX.LateUpdate () (at <d148da5d5d9249218e63843d11b290e5>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

That's great to hear :) 

I will do some checks in KSP stock, but I don't see how a mod like Aurora Space Center can do NRE to KK
Could you try with the pad "LC-17" of Tundra Space Center ? I think it's the animation manager in KK 

Link to post
Share on other sites
2 hours ago, Zoeille said:

Could you try with the pad "LC-17" of Tundra Space Center ? I think it's the animation manager in KK 

No problem with LC-17. But this looked suspicious:

KerbalKonstructs.KKPadFX.Setup (System.Collections.Generic.List`1[T] emitterTransformNames, UnityEngine.GameObject baseObject, System.String smokeName) (at <d148da5d5d9249218e63843d11b290e5>:0)
KerbalKonstructs.PadSmoke.Start () (at <d148da5d5d9249218e63843d11b290e5>:0)

Is it possible that smoke is not configured correctly? I tried your landing zone - no FPS drop.

Link to post
Share on other sites
On 9/5/2020 at 1:55 AM, infinite_monkey said:

No problem with LC-17. But this looked suspicious:


KerbalKonstructs.KKPadFX.Setup (System.Collections.Generic.List`1[T] emitterTransformNames, UnityEngine.GameObject baseObject, System.String smokeName) (at <d148da5d5d9249218e63843d11b290e5>:0)
KerbalKonstructs.PadSmoke.Start () (at <d148da5d5d9249218e63843d11b290e5>:0)

Is it possible that smoke is not configured correctly? I tried your landing zone - no FPS drop.

I will check this weekend 
I plan to release the 1.1 the next week !

Link to post
Share on other sites

Aurora Space Center 1.1: Kodiak Update !

k2qkpFD.jpg

 

List of new launchpads, HIF, and other cool things:

Spoiler

 

New Launch Pad: Kodiak LP-3

z3oGZjY.png

New Launch Pad: Kodiak LP-2

u03vswc.png

New Launch Pad: Kourou ELA-2 Launch Pad

bwUQXUy.png

New Hangar: Medium Horizontal Integration Facility with interior and animated doors!

sBXF7VZ.png

New Hangar: Big Horizontal Integration Facility

ZAlQ8SH.png

Rework Launch Pad: LC-20 ! (the old is still available)

r3kcZiV.png

Add Ligths: Small, Medium, Big sizes.

9C3wRZa.png

 

 

DOWNLOAD:

Dependencies: Kerbal Konstructs & Module Manager

 

7oiWdU3.jpg     1AsUPoM.jpg

 

This version is compatible and work from KSP 1.8.X to 1.10.X

 

Changelog:

1.1: Kodiak Update
- Add ELA-2
- Add Kodiak LP-3 (Astra Rocket3.0's launch pad)
- Add Medium HIF with interior
- Add Kodiak LP-2 
- Add Big HIF with interior
- Rework of LC-20 launch pad (the old one is still available but will not be updated)
- Add lights system
- Fix default position for Crew Access Arm right

Edited by Zoeille
Link to post
Share on other sites

@Zoeille I was convinced I wrote some feedback on the latest release, but apparently I forgot to submit it :D

So first of all, congrats to the new release! I like the new lights (mainly the big flood light), since many pads don't have any - including yours, except for the Medium Pad 2. My only problem with that one is the orientation towards the corner, so that my roads can't attach nicely to it. But that's just me.

What's the Big Factory supposed to be?

I tested all pads for my low FPS issue. ELA-2 has the problem, ELA-3 works fine. "LC-20 Launch Pad" is problematic, "LC-20 - Medium Pad" works fine. Is there anything special about ELA-2 and LC-20?

Link to post
Share on other sites
On 9/23/2020 at 2:54 AM, kylelander said:

I actually don't know , but KSC Extended and Tundra Space Centre pads work normally.

Oh wait, I think I misunderstood your problem. The launch pads are visible, but are not in the launch site selector?

Yes there's room for improvement here: While everything in this mod is in the "Launchpad" category, they're not actually yet configured as launch sites. In the KK editor of the static, you need to click "make launch site" in order to make them appear on the list.

Link to post
Share on other sites
10 hours ago, infinite_monkey said:

Oh wait, I think I misunderstood your problem. The launch pads are visible, but are not in the launch site selector?

Yes there's room for improvement here: While everything in this mod is in the "Launchpad" category, they're not actually yet configured as launch sites. In the KK editor of the static, you need to click "make launch site" in order to make them appear on the list.

Oh. No problem, then. Thanks

Link to post
Share on other sites
On 9/22/2020 at 1:51 PM, infinite_monkey said:

@Zoeille I was convinced I wrote some feedback on the latest release, but apparently I forgot to submit it :D

So first of all, congrats to the new release! I like the new lights (mainly the big flood light), since many pads don't have any - including yours, except for the Medium Pad 2. My only problem with that one is the orientation towards the corner, so that my roads can't attach nicely to it. But that's just me.

What's the Big Factory supposed to be?

I tested all pads for my low FPS issue. ELA-2 has the problem, ELA-3 works fine. "LC-20 Launch Pad" is problematic, "LC-20 - Medium Pad" works fine. Is there anything special about ELA-2 and LC-20?

uhhhhh, that's really weird, i don't know where the lags can from for you, I thinking about the lights but the new LC-20 didn't have lights, it's also not the animation ELA-2 and LC-20 didn't have animations.
I don't know what can I do to be honest, lot of people tested it and you are the only one to have this fps issue it's really weird

 

5 hours ago, miguelsgamingch said:

Amazing Mod :)

Thanks you !

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...