Jump to content

[1.11] Connected Living Spaces (Adopted) 2.0.0.6 (2020-12-29)


Recommended Posts

  • 2 weeks later...

Is this mod suppose to put two parts together like this?  See screenshot.

I added Connected Liiving Space via a Moduel Manager patch to the FASA Gemini MOL

But the utility seems to thing the Universal Bay and the MOL are connected for Living Space.

Not sure what to make of this.  Yep I know its just cosmetic.

https://imgur.com/a/lmHLHC0

 

 

Link to post
Share on other sites
56 minutes ago, SkiRich said:

Is this mod suppose to put two parts together like this?  See screenshot.

I added Connected Liiving Space via a Moduel Manager patch to the FASA Gemini MOL

But the utility seems to thing the Universal Bay and the MOL are connected for Living Space.

Not sure what to make of this.  Yep I know its just cosmetic.

https://imgur.com/a/lmHLHC0

I don't see any issue there.  The MOL is a space that can hold a Kerbal, an the Universal Storage Fairing is a part that's passable - There's no seat for a Kerbal, but they can move through it.  (Of course there's nothing on the other side in this case, but if there were another passable space they could move through that or if there was a space with a seat they could move into it.)

Link to post
Share on other sites
13 minutes ago, DStaal said:

I don't see any issue there.  The MOL is a space that can hold a Kerbal, an the Universal Storage Fairing is a part that's passable - There's no seat for a Kerbal, but they can move through it.  (Of course there's nothing on the other side in this case, but if there were another passable space they could move through that or if there was a space with a seat they could move into it.)

I see, now it makes sense.  I didnt know thats the effect.  Thank you.

Link to post
Share on other sites

Is the option "Open Hatch" on clampotrons a feature added by this mod?  I cant remember if this is in stock or not and never really noticed.

If it is a feature of the mod, whats it's purpose? (dont say open the hatch, i get that part)

Link to post
Share on other sites

Seems to be working fine with KSP1.10.

@SkiRich I think so; at the very least, CLS makes use of it.  It controls whether or not Living Spaces are connected. So even though the ships may be docked together, if the hatches are closed, CLS treats the ships as separate Living Spaces and stops Kerbals from transferring between them.

Could be useful for example if you have "Hot Seat" installed which makes Kerbals move around, but you don't want them to enter a particular part of your ship.

Link to post
Share on other sites
5 hours ago, micha said:

Seems to be working fine with KSP1.10.

@SkiRich I think so; at the very least, CLS makes use of it.  It controls whether or not Living Spaces are connected. So even though the ships may be docked together, if the hatches are closed, CLS treats the ships as separate Living Spaces and stops Kerbals from transferring between them.

Could be useful for example if you have "Hot Seat" installed which makes Kerbals move around, but you don't want them to enter a particular part of your ship.

Thanks, that makes sense.

 

Link to post
Share on other sites
  • 2 weeks later...

Hi, I needed to make the Mk2 Lander's bottom node passable, so I tried to modify the configs. 
I deleted the "impassablenodes = " line under the part's section in GameData\ConnectedLivingSpace\Configs\CLSStock.cfg , 
and yet it doesn't make any difference in-game.
Does anyone know what i'm doing wrong ?

Link to post
Share on other sites
1 hour ago, BarnabeLEPD said:

Hi, I needed to make the Mk2 Lander's bottom node passable, so I tried to modify the configs. 
I deleted the "impassablenodes = " line under the part's section in GameData\ConnectedLivingSpace\Configs\CLSStock.cfg , 
and yet it doesn't make any difference in-game.
Does anyone know what i'm doing wrong ?

You can look in your ModuleManager.ConfigCache.  Find the Mk2 Lander configuration there and see if the CLS config represents what you think it should.  This is usually my first step troubleshooting any config file issue.  Look at what got into the ConfigCache and then try to fix it.

When I used CLS, I used this patch to deactivate the impassable nodes.  It's safer to use patches to change behavior than editing a mod directly.  When the mod updates you risk losing your changes your changes are overwritten by the update.

@PART[mk1pod,Mk2Pod,cupola,mk2LanderCabin,landerCabinSmall,MEMLander,kv1Pod,kv2Pod,kv3Pod,TaurusHCV]:NEEDS[ConnectedLivingSpace]:FINAL
{
    @MODULE[ModuleConnectedLivingSpace]
    {
	@impassablenodes = 
    }
}

I don't use CLS anymore.  I think it's a good design paradigm for craft and still follow it in principal. I just found I'd rather do it by the honor system than waste time debugging connection I thought should work and always having to open hatches to transfer crew. I really don't miss it.

Link to post
Share on other sites
On 7/19/2020 at 4:55 PM, Tonka Crash said:

You can look in your ModuleManager.ConfigCache.  Find the Mk2 Lander configuration there and see if the CLS config represents what you think it should.  This is usually my first step troubleshooting any config file issue.  Look at what got into the ConfigCache and then try to fix it.

When I used CLS, I used this patch to deactivate the impassable nodes.  It's safer to use patches to change behavior than editing a mod directly.  When the mod updates you risk losing your changes your changes are overwritten by the update.

@PART[mk1pod,Mk2Pod,cupola,mk2LanderCabin,landerCabinSmall,MEMLander,kv1Pod,kv2Pod,kv3Pod,TaurusHCV]:NEEDS[ConnectedLivingSpace]:FINAL
{
    @MODULE[ModuleConnectedLivingSpace]
    {
	@impassablenodes = 
    }
}

I don't use CLS anymore.  I think it's a good design paradigm for craft and still follow it in principal. I just found I'd rather do it by the honor system than waste time debugging connection I thought should work and always having to open hatches to transfer crew. I really don't miss it.

Thanks a lot ! I feel a bit ashamed that after modding the game for so long I still don't know any technical stuff. But I think I'll just uninstall it as you did. 

Otherwise I'd keep running into new issues every time I build a spacecraft.

Link to post
Share on other sites
  • 3 months later...
  • 1 month later...
1 hour ago, Saul Retav said:

On another note, seems to me that the Mk1 Stack Tri-Coupler should be passable, but that's just my opinion (and config). :D

Totally agree (on both points). No quibbles about girders and tanks, but things like that certainly should be passable.

Link to post
Share on other sites

Yeah, speaking of which, my config to make it passable doesn't seem to be working at all. :/
 

@PART[stackTriCoupler]:HAS[!MODULE[ModuleConnectedLivingSpace]] 
{
    	MODULE
	{
		name = ModuleConnectedLivingSpace
		passable = true
		surfaceAttachmentsPassable = true
	}
}


Any ideas?

Link to post
Share on other sites
  • 2 weeks later...
On 6/8/2020 at 10:11 AM, BarnabeLEPD said:

Well, things seem to actually work fine on my part. The issue disappeared after rebuilding the vessel. I've built a space station since then without a single issue. I've tried to pinpoint what causes the bug, and it is pretty weird: it happens when you place two parts radially and then break the symmetry, by re-rooting the vessel for example. Anyway, this would be worth looking into, since CLS greatly benefits from parts mods; stock ksp doesn't offer nearly enough building options to make interesting.

I've not been able to repro.  Can you please send me a save-game and detailed instructions to repro?

I enabled "Enable Optional Passable Parts" then made a part surface-attachable passable and added a couple of Radial Attachment Points and some more pods to those. Single CLS.

I then removed one from symmetry, the craft remained as a single CLS.

I then re-rooted the craft and again, the craft remained as a single CLS.

Link to post
Share on other sites

v2.0.0.6 is released for KSP1.11.

Fixes a few issues and adds more part configurations. Please see the Changelog.

Notably the StockFreedomAddon configuration is now enabled by default to have less restrictions. Also the "Enable Optional Passable Parts" option now takes effect immediately making it easier to tweak a parts' passability on the fly.

Link to post
Share on other sites

I wanted to make all parts passable because of jankery with Real Fuels and Procedural Parts and random parts not having CLS configs, so I wrote this to do so:

@PART[*]:HAS[!MODULE[ModuleConnectedLivingSpace]]:FINAL
{
    MODULE
    {
        name = ModuleConnectedLivingSpace
        passable = true
    }
}
@PART[*]:HAS[MODULE[ModuleConnectedLivingSpace]]:FINAL
{
    MODULE
    {
        @passable = true
    }
}

// or?

@PART[*]:FINAL
{
    %MODULE
    {
        %name = ModuleConnectedLivingSpace
        %passable = true
    }
}

Would this work?

EDIT: I've found that this works with no issues:

@PART[*]:HAS[!MODULE[ModuleConnectedLivingSpace]]:FINAL
{
    %MODULE[ModuleConnectedLivingSpace]
    {
        %passable = true
    }
}
@PART[*]:HAS[MODULE[ModuleConnectedLivingSpace]]:FINAL
{
    @MODULE[ModuleConnectedLivingSpace]
    {
        @passable = true
    }
}

 

Edited by bigyihsuan
Link to post
Share on other sites
  • 1 month later...

So I've just had an issue crop up... About a week ago I found that I couldn't transfer kerbals between parts on my ISS reproduction. Specifically, I've got Jeb trapped in Zvezda. I can't transfer him out of that single module, nor can I get him to EVA as it's saying all hatches are blocked. (Which I think is technically true, Tantares doesn't have hatches on the sides of those parts.) I've opened all the hatches between where I want to get him and the module, and still nothing... I'm resorting to a deorbit of the module so he can respawn, and I sort of want to rebuild the module regardless, but I've got sa screenshot of what I'm seeing here. The pod (and the black docking adapter) attached only has 3 kerbals, with room for 7 on board so it's definitely not full.

TL;DR: Docking port hatches open, can't EVA, only move between parts within the single original module, Jeb's gonna try and survive a deorbit... thoughts on why?

8tSvZXj.png

Link to post
Share on other sites
2 hours ago, Hachiro said:

thoughts on why?

The error message is pretty straightforward - either the destination is full (you say it's not, so I believe you), or the parts are not internally reachable according to CLS rules (quite likely).

You have to make sure that all parts (and specifically the nodes which connect the parts) between the source and destination parts at the very least allow Kerbals to "pass" through them.

I see that the Eridani port is a size0.5 node - that is generally considered to be too small  for Kerbals.  You can override it using a ModuleManager patch (it's considered bad practise to edit the part config directly as an update will overwrite your changes) and either suggest CLS contains those configurations or contact whichever mod supplies that part to add CLS configurations directly.  Generally speaking I prefer mods to support CLS because then the mod author can directly control which parts they consider to be passable and which not, but I'm more than happy to also roll configurations into CLS.

And as I said, regardless of the CLS or mod config for a particular part, you can always override it yourself if that's what you prefer in your game.  In fact, check the tweakables (right-click menu), I think the latest version of CLS even allows you to set it "on the fly". (EDIT: You may need to enable "enhanced tweakables" to see this)

Edited by micha
Link to post
Share on other sites
50 minutes ago, micha said:

The error message is pretty straightforward - either the destination is full (you say it's not, so I believe you), or the parts are not internally reachable according to CLS rules (quite likely).

You have to make sure that all parts (and specifically the nodes which connect the parts) between the source and destination parts at the very least allow Kerbals to "pass" through them.

I see that the Eridani port is a size0.5 node - that is generally considered to be too small  for Kerbals.  You can override it using a ModuleManager patch (it's considered bad practise to edit the part config directly as an update will overwrite your changes) and either suggest CLS contains those configurations or contact whichever mod supplies that part to add CLS configurations directly.  Generally speaking I prefer mods to support CLS because then the mod author can directly control which parts they consider to be passable and which not, but I'm more than happy to also roll configurations into CLS.

And as I said, regardless of the CLS or mod config for a particular part, you can always override it yourself if that's what you prefer in your game.  In fact, check the tweakables (right-click menu), I think the latest version of CLS even allows you to set it "on the fly".

That does make sense, though I am somewhat confused as to why it only just recently started doing this. Jeb wasn't launched on that module, I did transfer him *into* it. I'm going to try launching the ROS again, as I said there were a few adjustments I needed to make anyway, and see if I can get the tweakables working. Will update when it's together.

Tantares is, at least as of 1.10's updates, being worked on, so hopefully it'll end up supported. It's one of my favourite mods!

 

Update: Seems like no internal transfers are possible with the ShadowWorks or the Tantares modules at all even with all hatches opened, now, so I might have to either go in and tweak everything, or uninstall for now :( 

Edited by Hachiro
Link to post
Share on other sites
1 hour ago, Hachiro said:

Update: Seems like no internal transfers are possible with the ShadowWorks or the Tantares modules at all even with all hatches opened, now, so I might have to either go in and tweak everything, or uninstall for now :( 

I'm afraid I don't know ShadowWorks or Tantares or what they are/do (and don't have the time to chase them down either), but if those mods recently had a major update I'd check to see whether the mod changed its support for CLS.  It's pretty easy to write a MM patch to put CLS support back in if they removed it .  If necessary I can help you if you give me direct links to the mod(s) and part(s) in question.

EDIT: In particular it seems Tantares recently wiped their entire repository and started from scratch 2 weeks ago.  I found some note in thier dev thread saying that CLS is supported out-of-the-box so possibly this was lost during the rework. Might be worthwhile contacting the mod about this?
But like I said, with "enhanced tweakables" and the latest version of CLS, you can adjust the CLS configuration for a part "on the fly". Or a simple MM patch should be able to fix it.

Edited by micha
Link to post
Share on other sites
10 hours ago, micha said:

I'm afraid I don't know ShadowWorks or Tantares or what they are/do (and don't have the time to chase them down either), but if those mods recently had a major update I'd check to see whether the mod changed its support for CLS.  It's pretty easy to write a MM patch to put CLS support back in if they removed it .  If necessary I can help you if you give me direct links to the mod(s) and part(s) in question.

Shadowworks and Tantares are a stockalike parts pack for the SLS/some ISS parts and Russian space program launchers and spacecraft. Tantares hasn't been updated since August, and ShadowWorks did just get updated but only for an animation fix on a non-crewable part, so I don't ~think~ that would have affected what's going on there. Like I said, the Tantares parts were the ones that caught me off first, so. 

 

I should also mention I am hardly versed in coding so MM is somewhat intimidating. 

 

 

There are the mods in question, as it were, though!

Link to post
Share on other sites

@micha I've added a compatibility patch to ShadowWorks to add ModuleConnectedLivingSpace if CLS is installed.  It should work as expected now.  The new version of ShadowWorks is now 2.0.4.1.  Of course if users have any issues with CLS in ShadowWorks, let me know in the ShadowWorks thread.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...