Jump to content

[1.9.x] TUFX - Post Processing


Shadowmage
 Share

Recommended Posts

11 hours ago, JonnyOThan said:

Please let me know if anything is broken, since I'm new to this codebase.

Thanks for sinking some time into this, it's very much appreciated.

Are you familiar with the HDR side effect of semi-transparent textures? Just wondering if it's on the radar or otherwise. Thanks!

Link to comment
Share on other sites

Posted (edited)
6 minutes ago, OrbitalManeuvers said:

Are you familiar with the HDR side effect of semi-transparent textures? Just wondering if it's on the radar or otherwise. Thanks!

I'm familiar with the issue but not the technical details.  Shadowmage was also aware, some details here: https://github.com/shadowmage45/TUFX/issues/14

I played around with it a while back and it looks like the texture isn't actually transparent; what's going on is that geometry behind the closest surface is stopping the HDR lighting from affecting that surface.  So they kinda come out as shadows.

Obviously other unity games can use HDR without a problem, but KSP is pretty unique in the massive draw distance (which seems to also affect the "tree ring" effect when SSAO is enabled).  I'm just speculating that it might be related.

Edited by JonnyOThan
Link to comment
Share on other sites

28 minutes ago, Forked Camphor said:

That too. I did another test but was not able to reproduce it, until I zoomed in and out in the IVA. Using the the default zoom level seems to fix it. I only have KSP.log since I play with -nologs argument, I see if I could upload it somewhere

I still need better repro steps.  Putting a mk1 cockpit on the runway and zooming in and out with the mousewheel works fine for me.

Link to comment
Share on other sites

Posted (edited)
3 hours ago, JonnyOThan said:

I still need better repro steps.  Putting a mk1 cockpit on the runway and zooming in and out with the mousewheel works fine for me.

I did another test in a clean install with only TUFX, and other with TUFX and IVA/Visual mods, but I wasn't able to reproduce the bug. So it's probably some interaction with another of my 250+ mods. If I find something else I will let you know. Thanks for your time

Edited by Forked Camphor
Link to comment
Share on other sites

5 hours ago, OrbitalManeuvers said:

Thanks for sinking some time into this, it's very much appreciated.

Are you familiar with the HDR side effect of semi-transparent textures? Just wondering if it's on the radar or otherwise. Thanks!

OK so...I have a pretty good theory about what's going on and what would be required to fix it...

When you enable HDR, I think the alpha channel can go over 1, then when the blend is applied it *inverts* the color underneath.  I had an epiphany when I realized the colors were getting inverted, and then someone else clued me into the alpha channel thing.

Clamping the alpha channel to 1 would require altering the stock KSP shaders.  This is pretty technically difficult, plus distributing modified assetbundles and whatnot is probably a non-starter for something distributed on this forum.

HOWEVER...Textures Unlimited already has the ability to replace the shaders used for various models.  I successfully did a simple test of the mobile processing lab, where previously I could see the ladder parts on the other side of it.

The other test case I was using (and where I notice this problem most often) is with fairings.  But since the fairing is not a standard model, I don't think TexturesUnlimited can patch it (but I only just started using TU an hour ago, so maybe I'm missing something).  It would also be prohibitive to list EVERY model in the game for TU to patch, and wouldn't help non-stock parts that use the broken stock shaders.

It *may* be possible to create a mod that uses TU and entirely replaces the stock shaders with TU's versions at runtime, which would *just fix* this problem for everyone.

Link to comment
Share on other sites

  • 3 weeks later...
5 hours ago, physius said:

How do I export a profile I made in the editor? I don't see it in the ksp.log

Press a couple of times, sometimes it doesn't register it. But it works, I used it recently

Edited by Forked Camphor
Link to comment
Share on other sites

5 hours ago, physius said:

How do I export a profile I made in the editor? I don't see it in the ksp.log

The KSP.log file doesn’t get flushed to disk immediately.  If you do a scene switch it should write it out.  You might also be able to copy the config out of the console output in the debug window..

Link to comment
Share on other sites

  • 4 weeks later...
On 6/28/2022 at 3:56 PM, physius said:

How do I export a profile I made in the editor? I don't see it in the ksp.log

Profile is firstly exported on Player.log (when UI say it exported on KSP.log) and later on KSP.log

 

Otherwise, I get an issue with profile auto change when I switch from flight scene to map view, UI say :

Current scene: FLIGHT map view active: True internal cam active: False
Current profile: MyStrongProfileToSeeIfIsActive

So info are correct but I can see that my profile isn't loaded (moreover it don't auto load any profile even default profiles). At this stage, if I manually pick this profile again, it's loaded and I can see it. But when I revert back to flight scene and I switch to map view again, I can see no profile is loaded.

Also, I can see in my persistent.sfs that MapSceneProfile is set correctly, so it's just an auto load issue.

Is there someone else who get this problem ?

Link to comment
Share on other sites

1 hour ago, mcniff said:

Enabling HDR makes some objects partially see-through, is this a known thing?

Yep.   Short answer: use Textures Unlimited (plus some config pack for stock parts like TURD) but that will likely use more GPU time.

 

Edited by JonnyOThan
Link to comment
Share on other sites

1 hour ago, JonnyOThan said:

Yep.   Short answer: use Textures Unlimited (plus some config pack for stock parts like TURD) but that will likely use more GPU time.

 

Alright, thank you.

I will try that.

Link to comment
Share on other sites

Hello @JonnyOThan, I saw you've made a bug report on Github that point on my post :

On 7/24/2022 at 5:27 AM, Vandest said:

Otherwise, I get an issue with profile auto change when I switch from flight scene to map view, UI say :

Current scene: FLIGHT map view active: True internal cam active: False
Current profile: MyStrongProfileToSeeIfIsActive

So info are correct but I can see that my profile isn't loaded (moreover it don't auto load any profile even default profiles). At this stage, if I manually pick this profile again, it's loaded and I can see it. But when I revert back to flight scene and I switch to map view again, I can see no profile is loaded.

Also, I can see in my persistent.sfs that MapSceneProfile is set correctly, so it's just an auto load issue.

Is there someone else who get this problem ?

I've found a solution and I sent you a PR.

Link to comment
Share on other sites

Yes, auto load for tracking station was work good on 1.0.3.0 and still work good after my patch. Besides, we can have a profile for tracking station and another for flight map, because this is two different scene. It's not necessarily useful but it is possible.

Link to comment
Share on other sites

44 minutes ago, JonnyOThan said:

New release! https://github.com/shadowmage45/TUFX/releases/tag/1.0.4.0

Notable fixes:

-map mode profile was not applying to the camera properly (thanks @Vandest)
-added fov-dependent depth of field setting (thanks @jrodriguez)
-hooked up chromatic aberration & color grading LUTs (thanks @jrodriguez)

Awesome! Thanks for keeping it alive :)

Link to comment
Share on other sites

1 hour ago, MAFman said:

Why is it that last time I installed TUFX, it would occasionally make the scene blurry and shaky until I restarted the game?

This sounds like the side-effects of temporal antialiasing.  Note that scatterer also provides an option for TAA and generally causes more of these issues than TUFX does. But if it’s causing a problem, just turn it off.

Link to comment
Share on other sites

Greetings :) would it be possible to add 'disable toolbar' as a setting? I like to set my visuals at the start, and then disable all non-flight control mod icons to keep my toolbar clean, but there isn't an option for that in TUFX

Edited by HafCoJoe
Link to comment
Share on other sites

On 7/27/2022 at 11:45 PM, HafCoJoe said:

Greetings :) would it be possible to add 'disable toolbar' as a setting? I like to set my visuals at the start, and then disable all non-flight control mod icons to keep my toolbar clean, but there isn't an option for that in TUFX

Don’t the toolbar mods already allow for this?  If not I’ll look into it

Link to comment
Share on other sites

6 hours ago, JonnyOThan said:

Don’t the toolbar mods already allow for this?  If not I’ll look into it

Alas TUFX is rather stubborn, and it's one of the few mods Adjustable Mod Panel (KAMP) can't hide. It's a known enough issue that there's a comment about in the op :/

Edit: I might give Janitor's Closet a try, as it seems to have a hide toolbar icon function as well

Edited by HafCoJoe
Link to comment
Share on other sites

1 hour ago, HafCoJoe said:

Alas TUFX is rather stubborn, and it's one of the few mods Adjustable Mod Panel (KAMP) can't hide. It's a known enough issue that there's a comment about in the op :/

Edit: I might give Janitor's Closet a try, as it seems to have a hide toolbar icon function as well

Ah, well I added a config option earlier today, will be in the next release.

Link to comment
Share on other sites

2 hours ago, JonnyOThan said:

Ah, well I added a config option earlier today, will be in the next release.

:O a config where? I'd love access to this if possible :)

Link to comment
Share on other sites

49 minutes ago, HafCoJoe said:

:O a config where? I'd love access to this if possible :)

I’ll probably push this out soon; I don’t really like releasing small updates quickly but as I get better at the release process there’s not much reason not to.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...