Jump to content

Recommended Posts

I've followed exacts steps from parttools 1.10 installation instruction and I also have the exact error like @theonegalen. This ( Shader error in 'KSP/Alpha/CutoffBackground': failed to open source file: '../CustomUnityShadowLibrary.cginc' at Assets/PartTools/Shaders/AutoLight.cginc(6) (on d3d11) ) error is even on the unity ksp part import tutorial.

Spoiler

 

@JPLRepo Can you save help us ?

 

(1.9 parttools work normally)

Link to post
Share on other sites
On 10/5/2020 at 8:10 AM, MrFancyPL said:

I've followed exacts steps from parttools 1.10 installation instruction and I also have the exact error like @theonegalen. This ( Shader error in 'KSP/Alpha/CutoffBackground': failed to open source file: '../CustomUnityShadowLibrary.cginc' at Assets/PartTools/Shaders/AutoLight.cginc(6) (on d3d11) ) error is even on the unity ksp part import tutorial.

  Reveal hidden contents

@JPLRepo Can you save help us ?

 

(1.9 parttools work normally)

Yes know about this. and had one of the other modders test a fix which worked. Will schedule in some time so we can put a fix out for parttools.

Link to post
Share on other sites
On 10/4/2020 at 3:10 PM, MrFancyPL said:

I've followed exacts steps from parttools 1.10 installation instruction and I also have the exact error like @theonegalen. This ( Shader error in 'KSP/Alpha/CutoffBackground': failed to open source file: '../CustomUnityShadowLibrary.cginc' at Assets/PartTools/Shaders/AutoLight.cginc(6) (on d3d11) ) error is even on the unity ksp part import tutorial.

  Reveal hidden contents

 

@JPLRepo Can you save help us ?

(1.9 parttools work normally)

You can delete the autolight.cginc file all together from the folder and restart unity as a temporary stop this error

Link to post
Share on other sites
  • 2 weeks later...

hi !!

i'm back i've found the cause of my problem, "." replaced by "," in cfg export and prop not loaded in unity.

bV1qogS.jpg

i'm forced to switch region and regional format to English ! on a french windows install.

the answer from unity forum :

Quote

This sounds like an issue with the tool
It sounds like they are using culture-specific number formatting when they should be using culture-independent (invariant). Try posting on the forum for the tool. It should be a simple fix once they spot the problem. https://forum.kerbalspaceprogram.com/index.php?/topic/160487-parttools-updated/

need a fix for french windows user i think ! if it's possible , i prefer to keep  my windows setting french.

bye !

Link to post
Share on other sites
  • 2 months later...

this thread is kinda old but i figure i should help anyone who has this primary issue of Non compiling shaders, with that dead link for the correct shadowmap here is a bandaid fix

Crossposted from another thread i have -

Missing Custom shaders binary curt. this code i found while googling and as far as i can tell is just default Unity code and is MIT licensed- https://github.com/TwoTailsGames/Unity-Built-in-Shaders/blob/master/CGIncludes/UnityShadowLibrary.cginc

 

And i changed 2 lines in AutoLight.cginc to make it all function. will be crossposting this to a thread i had seen that was similar

Heres a link, just put the files in the Assets/Parttools/Shaders folder and replace the AutoLight.cginc with the new on.

https://www.dropbox.com/s/e7a8phoz9zdbxq3/ShaderFix.zip?dl=1

lines changed - Commented out the top line mentioning the custom library and uncommented out the bottom one. probably not necessary but it worked for me

I dont know if it will still look for the custom library or not, i just put it in there but my drunk a%$ is pretty sure its defaulting to Unity's default shadow maps, which is fine for editing parts and the likes as KSP as a game has its own shader set it will compile, and i dont think its far off from default until you start messing with the new stuff that got introduced in the more recent versions.

uwuwuwyna.png

Link to post
Share on other sites
  • 2 weeks later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...