Jump to content

[1.12.4] ScrapYard (SYD) The Common Part Inventory - v2.2.99.0-prerelease `<Project Zelda II>` edition [08 Jan 2023]


zer0Kerbal
 Share

Recommended Posts

I lost only the engine of my aircraft and when I click edit in KCT window to fix it, construction percentage shows 0% and it will took as much time as to build the aircraft completely, instead of just the engine. I tried removing ScrapYard and so; KCT showed 53% construction time without fixing and slightly less than that for fixing the engine. I am confused about this. Anyone encountered similar issue?

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
Posted (edited)
On 7/27/2022 at 2:05 PM, Alexsys said:

Gents,

For some reason Scrapyard fails to reuse Command pods, they just stack up every time, 1 use each.

 

When I apply it, it appears "1 previous use" for a split second, then switches to Part Is New immediately.

Command pods aren't in favor or something?

Ofc I run it with KCT and kerbalism

 

Writes this in the log, for some reason 

[LOG 22:03:11.816] [ScrapYard] Copied tracker. Recovered 1 times with id 2740612802
[LOG 22:03:11.816] [ScrapYard] Found inventory part on vessel that is not in inventory. Resetting. mk1pod.v2:2740612802


https://www.dropbox.com/s/ud0qj4mdn6e6087/KSP.log?dl=0   zi log

@Alexsys issue is here: https://github.com/zer0Kerbal/ScrapYard/issues/62

working on pushing out 2.2.99.0-prerelease and confirmed what you saw.

I know have a large stack of Mk1 pods in Kanford and Sons junk yard.


KSP.log:9866:[LOG 22:45:13.655] [ScrapYard] Vessel Rollout!
KSP.log:9869:[LOG 22:45:13.655] [ScrapYard] Adding build (parts)
KSP.log:9870:[LOG 22:45:13.655] [ScrapYard] mk1pod.v2 has been used 5/5/0 (T/N/I) times.
KSP.log:9871:[LOG 22:45:13.655] [ScrapYard] mk1pod.v2 has been used in 4/4/0 (T/N/I) builds.
KSP.log:9876:[LOG 22:45:13.661] [ScrapYard] OnSave
KSP.log:10272:[LOG 22:45:52.096] [ScrapYard] Found a part in inventory for mk1pod.v2
KSP.log:10273:[LOG 22:45:52.096] [ScrapYard] VerifyEditor.ApplyInventoryToVessel: 0ms
KSP.log:10274:[LOG 22:45:52.097] [ScrapYard] Copy: 0ms
KSP.log:10275:[LOG 22:45:52.097] [ScrapYard] Convert To IParts: 0ms
KSP.log:10276:[LOG 22:45:52.097] [ScrapYard] Found part on vessel with same ID as inventory part, but not matching. Resetting. mk1pod.v2:2904372386
KSP.log:10279:[LOG 22:45:52.097] [ScrapYard] Check Parts: 0ms
KSP.log:10281:	ScrapYard.Utilities.EditorHandling.VerifyEditorShip () (at <ef3e45a011a34dcb890693cee6e67d1f>:0)
KSP.log:10282:	ScrapYard.ScrapYard.VerifyEditor () (at <ef3e45a011a34dcb890693cee6e67d1f>:0)

 

Edited by zer0Kerbal
flocking the trees
Link to comment
Share on other sites

Posted (edited)

ScrapYard! (SYD)
KSP version License
AVC .version files Pages

Code

Version 2.2.99.0-prerelease - <Project Zelda II> edition

Release Notes

  • Released
    • 08 Jan 2023
    • for Kerbal Space Program 1.12.4
    • by zer0Kerbal

For best results - DO A CLEAN INSTALL; DELETE EXISTING INSTALLATION THEN RE-INSTALL

Download from CurseForge

Summary

Spoiler
  • Recompiled for 1.12.4 with .NET 4.7.2 using C# 7.0
  • Added Agency and Flags
  • Split configs between Compatibility and Config
  • Deployed science parts now blacklisted, without a cool hat
  • fix for game settings localization string (code)
  • two releases:
    • one with and one without SYD_ContractConfigurator.dll
    • best solution right now
    • seems to work

Code

  • Recompile for
    • KSP 1.12.2
      • .Net 4.7.2
      • C# 7.0
    • <ScrapYard.dll> v2.2.1.23 --> 2.2.99.89
    • <ScrapYard_ContractConfigurator.dll> v2.2.1.6 --> 2.2.99.58
  • cannot duplicate issues described in #62

Localization

  • Code is localized.
    • <en-us.cfg> 1.1.0.0
    • add agent specific strings

See More

Spoiler

Localization

  • English English
  • your translation here

HELP WANTED - See the README in the Localization folder or the Quickstart Guide for instructions for adding or improving translations. GitHub push is the best way to contribute. Additions and corrections welcome!

red box below is a link to forum post on how to get support

How to get support

Be Kind: Lithobrake, not jakebrake! Keep your Module Manager up to date

How to support this and other great mods by zer0Kerbal

Support Patreon Github Sponsor Buy zer0Kerbal a snack

compiled with: KSP 1.12.4 — .NET 4.7.2 — C# 7.0

Release Schedule

Spoiler
  1. GitHub, reaching first manual installers and users of KSP-AVC. Right now.
  2. CurseForge. Right now.
  3. SpaceDock (and CKAN users). Soon™ (the button has been pushed)

@Zelda

Edited by zer0Kerbal
update links and lasso the birds
Link to comment
Share on other sites

  • 2 weeks later...

I don't want to have to say this but since the latest update (I am on a fully fresh install with the latest version) the issue of the errors shown by skt2008 6 posts above have gone from an annoyance to fully breaking vehicle assembly if you have more than ~30 parts in inventory. Once I hit around this threshold the VAB/SPH began to stutter so horribly that you cant actually place parts anymore since the game cant figure out where the cursor is. The log shows around 2k errors produced in 2 min it is just infinitely looping through the parts in inventory and spitting 1-3 errors per part. Been a long time fan of the mod but this is a game breaking level issue now. Unfortunately I cant even get a log for you since the game is working so hard to spit out these errors that printing the log is actually broken. No errors showing up in the default logs and it is not causing crashes. Wish I had better info for you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...