Jump to content

[1.12.x] GravityTurn continued - Automated Efficient Launches


linuxgurugamer
 Share

Recommended Posts

59 minutes ago, chris-kerbal said:

I have tons of mods installed, the full list is here: https://pastebin.com/9je5i0tt

For Tantares specifically the NewTantares (v22.2) and NewTantaresLV (v12.1) from CKAN.

EDIT: If I can help and put a test setup together, let me know.

Could you do it as an exported modpack from CKAN?  Would make it easier for me to get set up, other wise I'm going to spend a while setting up

Link to comment
Share on other sites

On 1/22/2021 at 5:50 AM, chris-kerbal said:

So after testing on 1.9.1 I can confirm, that with 1.8.1.2 the crafts work as expected. Stock and Tantares parts.

Using 1.8.1.4 stock craft still work like expected, however a Tantares craft will just sit on the pad and switch throttle between 0 and 100%.

For Tantares I was using following craft: https://pastebin.com/qGr0Kvjd

So I managed to get all necessary mods installed, and did a test launch with this.

It was a strange launch, kind of wandered all over the place, and I did see that the radial decouplers did not automatically decouple.  But it did make it to orbit.

I'll compare against  1.8.1.2 later to see the differences.

Also, you and @antipro, could you test against 1.8.1.3?  Would be helpful to know if that was ok or not.

Thanks

 

Edit: @antipro  I saw that you had tested against 1.8.1.3.  Could you make those craft available again for download?

Edited by linuxgurugamer
Link to comment
Share on other sites

2 hours ago, linuxgurugamer said:

So I managed to get all necessary mods installed, and did a test launch with this.

It was a strange launch, kind of wandered all over the place, and I did see that the radial decouplers did not automatically decouple.  But it did make it to orbit.

I'll compare against  1.8.1.2 later to see the differences.

The Tantares engines you are using  (RD-107 & RD-108) have a very unusual vectoring range, one direction is 0, the other direction is 10 degrees.  Apparently GravityTurn has problems controlling a vessel with these engines.  The earlier (1.8.1.2) version did decouple the first stage properly, a second test of 1.8.1.4  showed that the radial decouplers are being triggered  properly, I think I had missed the Auto Stage setting in the first test.    Both versions had problems controlling the vessel..

Just as an FYI, MechJeb was able to control this vessel very nicely.

So, @chris-kerbal & @antipro I'm going to have to ask that you  do two things:  First, zip up the entire save folder and get it to me, and then zip up your whole GameData directory (without the Squad folders).  Something is happening, and I cannot replicate what's going on.  Send me the links via PM please.  It's going to be a big file, but at this point, it's the only way I can think of  to try to replicate the problem.  If I'm lucky, the save file by itself will let me replicate it, but I'm at a loss as to what's going on.

 

Link to comment
Share on other sites

9 hours ago, linuxgurugamer said:

The Tantares engines you are using  (RD-107 & RD-108) have a very unusual vectoring range, one direction is 0, the other direction is 10 degrees.  Apparently GravityTurn has problems controlling a vessel with these engines.  The earlier (1.8.1.2) version did decouple the first stage properly, a second test of 1.8.1.4  showed that the radial decouplers are being triggered  properly, I think I had missed the Auto Stage setting in the first test.    Both versions had problems controlling the vessel..

Just as an FYI, MechJeb was able to control this vessel very nicely.

So, @chris-kerbal & @antipro I'm going to have to ask that you  do two things:  First, zip up the entire save folder and get it to me, and then zip up your whole GameData directory (without the Squad folders).  Something is happening, and I cannot replicate what's going on.  Send me the links via PM please.  It's going to be a big file, but at this point, it's the only way I can think of  to try to replicate the problem.  If I'm lucky, the save file by itself will let me replicate it, but I'm at a loss as to what's going on.

 

I created a save with the 1.8.1.3 in which the problem also occurs. Zipped save and gamedata. Both is uploading now and I will send you the link later today, when it is done.

The wobbling you experienced seems to be usual (for this built), it gets better with autostruts activated, however when using gravityturn for launch, it has way more difficulties to stabilize the rocket than I have when doing the launch manually.

Link to comment
Share on other sites

  • 3 weeks later...

I feel like the default Roll setting should be 270 out of the box, so that a craft won't Roll, maybe for new players.  I usually set my Roll 180 anyways, I do that too in MJ if I were using Ascent Guidance Instead.

I found it weird that MJ default roll setting is 90, so it doesn't roll. But for GravityTurn, setting it 270 makes it not roll.

==========================================

Gravity Turn Mod:          MechJeb Mod:

 

      Back side                          Back side  

          90                                         270           
            |                                              |
            |                                              |
 0----+----180                  0----+----180
            |                                              |
            |                                              |
        270                                        90
    
     Front side                        Front side     @Launch

Edited by therealcrow999
Link to comment
Share on other sites

I have been using this a lot lately, with a lot of ships I am testing. I might have had like 2 or 3 issues with certain craft, where it wouldn't let me do First Guess. Come to find out, it is not the mod, it was the craft. It was like a fail safe telling me there is something off with my craft.

The one craft, the first launch stage wasn't quiet right. It never fired, it was issue with build. The other ship I had issues with GT, I had to turn off Auto Stage and I had to stage myself. There was something off about one stage, it had a lot of tiny parts to it and tiny engines.

In conclusion the mod seems to be working fine. I know there were reports where it was not working on some craft, maybe it was issue with craft and not mod. I don't know, I am not a modder, I am just giving my feedback on that main bug I heard about.

Edit: A few ships I had to turn Auto Stage off and manually do it myself. Seemed weird.

Edited by therealcrow999
Link to comment
Share on other sites

There are situations I've had where the first time GravTurn does a stage it does not ignite the first stage engines. This has only happened when using mods that add ignition to engines for me though. Not really a problem since I can always hit stage manually at launch.

On 1/23/2021 at 3:15 PM, linuxgurugamer said:

Using 1.8.1.4 stock craft still work like expected, however a Tantares craft will just sit on the pad and switch throttle between 0 and 100%.

I've had throttle go back and forth like that when my control part was not facing UP at launch on pad.... check that

Link to comment
Share on other sites

 

On 2/8/2021 at 2:24 PM, therealcrow999 said:

I feel like the default Roll setting should be 270 out of the box, so that a craft won't Roll, maybe for new players.  I usually set my Roll 180 anyways, I do that too in MJ if I were using Ascent Guidance Instead.

I found it weird that MJ default roll setting is 90, so it doesn't roll. But for GravityTurn, setting it 270 makes it not roll.

==========================================

Gravity Turn Mod:          MechJeb Mod:

 

      Back side                          Back side  

          90                                         270           
            |                                              |
            |                                              |
 0----+----180                  0----+----180
            |                                              |
            |                                              |
        270                                        90
    
     Front side                        Front side     @Launch

I agree about confusion, but think its more accurate in GT, because in the VAB the default position of the "cockpit" of the rocket is with the 'top' on the south side of VAB. So when you launch to 'top' of space shuttle for instance would be on south sitde, of focket and to fly east and have shuttle on top, you would rotate 90 deg. TO have the shuttle upside-down as IRL you would rotate 270.

 

If GT if you fly a polar orbit you should not need to rotate at all because you will end up facing 0/360 once rotating with the cockpit will be on top . 

Link to comment
Share on other sites

Too bad the feature to circularize orbit, when reaching destination height is not built into this. I know MJ allows this when it is installed with this mod, but it could be nice to have it in GT, and could be toggled off and on. I kind of stopped using MJ a while back.

Link to comment
Share on other sites

1 minute ago, therealcrow999 said:

Too bad the feature to circularize orbit, when reaching destination height is not built into this. I know MJ allows this when it is installed with this mod, but it could be nice to have it in GT, and could be toggled off and on. I kind of stopped using MJ a while back.

Not going to be added, either.  Sorry

Link to comment
Share on other sites

11 hours ago, therealcrow999 said:

Too bad the feature to circularize orbit, when reaching destination height is not built into this. I know MJ allows this when it is installed with this mod, but it could be nice to have it in GT, and could be toggled off and on. I kind of stopped using MJ a while back.

I didn't even realize that circularization was not part of this mod until you said it :o

Link to comment
Share on other sites

1 hour ago, Tacombel said:

I didn't even realize that circularization was not part of this mod until you said it :o

Yeah you have to do it manually. If you have MJ, it will take over automatically. Kind of the only feature I use from MJ, and node execute, but I honestly don't use MJ anymore, I do things more manually. I do however like my nice launches.

Link to comment
Share on other sites

4 hours ago, Tacombel said:

I didn't even realize that circularization was not part of this mod until you said it :o

Gravity Turn ceases to control the vehicle as soon as these two conditions are met:  (1) the target apoapsis has been attained, and (2) the vehicle is out of the atmosphere.  Therefore, it does not perform the circularization burn at apoapsis.  Of course that's pretty easy to do yourself.  I generally use Precise Maneuver - just place a maneuver node, click the AP button, then click the Circularize Orbit button.  All you then have to do is perform the burn when you get to the node.
 

Edited by OhioBob
Link to comment
Share on other sites

  • 1 month later...
8 hours ago, MysticDaedra said:

Couple of days ago (perhaps related to the most recent update?) GravityTurn stopped auto-staging even when the option is enabled. I'm currently on KSP 1.11.2 and GravityTurn 1.8.14.

You're going to need to post a link your player.log file. Also need to tag @linuxgurugamer so he sees it.

Link to comment
Share on other sites

GT 1.8.1.2
Issue: apparently random small vertical axis rotation at launch.

The following video shows 4 identical launches, 2 of these have the problem:
a small rotation of a few degrees on the vertical axis which is immediately corrected.

https://www.dropbox.com/s/m1f0ss6o6jm6k2q/gt small rotation at launch.mkv?dl=0

I have also experienced this problem on other rockets and I can't figure out what the cause could be,
have any of you ever noticed it?

Edited by antipro
Link to comment
Share on other sites

1 hour ago, antipro said:

GT 1.8.1.2
Issue: apparently random small vertical axis rotation at launch.

The following video shows 4 identical launches, 2 of these have the problem:
a small rotation of a few degrees on the vertical axis which is immediately corrected.

https://www.dropbox.com/s/m1f0ss6o6jm6k2q/gt small rotation at launch.mkv?dl=0

I have also experienced this problem on other rockets and I can't figure out what the cause could be,
have any of you ever noticed it?

It's not a bug, it's just physics.  Nothing is identical.  something is off very slightly in the vessel, and it happens.

Link to comment
Share on other sites

10 hours ago, antipro said:

ok not a bug but, what exactly this mean?
"something is slightly out of place in the vessel"?
what?

 

Floating point roundoff errors.  No craft is perfect, no matter what you do in the editor, it's not going to be totally perfect.  So when you launch, it will go off (ie:  twist a bit) before GT can correct it.  GT might be thinking that it needs a specific correction at launch, when it either may not, or may be too much/too little, etc.

Link to comment
Share on other sites

This was a little hard to get right for my first whack at it, possibly because my rocket is an attempt at solid SSTO which maybe this plugin isn't designed for initially?

Here's what I ended up with after 8 improved guesses and then some manual tweaking, let me know if it looks roughly optimized. Improved guesses only got me down to about 600km apogee, needed manual tweaking to get better than that.

Hi2hDKI.jpg

 

5CpS5zH.jpg

 

 

I locked sensitivity at 1.0 because otherwise I saw it trying to throttle my SRBs.  I locked Start m/s at 10 because the improved guesses started going negative. I locked pressure cutoff and manually set it much higher because improve guess didn't seem to change that number but it originally occurred well past engine shutoff.  I locked turn angle and had to start manually increasing it to 42 because improve guess kept it around 23-25 which wasn't nearly aggressive enough.  Now I'm still slightly overshooting my target apogee, but 250 apogee / -78 perigee is  much better than I could do by hand (previous best was -350 perigee), before blowing up from getting too shallow and hot. Probably a product of my ship design. Maybe need to limit my SRB max thrust? I'm at the point where if I increase my turn angle by 0.5 I overheat and blow up right before engine cutoff :D

 

I'm also aware I'm about 300 m/s shy of orbital velocity but this is close enough for me (second stage is all nukes, it's a Tylo visit and return mission).

Edited by immolated
Link to comment
Share on other sites

5 hours ago, immolated said:

This was a little hard to get right for my first whack at it, possibly because my rocket is an attempt at solid SSTO which maybe this plugin isn't designed for initially?

Here's what I ended up with after 8 improved guesses and then some manual tweaking, let me know if it looks roughly optimized. Improved guesses only got me down to about 600km apogee, needed manual tweaking to get better than that.

 

I locked sensitivity at 1.0 because otherwise I saw it trying to throttle my SRBs.  I locked Start m/s at 10 because the improved guesses started going negative. I locked pressure cutoff and manually set it much higher because improve guess didn't seem to change that number but it originally occurred well past engine shutoff.  I locked turn angle and had to start manually increasing it to 42 because improve guess kept it around 23-25 which wasn't nearly aggressive enough.  Now I'm still slightly overshooting my target apogee, but 250 apogee / -78 perigee is  much better than I could do by hand (previous best was -350 perigee), before blowing up from getting too shallow and hot. Probably a product of my ship design. Maybe need to limit my SRB max thrust? I'm at the point where if I increase my turn angle by 0.5 I overheat and blow up right before engine cutoff :D

 

I'm also aware I'm about 300 m/s shy of orbital velocity but this is close enough for me (second stage is all nukes, it's a Tylo visit and return mission).

I'm amazed you had it working as well as you did.

This mod NEEDS to have the engines both throttleable and to be able to shut them off.  It's the way it works.  SRBs are neither.

You may want to try the MechJeb Ascent Guidance module

Link to comment
Share on other sites

7 hours ago, immolated said:

(...)Probably a product of my ship design. Maybe need to limit my SRB max thrust? I'm at the point where if I increase my turn angle by 0.5 I overheat and blow up right before engine cutoff :D

 

(...)

Are you using the mod deadly reentry? Last week it gave me that weird bug where srbs overheat before they have time to finish burning...

EDIT: I just looked at your settings and I think you start your turn too quick at 10m/s... I have better success at 80-100m/s, the rocket gets out of thick air faster...

Edited by flack
Link to comment
Share on other sites

5 hours ago, linuxgurugamer said:

I'm amazed you had it working as well as you did.

This mod NEEDS to have the engines both throttleable and to be able to shut them off.  It's the way it works.  SRBs are neither.

You may want to try the MechJeb Ascent Guidance module

 

Thought so, lol. I'm determined to make it work though, I think with a little more tweaking I'll get there.

 

 

3 hours ago, flack said:

Are you using the mod deadly reentry? Last week it gave me that weird bug where srbs overheat before they have time to finish burning...

EDIT: I just looked at your settings and I think you start your turn too quick at 10m/s... I have better success at 80-100m/s, the rocket gets out of thick air faster...

Nope no other mods except hyper warp. I'm just really low, and really fast, which is the only way to make solid SSTO work, I think. I'll experiment with getting higher before the turn.

Edited by immolated
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...