Jump to content

[1.12.x] GravityTurn continued - Automated Efficient Launches


linuxgurugamer
 Share

Recommended Posts

Perhaps a clue - variations of this

Quote

[EXC 21:12:36.278] KeyNotFoundException: The given key was not present in the dictionary.
    System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0)
    GravityTurn.StageController.InverseStageDecouplesActiveOrIdleEngineOrTank (System.Int32 inverseStage, Vessel v, System.Collections.Generic.List`1[T] tankResources) (at <784d401db2d14e16901ded08728ab5dd>:0)
    GravityTurn.StageController.Update () (at <784d401db2d14e16901ded08728ab5dd>:0)
    GravityTurn.GravityTurner.fly (FlightCtrlState s) (at <784d401db2d14e16901ded08728ab5dd>:0)
    Vessel.FeedInputFeed () (at <06f13185617646e5bc801baeab53ab75>:0)
    FlightInputHandler.FixedUpdate () (at <06f13185617646e5bc801baeab53ab75>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

thousands of times in my log

Link to comment
Share on other sites

Found it. The problem occured because the root part was "Rockomax HubMax Multi-Point" and NOT a probe core or capsule.

Once I re-rooted the craft so the RC-L01 Remote Guidance Unit was the root part, it worked correctly.

Link to comment
Share on other sites

7 hours ago, tg626 said:

Anyone else experience this?

it appears you are experiencing GT's behavior as I have described and shown in multiple videos of eleven different vessels, three days ago, four posts above your first.
(in this case the count of users who reported the problem rises to 4.)
so, yes I'm experiencing it too. Have you tried to modify the vessel slightly, like removing, adding or moving small parts, for example the batteries?
or revert to GT v1.8.1.2?

Edited by antipro
Link to comment
Share on other sites

8 hours ago, tg626 said:

Anyone else experience this?

Stage 1 (well, 6 because KSP counts from the top down...)

5 Liquid Fueled Engines

Stage 2

4 SRB and Launch Clamps

Hit "LAUNCH": Liquid engines fire up at full throttle.

Hit Space to light SRBs and release clamps: Throttle goes to ZERO (should never drop below 33% per settings) Rocket flys with no guidance at all (no deflection of the Pitch Roll Yaw needles) fall over and eventually into the ground.

 

Tried putting all engines and clamps in 1st stage, no good.

Tried manual throttle and SAS and I can throttle up and SAS turns on (shouldn't both ignore me?)

 

Can you check to be sure you don't have any controllers installed?  

Link to comment
Share on other sites

@linuxgurugamer I've found a bug/incompatibility with throttle limit extended where the throttle control from the autopilot in this mod bypasses the throttle limits functionality. Could you possibly make the throttle authority for the autopilot optional?

Link to comment
Share on other sites

Hi @linuxgurugamer,

I have a feature request.  I'm sure you have a full plate so if you can't do it I completely understand.  However, if you find yourself with a bit of free time, if you could add a keybind feature so that you can start a GravityTurn launch without having the HUD up, that would be awesome for taking screenshots and capturing video.  

 

Link to comment
Share on other sites

5 minutes ago, DeliriumTrigger said:

Hi @linuxgurugamer,

I have a feature request.  I'm sure you have a full plate so if you can't do it I completely understand.  However, if you find yourself with a bit of free time, if you could add a keybind feature so that you can start a GravityTurn launch without having the HUD up, that would be awesome for taking screenshots and capturing video.  

 

What happens when you set all values, and then hide the HUD (I assume you mean all UI elements)?  and then press the spacebar to launch?

Link to comment
Share on other sites

4 minutes ago, linuxgurugamer said:

What happens when you set all values, and then hide the HUD (I assume you mean all UI elements)?  and then press the spacebar to launch?

It just stages as though you're not using GravityTurn at all.

One of the main reasons I use GravityTurn is so that I can focus on camera angles and scene composition.  Unfortunately if I want to capture a nice scene of the sparks firing, then the main engine and finally the clamps releasing when using Modular Launch Systems I need to also be ready to control the rocket once it leaves the pad.  Which is fine, I can quicksave, record, launch, get the shot I want and then reload and launch with GravityTurn to focus on shots once it's cleared the pad and just make it look seamless in editing.   But it would be so much simpler and a lot less time consuming if I could just hit a keybind and only have to focus on the camera after that.

If I knew anything about programming I would dig around in the source and submit a PR, but unless its a CNC mill and G-code I'm completely lost in that regard, hence the request.

Link to comment
Share on other sites

1 hour ago, DeliriumTrigger said:

It just stages as though you're not using GravityTurn at all.

One of the main reasons I use GravityTurn is so that I can focus on camera angles and scene composition.  Unfortunately if I want to capture a nice scene of the sparks firing, then the main engine and finally the clamps releasing when using Modular Launch Systems I need to also be ready to control the rocket once it leaves the pad.  Which is fine, I can quicksave, record, launch, get the shot I want and then reload and launch with GravityTurn to focus on shots once it's cleared the pad and just make it look seamless in editing.   But it would be so much simpler and a lot less time consuming if I could just hit a keybind and only have to focus on the camera after that.

If I knew anything about programming I would dig around in the source and submit a PR, but unless its a CNC mill and G-code I'm completely lost in that regard, hence the request.

It's a reasonable request, I'll take a look at it. 

Link to comment
Share on other sites

On 5/25/2021 at 1:55 AM, tg626 said:

Ok, functions, but not error free...

LOG: https://1drv.ms/u/s!ApRsS13p52FhmTI7Sk5IpXXy7CH5?e=L7vozs

My payload, but the rocket was the stock GPLV3

Craft: https://1drv.ms/u/s!ApRsS13p52FhmTOpyCN6qoGcjqbo?e=5yc46P

I’ll take a look, thx

can you provide the save file as well?

Edited by linuxgurugamer
Link to comment
Share on other sites

I have a beta for anyone who is experiencing the KeyNotFound error

https://www.dropbox.com/s/mv6c65adu50mpw0/GravityTurn-1.8.1.6.zip?dl=0

Please try it out and let me know how it goes.

IMPORTANT

You MUST remove the old DLL by hand before copying this over.  The DLL has been renamed.  If you don't remove it, then the Kraken may be woken up

Link to comment
Share on other sites

here is yet another rocket, one of the simplest, which does not separate its first stage with v1815 but it does with v1812.
adding 2x
F3S0 SRB makes the rocket crashes cause of main engine hops.
 

v1812
v1812.png?dl=1

v1815
v1815.png?dl=1


v1815 + F3S0
v1815%20+%20F3S0.png?dl=1

Edited by antipro
Link to comment
Share on other sites

17 minutes ago, antipro said:

here is yet another rocket, one of the simplest, which does not separate its first stage with v1815 but it does with v1812.
adding 2x
F3S0 SRB makes the rocket crashes cause of main engine hops.

Craft file, please, for each rocket

 

Link to comment
Share on other sites

by replacing the C7 Brand Adapter with a Rockomax Brand Adapter and an X-200 Fuel Tank, the separation works.
even adding the F3SOs no longer cause the "hops" problem.

v1815 - C7  + Rockomax Brand Adapter + X200-8
v1815%20-%20C7%20%20+%20Rockomax%20Brand

 

1 hour ago, linuxgurugamer said:

Craft file, please, for each rocket


C7 = not working: https://www.dropbox.com/s/tcrlrwve16mq187/bop flyby.craft?dl=0
Rockomax + X200-8 = working: https://www.dropbox.com/s/082tq595cek32r9/bop flyby v2.craft?dl=0
bop flyby v2 + 2x F3S0 = it works: https://www.dropbox.com/s/mp9lftok4gxh922/bop flyby v3.craft?dl=0
bop flyby + 2x F3S0 = it does not work: https://www.dropbox.com/s/jm13x9pmier1ut2/bop flyby v4.craft?dl=0

Edited by antipro
Link to comment
Share on other sites

39 minutes ago, antipro said:

by replacing the C7 Brand Adapter with a Rockomax Brand Adapter and an X-200 Fuel Tank, the separation works.
even adding the F3SOs no longer cause the "hops" problem.

v1815 - C7  + Rockomax Brand Adapter + X200-8
v1815%20-%20C7%20%20+%20Rockomax%20Brand

 


C7 = not working: https://www.dropbox.com/s/tcrlrwve16mq187/bop flyby.craft?dl=0
Rockomax + X200-8 = working: https://www.dropbox.com/s/082tq595cek32r9/bop flyby v2.craft?dl=0
bop flyby v2 + 2x F3S0 = it works: https://www.dropbox.com/s/mp9lftok4gxh922/bop flyby v3.craft?dl=0
bop flyby + 2x F3S0 = it does not work: https://www.dropbox.com/s/jm13x9pmier1ut2/bop flyby v4.craft?dl=0

Ok, please take the rocket which worked, and replace the Rockomax+X200 with the C7, and test again.  This will help show if it was something in the craft file or something else.

I'll download and test your files later, am at work now

Link to comment
Share on other sites

2 hours ago, antipro said:

here is yet another rocket, one of the simplest, which does not separate its first stage with v1815 but it does with v1812.

Would have been nice if had tried 1.8.1.6, which was posted in the message right above.  Also, this may be picky, but "v1815", "v1812" was very confusing, as those are NOT the version numbers which I use. No dots mean it could have been a build number, or any other number.  Dots are there for a reason, please use them when referring to the version of the mod.

 

I got some time to test this in a stock 1.11.2 game, initially with the default settings:

50 minutes ago, antipro said:

Worked, got out of the atmosphere on first stage.  GT stops working when out of the atmo AND desired AP is reached (not at the AP, but when the AP is what is set)

I then tested using your settings:

  • Start m/s: 40
  • Turn Angle: 24
  • Destination Height: 120

Besides the fact that this was much less efficient, it worked.

I then tested the 2xF3S0 v4 craft.  Worked with default settings, tried your settings, also worked, again, a much shallower launch, but that's not what's at issue here

 

Link to comment
Share on other sites

1 hour ago, linuxgurugamer said:

Ok, please take the rocket which worked, and replace the Rockomax+X200 with the C7, and test again.  This will help show if it was something in the craft file or something else.

done: it does not separate.
 


 

1 hour ago, linuxgurugamer said:

Would have been nice if had tried 1.8.1.6, which was posted in the message right above.

searched for "keynotfound" in ksp.log and found the strings.
tried 1.8.1.6 with bop flyby.craft = it now separates. it works.
can you put 1.8.1.6 on CKAN?


 

1 hour ago, linuxgurugamer said:

Also, this may be picky, but "v1815", "v1812" was very confusing

got it.


 

1 hour ago, linuxgurugamer said:

I got some time to test this in a stock 1.11.2 game, initially with the default settings:

2 hours ago, antipro said:

Worked, got out of the atmosphere on first stage.  GT stops working when out of the atmo AND desired AP is reached (not at the AP, but when the AP is what is set)

I then tested using your settings:

  • Start m/s: 40
  • Turn Angle: 24
  • Destination Height: 120

Besides the fact that this was much less efficient, it worked.


assuming you used the version 1.8.1.6 with default settings, that are:
Start m/s: 100
Turn angle: 10

Destination Height: 80

yes, I got out of the atmosphere and reached Ap on first stage too, so it isn't possible to determine if the separation works or not.

I can't understand why you say that my settings are much less efficient.
using 40/24/120, I have +347m/s dV at destination than when using 100/10/120 and
+268m/s dV than when using 100/10/80.

anyway, as already said, the first stage now separates with version 1.8.1.6, that rocket now works.
this is the important thing.



 

1 hour ago, linuxgurugamer said:

I then tested the 2xF3S0 v4 craft.  Worked with default settings, tried your settings, also worked, again, a much shallower launch, but that's not what's at issue here

yes, with 1.8.1.6, no longer main engine "hops", it works here too.
but again can't understand why does a shallower trajectory have to be an issue.

Edited by antipro
Link to comment
Share on other sites

1 hour ago, antipro said:

can you put 1.8.1.6 on CKAN?

It is a beta, will be a full release soon

1 hour ago, antipro said:

but again can't understand why does a shallower trajectory have to be an issue.

It isn’t, was more of an observation of the differences.

Link to comment
Share on other sites

On 6/5/2021 at 12:48 PM, linuxgurugamer said:

I’ll take a look, thx

can you provide the save file as well?

I've done a lot since then, so no I can't unfortunately.  Next time I'll include that too. 

What did you mean by "controller" - like Xbox controller or that stock robotics controller that I never use so I don't remember the name?

Link to comment
Share on other sites

17 hours ago, tg626 said:

I've done a lot since then, so no I can't unfortunately.  Next time I'll include that too. 

What did you mean by "controller" - like Xbox controller or that stock robotics controller that I never use so I don't remember the name?

game controller

Link to comment
Share on other sites

New release, 1.8.1.7

  • Fixed creating extra PluginData directories under the Plugin directory
  • Added support for ThrottleLimitExtended
  • Added keybinding, letter L will launch even if game UI is hidden.  Key can be changed by editing a file:  GravityTurn/PluginData/keybind.cfg
  • Added code to disable mod above atmosphere
  • Renamed DLL for better CKAN compatibility
  • Optimized InverseStageDecouplesActiveOrIdleEngineOrTank to reduce number of key access, also should solve the KeyNotFound errors
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...