Jump to content

[1.8.1 ONLY] KSRSS(VE) 0.6.1 - More things around rings


Recommended Posts

On 5/6/2020 at 3:51 AM, M42-Orion said:

Bravo!:o

Can I translate the mod into Chinese?:D

Of course ! But please wait 0.6.1 release for translate Mars Biome ! Some change on this planet :)

Some news about 0.6.1 :

- we've finally fixed the quicksave bug ! 
- KK-KSRSS will probably not be updated for 0.6.1. We can't place mapdecals properly, so we have a choice : let the lauchpads float and publish a non-final update (working but not pretty), or push back the release of KK-KSRSS for final release of KSRSS. What do you prefer?

So... all major bugs were fixed. We'll release the 0.6.1 when we have decided what to do with KK-KSRSS.

Link to post
Share on other sites
4 hours ago, Kierra said:

Of course ! But please wait 0.6.1 release for translate Mars Biome ! Some change on this planet :)

Some news about 0.6.1 :

- we've finally fixed the quicksave bug ! 
- KK-KSRSS will probably not be updated for 0.6.1. We can't place mapdecals properly, so we have a choice : let the lauchpads float and publish a non-final update (working but not pretty), or push back the release of KK-KSRSS for final release of KSRSS. What do you prefer?

So... all major bugs were fixed. We'll release the 0.6.1 when we have decided what to do with KK-KSRSS.

Will the Mars biome changes affect anything currently on the surface? I have a 6-astronaut mission down there currently. And also, will previously gathered Martian science become broken? Also, great work on this mod! I tried to go back to normal RSS while I waited and it just isn't as fun as this.

Link to post
Share on other sites
7 hours ago, BadModder54 said:

Will the Mars biome changes affect anything currently on the surface? I have a 6-astronaut mission down there currently. And also, will previously gathered Martian science become broken? Also, great work on this mod! I tried to go back to normal RSS while I waited and it just isn't as fun as this.

Nop, there is any terrain change :

Link to post
Share on other sites
14 hours ago, Kierra said:

Of course ! But please wait 0.6.1 release for translate Mars Biome ! Some change on this planet :)

Some news about 0.6.1 :

- we've finally fixed the quicksave bug ! 
- KK-KSRSS will probably not be updated for 0.6.1. We can't place mapdecals properly, so we have a choice : let the lauchpads float and publish a non-final update (working but not pretty), or push back the release of KK-KSRSS for final release of KSRSS. What do you prefer?

So... all major bugs were fixed. We'll release the 0.6.1 when we have decided what to do with KK-KSRSS.

I can wait for KK-KSRSS. But, correct me if I'm mistaken, that doesn't stop people having KK installed and creating our own KSC launch pads does it? I'm basically running 0.6 without KK-KSRSS and still have the stock KK installed so I can create my own KSC.

Just release the 0.6.1 without KK-KSRSS I say

Link to post
Share on other sites
On 5/10/2020 at 8:10 PM, Kierra said:

Of course ! But please wait 0.6.1 release for translate Mars Biome ! Some change on this planet :)

Some news about 0.6.1 :

- we've finally fixed the quicksave bug ! 
- KK-KSRSS will probably not be updated for 0.6.1. We can't place mapdecals properly, so we have a choice : let the lauchpads float and publish a non-final update (working but not pretty), or push back the release of KK-KSRSS for final release of KSRSS. What do you prefer?

So... all major bugs were fixed. We'll release the 0.6.1 when we have decided what to do with KK-KSRSS.

I was thinking about translating it to portuguese but I guess I'll wait too.
BTW, what's the best way for you to receive the file?

About KK, I say release  0.6.1 without it

Link to post
Share on other sites
On 5/11/2020 at 7:10 AM, Kierra said:

Of course ! But please wait 0.6.1 release for translate Mars Biome ! Some change on this planet :)

Some news about 0.6.1 :

- we've finally fixed the quicksave bug ! 
- KK-KSRSS will probably not be updated for 0.6.1. We can't place mapdecals properly, so we have a choice : let the lauchpads float and publish a non-final update (working but not pretty), or push back the release of KK-KSRSS for final release of KSRSS. What do you prefer?

So... all major bugs were fixed. We'll release the 0.6.1 when we have decided what to do with KK-KSRSS.

Thanks:DMy Github username is XCM42-Orion(I'm not very good at English)

Link to post
Share on other sites
10 hours ago, gbggk said:

It's great, but I have a little bit of a problem. When it's about 100km from the ground, there's a black edge in the distance. It's the same with other planets. What did I miss

We can't do anything if you don't provide screen of your GameData and KSP.log

Link to post
Share on other sites
On 5/10/2020 at 4:10 PM, Kierra said:

- KK-KSRSS will probably not be updated for 0.6.1. We can't place mapdecals properly, so we have a choice : let the lauchpads float and publish a non-final update (working but not pretty), or push back the release of KK-KSRSS for final release of KSRSS. What do you prefer?

What trouble are you having with floating launchpads/map decals? I just fixed a similar sounding issue in my Airports mod.

Edited by Nightside
Link to post
Share on other sites
17 hours ago, Nightside said:

What trouble are you having with floating launchpads/map decals? I just fixed a similar sounding issue in my Airports mod.

I am unable to put map decals under launchdpads & other KK statics. There are just not spawning, and i'm unable to find why :(

Link to post
Share on other sites
// ActualSizeAirports config by Nightside
// Map Decal For GroupCenter_NSAS_AAL

KK_MapDecal
{
Name = NSAS_AAL_MapDecal
CelestialBody = Earth					//Make sure this is set to Earth
Latitude =  57.09275891 
Longitude =  9.849243164 
Radius =  30000 
HeightMapName = height_KSC				//no file type suffix, make sure the HeightMap is properly defined
ColorMapName = None
RemoveScatter = True
UseAlphaHeightSmoothing = True
UseAbsolut = True
AbsolutOffset =  3 
CullBlack = False
HeightMapDeformity =  1 
SmoothColor =  0 
SmoothHeight =  0.125 
Angle =  0 
Order =  110000 			//Draw order - this value is hard to adjust within Kerbal Konstructs
Group = NSAS_AAL
}

I've experienced something similar, (although not my recent issue -that was just me making a unit conversion error between runways and map decal ground levels). 

The config above has a few notes that might help. Maybe you already know all this, but hopefully there is something helpful here.

1. If you are using a custom height map make sure you also make a config file for it.

2. It could be related to Order. If you have 2 overlapping Map Decals in one place the one with the higher order will supersede. That is straight forward, just within Kerbal Konstructs. However, Kopernicus may also be changing things - and this is where I've been confused in the past when I am trying to work with both Kopernicus and KK mapDecals at the same time. Basically, make sure KK MapDecal Order > Kopernicus MapDecal Order. Kopernicus's vertex and noise stuff may also interfere with Kopernic

3. If none of that works, you can also just define height map directly in Kopernicus, but it is more difficult to edit. Here is an Kopernicus map decal that someone made, that I use in my full size RSShttps://github.com/AnticlockwisePropeller/RSSHiDefCape

Hopefully that helps! Thanks for putting together such a great looking system!  Also, I was able to use your configs as an example to finally learn how to define terrain scatters, so thank you!

Link to post
Share on other sites

I would personally release KSRSS 6.1 without the KK configs, since they are the only thing delaying release. That way, the KK stuff could be developed and released later as not to hold up development. Just my opinion, keep up the great work!

Link to post
Share on other sites
Just now, BadModder54 said:

I would personally release KSRSS 6.1 without the KK configs, since they are the only thing delaying release. That way, the KK stuff could be developed and released later as not to hold up development. Just my opinion, keep up the great work!

100% agree with this. KK should be delayed, and taken care of later.

Link to post
Share on other sites

BUGFIX 0.6.1

Changelog :

  • Added Commnet Stations
  • Fixed lag on Saturn moons
  • Added Dione terrain preset
  • Fixed KSC Height in x2.5
  • Fixed diplay pressure on Venus, Titan, Mars
  • New PlanetShine config
  • Added mars biomes
  • Added an install checker
  • Added Final Frontier ribbons
  • Fixed quicksave bug by removing MH launchsites
  • Added loading screens (Thanks @Zarbon44 for the Titan loading screen)
  • Added chinese localization by
  • New atmospheres for Jupiter, Saturn, Uranus and Neptune
  • fix localization bugs
  • new Mars colormap
  • new moon colormap
  • new mercury colormap
  • reduced pluto biomemap size

To update, delete KSRSS and KSRSS-Textures in your GameData and install the new version.

 

On 5/17/2020 at 12:16 PM, DA299 said:

I have a question: 

Is this mod compatible with Kerbalism?

Not yet.

Link to post
Share on other sites
26 minutes ago, winproof said:

Problem "new text" in settings is still here. (on french ksp version, not tested on english version)

That’s a stock/Kopernicus bug.

27 minutes ago, winproof said:

and can we use scatterer 0.0610 or only 0.055?

We didn’t test KSRSSVE with 0.0610 but it should work.

Link to post
Share on other sites

@tony48 great work, Fixed quite a few of my issues. May i ask how i can prevent cities from changing to city lights as you go above a certain height in the day side of Earth? I have brought up the issue before but i'm unsure as to whether or not the issue was picked up by yourselves or looked at. Its not major but can look a little weird when ascending from the ground. If you know where this is configured i can have a look for myself until the next bugfix/version release. thanks

Link to post
Share on other sites
13 hours ago, tony48 said:

We didn’t test KSRSSVE with 0.0610 but it should work.

Scatterer works splendidly, however EVE won't show up any clouds on any body, the ingame Config Editor just says 'invalid name' for the cloud configs.

Link to post
Share on other sites
9 minutes ago, theorimha said:

Scatterer works splendidly, however EVE won't show up any clouds on any body, the ingame Config Editor just says 'invalid name' for the cloud configs.

That's strange, they are working fine on my game.

Link to post
Share on other sites
1 hour ago, si2504 said:

That's strange, they are working fine on my game.

Turns out this EVE stuff is just plain weird. I restarted the game and bam, beautiful clouds on every (configured) planet. Well, I'm not complaining...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...