Jump to content

[BETA] KSRSS 0.7 - Kerbin (or x2.5) sized RSS


tony48
 Share

KSC location for the next release  

26 members have voted

  1. 1. Where should the KSC be located?

    • Cape Canaveral, Florida (28 degrees North)
      20
    • Kourou, French Guiana (5 degrees North)
      6


Recommended Posts

On 2/13/2021 at 1:53 PM, R-T-B said:

That's a nice clue.  Try putting the following in a config .cfg file (name does not matter), maybe?

@Kopernicus:FINAL
{
	useOnDemand = False
}

It WILL increase your ram usage.  But it might fix the bug.

I'm not sure if this is super obvious, but the black moon issue might be a problem with the fact that all of the planets except Earth and Mars don't have a .dds file labeled "Surface." Maybe it's trying to switch to surface textures but there are none? I don't know anything about this, I just noticed it in the files and thought it might be important :)

Link to comment
Share on other sites

On 3/2/2021 at 5:46 PM, user_25th9p7 said:

2:EVE-1.8.0-2 and 3:v0.055 (scatterer) both installed with ckan 

I had this same issue, but with the scatterer version from SpaceDock. Search for the scatterer GitHub page and go to the "releases" section. For me, version 0.0600 worked just fine (it was the newest one that directly said it supports 1.8.x) but if that still fails to work there are many more versions to try out. Hope I could help.

Link to comment
Share on other sites

---(EDIT: FIXED NOW, After a computer restart the game starts at a reasonable speed again)---

Hi, I have a problem loading up the mods. 

When I load up the game, all goes well until it gets to the final stage, "Expansion loading complete. " When it gets to this stage, my memory usage ramps up significantly (i have seen it push my total memory usage up to 98% with a few google chrome tabs that are just forum pages being the only other thing open) and takes about 15 minutes just to get from that screen to the main menu. This is not normal for me as previously I could load a full RSS modpack with it not taking nearly as long.

Edited by CaptainZulu
Link to comment
Share on other sites

35 minutes ago, SpaceX_Boi said:

This mod looks so epic:awe::D !1

Quick question before I get it though,

Will this corrupt my savegame if I delete 2.5 scale Kerbin, and install this mod at it's 2.5 scale?

Most definitely.

For sure all surface stuff will be done for, most probably orbital stuff too.

Start new savegames whenever you change the planet pack. I'd even say between KSP versions too.

Link to comment
Share on other sites

Hi, I don't know if anyone else has this problem, but the config link takes me to the exact same link as the mod download link does. Is this normal??? :/ 

Also, where is the "settings.cfg" file located?

It would be great if I got some info from you, @tony48 :) 

Edited by SpaceX_Boi
Link to comment
Share on other sites

So i got the 0.7 version from github and was wondering which folders need to be in placed in the "Gamedata" folder.  I initially just placed the KSRSS folder from the KSRSS megapack zip in Gamedata but then I noticed in prior versions some folders in KSRSS (like KSRSSVE) were in Gamesdata on their own. Any help for a noob installing this mod would be much appreciated.

Link to comment
Share on other sites

1 hour ago, R_U_Sirius said:

So i got the 0.7 version from github and was wondering which folders need to be in placed in the "Gamedata" folder.  I initially just placed the KSRSS folder from the KSRSS megapack zip in Gamedata but then I noticed in prior versions some folders in KSRSS (like KSRSSVE) were in Gamesdata on their own. Any help for a noob installing this mod would be much appreciated.

Welcome to the forums!

For 0.7, you should place only KSRSS folder in Gamedata. It contains all the stuff (textures, VE, 2.5x configs etc). 0.6.1 comes in three folders - KSRSS, KSRSS-Textures and KSRSSVE - be sure to delete all of these before updating.

Also, you should get the latest version from Gitlab, not Github (link: Files · megapack · KSRSS / KSRSS · GitLab )

Edited by biohazard15
Link to comment
Share on other sites

Cheers, and thanks for the warm welcome! And ya I meant Gitlab, just so used to using Github. So the reason I asked is that I was getting some strange graphical artifacts specifically from Scatterer's godrays that I haven't gotten before and just guessed I installed the mod improperly to get that bug. 

Here's a pic of it, its much much more visible ingame compared to the screenshot. The glitch in question are the diagonal lines coming off the plane. Only way I've found to stop it is to turn off godrays entirely

In case its relevant I'm on 1.10, max graphics settings.

Y94iKD9.png

 

 

Link to comment
Share on other sites

6 hours ago, akkhor said:

Okay so haven't extensively tested but Mars doesn't seem to have parallax and Ganymede is all out of whack in 0.7. Is it supposed to be like that or have I missed something?

I am having similar issues with Ganymede, but the only issue that I can comment on that will help the devs out is the parallax terrain height not the same as actual terrain height. There is an offset of about 2m and the physical terrain is below the parallax terrain by that amount.

Link to comment
Share on other sites

Do I have to activate Parallax somehow? Because I don't see anything on the moon. Parallax is installed and I've tried it with Kopernicus and Kopernikus Bleeding Edge.

I also tried to move the Parallax.cfg from the "patches" folder to different locations (\Gamedata and \KSRSS)

EDIT

I forgot: I also sink in the surfarce of the moon. KSP is a completly fresh installation with a new savegame. 

Edited by Hinkypunk
Link to comment
Share on other sites

26 minutes ago, Hinkypunk said:

Do I have to activate Parallax somehow? Because I don't see anything on the moon. Parallax is installed and I've tried it with Kopernicus and Kopernikus Bleeding Edge.

I also tried to move the Parallax.cfg from the "patches" folder to different locations (\Gamedata and \KSRSS)

EDIT

I forgot: I also sink in the surfarce of the moon. KSP is a completly fresh installation with a new savegame. 

Parallax is broken on Mars and The Moon, it will be fixed in 0.8 if you want Parallax for the other bodies just go into the config and delete the = Mars/Moon 

Link to comment
Share on other sites

On 3/15/2021 at 8:51 PM, TruthfulGnome said:

it will be fixed in 0.8

Is there an official timeline or rollout for 0.8? 0.7 works fine except for significant lag at the KSC and on Earth, along with those pesky parallax issues.

Link to comment
Share on other sites

I'm having some issues with Martian terrain (without parallax installed). There seems to be regions where the terrain disappears below 1m, and the shaded regions have no visible terrain under normal zoom levels. I have medium confidence that this is not a Kopernicus bleeding edge issue because a version update does not fix these terrain issues. 

Zoomed out

aQinRq9.jpg

Normal Zoom (Terrain missing and negative altimeter)

4MbNQ1I.jpg

Other shaded areas that have the same issues

OChtavI.jpg

Link to comment
Share on other sites

1 hour ago, InfoTheGamer said:

shaded regions have no visible terrain under normal zoom levels

add 

                FlattenOcean
                {
                    oceanRadius = 1
                    order = 9999992
                    enabled = True
                    name = No_water
                }

in Mods{} node in Mars.cfg and there will be no negative elevations at all. Make sure your rovers arent there before adding this.

Edited by Hohmannson
Link to comment
Share on other sites

I'm running with 1.11  (which I know is not a supported version).  Only other modes are EVE for clouds/city lights, Kopernicus and similar for compatibility, and Kerbal Alarm Clock.

I'm on a laptop so I'm running the Lite version.  Everything seems to be working smoothly - no odd textures yet, no weird height maps.  First couple of splash downs I sank a bit deeper in the water than I'd expected but nothing too big.  No "black moon" yet.

 

I'm still relearning how to play (haven't Kerballed in a couple of years).

 

Everything this running great so far and I'm looking forward to updates.

 

The one thing I've run into that I wasn't sure if it was working as intended, a known issue that hasn't been solved yet, or something that comes from me using the mod with the wrong version of KSP:  The Kerbnet function on probe cores and such is broken.  This is mostly a non-issue.  I'm trying to plan my missions around landing at specific locations (something I've never done before) and was going to use the in-game tools to set markers at Frau Maru for Apollo 13 to aim for and such.  I can easily just use an actual map of Mars or the Moon and try to land on target that way too.  I was just curious if this was me having broken the game because I didn't keep a save file of the older version or if there was an easy fix.

Link to comment
Share on other sites

On 3/16/2021 at 2:51 AM, TruthfulGnome said:

Parallax is broken on Mars and The Moon, it will be fixed in 0.8 if you want Parallax for the other bodies just go into the config and delete the = Mars/Moon 

Oh :-/ I was really looking forward to land on the moon with parallax. But still an amazing mod. Love it.

And thank you for the clarification :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...