Jump to content

[BETA] KSRSS 0.7 - Kerbin (or x2.5) sized RSS


tony48
 Share

KSC location for the next release  

147 members have voted

  1. 1. Where should the KSC be located?

    • Cape Canaveral, Florida (28 degrees North)
      107
    • Kourou, French Guiana (5 degrees North)
      40


Recommended Posts

35 minutes ago, DaveyJ576 said:

I then want to be able to switch back and forth from Cape Canaveral to Vandenberg to WSMR, etc., to launch rockets.

Yeah, can't help you there. This is exactly what I want to avoid. I don't really have a reason to move the KSC when I can launch from anywhere with a click already. I actually uninstalled KSC Switcher to fix the black terrain outside of the VAB. Is there a benefit to moving the KSC that I'm not thinking of?

Link to comment
Share on other sites

23 minutes ago, OrbitalManeuvers said:

Yeah, can't help you there. This is exactly what I want to avoid. I don't really have a reason to move the KSC when I can launch from anywhere with a click already. I actually uninstalled KSC Switcher to fix the black terrain outside of the VAB. Is there a benefit to moving the KSC that I'm not thinking of?

I don't want to move the KSC, I want to establish a new one so that the new base at WSMR is just like the ones at Canaveral, Vandenberg, Kodiak, and Wallops.

At the end of the day it isn't that big of a deal. If I have to I will launch the WSMR flights out of Wallops. A deviation from history, but not huge. Thanks for taking a stab at it!

Link to comment
Share on other sites

Originally posted this on the Kopernicus thread, no responses. Maybe here I can find some answers.

I recently had an issue crop up that I am unable to fix on my own. Here's what I'm running into and my GameData: https://imgur.com/a/tN3Bmlv. Here's everything the message asks for: https://www.dropbox.com/sh/fmap2wvas9kiz57/AAC1WcjpAffEs0whZTWpaA8aa?dl=0

When it popped up I had just installed KCCPlus and Vanadin's 39A and this seemingly triggered the issue. My Kopernicus was a couple versions old so I updated and uninstalled those 2 mods. This did not fix it. So I reinstalled Kopernicus again and KSRSS. This also did not fix it. I've updated Janitor's Closet (I saw somewhere that could cause issues), I also reinstalled CD and Shabby as I was told that could be impacting it, finally I tried refreshing all the log things. I seemingly haven't made any ground on it. The attached files feature all these attempted fixes and the mods that originally caused the issue. 

Thanks in advance for any help you may be able to provide!

Link to comment
Share on other sites

29 minutes ago, cameronisher3 said:

I recently had an issue crop up

Not sure about your kopernicus situation without digging deeper, but there are a couple simple surface problems, too. MiniAVC needs to be deleted - there should be zero instances of miniavc.dll in your gamedata folder. The second is Spectra - that's not for KSRSS and it's probably just going to conflict with KSRSS's eve/scatterer configs. Hopefully someone else will dive deeper and help with the Kop problem. For my own sanity, I always nail down the solar system and its mods before installing anything else. 

Link to comment
Share on other sites

50 minutes ago, OrbitalManeuvers said:

Not sure about your kopernicus situation without digging deeper, but there are a couple simple surface problems, too. MiniAVC needs to be deleted - there should be zero instances of miniavc.dll in your gamedata folder. The second is Spectra - that's not for KSRSS and it's probably just going to conflict with KSRSS's eve/scatterer configs. Hopefully someone else will dive deeper and help with the Kop problem. For my own sanity, I always nail down the solar system and its mods before installing anything else. 

Thanks, will do that.

I've been running this GameData for a couple months now adding stuff every now and then. The woes of having so many mods lol

Link to comment
Share on other sites

Never gotten this one before!
Any help would be greatly appreciated, as I've never dealt with this.

unknown.png
"Kopernicus not able to load the custom planetary system due to an exception in the loading process. Loading your saved game is NOT recommended, because the missing planets could corrupt it and delete your progress.

My quick cropping job wasn't great in hindsight!

Kopernicus Log: https://drive.google.com/file/d/1kytzl89cFMEBgFZXK6wCL-DV4GkOBkY6/view?usp=sharing

ModuleManager.ConfigCache: https://drive.google.com/file/d/1rYcqDkB1YI8WJnjlVeIAJ5T7nXXa20mM/view?usp=sharing

KSP.log: https://drive.google.com/file/d/1bKbAB9RcsC8rhkXRb_OuBTp7VZQCSo-f/view?usp=sharing

Link to comment
Share on other sites

29 minutes ago, mariagorl said:

Never gotten this one before!

Hi - you are missing SpaceTuxLibrary which is a dependency of Janitor's Closet. You can find the link to it here:

Not 100% positive that will fix the startup error, but fixing this will help sooner or later.

Link to comment
Share on other sites

I Need help... I cant get to orbit on 2.5x Rescale with the titan GLV on Bluedog design. I cant get to orbit with any rocket that ive made... Help? Configs?

Btw is there any 2.5x Scale Configs for parts (bc none of my rockets can get to orbit)

5 minutes ago, donnager fan said:

I Need help... I cant get to orbit on 2.5x Rescale with the titan GLV on Bluedog design. I cant get to orbit with any rocket that ive made... Help? Configs?

 

Link to comment
Share on other sites

9 hours ago, donnager fan said:

Btw is there any 2.5x Scale Configs for parts (bc none of my rockets can get to orbit)

You need 5400-5600 m/s of dv to reach orbit in 2,5x rescale, against 3400 m/s in stock, that may be your issue. Stock parts are still well performing with rescale, no need for configs; your rockets will just end up being larger. Since the titan comes from BDB, maybe ask in the respective thread? Balancing part performance is not the goal of rescale, but of the part mods themselves :wink:

Link to comment
Share on other sites

21 hours ago, donnager fan said:

I Need help... I cant get to orbit on 2.5x Rescale with the titan GLV on Bluedog design. I cant get to orbit with any rocket that ive made... Help? Configs?

Btw is there any 2.5x Scale Configs for parts (bc none of my rockets can get to orbit)

 

Here, I didn't use KSRSS yet, but this is the patch that I used when I played with 10.625x Rescale, you just need to adjust the values to something lower for 2.5x
 

Spoiler

@PART[*]:HAS[@MODULE[ModuleEngines*]]:FINAL
{
    @MODULE[ModuleEngines*],*
    {
        @maxThrust *= 1.7

        @atmosphereCurve
        {
            @key[1, ] *= 1.7
            @key,1[1, ] *= 1.7
            @key,2[1, ] *= 1.7
        }
    }
}

This targets all parts with "moduleengines", so it will be compatible (Probably) with any parts mod. Sadly I don't remember the original author to give him/her proper credit, but is an ingenious solution. The only thing that I've done was an edit for it to function properly with multi-mode engines such as the RAPIER.

 

Hope this helps

Link to comment
Share on other sites

Posted (edited)

Does anyone know why I'm getting this weird surface texture bug? Whenever I get below a certain altitude near the moon, the crafts and textures do this the whole time through. It makes landing on the moon completely impossible.

Spoiler

Keine Beschreibung verfügbar.

Keine Beschreibung verfügbar.

Keine Beschreibung verfügbar.

As you can see, some terrain textures are very detailed, while the rest aren't. As soon as I move the camera, everything becomes blurry again and other parts get loaded. It makes seeing things impossible.

I've also been reading stuff on this forum about a black moon. I don't have that problem, but it might be relevant info. Also, when I zoom in on the moon too closely in the Tracking Station, that black moon does appear.

Edited by Colonel of Ferocity
Additional info.
Link to comment
Share on other sites

9 hours ago, Colonel of Ferocity said:

Does anyone know why I'm getting this weird surface texture bug? Whenever I get below a certain altitude near the moon, the crafts and textures do this the whole time through. It makes landing on the moon completely impossible.

  Reveal hidden contents

Keine Beschreibung verfügbar.

Keine Beschreibung verfügbar.

Keine Beschreibung verfügbar.

As you can see, some terrain textures are very detailed, while the rest aren't. As soon as I move the camera, everything becomes blurry again and other parts get loaded. It makes seeing things impossible.

I've also been reading stuff on this forum about a black moon. I don't have that problem, but it might be relevant info. Also, when I zoom in on the moon too closely in the Tracking Station, that black moon does appear.

I managed to solve the problem myself already, however. I just gave everything a clean reinstall minus some other mods that weren't need. Might have been ReScale (didn't realise I don't need that one) or KSRSS textures, installed wrongly.

 

Link to comment
Share on other sites

Posted (edited)

I continued to tinker with the idea of adding a launch site at White Sands, NM. I studied the launchsites.cfg file and realized that it wouldn't be that hard. I cloned the Wallops portion, changed the latitude & longitude, and edited the description. I copied and pasted my patch into the launchsites.cfg file right at the end just under the Wallops portion. It worked perfectly! I now have a launch site in New Mexico to launch the early sounding rockets and the Little Joe 2 from. I haven't yet figured out how to match the grass color with the yellowish sand color of New Mexico, but I will continue to tinker with that too. The patch is in the spolier:

I learned one important lesson: make a backup copy of the launchsites.cfg file BEFORE you start to tinker with it. If you screw it up you can reload the original and reset everything.

I have one other question: Given the rather primitive state of White Sands in the late 1940's and into the 50's, the fully developed KSC seems a little out of place. Is there a way of converting just this launch site to the Level 1 facilities while leaving the others at Level 3? I play in Sandbox mode.

Thanks!

Edited by DaveyJ576
Link to comment
Share on other sites

On 5/6/2022 at 2:49 AM, KawaiiLucy said:

You need 5400-5600 m/s of dv to reach orbit in 2,5x rescale, against 3400 m/s in stock, that may be your issue. Stock parts are still well performing with rescale, no need for configs; your rockets will just end up being larger. Since the titan comes from BDB, maybe ask in the respective thread? Balancing part performance is not the goal of rescale, but of the part mods themselves :wink:

FYI. I made a patch for KSRSS x2.5 scale to "Where Can I Go?" - basically an in-editor automatic delta-V map utility - it shows a tabular/color coded a summary of your rocket build's capability to get to orbit, geo, Moon, Mars etc. I found it useful in stock, so I did this when I started KSRSS. Based off a delta-V map posted here and checked against half RSS full scale delta-V map, but I could have easily made mistakes, so always double check with other sources, not responsible for loss of expensive equipment or missing Kerbals.

Link to comment
Share on other sites

Hi there - I've got a super quick question about KSRSS for help balancing a mod of mine which is designed to support KSRSS among other planet packs? What is KSRSS's day length when its scaled to 2.5x? Does it scale the same as stock KSP or is it different?

 

Link to comment
Share on other sites

11 hours ago, Galileo chiu said:

can you send me a link?

Welcome to the internet!  OP can either stand for Original Poster (the person who started the thread) or Original Post (the first post of the thread).  What you're gonna want to do now is click the first page button, looks like <<.  You then wanna scroll down that first post created by tony48 and find DV Map.  Now there's 2 of them, one for normal KSP size, and one for 2.5x size.  Just click that bar that says "reveal hidden contents", and you should now be looking at a Delta V map of your choice.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...