Jump to content

[BETA] KSRSS 0.7 - Kerbin (or x2.5) sized RSS


tony48
 Share

KSC location for the next release  

292 members have voted

  1. 1. Where should the KSC be located?

    • Cape Canaveral, Florida (28 degrees North)
      208
    • Kourou, French Guiana (5 degrees North)
      84


Recommended Posts

1 hour ago, zw_45 said:

@ballisticfox0Now the game loads normally, thanks!

Also, I worte a small patch that adds compatibility for Nertea's spacedust suites, would you allow me to upload this patch to KSRSS dev branch?

https://1drv.ms/u/s!Anlnec-q1Uv7ghmEN2bLX8gQ1KtT?e=gsrdBF

 

1 hour ago, zw_45 said:

@ballisticfox0Now the game loads normally, thanks!

Also, I worte a small patch that adds compatibility for Nertea's spacedust suites, would you allow me to upload this patch to KSRSS dev branch?

https://1drv.ms/u/s!Anlnec-q1Uv7ghmEN2bLX8gQ1KtT?e=gsrdBF

Feel free to make a PR, alternatively I can commit it for you.

51 minutes ago, xtasy said:

Yes, now game runs properly. But with x2.7 config parallax objects load in small radius around my ship.
https://prnt.sc/i6GCowlRl-LN

Thanks for the feedback!

(also before you report it, yes there’s a weird tree distribution near the ksc, I’m working on it) 

Link to comment
Share on other sites

8 minutes ago, ballisticfox0 said:

Thanks for the feedback!

(also before you report it, yes there’s a weird tree distribution near the ksc, I’m working on it) 

this is not a bug, it's the same in stock version. But in stock version there are trees and this smooths out the effect. )

Link to comment
Share on other sites

If anyone has the unction/interest, here's a log file for a minimal install that hangs KSP at the main menu. It seems related to scatterer. As the main menu screen is rendering, first the Earth displays cloudless for about 60 seconds, and then clouds finally pop in, but then ksp.exe is hung and the main menu never renders.

https://drive.google.com/drive/folders/1GbPJ5qEHi32ypmwNpMl9XYvHB2ikq_mh?usp=sharing

Any ideas? Thanks!

Some other potentially interesting EVE tidbits:

Spoiler

[LOG 11:07:27.465] [EVE CloudsManager]: Unable to parse config node:
OBJECT
{
    name = EarthCloudsShadow
 

[LOG 11:07:27.466] EVEManager: Issue loading CloudsManager! Error:
UnityEngine.UnityException: Unable to apply node! ---> UnityEngine.UnityException: Unable to parse "settings" in "OBJECT"! ---> UnityEngine.UnityException: Unable to parse "_MainTex" in "settings"!
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x000f1] in <fde2571077d14a4c9cde0e9336baf625>:0 
  at Utils.ConfigHelper.Parse (System.Reflection.FieldInfo field, System.Object& obj, System.String[] value, ConfigNode node) [0x003b7] in <fde2571077d14a4c9cde0e9336baf625>:0 
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x00062] in <fde2571077d14a4c9cde0e9336baf625>:0 
   --- End of inner exception stack trace ---
 

 


 

Link to comment
Share on other sites

23 minutes ago, OrbitalManeuvers said:

If anyone has the unction/interest, here's a log file for a minimal install that hangs KSP at the main menu. It seems related to scatterer. As the main menu screen is rendering, first the Earth displays cloudless for about 60 seconds, and then clouds finally pop in, but then ksp.exe is hung and the main menu never renders.

https://drive.google.com/drive/folders/1GbPJ5qEHi32ypmwNpMl9XYvHB2ikq_mh?usp=sharing

Any ideas? Thanks!

Some other potentially interesting EVE tidbits:

  Reveal hidden contents

[LOG 11:07:27.465] [EVE CloudsManager]: Unable to parse config node:
OBJECT
{
    name = EarthCloudsShadow
 

[LOG 11:07:27.466] EVEManager: Issue loading CloudsManager! Error:
UnityEngine.UnityException: Unable to apply node! ---> UnityEngine.UnityException: Unable to parse "settings" in "OBJECT"! ---> UnityEngine.UnityException: Unable to parse "_MainTex" in "settings"!
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x000f1] in <fde2571077d14a4c9cde0e9336baf625>:0 
  at Utils.ConfigHelper.Parse (System.Reflection.FieldInfo field, System.Object& obj, System.String[] value, ConfigNode node) [0x003b7] in <fde2571077d14a4c9cde0e9336baf625>:0 
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x00062] in <fde2571077d14a4c9cde0e9336baf625>:0 
   --- End of inner exception stack trace ---
 

 


 

Please read above, I know what the issue is and what is causing just not how to solve it at the moment.

Link to comment
Share on other sites

55 minutes ago, ballisticfox0 said:

 

Feel free to make a PR, alternatively I can commit it for you.

Thanks for the feedback!

(also before you report it, yes there’s a weird tree distribution near the ksc, I’m working on it) 

I’m not sure how to send pull request, could you just upload the cfg files in the zip folder to repository?

Link to comment
Share on other sites

12 minutes ago, OrbitalManeuvers said:

ah so you think this is the same as the parallax issue? because I don't have parallax ...  Will stay tuned, of course.

Upon further inspection it’s the breaking ground Roc issue that was supposed to be fixed a couple hours ago

Link to comment
Share on other sites

1 hour ago, ballisticfox0 said:

Upon further inspection it’s the breaking ground Roc issue that was supposed to be fixed a couple hours ago

Unfortunately, syncing with gitlab just now didn't change any of the behavior and it still hangs at startup.  I've updated the log file here in this folder, but also, if I'm the only one getting startup hangs then I'm happy to just wait and try again at a later date.

https://drive.google.com/drive/folders/1GbPJ5qEHi32ypmwNpMl9XYvHB2ikq_mh?usp=sharing

Link to comment
Share on other sites

There is huge FPS degradation with new KSRSS and Parallax2.0.
Stock KSP + KSRSS(30.08.2022) x2.7 + Parallax old

Screenshot_1.png

 

Stock KSP + KSRSS(06.09.2022 with all new patches 1h ago) x2.7 + Parallax 2.0

Screenshot_2.png

New career in both games.
No effect with any changes in config parallax.

 

Stock KSP without KSRSS + Parallax 2.0
Screenshot_3.png

Edited by xtasy
Link to comment
Share on other sites

17 hours ago, ballisticfox0 said:

There it is, I wondered how long it would take for someone to ask that, yes we will! Here’s some screenshots from the configs I released about an hour ago:

screenshot231.pngscreenshot214.png

If my computer doesn't immediately spontaneously combust I'm going to be surprised. This looks absolutely stunning and I can't wait to try it out in the full release!

EDIT: It's also going to give me an incentive to actually land my shuttle missions on a runway rather than just aim for north america  :D

Edited by KeaKaka
Link to comment
Share on other sites

2 hours ago, xtasy said:

Omg... FPS with new KSRSS x2.7 without parallax!
unknown.png

 

Please, check your configs...

What resolution of clouds are you running on Stock? If it's not 48k then it's not really a fair comparison now is it?

Additional cloud and planet texture resolutions will be available on the full release, please keep in mind that you are playing a beta.

If you have anything specific other than "please check your configs", feel free to make an issue on the GitLab. :)

Link to comment
Share on other sites

Looking for some help with my textures. I'm coming off an old install of KSRSS 2.5x, and have done clean installs of EVE and Scatterer. My atmosphere is cloudless and the reflections aren't behaving. I'm running the stock configs for EVE and Scatterer, so maybe that's the issue. I also have TUFX if that helps.

 

image of current situation: https://imgur.com/a/7Qr0eVr (brand new to the forums, couldn't get image embed working.)

Link to comment
Share on other sites

10 hours ago, ballisticfox0 said:

What resolution of clouds are you running on Stock? If it's not 48k then it's not really a fair comparison now is it?

I agree, comparing stock and mod is not correct. But i compared two builds - befor https://gitlab.com/ksrss/KSRSS/-/commit/79108ac108493ba1834209c3314065f35b6fa686 and after. There was a 15 fps drop. In this build you add 48k clouds?

10 hours ago, ballisticfox0 said:

If you have anything specific other than "please check your configs", feel free to make an issue on the GitLab. :)

Ok, i only want to help make KSRSS better)

Edited by xtasy
Link to comment
Share on other sites

16 hours ago, kerbalboi said:

after i installed reborn again kk started not working, any idea on a fix?

KK is working. The configs aren't, because Earth name is now Kerbin. Change CelestialBody = Earth to CelestialBody = Kerbin in all your configs, or remake them.

24 minutes ago, AstroKerbal1B said:

Do I have to use the KSRSS-64k? And what exacly it adds?

64K textures for Earth land.

25 minutes ago, AstroKerbal1B said:

(will it impact fps significantly?)

Yes

25 minutes ago, AstroKerbal1B said:

Will you add 32k, 16k 8k etc. options in the future?

If you don't install it, Earth land will be in 16k. We will provide a 8k option in the future.

Link to comment
Share on other sites

18 hours ago, OrbitalManeuvers said:

Unfortunately, syncing with gitlab just now didn't change any of the behavior and it still hangs at startup.  I've updated the log file here in this folder, but also, if I'm the only one getting startup hangs then I'm happy to just wait and try again at a later date.

https://drive.google.com/drive/folders/1GbPJ5qEHi32ypmwNpMl9XYvHB2ikq_mh?usp=sharing

Fixed in the latest commit

Link to comment
Share on other sites

23 hours ago, ballisticfox0 said:

Will do :D

Noticed that SpaceDust config for KSRSS will not work unless you delete the stock definition folder, so I wrote a patch to delete the stock definition configs. Could you also upload this patch and restore the definitions for Earth?

https://1drv.ms/u/s!Anlnec-q1Uv7gjzhtWBNnG6S4SqV

Edited by zw_45
Link to comment
Share on other sites

On 9/5/2022 at 9:44 PM, ProCrast said:

Put that in the patches folder inside KSRSS , i made little changes so Kourou site is actually on the ground . :)

Thanks for these numbers, as they fix Kourou for me, too.

However, now for a blast from the past...

P7dZWlm.png

This remains an issue on the Reborn branch. I realize it was declared fixed in 0.7, but on my machine it was never fixed.

This is 100% caused by the presence of KSCSwitcher. Remove it, and the earth terrain returns to normal.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...