Jump to content

Contract Pack - History of Spaceflight - V1.0


Morphisor
 Share

Recommended Posts

6 hours ago, Morphisor said:

No, reputation shouldn't affect this. You might try fast forwarding a bit or just going through other screens on the KSC for a while, it may just be CC not generating the new contract right away, for some reason. 

Otherwise it's likely to be an issue with a data node not solving, though I can't see any issues for now.

Could it be related to other contacts? For example, I have, in addition to others.
Career Evolution
Contract Pack: Exploration Plus
Epic Space Program

Link to comment
Share on other sites

Posted (edited)

I changed GIRD-5 to GIRD-9, everything is the same. Waited a few days - no change. I'll try to start a career again, I'll check quickly

 

Installed KSP. Installed History of Spaceflight Stock Everything is working. Apparently some mod fails and it turns out that Ivanov does not work. I will turn off my mods, see what is causing this.

Edited by Russos
Link to comment
Share on other sites

1 hour ago, Russos said:

I changed GIRD-5 to GIRD-9, everything is the same. Waited a few days - no change. I'll try to start a career again, I'll check quickly

 

Installed KSP. Installed History of Spaceflight Stock Everything is working. Apparently some mod fails and it turns out that Ivanov does not work. I will turn off my mods, see what is causing this.

Yeah I just confirmed myself that the mission loads fine under regular playing conditions, so I'm afraid you've got some kind of conflict going on. If you're lucky the ksp.log may provide some hints, look for exceptions and warnings.

Link to comment
Share on other sites

@Morphisor
It seems to be a matter of reputation. Installed the game. Installed these mods:

Celestial Body Science Editor (CelestialBodyScienceEditor 12.0)
Community Category Kit (CommunityCategoryKit v112.0.1)
Community Resource Pack (CommunityResourcePack v112.0.1)
Community Tech Tree (CommunityTechTree 1:3.4.4)
Contract Configurator (ContractConfigurator 1.30.5)
Contract Parser (ContractParser 9.0)
Contracts Window + (ContractsWindowPlus 9.4)
Custom Barn Kit (CustomBarnKit 1.1.22.0)
Custom Bulkhead Profiles (CBH) (CustomBulkheadProfiles 0.2.0.0)
History of Spaceflight Stock (ContractConfigurator-HistoryofSpaceflight-Stock 1.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.9.0)
MechJeb 2 (MechJeb2 2.14.1.0)
MechJeb and Engineer for all! (MechJebForAll 1.3.0.7)
Module Manager (ModuleManager 4.2.2)
Probes Before Crew [PBC] (ProbesBeforeCrew 2.93)
Progress Parser (ProgressParser 11.0)
Strategia (Strategia 1.8.0)

started a new career. If you make the reputation -490 at the start, then the Ivanov scenario does not start. And if you start a career with zero reputation, then everything is OK - Ivanov works.

I'll try to install the game, install only your pack of contracts and check.

Link to comment
Share on other sites

@Morphisor

Contract Configurator (ContractConfigurator 1.30.5)
History of Spaceflight Stock (ContractConfigurator-HistoryofSpaceflight-Stock 1.0)
Module Manager (ModuleManager 4.2.2)

This is what comes by default with your pack. New career, reputation -100. Mission Ivanov does not work. And the three GIRDs in front of her are being executed.

Link to comment
Share on other sites

3 hours ago, rUUk said:

I finally finished 0.9.2 and now 1.0 is out.  That's really awesome.  Though, I think I need a break:

https://imgur.com/a/Xtv5Egp

I love it! I'm amazed you got that far. In the one save where I tried to do the same myself, the tracking station view basically broke down on itself.

3 hours ago, Russos said:

@Morphisor

Contract Configurator (ContractConfigurator 1.30.5)
History of Spaceflight Stock (ContractConfigurator-HistoryofSpaceflight-Stock 1.0)
Module Manager (ModuleManager 4.2.2)

This is what comes by default with your pack. New career, reputation -100. Mission Ivanov does not work. And the three GIRDs in front of her are being executed.

The only thing I could consider doing is adjusting the contract prestige value.  I really don't know why it isn't working for you however, I had no trouble with this myself in testing.

Link to comment
Share on other sites

  • 4 weeks later...

Hello. Can't complete Elektron-1 mission. As soon as I fulfill the conditions of the first orbit and 30 seconds pass, everything freezes. I tried to fulfill two conditions at once. But still, it didn't work. In the first orbit, 30 seconds passed and everything hung. In which direction should you look?

Link to comment
Share on other sites

14 hours ago, Russos said:

Hello. Can't complete Elektron-1 mission. As soon as I fulfill the conditions of the first orbit and 30 seconds pass, everything freezes. I tried to fulfill two conditions at once. But still, it didn't work. In the first orbit, 30 seconds passed and everything hung. In which direction should you look?

There's likely some kind of bad interaction going on, the mission parameters themselves are pretty standard.  The mission calls for 2 craft, in what order are you setting their orbits?
You could try disabling the duration sub-parameter and see if it works for you then.

Link to comment
Share on other sites

21 minutes ago, Morphisor said:

There's likely some kind of bad interaction going on, the mission parameters themselves are pretty standard.  The mission calls for 2 craft, in what order are you setting their orbits?
You could try disabling the duration sub-parameter and see if it works for you then.

I launched two satellites on one rocket. I'll try to just launch two satellites. But probably in a week, when I return to the city.

Link to comment
Share on other sites

Made two launches. The first one put Electron-2 into orbit. Everything is fine. I am doing the second launch, putting Electron-1 into orbit. 30 seconds are counted, after which the KPS is completely. The mission is not completed.

ksp-2.png

 

UPD: Removed from the parameters waiting for 30 seconds. Launched Electron-1 into orbit. All OK. But as soon as he completed the experiment, i.e. there were conditions for the execution of the entire first part - everything hung :(

 

UPD2: I completely removed the entry about Electron-1, left about the second. Then I was able to complete the mission without failure

 

UPD3: But in the Electro 3 and 4 missions, there were no problems. Brought two satellites into calculated orbits. Weird. Something is wrong, probably, in the parameters of the first Electron. But the Voshod mission didn't start :( Damn. ;.;

Edited by Russos
Link to comment
Share on other sites

4 hours ago, Russos said:

Made two launches. The first one put Electron-2 into orbit. Everything is fine. I am doing the second launch, putting Electron-1 into orbit. 30 seconds are counted, after which the KPS is completely. The mission is not completed.

ksp-2.png

 

UPD: Removed from the parameters waiting for 30 seconds. Launched Electron-1 into orbit. All OK. But as soon as he completed the experiment, i.e. there were conditions for the execution of the entire first part - everything hung :(

 

UPD2: I completely removed the entry about Electron-1, left about the second. Then I was able to complete the mission without failure

 

UPD3: But in the Electro 3 and 4 missions, there were no problems. Brought two satellites into calculated orbits. Weird. Something is wrong, probably, in the parameters of the first Electron. But the Voshod mission didn't start :( Damn. ;.;

Elektron 3-4 is exactly identical to elektron 1-2, except for the orbit that needs to be achieved. If that works, the other should, too.  Something else is breaking things in your game I'm afraid.

Link to comment
Share on other sites

  • 3 weeks later...
3 hours ago, Russos said:

Hello. How to understand what devices and parts are needed? Tried a few things, nothing works. Mission Gemini IV

ksp-4.png

You're using an older version. The latest version simplified the objectives to only include experiments from the vessel parts associated with the mission, at least insofar as they were made in BDB/Tantares at time of release. If you still wish to continue, try looking up the experiment name in the part search bar inside the VAB.

Link to comment
Share on other sites

18 minutes ago, Morphisor said:

You're using an older version. The latest version simplified the objectives to only include experiments from the vessel parts associated with the mission, at least insofar as they were made in BDB/Tantares at time of release. If you still wish to continue, try looking up the experiment name in the part search bar inside the VAB.

checked. I use version 1.0. Installed via CKAN

Bluedog Design Bureau — v1.10.4

Link to comment
Share on other sites

10 hours ago, Russos said:

checked. I use version 1.0. Installed via CKAN

Bluedog Design Bureau — v1.10.4

The experiments you show requested are not part of the current version of Gemini IV mission. If they are there for you, your install is incorrect.

Link to comment
Share on other sites

On 8/15/2022 at 11:40 PM, Morphisor said:

The experiments you show requested are not part of the current version of Gemini IV mission. If they are there for you, your install is incorrect.

Downloaded stock version from spacedock site I look at the Gemini-IV.cfg file

 

PARAMETER:NEEDS[Bluedog_DB]
		{
			name = CollectScienceC
			type = CollectScience
			situation = InSpaceLow
			recoveryMethod = Recover
			experiment = bd_magScan
			title = Study and recover additional experiments
			disableOnStateChange = true
		}

I deleted this code and only then the experiment I mentioned earlier disappeared.

Link to comment
Share on other sites

1 hour ago, Russos said:

Downloaded stock version from spacedock site I look at the Gemini-IV.cfg file

 

PARAMETER:NEEDS[Bluedog_DB]
		{
			name = CollectScienceC
			type = CollectScience
			situation = InSpaceLow
			recoveryMethod = Recover
			experiment = bd_magScan
			title = Study and recover additional experiments
			disableOnStateChange = true
		}

I deleted this code and only then the experiment I mentioned earlier disappeared.

I strongly recommend to fully remove the mod's folders before doing a reinstall of the latest version. Something has gone wrong with it given the behaviour you're seeing.

Link to comment
Share on other sites

23 minutes ago, Morphisor said:

I strongly recommend to fully remove the mod's folders before doing a reinstall of the latest version. Something has gone wrong with it given the behaviour you're seeing.

Well thank you. Will completed missions disappear?

Link to comment
Share on other sites

  • 2 weeks later...
On 8/31/2022 at 2:50 AM, TKMK said:

So do i need  Tantares and BDB, cos I dont want anything that i dont need (8gb of ram causes some mod problems)

Can i get away with not having it, or will it cause the contracts to have parts i dont have?

They're entirely optional, everything will work without them. There will be a few less things to do is all. Of course, replaying history is not nearly the same without those mods so I'd still recommend them if at all possible.

But then, 8GB RAM is really insufficient for a modded install in general, good luck trying to stay off the good stuff.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...