ferram4

[1.3.1] Ferram Aerospace Research: v0.15.9.1 "Liepmann" 4/2/18

Recommended Posts

Just a note that CKAN is offering the 1.3 update for my 1.2.2 RSS/RO/RP0 install resulting in a crash on startup. I'm not sure if CKAN supports rolling back a version, but manually removing the installed version and installing the files from git seems to be working.

Share this post


Link to post
Share on other sites

PIrlIwI.jpg

It seems like there is bug in "air req met" display.

What does Cy, spec. excess pwr or v*l/d actually measure?

Share this post


Link to post
Share on other sites
11 hours ago, ferram4 said:

Alright, so FAR v0.15.9 "Liebe" is out.  It includes 1.3 compatibility, some mod interaction fixes, and localization support.  Also includes volunteer-provided German, Russian, and Chinese translations.

Anyone who wants to help contribute to more translations is welcome to, and I apologize if anything isn't translated correctly, I only know English myself.

Hey @ferram4, has anybody taken care of the french translation? I absolutely could. French is my native tongue, after all. Let me know (pm me).

Just now, Calvin_Maclure said:

Hey @ferram4, has anybody taken care of the french translation? I absolutely could. French is my native tongue, after all. Let me know (pm me).

Also, MANY thanks for the 1.3 update! LOVE THIS MOD!

Share this post


Link to post
Share on other sites

:0.0:FAR is updated for 1.3? PRAISE THE FERRAM4! *throws donation*

Now I might actually get back to KSP for once!

(Paypal says they are checking the info for the donation, could take some time)

EDIT: It's done, they approved it!

Edited by BigNose
Paypal update

Share this post


Link to post
Share on other sites
3 hours ago, jacksawild said:

Just a note that CKAN is offering the 1.3 update for my 1.2.2 RSS/RO/RP0 install resulting in a crash on startup. I'm not sure if CKAN supports rolling back a version, but manually removing the installed version and installing the files from git seems to be working.

Yeah we had that with many mods where the minimum version defined in the version file was corrupted and let CKAN think it's ok to install it into a 1.2.2 install. 

 

 

Congrats @ferram4, appreciate all the work. 

Share this post


Link to post
Share on other sites

Yep, CKAN seems to believe 0.15.9 is for KSP 1.2.2 and marks it as incompatible for the 1.3 install.

Share this post


Link to post
Share on other sites

@ferram4 Hooray!

1 hour ago, garwel said:

Yep, CKAN seems to believe 0.15.9 is for KSP 1.2.2 and marks it as incompatible for the 1.3 install.

Instead, it promptly installs it on 1.2.2 and crashes the game.:)

Share this post


Link to post
Share on other sites

I wonder if KSP 1.3.1 will be released soon and will break FAR. It's becoming a tradition already.

Share this post


Link to post
Share on other sites

There's a separate thread for CKAN support.  Don't bother ferram with it

 

@ferram4 The .version file in the download appears to be the old one.  This would explain the CKAN woes, would probably cause some other trouble with AVC as well.

  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, blowfish said:

There's a separate thread for CKAN support.  Don't bother ferram with it

In this case, though, the bad metadata is likely coming from the FAR package itself:

$ unzip -c FAR_0_15_9_Liebe.zip GameData/FerramAerospaceResearch/FAR.version
Archive:  FAR_0_15_9_Liebe.zip
  inflating: GameData/FerramAerospaceResearch/FAR.version  
{
  "NAME"     : "Ferram Aerospace Research",
  "DOWNLOAD" : "https://github.com/ferram4/Ferram-Aerospace-Research/releases",
  "URL"      : "https://raw.githubusercontent.com/ferram4/Ferram-Aerospace-Research/master/GameData/FerramAerospaceResearch/FAR.version",
  "GITHUB" : {
    "USERNAME"   : "ferram4",
    "REPOSITORY" : "Ferram-Aerospace-Research"
  },
  "VERSION" : {
    "MAJOR" : 0,
    "MINOR" : 15,
    "PATCH" : 8,
    "BUILD" : 1
  },
  "KSP_VERSION_MIN" : {
    "MAJOR" : 1,
    "MINOR" : 2,
    "PATCH" : 0
  },
  "KSP_VERSION_MAX" : {
    "MAJOR" : 1,
    "MINOR" : 2,
    "PATCH" : 2
  }
}

EDIT: Ninja'd!

Edited by HebaruSan

Share this post


Link to post
Share on other sites

@HebaruSan I'd say it's different if you actually identify the issue (which you did).  But in general it's better if any CKAN related support requests go in that thread and someone who knows more about FAR/CKAN can look at the issue and determine where the problem is happening.

Share this post


Link to post
Share on other sites

How... that's strange, considering I copied the FAR stuff for release from the github repo.  Must not have grabbed the one after the last-minute .version fix.

Well, once the metadata gets updated for CKAN it'll be fine.

  • Like 2

Share this post


Link to post
Share on other sites

Unfortunately the new version of FAR has some serious performance issues.

When I attempt to fly the game lags out and stutters, it seems to be worse when pitching. It also gets pretty bad when nearing transonic/supersonic speed.

Share this post


Link to post
Share on other sites
34 minutes ago, FunnelVortex said:

Unfortunately the new version of FAR has some serious performance issues.

When I attempt to fly the game lags out and stutters, it seems to be worse when pitching. It also gets pretty bad when nearing transonic/supersonic speed.

You are the only one so far (that I have seen) making such a claim... I'm running 108 mods, FAR being one of them, and I have seen ZERO performance impacts from this mod.

Maybe there is something else clashing with FAR on your install. Try Exception Detector and see if something else is spamming your log.

Edited by TheKurgan
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, FunnelVortex said:

Unfortunately the new version of FAR has some serious performance issues.

When I attempt to fly the game lags out and stutters, it seems to be worse when pitching. It also gets pretty bad when nearing transonic/supersonic speed.

I experienced this same issue using the Dev build this past week.  I have yet to use the new 1.3 release, but I will tell you what caused the same lag for me - especially while pitching - the "Trajectories" mod.

I isolated the problem down to Trajectories (my other 40 mods work fine with FAR without Trajectories).  I removed the Trajectories mod and FAR works flawlessly.  I will go test FAR for 1.3 this evening and will come back to post should the issue persist without Trajectories.  Hopefully this is an appropriate place to share my experience with this issue (first post here).

  • Like 3

Share this post


Link to post
Share on other sites

Once again, Ferram, you've given me a reason to continue on with KSP! It's always appreciated. Thanks! :)

Share this post


Link to post
Share on other sites
1 hour ago, wyattb773 said:

I experienced this same issue using the Dev build this past week.  I have yet to use the new 1.3 release, but I will tell you what caused the same lag for me - especially while pitching - the "Trajectories" mod.

I isolated the problem down to Trajectories (my other 40 mods work fine with FAR without Trajectories).  I removed the Trajectories mod and FAR works flawlessly.  I will go test FAR for 1.3 this evening and will come back to post should the issue persist without Trajectories.  Hopefully this is an appropriate place to share my experience with this issue (first post here).

This is absolutely an appropriate place to share your experience. Welcome to the forums!!

I'm using the newest FAR, and the newest Trajectories on KSP 1.3, and I'm having no delectable issues.

@FunnelVortex , is it at all possible that you have remnants of an old FAR install still in your Gamedata folder?

Did you try deleting the FerramAerospaceResearch folder, the  ModularFlightIntegrator folder and reinstalling them?

Edited by TheKurgan

Share this post


Link to post
Share on other sites
28 minutes ago, TheKurgan said:

This is absolutely an appropriate place to share your experience. Welcome to the forums!!

I'm using the newest FAR, and the newest Trajectories on KSP 1.3, and I'm having no delectable issues.

@FunnelVortex , is it at all possible that you have remnants of an old FAR install still in your Gamedata folder?

Did you try deleting the FerramAerospaceResearch folder, the  ModularFlightIntegrator folder and reinstalling them?

Hi and thank you for welcoming me.

I have made a completely clean KSP install and still experienced the issue only while running Trajectories.

Today I installed FAR 1.3 and found that the lag disappears as soon as I disabled "Show Trajectory" in the Trajectories in game menu.

Needless to say the lag also disappears entirely if I run KSP without Trajectories at all.

It must be something in my configuration given that you are able to use the two without detectable issues.

Perhaps my experience may help the other user who posted about the same lag I experienced while pitching before disabling Trajectories.

Share this post


Link to post
Share on other sites

I have Trajectories installed... but I have not used it since installing the newest FAR... I will test as well.

 

Well I just did some testing, and not a single drop in FPS with trajectories on or off. Going to remove trajectories and try again.

Edited by TheKurgan

Share this post


Link to post
Share on other sites
1 hour ago, TheKurgan said:

This is absolutely an appropriate place to share your experience. Welcome to the forums!!

I'm using the newest FAR, and the newest Trajectories on KSP 1.3, and I'm having no delectable issues.

@FunnelVortex , is it at all possible that you have remnants of an old FAR install still in your Gamedata folder?

Did you try deleting the FerramAerospaceResearch folder, the  ModularFlightIntegrator folder and reinstalling them?

No, I don't have an old install in my save. 

I also have Atmosphere Autopilot installed, and also Trajectories. I remember in the older versions (1.1 versions and 1.2 dev builds) I used both with FAR without getting a performance hit. I am updating all the mods in my folder to see if that works.

Edited by FunnelVortex
  • Like 1

Share this post


Link to post
Share on other sites

Removed Trajectories and made several more test flights... not a single frame drop in my FPS average... I don't know what to tell you guys.

Share this post


Link to post
Share on other sites

I just removed Trajectories and it's running smoothly now. Trajectories was the issue.

I hope Ferram finds a way to fix the issue, because Trajecories has proven to be very useful to me.

Share this post


Link to post
Share on other sites

Nothing I can fix, considering the "issue" is that Trajectories is calling FAR's aerodynamic simulations to predict in-atmosphere flight.  It's already about as optimized as I can make it, but there's no way for me to optimize another mod increasing the aerodynamic calculations by x100 every frame for future predictions.

I mean, I can "fix" it by preventing the functions that Trajectories calls from actually doing anything and returning 0, but that would defeat the purpose entirely.

  • Like 4

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now