ferram4

[1.3.1] Ferram Aerospace Research: v0.15.9.1 "Liepmann" 4/2/18

Recommended Posts

Does FAR change the behavior of landing wheels? Because I find it way more dificult to keep my airplane "stable" while taxing. It tends to drop to one side and the spring does not seen to have enough force to push it back.
Without FAR, I usually don't need more than 3 landing gears for a simple jet design, but with FAR I usually end adding an extra couple of gears to the rear of the ship.

Share this post


Link to post
Share on other sites

@Scoppio no, but it changes the default weight of your wing parts so that they don't rip apart as easily.

The default mass strength multiplier with FAR is a bit overkill but ferram had to do that because people were suiciding and complaining that airplanes were not standing their 15G mach 2 turns (also a keyboard's fault, but that is no excuse now with MAF).

Edited by tetryds

Share this post


Link to post
Share on other sites

Hi, everyone!

I've tried FAR from, ahem, super secret location. It works fine in general, although I've found two problems:

1. chute safety triggers seem to remain at stock values. Mk1-2 capsule reentry profile seems fine, but chutes (2xMk12-R and 2xMk2-R) fire early and are ripped away.

2. Sea level drag is too low. A Golfstream-like 1.25m plane with two Basic Jets not only accelerates to 0.95 Mach with ease, but also takes a couple of minutes to slow down to ~ 0.7 Mach while unpowered. (1-3km altitude).

Edited by Psycho_zs

Share this post


Link to post
Share on other sites

All this wait without the ultimate mod makes KSP a dull game.

Share this post


Link to post
Share on other sites
On 01/02/2017 at 3:04 PM, Psycho_zs said:

Hi, everyone!

I've tried FAR from, ahem, super secret location. It works fine in general, although I've found two problems:

1. chute safety triggers seem to remain at stock values. Mk1-2 capsule reentry profile seems fine, but chutes (2xMk12-R and 2xMk2-R) fire early and are ripped away.

2. Sea level drag is too low. A Golfstream-like 1.25m plane with two Basic Jets not only accelerates to 0.95 Mach with ease, but also takes a couple of minutes to slow down to ~ 0.7 Mach while unpowered. (1-3km altitude).

For number one, Ive not tried FAR without RealChutes since... well, since I discovered RealChutes.

For number two, thats worth writing a bug report about. Bug reports should be posted as Issues to the Github repo, and should ideally include a craft file and reproduction instructions.

@Antonio432 et al, FWIW Ive not seen any issues with the dev version in my very limited testing. Thats not me warranting your career save to be brought across, but the mod is available at that super secret location alluded to above. Its not even an obscured location, either. Nor particularly obscure. YMMV, conditions apply, may not be available at all stores, see instore for details.

Edited by blu3wolf

Share this post


Link to post
Share on other sites
3 hours ago, blu3wolf said:

 

@Antonio432 et al, FWIW Ive not seen any issues with the dev version in my very limited testing. Thats not me warranting your career save to be brought across, but the mod is available at that super secret location alluded to above. Its not even an obscured location, either. Nor particularly obscure. YMMV, conditions apply, may not be available at all stores, see instore for details.

I was digging everywhere and I think I might have found the super secret. Will test it and I will confirm if it is real or not. That was easier than expected though, i though i had to do some serious config editing to make it work myself so that it was obvious for others because they know coding while unknown to me since I am very dumb concerning serious config edits. 

Share this post


Link to post
Share on other sites

Well, if you use it, its a dev version (not even a dev release). So dont complain about it wrecking a save, if it does that. But do report the bug, as an Issue on the GitHub. Joys of open source development, distributed bugtesting!

Share this post


Link to post
Share on other sites
30 minutes ago, blu3wolf said:

Well, if you use it, its a dev version (not even a dev release). So dont complain about it wrecking a save, if it does that. But do report the bug, as an Issue on the GitHub. Joys of open source development, distributed bugtesting!

Yep, I did actually find it. I now feel special because I too know the secret location now.

Share this post


Link to post
Share on other sites
On ‎2‎/‎1‎/‎2017 at 1:04 AM, Psycho_zs said:

1. chute safety triggers seem to remain at stock values. Mk1-2 capsule reentry profile seems fine, but chutes (2xMk12-R and 2xMk2-R) fire early and are ripped away.

This was something I noticed when I started testing the dev build: There's no deploy mode (Safe / Risky / Always) option to select. I do have Advanced Tweakables enabled because I can set autostrut options and fuel flow priorities. The chutes behave much like the KSP 1.1 / FAR official release chutes, but maybe ferram4 hasn't updated the RealChute Lite code yet to the current RealChute release.

Hasn't stopped me from designing around it like I did in KSP 1.1 though.

--

Share this post


Link to post
Share on other sites
4 hours ago, Antonio432 said:

Yep, I did actually find it. I now feel special because I too know the secret location now.

You can start feeling special once you at least compile it yourself. Downloading a file is hardly special :P

Share this post


Link to post
Share on other sites
On 1/27/2017 at 1:14 PM, kcs123 said:

IIRC, it is for meemorial of Martin Knudsen and his contribution in physics. More info is on wiki page regarding Knudsen number or to be more specific, relationship with mach and Reynolds number in fluids. More accurate info might be found if you search this thread where ferram anounced news about that FAR release.

Damn. I have a great grandfather with the last name Knudsen who was an engineer so I was like "Whoa, is he famous? I have a famous engineer's sliderule framed on my wall?"

Share this post


Link to post
Share on other sites

Looking forward to the release. Been missing FAR for a looong time. Does anyone know of any mods that offer similar craft-based aero properties that are updated for 1.2.2? I've been itching to do some area-ruling on SSTOs for months. :) 

Share this post


Link to post
Share on other sites

Hi, long time user but first time poster here :) I think I've found an issue with the development version of FAR (ksp 1.2.2): to reproduce, simply put any RCS block inside a fairing, launch the rocket and deploy the fairing. The RCS block does not work as long as it is connected (directly or indirectly) to the fairing base; it starts working if for example I put it on a decoupler and decouple it. I'm reporting it here since removing FAR makes it work for me.

Share this post


Link to post
Share on other sites
27 minutes ago, kbios said:

Hi, long time user but first time poster here :) I think I've found an issue with the development version of FAR (ksp 1.2.2): to reproduce, simply put any RCS block inside a fairing, launch the rocket and deploy the fairing. The RCS block does not work as long as it is connected (directly or indirectly) to the fairing base; it starts working if for example I put it on a decoupler and decouple it. I'm reporting it here since removing FAR makes it work for me.

Welcome to the forums!  Are you on a development version of FAR?  (no released version works with 1.2.2)

Share this post


Link to post
Share on other sites
Just now, blowfish said:

Welcome to the forums!  Are you on a development version of FAR?  (no released version works with 1.2.2)

Thanks! Yes, it's the super secret development version :) Apart from this issue it's working great for me!

Share this post


Link to post
Share on other sites
11 minutes ago, kbios said:

Thanks! Yes, it's the super secret development version :) Apart from this issue it's working great for me!

hmmm... well, first step of figuring out the issue is isolation. See if you can replicate it in an install with JUST FAR installed, or if it's a mod interaction.

Share this post


Link to post
Share on other sites
10 hours ago, Volatar said:

hmmm... well, first step of figuring out the issue is isolation. See if you can replicate it in an install with JUST FAR installed, or if it's a mod interaction.

I just tried with a clean install, with only FAR and its dependencies, and the issue is still present. Here you   can download an example craft which exhibits the problem: just launch it, deploy the fairing, enable rcs and try to use it :)

Share this post


Link to post
Share on other sites

<REDACTED> found this

Quote

secret location

in like two minutes. I just followed White Rabbit, hah.

But since i first time trying this mod (i bought game pretty recently) there is two questions, please help this junior. It is fine if i going to keep CKAN version of mod manager instead of one which coming with dev build of FAR? Or it's absolutely should be other way around?

Second question, how this mod is changing behaviour of ships? The ones that moving on the water instead of airships and spaceships?

Edited by diomedea
taking away hints

Share this post


Link to post
Share on other sites

@Draakon: removed something in your post hinting too much at where to find the current FAR build. Unless the author wants that published, it has not to be.

Share this post


Link to post
Share on other sites
1 hour ago, Draakon said:

It is fine if i going to keep CKAN version of mod manager instead of one which coming with dev build of FAR? Or it's absolutely should be other way around?

I just looked. Module Manager is not packaged with the dev build...

 

You still need it, and the latest release should be the right one to pick, so yes use the CKAN one, but I am concerned. You really shouldn't be using a hidden dev build of a mod if you are new to the game.

Edited by Volatar

Share this post


Link to post
Share on other sites
On 03.02.2017. at 0:01 AM, Morse said:

You can start feeling special once you at least compile it yourself. Downloading a file is hardly special :P

But the file is sekrit

Share this post


Link to post
Share on other sites
19 hours ago, kbios said:

simply put any RCS block inside a fairing, launch the rocket and deploy the fairing. The RCS block does not work as long as it is connected (directly or indirectly) to the fairing base.

I can't reproduce that problem with your craft. However I am finding that RCS block on the craft is fighting with the reaction wheels on the probe core you chose. That's a different problem. When I turn reaction wheels off, the thrusters appear to behave as intended.

--

Share this post


Link to post
Share on other sites
3 hours ago, Gordon Fecyk said:

I can't reproduce that problem with your craft. However I am finding that RCS block on the craft is fighting with the reaction wheels on the probe core you chose. That's a different problem. When I turn reaction wheels off, the thrusters appear to behave as intended.

--

Hey, thanks a lot for testing! So, I just tried about 20 launches in a row with the test ship :0.0: . It appears that this issue is non-deterministic: out of the 20 launches, the RCS worked exactly 4 times. All the other times, I can confirm it was completely non functional, both with reaction wheels enabled and disabled: monopropellant usage was zero and there wasn't any smoke out of the thrusters. It seems that reverting to launch is enough to get another possibility of it working, there is no need to restart the game or quit to the main menu.

As far as I can tell, I did exactly the same sequence of actions in all the 20 launches: press R, T, space, wait 5 seconds, space again, then JLKI

Here is a log snippet from a working launch:

[LOG 00:19:19.504] [HighLogic]: =========================== Scene Change : From FLIGHT to FLIGHT =====================
[LOG 00:19:20.339] [PlanetariumCamera]: Focus: Kerbin
[LOG 00:19:20.346] KbApp.OnDestroy NullName
[LOG 00:19:20.346] [UIApp] OnDestroy: KSPedia
[LOG 00:19:20.346] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:20.353] [UIApp] OnDestroy: ResourceDisplay
[LOG 00:19:20.353] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:20.354] KbApp.OnDestroy Vessel Crew
[LOG 00:19:20.355] KbApp.OnDestroy Planet Info
[LOG 00:19:20.355] KbApp.OnDestroy Planet Resources
[LOG 00:19:20.356] KbApp.OnDestroy Unowned Info
[LOG 00:19:20.356] KbApp.OnDestroy Vessel Info
[LOG 00:19:20.356] KbApp.OnDestroy Planet Parameters
[LOG 00:19:20.368] UICanvasPrefabSpawner FlightUI spawning Flight
[LOG 00:19:20.383] UICanvasPrefabSpawner FlightUI spawning VesselLabels
[LOG 00:19:20.384] [UiApp] Awake: ResourceDisplay
[LOG 00:19:20.390] [AddonLoader]: Instantiating addon 'AeroGUI' from assembly 'KSP'
[LOG 00:19:20.393] [AddonLoader]: Instantiating addon 'MFIManager' from assembly 'ModularFlightIntegrator'
[LOG 00:19:20.393] [AddonLoader]: Instantiating addon 'FARKSPAddonFlightScene' from assembly 'FerramAerospaceResearch'
[LOG 00:19:20.394] [PlanetariumCamera]: Focus: Kerbin
[LOG 00:19:20.394] [UIMasterController]: ShowUI
[LOG 00:19:21.781] ------------------- initializing flight mode... ------------------
[LOG 00:19:21.786] Loading Depletion Nodes
[LOG 00:19:21.786] DepNodeCount:  0
[LOG 00:19:21.786] Loading Biome Nodes
[LOG 00:19:21.786] BiomeNodeCount:  0
[LOG 00:19:21.786] Loading Planet Nodes
[LOG 00:19:21.786] PlanetNodeCount:  0
[LOG 00:19:21.790] [ScenarioDestructibles]: Loading... 0 objects registered
[LOG 00:19:21.790] Loading FAR Data
[LOG 00:19:21.796] FAR: loaded AG actionGroupSpoiler as Brakes
[LOG 00:19:21.796] FAR: loaded AG actionGroupIncreaseFlapDeflection as None
[LOG 00:19:21.796] FAR: loaded AG actionGroupDecreaseFlapDeflection as None
[ERR 00:19:21.796] Cannot find a Module of typename 'DiscoverableObjects'

[ERR 00:19:21.796] ScenarioModule is null.

[ERR 00:19:21.796] Cannot find a Module of typename 'StnSciScenario'

[ERR 00:19:21.796] ScenarioModule is null.

[LOG 00:19:21.816] Target vessel index: 2  vessel count: 3
[LOG 00:19:21.817] [FLIGHT GLOBALS]: Switching To Vessel rcsbug ---------------------- 
[LOG 00:19:21.817] setting new dominant body: Kerbin
FlightGlobals.mainBody: Kerbin
[LOG 00:19:21.817] Reference Frame: Rotating
[LOG 00:19:21.859] [rcsbug]: landed - waiting for ground contact to resume physics...
[LOG 00:19:21.861] Camera Mode: AUTO
[LOG 00:19:27.310] all systems started
[LOG 00:19:27.313] [MFIManager] Current active VesselModule : 
  CommNet.CommNetVessel active=True order=999
  FlightIntegrator active=False order=0
  ModularFI.ModularFlightIntegrator active=True order=0
  FerramAerospaceResearch.FARAeroComponents.FARVesselAero active=True order=999
  FerramAerospaceResearch.FARGUI.FARFlightGUI.FlightGUI active=True order=999

[LOG 00:19:27.337] DragCubeSystem: Rendering procedural drag for fairingSize2
[LOG 00:19:27.431] [ModularFlightIntegrator] MFI Start
[LOG 00:19:27.432] [ModularFlightIntegrator] Start. VesselModule on vessel : 
  ModularFlightIntegrator
  FlightGUI
  FARVesselAero
  CommNetVessel

[LOG 00:19:27.432] FAR Vehicle Voxel Setup started
[LOG 00:19:27.432] FAR Vehicle Voxel Setup complete
[LOG 00:19:27.432] [AsteroidSpawner]: No new objects this time. (Odds are 1:2)
[LOG 00:19:27.433] FARVesselAero on Ast. HSJ-227 (unloaded) reporting startup
[LOG 00:19:27.434] FARVesselAero on Ast. HSJ-227 (unloaded) reporting startup
[LOG 00:19:27.439] FARVesselAero on probeStackSmall (rcsbug) reporting startup
[LOG 00:19:27.444] [Progress Tracking]: Posted anonymous data to server successfully. Server Reply: KSP PROGRESS DATA OBTAINED
[LOG 00:19:27.454] [UiApp] Awake: CurrencyWidgetsApp
[LOG 00:19:27.454] [UiApp] Awake: ResourceDisplay
[LOG 00:19:27.454] [UiApp] Awake: KSPedia
[LOG 00:19:27.454] [ApplicationLauncher] OnSceneLoadedGUIReady: scene FLIGHT ShouldBeVisible() True ShouldBeOnTop() True iIsPositionedAtTop True
[LOG 00:19:27.455] ScaleModList: listSize 41 maxListSize 989
[LOG 00:19:27.455] [KnowledgeBase] OnAppLauncherReady 4200
[LOG 00:19:27.469] [UIApp] OnDestroy: ContractsApp
[LOG 00:19:27.548] [MessageSystem] Reposition 0.02 4201
[LOG 00:19:27.551] Cannot assign AudioClip '' to AudioFX
[ERR 00:19:27.551] AudioFX: Cannot find transform of name ''

[LOG 00:19:27.558] [FlightIntegrator]: Reloaded drag cube for zeroed cube root part probeStackSmall (rcsbug) on vessel rcsbug
[LOG 00:19:27.611] [PlanetariumCamera]: Focus: rcsbug
[LOG 00:19:27.632] [UIApp] Adding ResourceDisplay to Application Launcher
[LOG 00:19:27.633] ScaleModList: listSize 41 maxListSize 949
[LOG 00:19:27.633] [UIApp] Adding ResourceDisplay to Application Launcher
[LOG 00:19:27.634] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:27.672] [ResourceDisplay] OnAppStarted(): id: -199168
[LOG 00:19:27.673] [GenericAppFrame] Reposition 0.161203 4205
[LOG 00:19:27.673] [ResourceDisplay] OnAppStarted(): id: 112746
[LOG 00:19:27.673] ResourceDisplay already exist, destroying this instance
[LOG 00:19:27.673] [UIApp] OnDestroy: ResourceDisplay
[LOG 00:19:27.673] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:27.716] CURRENCY WIDGET False False False
[LOG 00:19:27.720] [UIApp] OnDestroy: CurrencyWidgetsApp
[LOG 00:19:27.753] [UIApp] Adding KSPedia to Application Launcher
[LOG 00:19:27.754] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:28.085] Flight State Captured
[LOG 00:19:28.085] Saving Achievements Tree...
[LOG 00:19:28.085] saved
[LOG 00:19:28.090] Saving FAR Data
[LOG 00:19:28.095] FAR: save AG actionGroupSpoiler as Brakes
[LOG 00:19:28.095] FAR: save AG actionGroupIncreaseFlapDeflection as None
[LOG 00:19:28.095] FAR: save AG actionGroupDecreaseFlapDeflection as None
[LOG 00:19:28.100] [MessageSystem] Save Messages
[LOG 00:19:28.108] Game State Saved as persistent
[LOG 00:19:29.055] Update fairing event
[LOG 00:19:29.056] Updating vessel voxel for rcsbug
[LOG 00:19:29.294] Std dev for smoothing: 3 voxel total vol: 36,6814315172883 filled vol: 14,3976540579173

[LOG 00:19:31.231] Unpacking rcsbug
[LOG 00:19:31.374] [Progress Node Reached]: RecordsAltitude
[LOG 00:19:31.374] [Progress Node Reached]: RecordsSpeed
[LOG 00:19:31.374] [Progress Node Reached]: RecordsDistance
[LOG 00:19:32.120] RCS lock/unlock
[LOG 00:19:35.007] [Progress Node Reached]: FirstLaunch
[LOG 00:19:35.007] [Progress Node Complete]: FirstLaunch
[LOG 00:19:38.746] Update fairing event
[LOG 00:19:38.747] Updating vessel voxel for rcsbug
[LOG 00:19:38.994] Std dev for smoothing: 3 voxel total vol: 36,6814315172883 filled vol: 12,5193572587408

[LOG 00:19:47.154] [UIMasterController]: ShowUI
[LOG 00:19:47.154] Game Paused!

And here a nonworking one:

[LOG 00:19:49.126] [HighLogic]: =========================== Scene Change : From FLIGHT to FLIGHT =====================
[LOG 00:19:49.975] [PlanetariumCamera]: Focus: Kerbin
[LOG 00:19:49.979] [UIApp] OnDestroy: KSPedia
[LOG 00:19:49.979] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:49.979] KbApp.OnDestroy Unowned Info
[LOG 00:19:49.979] KbApp.OnDestroy Planet Parameters
[LOG 00:19:49.980] KbApp.OnDestroy Planet Info
[LOG 00:19:49.980] KbApp.OnDestroy Vessel Crew
[LOG 00:19:49.980] KbApp.OnDestroy NullName
[LOG 00:19:49.982] KbApp.OnDestroy Planet Resources
[LOG 00:19:49.982] KbApp.OnDestroy Vessel Info
[LOG 00:19:49.982] [UIApp] OnDestroy: ResourceDisplay
[LOG 00:19:49.983] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:49.993] UICanvasPrefabSpawner FlightUI spawning Flight
[LOG 00:19:50.008] UICanvasPrefabSpawner FlightUI spawning VesselLabels
[LOG 00:19:50.008] [UiApp] Awake: ResourceDisplay
[LOG 00:19:50.014] [AddonLoader]: Instantiating addon 'AeroGUI' from assembly 'KSP'
[LOG 00:19:50.018] [AddonLoader]: Instantiating addon 'MFIManager' from assembly 'ModularFlightIntegrator'
[LOG 00:19:50.018] [AddonLoader]: Instantiating addon 'FARKSPAddonFlightScene' from assembly 'FerramAerospaceResearch'
[LOG 00:19:50.019] [PlanetariumCamera]: Focus: Kerbin
[LOG 00:19:50.019] [UIMasterController]: ShowUI
[LOG 00:19:51.336] ------------------- initializing flight mode... ------------------
[LOG 00:19:51.340] Loading Depletion Nodes
[LOG 00:19:51.340] DepNodeCount:  0
[LOG 00:19:51.340] Loading Biome Nodes
[LOG 00:19:51.340] BiomeNodeCount:  0
[LOG 00:19:51.340] Loading Planet Nodes
[LOG 00:19:51.340] PlanetNodeCount:  0
[LOG 00:19:51.342] [ScenarioDestructibles]: Loading... 0 objects registered
[LOG 00:19:51.342] Loading FAR Data
[LOG 00:19:51.345] FAR: loaded AG actionGroupSpoiler as Brakes
[LOG 00:19:51.345] FAR: loaded AG actionGroupIncreaseFlapDeflection as None
[LOG 00:19:51.345] FAR: loaded AG actionGroupDecreaseFlapDeflection as None
[ERR 00:19:51.346] Cannot find a Module of typename 'DiscoverableObjects'

[ERR 00:19:51.346] ScenarioModule is null.

[ERR 00:19:51.346] Cannot find a Module of typename 'StnSciScenario'

[ERR 00:19:51.346] ScenarioModule is null.

[LOG 00:19:51.355] Target vessel index: 2  vessel count: 3
[LOG 00:19:51.357] [FLIGHT GLOBALS]: Switching To Vessel rcsbug ---------------------- 
[LOG 00:19:51.357] setting new dominant body: Kerbin
FlightGlobals.mainBody: Kerbin
[LOG 00:19:51.357] Reference Frame: Rotating
[LOG 00:19:51.392] [rcsbug]: landed - waiting for ground contact to resume physics...
[LOG 00:19:51.393] Camera Mode: AUTO
[LOG 00:19:56.868] all systems started
[LOG 00:19:56.871] [MFIManager] Current active VesselModule : 
  CommNet.CommNetVessel active=True order=999
  FlightIntegrator active=False order=0
  ModularFI.ModularFlightIntegrator active=True order=0
  FerramAerospaceResearch.FARAeroComponents.FARVesselAero active=True order=999
  FerramAerospaceResearch.FARGUI.FARFlightGUI.FlightGUI active=True order=999

[LOG 00:19:56.893] DragCubeSystem: Rendering procedural drag for fairingSize2
[LOG 00:19:56.987] [ModularFlightIntegrator] MFI Start
[LOG 00:19:56.987] [ModularFlightIntegrator] Start. VesselModule on vessel : 
  ModularFlightIntegrator
  FlightGUI
  FARVesselAero
  CommNetVessel

[LOG 00:19:56.988] FAR Vehicle Voxel Setup started
[LOG 00:19:56.988] FAR Vehicle Voxel Setup complete
[LOG 00:19:56.988] [AsteroidSpawner]: No new objects this time. (Odds are 1:2)
[LOG 00:19:56.988] FARVesselAero on Ast. HSJ-227 (unloaded) reporting startup
[LOG 00:19:56.990] FARVesselAero on Ast. HSJ-227 (unloaded) reporting startup
[LOG 00:19:56.997] FARVesselAero on probeStackSmall (rcsbug) reporting startup
[LOG 00:19:57.003] [Progress Tracking]: Posted anonymous data to server successfully. Server Reply: KSP PROGRESS DATA OBTAINED
[LOG 00:19:57.016] [UiApp] Awake: CurrencyWidgetsApp
[LOG 00:19:57.016] [UiApp] Awake: ResourceDisplay
[LOG 00:19:57.016] [UiApp] Awake: KSPedia
[LOG 00:19:57.016] [ApplicationLauncher] OnSceneLoadedGUIReady: scene FLIGHT ShouldBeVisible() True ShouldBeOnTop() True iIsPositionedAtTop True
[LOG 00:19:57.017] ScaleModList: listSize 41 maxListSize 989
[LOG 00:19:57.017] [KnowledgeBase] OnAppLauncherReady 4590
[LOG 00:19:57.031] [UIApp] OnDestroy: ContractsApp
[LOG 00:19:57.097] [MessageSystem] Reposition 0.02 4591
[LOG 00:19:57.100] Cannot assign AudioClip '' to AudioFX
[ERR 00:19:57.100] AudioFX: Cannot find transform of name ''

[LOG 00:19:57.109] [FlightIntegrator]: Reloaded drag cube for zeroed cube root part probeStackSmall (rcsbug) on vessel rcsbug
[LOG 00:19:57.163] [PlanetariumCamera]: Focus: rcsbug
[LOG 00:19:57.183] [UIApp] Adding ResourceDisplay to Application Launcher
[LOG 00:19:57.184] ScaleModList: listSize 41 maxListSize 949
[LOG 00:19:57.184] [UIApp] Adding ResourceDisplay to Application Launcher
[LOG 00:19:57.184] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:57.230] [ResourceDisplay] OnAppStarted(): id: -217274
[LOG 00:19:57.231] [GenericAppFrame] Reposition 0.1601609 4595
[LOG 00:19:57.231] [ResourceDisplay] OnAppStarted(): id: 112866
[LOG 00:19:57.231] ResourceDisplay already exist, destroying this instance
[LOG 00:19:57.231] [UIApp] OnDestroy: ResourceDisplay
[LOG 00:19:57.232] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:57.276] CURRENCY WIDGET False False False
[LOG 00:19:57.282] [UIApp] OnDestroy: CurrencyWidgetsApp
[LOG 00:19:57.322] [UIApp] Adding KSPedia to Application Launcher
[LOG 00:19:57.323] ScaleModList: listSize 41 maxListSize 908
[LOG 00:19:57.671] Flight State Captured
[LOG 00:19:57.671] Saving Achievements Tree...
[LOG 00:19:57.671] saved
[LOG 00:19:57.675] Saving FAR Data
[LOG 00:19:57.678] FAR: save AG actionGroupSpoiler as Brakes
[LOG 00:19:57.678] FAR: save AG actionGroupIncreaseFlapDeflection as None
[LOG 00:19:57.678] FAR: save AG actionGroupDecreaseFlapDeflection as None
[LOG 00:19:57.681] [MessageSystem] Save Messages
[LOG 00:19:57.688] Game State Saved as persistent
[LOG 00:19:58.597] Update fairing event
[LOG 00:19:58.597] Updating vessel voxel for rcsbug
[LOG 00:19:58.833] Std dev for smoothing: 3 voxel total vol: 36,6814364957332 filled vol: 14,3977831743389

[LOG 00:20:00.721] Unpacking rcsbug
[LOG 00:20:00.871] [Progress Node Reached]: RecordsAltitude
[LOG 00:20:00.871] [Progress Node Reached]: RecordsSpeed
[LOG 00:20:00.871] [Progress Node Reached]: RecordsDistance
[LOG 00:20:01.472] RCS lock/unlock
[LOG 00:20:05.477] [Progress Node Reached]: FirstLaunch
[LOG 00:20:05.477] [Progress Node Complete]: FirstLaunch
[LOG 00:20:09.203] Update fairing event
[LOG 00:20:09.203] Updating vessel voxel for rcsbug
[LOG 00:20:09.436] Std dev for smoothing: 3 voxel total vol: 36,6814364957332 filled vol: 14,3977831743389

[LOG 00:20:19.247] [AsteroidSpawner]: No new objects this time. (Odds are 1:2)
[LOG 00:20:19.864] [UIMasterController]: ShowUI
[LOG 00:20:19.864] Game Paused!

The only important difference I see is near the end, where it says

[LOG 00:19:38.994] Std dev for smoothing: 3 voxel total vol: 36,6814315172883 filled vol: 12,5193572587408

in the working case and

[LOG 00:20:09.436] Std dev for smoothing: 3 voxel total vol: 36,6814364957332 filled vol: 14,3977831743389

in the nonworking one.

Edited by kbios
Log differences

Share this post


Link to post
Share on other sites
3 hours ago, kbios said:

It appears that this issue is non-deterministic: out of the 20 launches, the RCS worked exactly 4 times.

Have you submitted this to ferram4's project page on GitHub as an issue?

I can't reproduce the problem, but it might be you're using a different build than me or you're using a different version of Module Manager or Modular Flight Integrator. I have Module Manager 2.7.5.0, Modular Flight Integrator 1.2.3.0, and finally the FAR DLL version is 0.15.7.2 but this is the one meant for KSP 1.2.2 and the version number doesn't mean much in this case... I forgot when I put it in there but my Created date says 25 JAN 2017.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.