Jump to content

CKAN help


dmav522
 Share

Recommended Posts

You want to install all 2386 mods which are currently listed on CKAN? I don't think that's possible and I cannot think of any reason to do that, especially since many mods are incompatible with other mods.

You can install a bunch of mods through CKAN and create a .ckan file to reinstall all of them the next time, for example for a second install, but you still have to select them manually first. 

Maybe the CLI version offers something some more options I'm not aware of but still, why would you (or anyone) want to do that?

Link to comment
Share on other sites

On Linux:

ckan.exe install $(ckan.exe available | tail -n +3 | awk '{print $2}')

But as @4x4cheesecake notes, this will not work. You will get errors because tons of these modules conflict with one another.

The following inconsistencies were found:
* AdvancedFlyByWire-Linux 1.8.3.1 conflicts with AdvancedFlyByWire 1.8.3.1
Install canceled. Your files have been returned to their initial state.

 

Link to comment
Share on other sites

35 minutes ago, 4x4cheesecake said:

You want to install all 2386 mods which are currently listed on CKAN? I don't think that's possible and I cannot think of any reason to do that, especially since many mods are incompatible with other mods.

You can install a bunch of mods through CKAN and create a .ckan file to reinstall all of them the next time, for example for a second install, but you still have to select them manually first. 

Maybe the CLI version offers something some more options I'm not aware of but still, why would you (or anyone) want to do that?

i meant for my mods  see my kerbalx profile for used mods https://kerbalx.com/mod_pack/for/hangar/12540

1 minute ago, HebaruSan said:

On Linux:

ckan.exe install $(ckan.exe available | tail -n +3 | awk '{print $2}')

But as @4x4cheesecake notes, this will not work. You will get errors because tons of these modules conflict with one another.

The following inconsistencies were found:
* AdvancedFlyByWire-Linux 1.8.3.1 conflicts with AdvancedFlyByWire 1.8.3.1
Install canceled. Your files have been returned to their initial state.

 

I am using MS windows 10

Link to comment
Share on other sites

6 minutes ago, dmav522 said:

i meant for my mods  see my kerbalx profile for used mods https://kerbalx.com/mod_pack/for/hangar/12540

Oh, that's much easier.

  1. Click "Download ModPack as a CKAN metapackage" and save it somewhere
  2. Open CKAN
  3. File → Install from .ckan...
  4. Select the file you downloaded earlier
Edited by HebaruSan
Link to comment
Share on other sites

27 minutes ago, HebaruSan said:

Oh, that's much easier.

  1. Click "Download ModPack as a CKAN metapackage" and save it somewhere
  2. Open CKAN
  3. File → Install from .ckan...
  4. Select the file you downloaded earlier

how do i select multiple mods? because it takes forever to install one by one

Link to comment
Share on other sites

Just now, HebaruSan said:

That's one way to do it, but it's not required.

There is a user guide available:  https://github.com/KSP-CKAN/CKAN/wiki/User-guide

it is above the file marked installed-Kerbal Space Program.ckan, is that correct because none of my mods show up

3 minutes ago, dmav522 said:

it is above the file marked installed-Kerbal Space Program.ckan, is that correct because none of my mods show up

thx FIXED!!!!!!! :cool:

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...