Jump to content

[1.8 - 1.10] PAWRangeBuff - Increase your EVA right click menu distance!


Recommended Posts

Posted (edited)

This mod automatically increases the Part Action Window maximum EVA click distance based on the part size.
 

Sometimes you are in a situation when you have a big part (like that new shiny 3.75m Habitation Module from SSPX you've just researched) and you wish you were able to interact with it. But you are not because of the part size: Bill just can't reach the part although literally touching it.

It seems that when you right click on the part, KSP calculates the distance to it's center making kerbanauts unable to interact with large enough parts. This even happens with 3.75m parts (and there are even larger ones!). It also seems that KSP defaults the distance required to 2 meters. Unfortunately, most mods do not modify the maximum distance to PAW.

CKAN-Indexed-green.svg
DOWNLOAD
Source code
Both links lead to the same repo though...

#######################

INSTALLATION
The mod can either be found on CKAN or downloaded manually using the link above. If manual is chosen, just extract the contents of the archive to your KSP root directory.

INSTALLATION FOR KSP PRE-1.8.0
In the repository root, there is a separate .zip archive for KSP 1.4.5 - 1.7.3 with the latest (0.2.2) version.
I do not intend to keep it up-to-date. However, the mod is very simple and small so I don't think there will be many updates.

SETTINGS
In case you need more, the coefficient can be modified in the Settings.cfg file located in the mod's directory.

#######################

This mod takes every action available through the PAW and increases its EVA availability distance according to the part's biggest attach node. The exact formula is quite simple:

  1. Take the current part's biggest attach node.
  2. Add a value to the current (or KSP default) maximum action range based on the following:
    -- 0.625m => 0.
    -- 1.250m => 1.
    -- 2.500m => 2.
    -- 3.750m => 3.
    -- 5.000m => 4.
  3. Multiply the sum by the coefficient specified in Settings.cfg (default: 1.0).

CHANGELOG

Spoiler

[01.07.2020] 0.2.3
-- recompile for KSP 1.10.0

[08.05.2020] 0.2.2
-- separate pre-1.8.0 source from 1.8+ (no changes for end-users);
-- update formula so it does not change the range if it thinks it is already sufficient;

[04.05.2020] 0.2.1
-- fix the AVC .version file (HebaruSan)

[04.05.2020] 0.2.0
-- minimum supported KSP version is now 1.8.0;
-- fix not patching craft that are loaded right from a hangar;
-- fix a small memory leak;

[03.05.2020] 0.1.5
-- improve file structure (also include LICENSE, CHANGELOG, etc);
-- update code to support automatic console builds;
-- introduce AVC support;
-- buff README up with the new development dependency;

[02.05.2020] 0.1.4
-- refactor code;
-- fix formula;
-- fix default coefficient value;

[01.05.2020] 0.1.0 - 0.1.3
Initial release and improvements

#######################

Thanks to
-- @IgorZ for KSPDev Utils & Release Tools which are used by this mod.
-- the fellowship of the KSP community that is the greatest I've ever seen. For all the mods, non-dying enthusiasm, support and inspiration. And gameplay features! Dude...
-- and obviously... @SQUAD and the dev team for making the greatest game of all time!

#######################
LICENSE
The mod code is licensed under the MIT license.

Edited by atomontage
Link to post
Share on other sites
Posted (edited)
7 hours ago, HebaruSan said:

Does it really work on 1.0.5 through 1.99.99? Usually a plugin is only compatible with a few major versions (1.8–1.9, 1.3–1.7, etc.).

Actually no. :(
After reading this, I've tested the issue in question. Unfortunately, the minimum supported version is now 1.8.0 due to Unity and 3rd-party library dependencies. I'd be ashamed if it was not my first KSP mod. Well, nevermind - I still am.

Fortunately, I've discovered it now and not a few days later after.

Anyways, thank you sir for both asking this and for your pull-request! Much appreciated!

UPD: forgot to mention that I also discovered a few annoying bugs. Fixes are rolled out now. So double thanks!

Edited by atomontage
Link to post
Share on other sites
Posted (edited)

Published a pre-1.8.0 build directly to the root of the repo (see OP). Its not on CKAN, its MiniAVC support is disabled but it should work on all versions from 1.4.5 to 1.7.3.

(Edit: MiniAVC support should be okay now as of 0.2.2+ for pre-1.8.0 versions as well.)

Edited by atomontage
Link to post
Share on other sites

I noticed you still announce compatibility with KSP up to 1.99, which at least on paper amounts to *ninety* releases, plus their respective hotfixes, into the future... are you certain about that? If so, why not also KSP-1.100 etc. ...

Seeing how even the single step from 1.7 to 1.8 broke compatibility for many mods–this one included–I'd think mod authors ought to be more cautious about future KSP releases and their assumptions of compatibility.

Link to post
Share on other sites

0.2.2

  • separate pre-1.8.0 source from 1.8+ (no changes for end-users);
  • update the formula so it does not change the range if it thinks it is already sufficient;
  • fix the max ksp version supported
9 hours ago, Corax said:

I noticed you still announce compatibility with KSP up to 1.99, which at least on paper amounts to *ninety* releases, plus their respective hotfixes, into the future... are you certain about that? If so, why not also KSP-1.100 etc. ...

Seeing how even the single step from 1.7 to 1.8 broke compatibility for many mods–this one included–I'd think mod authors ought to be more cautious about future KSP releases and their assumptions of compatibility.

You are absolutely correct.

This could've been a typo. I probably meant to specify 1.9.99 to support all future patch releases.
This has been fixed in the latest release - now 1.9.1 is specified for the sake of purity. Perhaps, in the future it'll become 1.9.99 when I play with the mod more.

Thank you for pointing that out!

Link to post
Share on other sites

If possible, you might want to adjust that in 0.2.1 as well. The latest release won't fix that particular issue, at least not on the CKAN, as long as 0.2.1 still claims 1.99.99 compatibility and remains available.

Link to post
Share on other sites
Posted (edited)
On 5/8/2020 at 7:52 PM, Corax said:

If possible, you might want to adjust that in 0.2.1 as well. The latest release won't fix that particular issue, at least not on the CKAN, as long as 0.2.1 still claims 1.99.99 compatibility and remains available.

Well, I fixed that in 0.2.1 too after your comment here. However, it seems CKAN caches releases as well as their version compatibility information. CKAN info has been updated. I'll probably look into that tomorrow. For existing users, there is the 0.2.2 update available so it should not be a huge problem (I hope). Anyways, there are not many yet. And I do not expect the download count to get much higher any time soon as this mod is mostly for end-game players or TweakScale users that like to adjust part sizes often.

Edited by atomontage
CKAN clarification
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...