VoidCosmos

[1.9.x] CollisionFX- ReUpdated -1.1.0 (29th/May/2020)

Recommended Posts

Posted (edited)

CollisionFX-ReUpdated

CollisionFX--ReUpdated-1.0.0-red%E2%80%8License-GPLv2-greenCKAN-Indexed-blueSpaceDock-Listed-blueGithub-Indexed-blueKSP%20Version%20Supported-1.9.X-orange

Add some drama to your rough landings! Collision FX-ReUpdated adds sparks and dust, with sound and lighting effects when you collide or scrape your craft. Landing gear also has a rubbery screech on contacting the ground!

Some gifs for you to get a better idea on how it works (more gifs are appreciated):

KGFV96p.gif

(Expand spoiler box to see more)

Spoiler

 

8dxxwVv.gif

TeqjtuY.gif

Previous Thread: 

Dependacy: 

Module Manager: It can be found here: 

Download Links:

RE4Ppr9.pngm0a7tn2.png

License: GPLv2

 

YdYfStN.jpg

Edited by VoidCosmos

Share this post


Link to post
Share on other sites
Posted (edited)

1.1.0

  •  Bugfix. Fixed sound bug
Edited by VoidCosmos

Share this post


Link to post
Share on other sites
Posted (edited)

1.1.0:

  • Bugfix. Fixed sound bug

 

1.0.0: 

  • Recompiled for KSP 1.9.X
  • Adopted by a new Author
  • Updated .dll to .net 4.X
  • Few bugfixes
  • Should work in KSP 1.8.X (use at your own risk)
  • Renamed to Collision FX-ReUpdated
Edited by VoidCosmos

Share this post


Link to post
Share on other sites

Feel free to post :wink:

Share this post


Link to post
Share on other sites
Posted (edited)
16 minutes ago, GluttonyReaper said:

Ah man, glad to see this back! Gonna give it a spin tonight :) 

All the best! Enjoy!

Edited by VoidCosmos

Share this post


Link to post
Share on other sites

@VoidCosmos, Forum rules dictate you include the source code for the mod.  The source code zip only includes the license. 

Share this post


Link to post
Share on other sites
Posted (edited)
23 minutes ago, Gargamel said:

@VoidCosmos, Forum rules dictate you include the source code for the mod.  The source code zip only includes the license. 

Okay, I'll fix that

And @Gargamel, should I add It to the download also?

Edited by VoidCosmos

Share this post


Link to post
Share on other sites

Hi there

so I shall start by saying I have a lot of other mods installed and I am on 1.8.1 but I have tested with and wihtout this mod

so with out I do no get this issue but with when i drop the landing gear on this craft

IcX31N0.jpg

i get a slide show (FPS DROPS TO LIKE 1) and the log is spammed to hell as you can see.

Now this might be because I am on 1.8.1 or I have another mod causing issues with this mod.

Any way IF you know what it might be and would be willing to look at it that would be cool.

 

Thanks so much in advance.

Share this post


Link to post
Share on other sites
5 hours ago, stk2008 said:

Hi there

so I shall start by saying I have a lot of other mods installed and I am on 1.8.1 but I have tested with and wihtout this mod

so with out I do no get this issue but with when i drop the landing gear on this craft

IcX31N0.jpg

i get a slide show (FPS DROPS TO LIKE 1) and the log is spammed to hell as you can see.

Now this might be because I am on 1.8.1 or I have another mod causing issues with this mod.

Any way IF you know what it might be and would be willing to look at it that would be cool.

 

Thanks so much in advance.

I can confirm it also happens in 1.9. The second anything causes the effects to start the game drops to 1 fps.

Share this post


Link to post
Share on other sites
50 minutes ago, Doggydog said:

I can confirm it also happens in 1.9. The second anything causes the effects to start the game drops to 1 fps.

I have not experienced anything like this. I have a really bad pc fyi. It has about 4 gigs of ram

Mind posting a modlist and the logs required (see op)

Share this post


Link to post
Share on other sites

Hello! The mod is lagging too much, it is impossible to play. Please fix it, I really like your mod. In the future, in addition to the sounds and sounds, I would like to see the Gorenje details, it will be very cool and realistic. I wish you good luck and success in your development!

Share this post


Link to post
Share on other sites

To whoever who has the lag problem, please post your modlist and log files(see OP)

Share this post


Link to post
Share on other sites
On 5/12/2020 at 1:35 PM, VoidCosmos said:

And @Gargamel, should I add It to the download also?

I saw the source in the download, it is not necessary to host it there, the separate link you have on github will do fine (once you add it :) ).  Including the source in the main zip file for the mod will just add size to the download (a problem for those on metered connections) and might cause some confusion for those trying to install it.   (Sorry for the delay, I never got the ping in your edit).

Share this post


Link to post
Share on other sites
5 hours ago, Gargamel said:

I saw the source in the download, it is not necessary to host it there, the separate link you have on github will do fine (once you add it :) ).  Including the source in the main zip file for the mod will just add size to the download (a problem for those on metered connections) and might cause some confusion for those trying to install it.   (Sorry for the delay, I never got the ping in your edit).

I dont know how to add it to the master branch

Share this post


Link to post
Share on other sites
Posted (edited)

thanks and grats for the release!

will download and test now to see if i also have the lags some others have reported..

edit: no i did not get any lag! :) altho i also didn't get any sounds either, was that not a feature of this mod?

edit2: scratch that :( it seems to have been an issue of speed, i did get a lot of lag (i.e. low fps) when i tried again at higher speeds. sorry.

Edited by canisin

Share this post


Link to post
Share on other sites
13 minutes ago, canisin said:

altho i also didn't get any sounds either, was that not a feature of this mod?

Interesting. Will look into it soon

Share this post


Link to post
Share on other sites

even if there might be a problem with the sound it might not be completely missing, because i think i have heard some tire squeals in my further attempts, it might just be a tuning issue, which can also be probably true for the sparks and the fps.

Share this post


Link to post
Share on other sites
14 minutes ago, canisin said:

thanks and grats for the release!

edit: no i did not get any lag! 

Thanks for your kind words!:)

I guess the lag is a system based issue. I have a bad PC, but I do not get any kind of lag. Pinging @Doggydog I feel it is a scatter related problem. It sucks a lot of fps

Share this post


Link to post
Share on other sites

I have a medium-ish gaming laptop and I tested CollisionFX on a clean install without Scatterer. I just a stock plane on the runway, accelerated a little and then retracted the landing gear. Depending on the plane's speed there was a very noticeable impact on FPS.

Share this post


Link to post
Share on other sites
1 minute ago, canisin said:

I have a medium-ish gaming laptop and I tested CollisionFX on a clean install without Scatterer. I just a stock plane on the runway, accelerated a little and then retracted the landing gear. Depending on the plane's speed there was a very noticeable impact on FPS.

And with scatterer?

Share this post


Link to post
Share on other sites
2 minutes ago, canisin said:

Haven't tried yet :)

Okay

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.