• 0
SoyIsNotMilk

KSP 1.9.1 hangs a few minutes after launching

Question

Posted (edited)

Hi there kind forum users,

My stock steam install is hanging a few minutes after launching.

Version: 1.9.1.2788, 1.3.1 Making History, 1.9.1 Breaking Ground
OS: Windows 10
64-bit
Steam

Output log(correct on this time): 

https://drive.google.com/file/d/1A9323FY1bYEUeouo4-xkVest_hR8PSIS/view?usp=sharing

System Specs: 

https://drive.google.com/file/d/18dQHV2oKg918bMVaixt3CcHbT6yhXr5H

It seems to hang anywhere, without discernible pattern.  It hangs in the menu, and at the KSC, in the VAB, and in flight; every screen I've been in in this install.  The mouse stays present and moveable on screen, and changes colour when I click.  The music also keeps playing.  Since the game only hangs, rather than crashing, the unity crash report thing doesn't appear, and I have to close the game using task manager.

I have no mods installed.  This install was made with Steam, after uninstalling and the deleting the Steam Kerbal Space Program folder of the previous install.  However, I don't think I can call it a completely clean install, since the save files from the previous install were present on the current install (I have since deleted them, in game).

In case it's relevant: Before this current install I had three installs on my computer: stock 1.9.1, rescaled 1.8.1, and RSS/RO/RP-1 1.8.1.  I played RSSetc exclusively for quite a while and it hung a lot, but at the time I put it down to the sheer amount of mods.  I can't remember if the other installs hung or not.  Also I used a combination of CKAN and manual installs.

I'd be very grateful for any help you can give me,

Cheers,

Soy

Edited by SoyIsNotMilk

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1

Your links are broken, drop the /view?usp=sharing from the end and they should become hyperlinks. You've also shared the wrong player.log file as that one is full of stuff for RSS and a big pile of exceptions at the end.

To me, your description sounds exactly like what I had where the game would freeze on screen but would continue to run and often resulted in explosions as whatever I was flying/driving at the time kept going and crashed. It only appeared in version 1.8.1 and beyond and 1.7.3 was unaffected by it. The cause was a DX11 graphics crash; the solution was to update my graphics driver software, and it hasn't reoccurred since then. Update your graphics drivers and see if that resolves the issue.

 

Share this post


Link to post
Share on other sites
  • 0

Thanks Jimmy,

I've fixed the hyperlinks and added the correct output log now.  I had a look through the log and I found something that looked suspect:

 

[HighLogic]: =========================== Scene Change : From LOADING to MAINMENU =====================
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Unloading 5 Unused Serialized files (Serialized files now loaded: 6)
WARNING: Shader Unsupported: 'Hidden/Nature/Terrain/Utilities' - All passes removed
WARNING: Shader Did you use #pragma only_renderers and omit this platform?
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: 'Hidden/Nature/Terrain/Utilities' - Setting to default shader.
UnloadTime: 2.046900 ms
[AddonLoader]: Instantiating addon 'ContractDefs' from assembly 'KSP'

 

My drivers are up to date according to Nvidia GeForce (I updated them a few days ago), and I have DirectX 12.  What other things are there that I could do?  I saw a post about a similar problem that you answered where you said to try using OpenGL, is that something I could try?
 

Cheers,

Soy

Share this post


Link to post
Share on other sites
  • 0
On 5/23/2020 at 4:32 AM, SoyIsNotMilk said:

Thanks Jimmy,

I've fixed the hyperlinks and added the correct output log now.  I had a look through the log and I found something that looked suspect:

 

[HighLogic]: =========================== Scene Change : From LOADING to MAINMENU =====================
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Unloading 5 Unused Serialized files (Serialized files now loaded: 6)
WARNING: Shader Unsupported: 'Hidden/Nature/Terrain/Utilities' - All passes removed
WARNING: Shader Did you use #pragma only_renderers and omit this platform?
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: 'Hidden/Nature/Terrain/Utilities' - Setting to default shader.
UnloadTime: 2.046900 ms
[AddonLoader]: Instantiating addon 'ContractDefs' from assembly 'KSP'

 

My drivers are up to date according to Nvidia GeForce (I updated them a few days ago), and I have DirectX 12.  What other things are there that I could do?  I saw a post about a similar problem that you answered where you said to try using OpenGL, is that something I could try?
 

Cheers,

Soy

You can try it, it might help. I think I explained how to do that in the thread you linked to but just in case-

Make a shortcut to the KSP.exe application > open the properties of the shortcut > add --force-opengl to the end of its target.

If you use the shortcut, the game will open using openGL; if you click the app itself or use CKAN to launch it, it won't use openGL.

You could also try turning scatters off, downgrading your terrain settings and if nothing else helps try this:

Open the settings file and change UNSUPPORTED_LEGACY_SHADER_TERRAIN = False to True

That will make the game use the old, pre-1.8 terrain which is uglier but might resolve the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.