Jump to content

[WIP] Jade's Dev Thread - Sterling Systems


JadeOfMaar
 Share

Recommended Posts

Posted (edited)

Scramjets!

Gentle reminder that these will be largely useless on stock scale, otherwise they take their rightful place as the cruising engine on your hypersonic planes, and can replace the RAPIER's closed cycle for upper atmosphere flat run phase. I'm doubtful about providing the shcramjet at this time. There are a few obvious texture faults. Those won't remain.

Parts:

  • 1.25/1.875m hollow (radial but goes over your fuselage like slipping yourself into some shorts)
  • 1.25m nacelle (radial only)

Variants:

  • Colors: White; White + Thermal Tiles; Only Thermal Tiles
  • Mounts (nacelle only): Shroud; Pylon (repeats per color variant)

Engines_Scramjet.png

On the side, I received quite a bit of crit on the design for one of the interstellar engines. I spent all the energy intended for unwrapping it into changing the raw model to make more sense for how it operates.

Edited by JadeOfMaar
Link to comment
Share on other sites

9 hours ago, JadeOfMaar said:

Engines_Scramjet.png

 

Weird question but, how hard would it be to add a variant of the third nacelle (the one with the extended heat shield on the bottom) without the engine in the middle? I know it's not its intended purpose, but it's a unique enough shape I could see it being quite useful for spaceplanes and similar as an engine mount. Though I understand you may not want to spend time on something like this

Link to comment
Share on other sites

11 hours ago, Beccab said:

I could see it being quite useful for spaceplanes and similar as an engine mount.

Concorde-alike engine body/mount, huh. Very interesting. That would be easy enough to do but I won't make it out of the scramjet body (for proportion/anatomy reasons and) I'm avoiding the scope creep (purely an intake; aero category) associated with it so no. If I do make a suite of intakes I'll be sure to remember this and its associated options/variants.

Link to comment
Share on other sites

  • 3 weeks later...
16 minutes ago, chaos113 said:

do you submerge yourself with so many projects to cope with something 

Hah no. I just come up with many, many ideas and want to see them happen. I do want to reduce the number of them since my intentions for KSP have changed more as time passes.

Link to comment
Share on other sites

29 minutes ago, JadeOfMaar said:

Hah no. I just come up with many, many ideas and want to see them happen. I do want to reduce the number of them since my intentions for KSP have changed more as time passes.

okay, i was just worried as it seemed you took on so much like a workaholic 

Link to comment
Share on other sites

27 minutes ago, SkyFall2489 said:

@JadeOfMaar what are the hard dependencies for Impulse Party? just ModuleManager and B9 part switch?

Just MM actually... B9PS actually isn't a hard dependency for this one but you'll miss the ability to change the plume style of the impulse rockets, and the warp coils upgrade config won't work.

Link to comment
Share on other sites

2 hours ago, JadeOfMaar said:

Just MM actually... B9PS actually isn't a hard dependency for this one but you'll miss the ability to change the plume style of the impulse rockets, and the warp coils upgrade config won't work.

Great! added to my save.

Link to comment
Share on other sites

On 6/11/2022 at 4:19 PM, JadeOfMaar said:

Scramjets!

Gentle reminder that these will be largely useless on stock scale, otherwise they take their rightful place as the cruising engine on your hypersonic planes, and can replace the RAPIER's closed cycle for upper atmosphere flat run phase. I'm doubtful about providing the shcramjet at this time. There are a few obvious texture faults. Those won't remain.

Parts:

  • 1.25/1.875m hollow (radial but goes over your fuselage like slipping yourself into some shorts)
  • 1.25m nacelle (radial only)

Variants:

  • Colors: White; White + Thermal Tiles; Only Thermal Tiles
  • Mounts (nacelle only): Shroud; Pylon (repeats per color variant)

Engines_Scramjet.png

On the side, I received quite a bit of crit on the design for one of the interstellar engines. I spent all the energy intended for unwrapping it into changing the raw model to make more sense for how it operates.

Those look epic. Is there any chance you’ll make a tiled version of the basic liquid fuel tank?

Link to comment
Share on other sites

1 hour ago, Spaceman.Spiff said:

Those look epic. Is there any chance you’ll make a tiled version of the basic liquid fuel tank?

Or he could make a flag with that tile texture and we could put it on wings and stuff too

Link to comment
Share on other sites

@JadeOfMaar Possible bug: in Impulse Party, the mk2 impulse drive seems to produce way more heat than the s1 or s2 drives - without KFS installed. 

To reproduce:

1. make a ship with the mk2 impulse drive, mk1 impulse drive, and what is needed to power and fuel them

2. turn on the s1 drive  and whatever is powering them

3. turn off the s1 drive and turn on the mk2 drive

4. watch as the temperature bars rappidly appear and fill up on all the parts near the mk2 drive, causing a lot of parts to explode

Link to comment
Share on other sites

1 hour ago, SkyFall2489 said:

@JadeOfMaar Possible bug: in Impulse Party, the mk2 impulse drive seems to produce way more heat than the s1 or s2 drives - without KFS installed. 

To reproduce:

1. make a ship with the mk2 impulse drive, mk1 impulse drive, and what is needed to power and fuel them

2. turn on the s1 drive  and whatever is powering them

3. turn off the s1 drive and turn on the mk2 drive

4. watch as the temperature bars rappidly appear and fill up on all the parts near the mk2 drive, causing a lot of parts to explode

I'll check that out. Seems like just another random, stupid, aggressive KSP bug though. That kind of crap really happens.

3 hours ago, Spaceman.Spiff said:

Those look epic. Is there any chance you’ll make a tiled version of the basic liquid fuel tank?

The feeling is mutual and has been present since I took the screenshot showing the scramjets in-game. I don't have Restock in that particular install but unless I'm mistaken, Restock doesn't touch the Mk1 airplane fuel tank so it looks all kinds of sad next to the scramjet. My own tank pack requires its own great deal of time and effort so it'll take some time to arrive and I've given it lower priority because I can easily substitute with Procedural Tanks for the most part. I plan to make it purely to provide for fusion and (some new) fission fuels, but that's where most of the effort is.

...I intend to ship Procedural Parts configs and textures in the meantime. I will include option(s) for shuttle tiles. Thanks for suggesting.

 

2 hours ago, SpaceFace545 said:

Or he could make a flag with that tile texture and we could put it on wings and stuff too

That can happen.

Link to comment
Share on other sites

Posted (edited)
22 hours ago, JadeOfMaar said:

I'll check that out. Seems like just another random, stupid, aggressive KSP bug though. That kind of crap really happens.

The feeling is mutual and has been present since I took the screenshot showing the scramjets in-game. I don't have Restock in that particular install but unless I'm mistaken, Restock doesn't touch the Mk1 airplane fuel tank so it looks all kinds of sad next to the scramjet. My own tank pack requires its own great deal of time and effort so it'll take some time to arrive and I've given it lower priority because I can easily substitute with Procedural Tanks for the most part. I plan to make it purely to provide for fusion and (some new) fission fuels, but that's where most of the effort is.

...I intend to ship Procedural Parts configs and textures in the meantime. I will include option(s) for shuttle tiles. Thanks for suggesting.

 

That can happen.

Oh, and the issue is with the s3 drive too.

Seems like the issue is that the exhaust transfrom may be misplaced, resulting in the engine getting super hot, and then transferring all the heat to nearby parts?

EDIT:

Further testing reveals that sometime sthe other drives have this issue too. may have to do with symmetry. When this happens, the engines don't produce thrust either, as if occluded. For now, I'm MMing the engines to not have exhaust damage.

EDIT 2:

Sometimes, if the engines are placed with symmetry, their thrust direction is reversed. Really weird, and I looked through the config file and didn't see any possible causes there.

Edited by SkyFall2489
Link to comment
Share on other sites

@JadeOfMaar, I further narrowed down the bug.

Seems like every once in a while, if an impulse drive is placed with symmetry, the thrust direction is aimed backwards. This leads to massive torque on the ship and/or melting of whatever is stacked on top of the engine from the exhaust damage.

Needed install: Impulse Party, no kerbal flying saucers

Steps to reproduce:

1. build a ship with what is needed to power the impulse drives, along with a few drives placed using radial symmetry and stuff on their top nodes

2. fire all engines

3. watch as the thing spins out of control and/or melts and/or goes nowhere and/or explodes

Link to comment
Share on other sites

On 7/4/2022 at 2:10 PM, SkyFall2489 said:

Seems like every once in a while, if an impulse drive is placed with symmetry, the thrust direction is aimed backwards.

Now that is just more KSP weirdness and not necessarily something I need to try and find the source of. However, it might be worth mentioning that for use with Angel's anti-grav engine, the part needs to have certain extra "transforms" (meshes or empty gameobjects) facing in practically the 6 cardinal directions. KSP might be getting confused with them, especially with Angel's mod present. That's all I can say.

 

All interplanetary category engines are in-game now. Some texture work still needs to be done in many places... On request I've made these engines to be especially friendly to the Simple Repaint mod (The white or repainted surfaces are meshes with a single name which is singled out for targeting).

screenshot21.png

Link to comment
Share on other sites

6 hours ago, JadeOfMaar said:

Now that is just more KSP weirdness and not necessarily something I need to try and find the source of. However, it might be worth mentioning that for use with Angel's anti-grav engine, the part needs to have certain extra "transforms" (meshes or empty gameobjects) facing in practically the 6 cardinal directions. KSP might be getting confused with them, especially with Angel's mod present. That's all I can say.

 

All interplanetary category engines are in-game now. Some texture work still needs to be done in many places... On request I've made these engines to be especially friendly to the Simple Repaint mod (The white or repainted surfaces are meshes with a single name which is singled out for targeting).

screenshot21.png

If that is the issue, would it be possible for the gravitic transforms to be a seperate model, using a MODEL node in the KFS MM patch to only have those transforms when KFS is installed?

Oh, and a request: 3.75m inline mega shield generator. Some big spherical shape inside a cylindrical frame, and a field of maybe 250m.

Link to comment
Share on other sites

19 hours ago, JadeOfMaar said:

Now that is just more KSP weirdness and not necessarily something I need to try and find the source of. However, it might be worth mentioning that for use with Angel's anti-grav engine, the part needs to have certain extra "transforms" (meshes or empty gameobjects) facing in practically the 6 cardinal directions. KSP might be getting confused with them, especially with Angel's mod present. That's all I can say.

 

All interplanetary category engines are in-game now. Some texture work still needs to be done in many places... On request I've made these engines to be especially friendly to the Simple Repaint mod (The white or repainted surfaces are meshes with a single name which is singled out for targeting).

screenshot21.png

dam that looks cool, meanwhile i cant use simple repaint because it takes forever to load with my mod list, i wish i could have it blacklist bluedog because i think thats what causes its long load times

Link to comment
Share on other sites

16 minutes ago, JadeOfMaar said:

@chaos113 Weird. From my brief experience, I had to nudge Simple Repaint to notice my parts. This tiny config should help you out:

@PART[bluedog*]:BEFORE[SimpleRepaint]
{
	%SR_Ignore = true
}

 

you have to blacklist all parts in a mod for that to work 

Link to comment
Share on other sites

9 hours ago, chaos113 said:

you have to blacklist all parts in a mod for that to work 

That's how that config works. All parts whose names start with "bluedog" and contain anything else after, represented by "*" are selected. It's good practice for any parts maker to have an identifying prefix for all their parts in order to show the mod they belong to and help for targeting with MM. Unfortunately, OPT parts (not made by me, therefore, the vast majority of them) are not named this way so I have to target all parts that have the mod name for their manufacturer:

@PART:HAS[#manufacturer[OPT*Division]]
{
  ...
}

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...