Jump to content

[1.7.1][1.8.1][1.9.1][1.10.1] Persistent Thrust Extended 1.7.5 (now with background persistent thrust)


FreeThinker
 Share

Recommended Posts

@Bej Kerman Wrong thread maybe? That seems like an NF Electrical issue (that's the mod the reactors are from), not a Persistant Thrust issue.
Furthermore, I have the same issue, and I don't have any version of Persistant Thrust installed in my game.

On second thought, it might be an issue with the stock game, but that doesn't mean that mods can't fix it. IIRC DynamicBatteryStorage (a companion mod that is a dependency of most of Nertea's mods) attempts to address this issue, but it seems it's cropped up again for reasons beyond my comprehension (I have a basic understanding of what is possible and not possible with mods, but have never attempted to make my own mod beyond MM patches {and before that existed, direct edits to .cfg files})

I think I'll post about it over in the relevant thread, hopefully it gets the proper attention there by someone who's in a position to do something about it.

Edited by SciMan
Link to comment
Share on other sites

Photonic Sailor sails don't have any buttons in the PAW to extend and Persistent Thrust has me locked at 1x warp. The effect is like if the / key was being spammed, I just get 'warp: 1x' without any indication about what the problem is.

Edit: toggling all the 'persistent x' PAW buttons fixed it. Not sure what causes the issue in the first place, or if fixing the sails will be as easy.

Edited by Bej Kerman
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...
7 hours ago, Omnipius said:

FYI, Persistent Thrust is broken by Kopernicus 67+ (through 68 at time of writing). Null ref spam on the GetRequestedDirection call when trying to save a vessel in flight, causing all attempts to save or exit flight to fail.

Log is Here

Best fix I have found for newer versions is to use the version on github. It seems to be a slightly newer version. It works for me but I don't think im using Kop 67+. The only problem I've found is these ugly vector lines from active engines

Link to comment
Share on other sites

Hi guys. Can you please tell me if is there a working mod for Sail Solar Navigator for KSP 1.8.1? I recently saw a video on YouTube where the author used a combination of Persistent Trust and Solar Sail Navigator in ksp 1.8.1. I tried to repeat it, I even installed 1.8.1, but for some reason the mods do not work (I downloaded the fork from Standecco from the github). If anyone knows, please help, I will be very grateful.:)

Edited by Gwilides
Link to comment
Share on other sites

  • 2 weeks later...

Is anyone having issues getting this mod to work with bipropellant engines in 1.10? Weirdly enough, ion engines work just fine and generate thrust during time warp, but other ones don't: the PAW shows them as not having their fuel requirements met (even if they work just fine if I uninstall Persistent Thrust) and I can "ignite" them, but no thrust is generated and I can't see the Waterfall exhaust effects. The engine does appear to emit light as predicted by Engine Lightning, so something's acting up :/ 

For reference, this is happening in an RO modpack.

Edited by Tonas1997
Link to comment
Share on other sites

  • 1 month later...
Hello everyone,
I'm having an issue with the latest version of the mod installed where at some point in orbit it keeps me from timewarping. The only way to get around this is going to the tracking station and back to my craft, but this is really annoying. I've uninstalled the mod, and now everything works fine. But I really want to use this mod, so does anyone have a solution for this.
Link to comment
Share on other sites

  • 3 months later...
On 6/15/2020 at 11:45 PM, nubeees said:

I'm getting a bug where its triggering the 'propellant depleted' dropout when propellant is most certainly not depleted. Still trying to track down the exact cause but it seems to be related to having multiple persistent engines active during high time warp.

Another fun one, is the vessel being pulled out of timewarp from very high timewarp levels seems to smear it across the fabric of spacetime in a spectacular explosion.

Same problem. I'm testing a VASIMR engine with full Xenon Gas and electric charge

Link to comment
Share on other sites

Posted (edited)

@Vollkotzbrocken @Steigleder Cut the throttle before you drop spent stages, even if they are SRBs (X->Space->Z->Space for example), that fixed it for me

On another topic: Anyone have a problem when the throttle seems to "blink" from 0 to max intermittently? Like, if you use something to monitor acceleration and TWR you will see that, with this mod installed, it will jump constantly from 0 to max, sometimes so fast that the audio and the plumes makes appear that the engines are running normally even when they don't (The rocket that have this performs way worst than a normal rocket, a 5000 d/v rocket barely had any fuel to maneuver once in orbit for example)

Edited by Guest
Link to comment
Share on other sites

  • 2 weeks later...
On 5/12/2022 at 9:41 PM, Steigleder said:

Same problem. I'm testing a VASIMR engine with full Xenon Gas and electric charge

I was just trying this, what I saw was that at extremely high warp, the amount of EC used in  a single tic was more than the vessel had in total.  Even though the vessel had more then enough charging capability, it was running out of ec in that single tic, and therefore thought the propellant was depleted.

 

Link to comment
Share on other sites

On 5/13/2022 at 4:43 AM, Forked Camphor said:

Anyone have a problem when the throttle seems to "blink" from 0 to max intermittently? Like, if you use something to monitor acceleration and TWR you will see that, with this mod installed, it will jump constantly from 0 to max, sometimes so fast that the audio and the plumes makes appear that the engines are running normally even when they don't (The rocket that have this performs way worst than a normal rocket, a 5000 d/v rocket barely had any fuel to maneuver once in orbit for example)

How can this be replicated?  What are you using to monitor acceleration and TWR?

Link to comment
Share on other sites

21 minutes ago, linuxgurugamer said:

How can this be replicated?  What are you using to monitor acceleration and TWR?

I was using KER to show that info. I think the last time it happened I was using Restock, Restock+ or NFLV engines, but in general you can replicate it building any rocket and launching it (The bug should trigger right away or in less than 5-10 seconds), if the engine/s runs smoothly then try a different engine until you find one that triggers it.

Link to comment
Share on other sites

Posted (edited)
On 6/4/2022 at 6:25 PM, linuxgurugamer said:

I was just trying this, what I saw was that at extremely high warp, the amount of EC used in  a single tic was more than the vessel had in total.  Even though the vessel had more then enough charging capability, it was running out of ec in that single tic, and therefore thought the propellant was depleted.

 

@linuxgurugamer Exactly that is what happens!  I had to apply a workaround that consists of activating the infinite electricity cheat.

By the way, I found out that antimatter tanks often explode during timewarp for the same reason.

Edited by Steigleder
Link to comment
Share on other sites

I'm guessing that the solution for this is not something that Persistent Thrust should be doing.

Sounds more like something Near Future Electrical should help solve. That has an included dependency "DynamicBatteryStorage" that I think aims to solve exactly that issue. If it's not working right, probably time to talk to Nertea about it, or if it's not installed, well it should be.

Link to comment
Share on other sites

  • 3 weeks later...
On 6/5/2022 at 2:48 PM, linuxgurugamer said:

How can this be replicated?  What are you using to monitor acceleration and TWR?

I have news on this bug: I found that the bug triggers if you deactivate options on the engines. For example, if you create a new game with the default settings and with "Maximize power" (Meaning, all options check), and you never touch that options again, all engines behave normally except for a little stutter when staging. If you, for example, deactivate any or all options (Either on the engine or on the options menu) the bug triggers.

Link to comment
Share on other sites

  • 2 weeks later...
On 12/13/2021 at 10:37 AM, Gwilides said:

Hi guys. Can you please tell me if is there a working mod for Sail Solar Navigator for KSP 1.8.1? I recently saw a video on YouTube where the author used a combination of Persistent Trust and Solar Sail Navigator in ksp 1.8.1. I tried to repeat it, I even installed 1.8.1, but for some reason the mods do not work (I downloaded the fork from Standecco from the github). If anyone knows, please help, I will be very grateful.:)

A bit late here, but I managed to get a build of SSN working with the most up to date version of PT

Link to comment
Share on other sites

  • 1 month later...

So... since i have V1.12.2 Can someone tell me if the integrated Persistent Thrust in KSPIE works better than this one?
If yes, i would back to IE since i never did serious interstellar missions before, and is the last thing that i have left to do in KSP. thx in advance.

Edit: I already tested KSPIE's Persistent Thrust and in fact works better than this one, indeed, better than my last experience with IE

Edited by Ariel Kerman
Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...