Jump to content

[Min KSP 1.11] Mk-33: X-33-inspired parts for KSP!


Angel-125
 Share

Recommended Posts

  • 1 month later...
10 minutes ago, JordanLOL said:

Which file do I have to import into the gamedata folder? WildBlueIndustries or Mk-33? or anything else?

You should copy-and-paste the entire WildBlueIndustries folder into GameData, because although there is nothing else in there, the asset URL paths rely on Mk-33 being inside of WildBlueIndustries.

Link to comment
Share on other sites

So I've been playing with this and the vehicle's performance envelope is ... interesting to say the least. For reference, I'm flying this on 2.5x rescale so I'm flying fully fueled.

Four aerospikes off the pad is actually way too much thrust, even with a full orange jumbo in the cargo bay. I was leaping off the pad at about 1.75 TWR. I found the ascent was much more manageable when I scaled this back to 3 aerospike segments. Fuel-wise, I had enough to fill out a 110km orbit with 1800m/s to spare. I could put my 64 ton payload on a geostationary transfer orbit and still make it back home. I had basically no heating issues when reentering even at over 3,000 meters/second. I did find that the glide profile on the bird is ... strange. Its very draggy and slows down pretty quick once you're no longer hypersonic, but its also oddly floaty. It felt like it was gliding rather well for how slow I was going. I'm still searching for the right descent path.

I was also surprised at how many kerbals were packed into the cockpit and I didn't lose any fuel capacity. I feel like anywhere from 25-50% of the tank space is being filled with crew cabin but its still carrying full fuel. I get that it's to ensure vehicle in both configurations but I was still surprised. Even if I did lose half that fuel I could probably be just fine so long as I didn't try to lift more than about 40 tons to orbit.

 

21 hours ago, Cloakedwand72 said:

Have been enjoying using the venture star mod! Just two things why is their lack of control while orbiting? And also what should the fuel balance look like & reentry profile look like for this SSTO?

I had success pushing all fuel to the aft tank. That greatly improved my aerodynamic control on entry.

Link to comment
Share on other sites

@Captain Sierra That's some golden feedback! :) I assume you're using CryoTanks, however? (This seems to be a very popular combination). The aerospike's thrust does not change to adjust to the (rather great) difference in wet mass when Mk-33 holds LFO vs LH2O. I could make this change but then you may end up with much less opportunity to use the filler wedges and their adapters/engine mounts, and this may upset its usability (through it's 3.75m adapter variant) with non-Mk33 parts.

Edited by JadeOfMaar
Link to comment
Share on other sites

3 hours ago, JadeOfMaar said:

I assume you're using CryoTanks, however?

I have cryotanks but the aerospike isn't patched to hydrolox, still an LFO engine. So I was launching with standard liquid fuel load. I don't think the configs mess with the LFO configuration but I could be wrong.

Link to comment
Share on other sites

1 hour ago, Captain Sierra said:

still an LFO engine

Hmm. Now I really wonder about that. I'm considering certain factors now that I really didn't when I contributed to configuring it. There should be a B9 module on it that lets you switch between LFO and LH2O but that *might* only be available for Classic Stock. I don't remember which is the case.

Link to comment
Share on other sites

6 hours ago, JadeOfMaar said:

There should be a B9 module on it that lets you switch between LFO and LH2O

No you're right, that is there. CryoTanks is patching the tanks to include LH2O configurations. AFAIK it shouldn't modify the default LFO configuration. The linear aerospike is not patched to LH2 burning, so I left the fuel load in the tanks at LFO. Here's the fuel load in editor. Do these numbers look correct versus not CT-patched?

Spoiler

kHFG3Wa.png

 

Link to comment
Share on other sites

TBH if players are using cryoengines then the KR-2200L and the fuel tanks should just use LH2/Oxidizer (Propellium/Oxidizer in Classic Stock) and not bother to switch between LFO and cryo. The mod was built to no require any dependencies at all, and hence run on LFO. The cryoengines patches are the one exception, and I've considered removing them altogether. For one, it has way too much propellant.

As for the cockpit, it has as much volume for propellant as the forward fuel tank does, and it is using less room than it actually has in order to match the aft tank. The IVA space does not take up 50% of the volume; if you look at the forward tank you'll see empty space up front. If anything, the cockpit takes up space in the probe core nose, which has plenty of extra room for exactly that purpose.

Link to comment
Share on other sites

  • 2 weeks later...

Hi! So I've downloaded this mod and installed it on 1.10.1 and, in-game inside the VAB and SPB all the parts work just fine apart from the nose probe core that goes on top of the cockpit section. When I select the part from the parts list, the build mode reacts as if I've just picked a part to attach so obviously the attach nodes appear. But, the part doesn't actually appear under my mouse.

As for my gamedata directory, I have ModuleManager 1.4.1 so it's up to date. If anyone has a solution to this then I'd appreciate the help :)

Link to comment
Share on other sites

Hi @Angel-125

I have a problem and I'm not sure what is causing it. I just let bob, bill and jeb into the cockpit and went into orbit, then I eva bill and re enter the cockpit..... no bill avatar ! the bill's inventory is showing up in the cockpit but his avatar is not showing up and I don't have any other way to let bill go eva ?!

 

Also another problem and I'm not sure if this problem is related to mk-33 or not, when i sent bill on eva, his rcs is not working at all on the jet pack !!!

Edited by Jiraiyah
Link to comment
Share on other sites

  • 1 month later...
On 12/18/2020 at 12:41 PM, Jiraiyah said:

Hi @Angel-125

I have a problem and I'm not sure what is causing it. I just let bob, bill and jeb into the cockpit and went into orbit, then I eva bill and re enter the cockpit..... no bill avatar ! the bill's inventory is showing up in the cockpit but his avatar is not showing up and I don't have any other way to let bill go eva ?!

 

Also another problem and I'm not sure if this problem is related to mk-33 or not, when i sent bill on eva, his rcs is not working at all on the jet pack !!!

I've not seen that issue. Make sure you install everything into the GameData/WildBlueIndustries/Mk-33 folder

1 hour ago, KIMCHI said:

I saw this has RF integration. Does this mean it will work with RO?

I've not tested this with RO.

Link to comment
Share on other sites

22 hours ago, Angel-125 said:

 

I've not tested this with RO.

Everything seems to work in RO since they are scaled in size. I created RP-1 patches for the parts adding them in the 2010's since this was a project cancelled in the 90's (assuming the entire project would be 20 years.) If anyone wants the parts they are in my RP-1 patch thread. If anyone has an suggestions or changes I should make to pricing let me know.

[1.8.1] Realistic Progression (RP-0/1) and Realism Overhaul Patches (On Going Project) - Add-on Releases - Kerbal Space Program Forums

Edited by KIMCHI
Link to comment
Share on other sites

  • 3 weeks later...
3 hours ago, 5cmPak38aufPzIISfl said:

Hello, i used this mod previously and it worked just fine, i recently reinstalled it and now the Aft Tank, Mk.33 Strongback, and the wing pieces don't spawn, i've tried going to different versions, pasting it in to the Directory folder with and without the WildBlueIndustries folder and im at a loss, Advice?

Sounds like an installation error. Try deleting your WBI folder and reinstalling.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...