Jump to content
  • 0

Updated AnimatedDecouplers?


TranceaddicT
 Share

Question

14 answers to this question

Recommended Posts

  • 0
On 6/17/2020 at 11:59 PM, TranceaddicT said:

UmbraSpaceIndustries/SoundingRockets

I don't think it causes probs NOT being there.

I'm just trying to eliminate errors in the log.

 

If there is a replacement for ...

@MODULE[ModuleDecouple]
{
	@name = ModuleAnimatedDecoupler
}

I'll take it.

 

If you are 100% positive that the errors in the log are linked to ModuleAnimatedDecoupler, did you report them? Is there a forum post I should know about? I certainly don't see a relevant issue for it on its Github page

Link to comment
Share on other sites

  • 0
6 hours ago, Starwaster said:

If you are 100% positive that the errors in the log are linked to ModuleAnimatedDecoupler, did you report them? Is there a forum post I should know about? I certainly don't see a relevant issue for it on its Github page

I didn't make a GitHub issue because this is a 1.9.1 install. Animated Decouplers stopped at 1.7, I figured it was abandoned.

I'll say I'm 100% positive that the errors in the log are linked to ModuleAnimatedDecoupler. 

1) It's not compatible with 1.9.1. So, I have to manual install.

2) Sounding Rockets is the ONLY mod I install that uses it.

3) When AD is not installed, I get the expect error letting me know the dll is missing.

4) When AD is installed, this happens ...

 

[LOG 20:09:26.397] Load(Assembly): AnimatedDecouplers/Plugins/AnimatedDecouplers
[LOG 20:09:26.397] AssemblyLoader: Loading assembly at C:\Games\Kerbal Space Program\KSPwin64-1.9.1\GameData\AnimatedDecouplers\Plugins\AnimatedDecouplers.dll
[ERR 20:09:26.408] Failed to load assembly C:\Games\Kerbal Space Program\KSPwin64-1.9.1\GameData\AnimatedDecouplers\Plugins\AnimatedDecouplers.dll:
System.BadImageFormatException: Format of the executable (.exe) or library (.dll) is invalid.
  at Mono.Cecil.PE.ImageReader.ReadImage () [0x00026] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.PE.ImageReader.ReadImageFrom (System.IO.Stream stream) [0x00007] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.IO.Stream stream, Mono.Cecil.ReaderParameters parameters) [0x00022] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.String fileName, Mono.Cecil.ReaderParameters parameters) [0x0000a] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.String fileName) [0x00007] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at AssemblyLoader.ScanForBadTypeRefs (System.String file) [0x00000] in <55ba45dc3a43403382024deac8dcd0be>:0 
  at AssemblyLoader.LoadExternalAssembly (System.String file) [0x00175] in <55ba45dc3a43403382024deac8dcd0be>:0 

[LOG 20:10:29.226] Applying update ModRocketSys/Patches/MRS_AD/@PART[NBLASshroud]:NEEDS[AnimatedDecouplers] to ModRocketSys/Parts/LAS/LASshroud/part.cfg/PART[NBLASshroud]

[LOG 20:10:44.889] Applying update UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_625]:NEEDS[AnimatedDecouplers] to UmbraSpaceIndustries/SoundingRockets/Parts/SR_PayloadFairing_625.cfg/PART[SR_PayloadFairing_625]
[LOG 20:10:44.894] Applying update UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_35]:NEEDS[AnimatedDecouplers] to UmbraSpaceIndustries/SoundingRockets/Parts/SR_PayloadFairing_35.cfg/PART[SR_PayloadFairing_35]

[LOG 20:13:41.590] Config(@PART[NBLASshroud]:NEEDS[AnimatedDecouplers]) ModRocketSys/Patches/MRS_AD/@PART[NBLASshroud]:NEEDS[AnimatedDecouplers]

[LOG 20:13:41.833] Config(@PART[SR_PayloadFairing_625]:NEEDS[AnimatedDecouplers]) UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_625]:NEEDS[AnimatedDecouplers]
[LOG 20:13:41.833] Config(@PART[SR_PayloadFairing_35]:NEEDS[AnimatedDecouplers]) UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_35]:NEEDS[AnimatedDecouplers]

I've created a issue.

Link to comment
Share on other sites

  • 0
19 hours ago, TranceaddicT said:

I didn't make a GitHub issue because this is a 1.9.1 install. Animated Decouplers stopped at 1.7, I figured it was abandoned.

I'll say I'm 100% positive that the errors in the log are linked to ModuleAnimatedDecoupler. 

1) It's not compatible with 1.9.1. So, I have to manual install.

2) Sounding Rockets is the ONLY mod I install that uses it.

3) When AD is not installed, I get the expect error letting me know the dll is missing.

4) When AD is installed, this happens ...

Spoiler



[LOG 20:09:26.397] Load(Assembly): AnimatedDecouplers/Plugins/AnimatedDecouplers
[LOG 20:09:26.397] AssemblyLoader: Loading assembly at C:\Games\Kerbal Space Program\KSPwin64-1.9.1\GameData\AnimatedDecouplers\Plugins\AnimatedDecouplers.dll
[ERR 20:09:26.408] Failed to load assembly C:\Games\Kerbal Space Program\KSPwin64-1.9.1\GameData\AnimatedDecouplers\Plugins\AnimatedDecouplers.dll:
System.BadImageFormatException: Format of the executable (.exe) or library (.dll) is invalid.
  at Mono.Cecil.PE.ImageReader.ReadImage () [0x00026] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.PE.ImageReader.ReadImageFrom (System.IO.Stream stream) [0x00007] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.IO.Stream stream, Mono.Cecil.ReaderParameters parameters) [0x00022] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.String fileName, Mono.Cecil.ReaderParameters parameters) [0x0000a] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at Mono.Cecil.ModuleDefinition.ReadModule (System.String fileName) [0x00007] in <7a890c320a104d46b8776d7dd2bc4e65>:0 
  at AssemblyLoader.ScanForBadTypeRefs (System.String file) [0x00000] in <55ba45dc3a43403382024deac8dcd0be>:0 
  at AssemblyLoader.LoadExternalAssembly (System.String file) [0x00175] in <55ba45dc3a43403382024deac8dcd0be>:0 

[LOG 20:10:29.226] Applying update ModRocketSys/Patches/MRS_AD/@PART[NBLASshroud]:NEEDS[AnimatedDecouplers] to ModRocketSys/Parts/LAS/LASshroud/part.cfg/PART[NBLASshroud]

[LOG 20:10:44.889] Applying update UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_625]:NEEDS[AnimatedDecouplers] to UmbraSpaceIndustries/SoundingRockets/Parts/SR_PayloadFairing_625.cfg/PART[SR_PayloadFairing_625]
[LOG 20:10:44.894] Applying update UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_35]:NEEDS[AnimatedDecouplers] to UmbraSpaceIndustries/SoundingRockets/Parts/SR_PayloadFairing_35.cfg/PART[SR_PayloadFairing_35]

[LOG 20:13:41.590] Config(@PART[NBLASshroud]:NEEDS[AnimatedDecouplers]) ModRocketSys/Patches/MRS_AD/@PART[NBLASshroud]:NEEDS[AnimatedDecouplers]

[LOG 20:13:41.833] Config(@PART[SR_PayloadFairing_625]:NEEDS[AnimatedDecouplers]) UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_625]:NEEDS[AnimatedDecouplers]
[LOG 20:13:41.833] Config(@PART[SR_PayloadFairing_35]:NEEDS[AnimatedDecouplers]) UmbraSpaceIndustries/SoundingRockets/SR_CargoBays/@PART[SR_PayloadFairing_35]:NEEDS[AnimatedDecouplers]


 

I've created a issue.

No, not abandoned, I'm just lazy about updating it because it's pretty resistant to KSP updates. I don't think I'm even having a problem with it in 1.9x

I'll take another look at it and see what's going on

Link to comment
Share on other sites

  • 0
On 6/18/2020 at 12:52 PM, linuxgurugamer said:

Are there any mods which still use it?

Yes, Corvus_CF and, based on a GitHub issue (eh, and the post above), Sounding Rockets and something called ModRocketSys.

I was just looking to see whether this mod needs a new maintainer, but looks like @Starwaster is still around :)

That said, if he wants some help I'm happy to pitch in considering I'm maintaining a dependant mod.

Link to comment
Share on other sites

  • 0
On 6/17/2020 at 8:52 PM, linuxgurugamer said:

Are there any mods which still use it?

H.G.R._Home grown rockets and S.D.H.I. Service module  Are the two most popular one's I can think of . But I am pretty sure their are at least about four or five more mods I've run across that are still using it ?

Link to comment
Share on other sites

  • 0
1 hour ago, micha said:

Like I said I'm happy to help Starwaster with it or take it over entirely.  But give him time to reply first, he said he'd look into it.

Hang on guys, I have tomorrow free for testing a rebuild from him.

Link to comment
Share on other sites

  • 0
On 6/22/2020 at 4:52 PM, TranceaddicT said:

Hang on guys, I have tomorrow free for testing a rebuild from him.

Doh! Didn't see this - I just recompiled this and made an unofficial release.  Oh well, guess not needed anymore.

Link to comment
Share on other sites

  • 0
6 hours ago, micha said:

Doh! Didn't see this - I just recompiled this and made an unofficial release.  Oh well, guess not needed anymore.

No it’s not, sorry but thanks anyway. 
 

I had a a 1.9 build already but my PSU woes made things chaotic. And we had a couple of older cats at our sanctuary pass within a few weeks of each other.

 I just have to assemble a release and put it up. 

Link to comment
Share on other sites

  • 0
3 hours ago, Starwaster said:

 I just have to assemble a release and put it up.

Cool :)

I'm sorry to hear about your personal issues - but private life always comes ahead of games.  Sorry to have jumped the gun!

On the upside, it seems there are many more mods using your plugin than you though!

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...