prestja

[1.9.1] Kopernicus Continued

Recommended Posts

2 hours ago, prestja said:

Hm, what planet pack? Any errors in the logs?

He's using -2, he probably has the OceanFX bug that -3 fixed.

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, prestja said:

Hm, what planet pack? Any errors in the logs?

Grannus Expansion Pack, planet Taranis.

I do see some errors in the logs but nothing that seems to be related to the ocean texture.

2 hours ago, R-T-B said:

He's using -2, he probably has the OceanFX bug that -3 fixed.

If that's the case, the problem may have already been fixed.  We should probably just wait and let me test it again in -3.  If the problem persists, I'll let you know.

(edit)  I see that -3 is now on GitHub.  The link in the OP still goes to -2.  I'm going to test it now.

(edit 2)  False alarm, works fine in 1.9.1-3.  Sorry to have bothered you.

 

Edited by OhioBob

Share this post


Link to post
Share on other sites

RSS  work for me on KSP 1.10 with this Kopernicus Continued. Thank you very much

Share this post


Link to post
Share on other sites
13 hours ago, R-T-B said:

He's using -2, he probably has the OceanFX bug that -3 fixed.

Is massively levitating scatters bug supposed to be fixed in 1.9.1-3? I`ve just caught it with GEP-Primary on 1.9.1

Share this post


Link to post
Share on other sites
3 hours ago, Hohmannson said:

Is massively levitating scatters bug supposed to be fixed in 1.9.1-3? I`ve just caught it with GEP-Primary on 1.9.1

It should be, yes.   I think that was only in release 1.

Share this post


Link to post
Share on other sites

@R-T-B Bug Report!

KSP Version 1.10 clean install

Mods: Kopernicus (multiple versions tried), ModularFlightIntegrator, ModuleManager, Hyperedit, RealExoplanets (link below)

 

Kopernicus will not load Real Exoplanets (REX) on any of the 1.10 versions. Versions tried: Dev110-release 3 as well as the github dev110 release. Also tried dev191 which didn't even try to load the pack. Oddly using Presja's 1.9.1-3 pre-release as well the build from your master branch it works. I realize they're releases for 1.9.1 but they still work on KSP 1.10 and REX loads/works. Here are the log files for each version tried (subfolders labeled with versions are inside the single zip file) https://drive.google.com/file/d/1mCgWZ8whjIvOm3nZoSGGHIby08xtZ2t1/view?usp=sharing

Share this post


Link to post
Share on other sites
Posted (edited)

The 1.10 release has a bug with systems with more than two gas giants, I am working on it.

1 hour ago, maxs139 said:

Oddly using Presja's 1.9.1-3 pre-release as well the build from your master branch it works.

Yeah, that's because it doesn't include my buggy gas giant work around (it prevents every gas giant from turning into a Jool appearance).  Thanks for the reports everyone.  As soon as I identify another way to disable Jool shaders on new gas giants, I will make another release for 1.10.

Edited by R-T-B

Share this post


Link to post
Share on other sites

Would allowing us to specify a material in the scaled space node be a good way to handle it? The default would be the lagacy shader so no additional info would be required and then if you want to use the new system, specify the new shader and then have a node inside the scaled space node where all the new shader's material properties can be set?

Thats, of course, if I'm understanding the implmentation correctly.

Share this post


Link to post
Share on other sites
Posted (edited)
29 minutes ago, Poodmund said:

Would allowing us to specify a material in the scaled space node be a good way to handle it? The default would be the lagacy shader so no additional info would be required and then if you want to use the new system, specify the new shader and then have a node inside the scaled space node where all the new shader's material properties can be set?

Thats, of course, if I'm understanding the implmentation correctly.

That's the end goal, really.  At the moment the code works more like "Look for a templated Jool, take away it's shaders at construction by rebuilding the body from scratch" and obviously that's not working correctly at the moment.  I hope to allow a full interface to control the Joolian shader system as well as opt for it eventually.  But the first fix will likely just remove Jool's shaders from templated worlds automatically.

Edited by R-T-B

Share this post


Link to post
Share on other sites
1 hour ago, Poodmund said:

Would allowing us to specify a material in the scaled space node be a good way to handle it? The default would be the lagacy shader so no additional info would be required and then if you want to use the new system, specify the new shader and then have a node inside the scaled space node where all the new shader's material properties can be set?

Thats, of course, if I'm understanding the implmentation correctly.

Absolutely, that way mod authors such as yourself could opt-in to the new Joolian shaders on a planet-by-planet basis. Is this something you're considering for OPM?

Share this post


Link to post
Share on other sites
Posted (edited)

I have 941 loaded in Ksp 1.10, my cfg is working well but I had to move its AFTER from [Kopernicus] to [XPCR]

I will update the number loaded when the game starts up fully again.

Also @prestja  you should add the kopernicus Wiki link: https://kopernicus.github.io/wiki/ and Kopernicus Discord: https://discord.gg/XmVp23s to the OP of the thread.

Edited by Shawn Kerman

Share this post


Link to post
Share on other sites

Hey @R-T-B I'm down to test out the build as well! I created the account just now though so I cant pm you either. Could you pm it to me as well? Thank you!!!

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, Shawn Kerman said:

I have 941 loaded in Ksp 1.10, my cfg is working well but I had to move its AFTER from [Kopernicus] to [XPCR]

I will update the number loaded when the game starts up fully again.

You were most helpful in diagnosing the issue with Joolian-templated (Gas Giant) bodies, btw.  I hope to have a fix pushed out tonight.

4 minutes ago, Minuense said:

Hey @R-T-B I'm down to test out the build as well! I created the account just now though so I cant pm you either. Could you pm it to me as well? Thank you!!!

I'll put you on the list.  You should receive a build this evening when next prerelease happens (the old one has a nasty bug with gas giants, don't worry about missing out on it).

Edited by R-T-B

Share this post


Link to post
Share on other sites

So all planets packs are loaded... and Every gas gaint I've seen is named Jool... that sounds like a major bug....

Share this post


Link to post
Share on other sites
14 minutes ago, Shawn Kerman said:

So all planets packs are loaded... and Every gas gaint I've seen is named Jool... that sounds like a major bug....

known bug with 1.10.  Please read posts above yours.

Share this post


Link to post
Share on other sites

Technically the the posts above mine talk about how jool's shader get transferred to all planets with a jool template and how the shader has been disabled. I posted "Every gas gaint has the same name" is because I haven't seen anyone comment about it yet.

Share this post


Link to post
Share on other sites

@R-T-B, I'm also happy to test 1.10 builds for you. I don't know much about C#, but perhaps I can still be of some help.

Thanks!

Share this post


Link to post
Share on other sites
8 hours ago, prestja said:

Absolutely, that way mod authors such as yourself could opt-in to the new Joolian shaders on a planet-by-planet basis. Is this something you're considering for OPM?

Potentially yes, but by implementing it the way I suggested (or similarly in the correct node location) keeps backwards compatibility with existing packs and also would follow convention with the implementation of new shaders like the triplanar terrain shader.

I would urge all new contributors to study the existing config syntax and structure, looking at the Kittopia stock body dumps and also looking at a range of the existing popular mods out there to get an understanding of how mods that use Kopernicus expect to be written with regards to their celestial body configs. It's a pain, not only, having, to fix bugs and get new feature implementation working but also considering third party mod dev usage but I think it's one that is still quite important to the makers of the Kopernicus packs to use Kopernicus' full potential.

Share this post


Link to post
Share on other sites

I don’t want to sound stupid but did the other Kopernicus made by Thomas p die or what I’m confuzzzled

Share this post


Link to post
Share on other sites
55 minutes ago, HansonKerman said:

I don’t want to sound stupid but did the other Kopernicus made by Thomas p die or what I’m confuzzzled

Thomas' Kopernicus still works and is the go to version up through KSP 1.8.1.  But that's where it ends.  For KSP 1.9.1 and newer, you're going to have to use Kopernicus Continued.

Share this post


Link to post
Share on other sites
7 hours ago, Poodmund said:

Potentially yes, but by implementing it the way I suggested (or similarly in the correct node location) keeps backwards compatibility with existing packs and also would follow convention with the implementation of new shaders like the triplanar terrain shader.

I would urge all new contributors to study the existing config syntax and structure, looking at the Kittopia stock body dumps and also looking at a range of the existing popular mods out there to get an understanding of how mods that use Kopernicus expect to be written with regards to their celestial body configs. It's a pain, not only, having, to fix bugs and get new feature implementation working but also considering third party mod dev usage but I think it's one that is still quite important to the makers of the Kopernicus packs to use Kopernicus' full potential.

That is exactly what is planned longterm.  For right now we are focusing on just getting a compatible loader going though, then we will focus on adding an interfacing method to work with the new shaders.

I'm pushing out a new build of 1.10 to testers now.  Should fix the Joolian name issue and other gas-giant issues, fingers crossed.

13 hours ago, Al2Me6 said:

@R-T-B, I'm also happy to test 1.10 builds for you. I don't know much about C#, but perhaps I can still be of some help.

Thanks!

Added to list.

Share this post


Link to post
Share on other sites

ive been experincing a bug, no matter what planetpack i use, no matter the mods i have installed, the game will load but i cant load my savegame

Share this post


Link to post
Share on other sites
5 hours ago, Not a Spy said:

ive been experincing a bug, no matter what planetpack i use, no matter the mods i have installed, the game will load but i cant load my savegame

Maybe something would be helpful in this situation, for the mod devs. Can you guess what it is?

Share this post


Link to post
Share on other sites

Thanks everyone for continuing this mod.  It's absolutely great and love seeing the community come together.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.