Jump to content

[1.11.x] CryoTanks: Liquid Hydrogen storage and management (Jan 13, 2021)


Recommended Posts

KSP 1.11.x  

CryoTanks [1.5.6] 
Last Updated January 13, 2021

This framework mod is oriented around providing storage solutions for LH2, which is not useful by itself but supports some of my other mods, namely CryoEngines, KerbalAtomics and Far Future Technologies. This thread is specifically for supporting it - previously it was a ghost-like mod only distributed in the other packages. As it doesn't do a lot by itself, it is in the Development forum. 

CryoTanks provides the following features. 

  • A fairly universal B9PartSwitch patch which allows most basic stock and modded LF/O tanks to switch between storing LF/O, LH2/O, LF, O and LH2. The balance for this depends on the patched tanks following standard KSP mass balance rules.
  • A new set of tanks in 1.25m, 2.5m, 3.75m, 5m and radial sizes for LH2 storage.
  • A plugin that causes LH2 to 'boil off' slowly unless a tank is actively cooled for a modest Electric Charge cost.

There is a fairly basic but functional set of documentation here. This can help you configure fuel tanks  if you want to customize things or if you want to activate advanced features. These include

  • Boiloff generating resources (e.g. LH2 boiling off to H2 gas)
  • Boiloff being scaled according to the shortwave and longwave fluxes affecting the craft. 

Frequently Asked Questions

Q: Will you add feature/part xxx?
A: The mod is feature complete and I am unlikely to do any more development.

Dependencies (Required)

  • Module Manager 
  • B9 Part Switch
  • Community Resource Pack
  • Dynamic Battery Storage

Licensing

  • All code and cfgs are distributed under the MIT License
  • All art assets (textures, models, animations) are distributed under an All Rights Reserved License.
  • All bundled mods are distributed under their own licenses.

Download Mirrors

  Primary (GitHub)

Issue Tracking and Source

Special Thanks 

A big hand to Fraz86, who basically wrote the original configs for fuel switching and balancing LH2 tanks :D.

If you appreciate this project, please consider contributing to my caffeine addiction! I really appreciate it, and also helps justify this time sink to my wife :wink:, which results directly in more models. btn_donate_SM.gif

Edited by Nertea
Link to post
Share on other sites
On 6/25/2020 at 10:41 PM, Incarnation of Chaos said:

Fantastic; i was wondering if you'd break this out into it's own thing. For no other reason than to make support and bug reports easier.

Yes I hat is basically the reason!

Link to post
Share on other sites
  • 1 month later...

Updated for KSP 1.10. Some changes:

  • Marked for KSP 1.10.x
  • Improved MFT compatibility (dlrk2)
  • Updated DynamicBatteryStorage to 2.1.7
  • Updated ModuleManager to 4.1.4
  • Updated B9PartSwitch to 2.17.0
Edited by Nertea
Link to post
Share on other sites
  • 1 month later...

Hello @Nertea I don't know if this should go here or into the Kerbal Atomics thread but whenever I try installing Kerbal Atomics it gives this error

KerbalAtomics 1:1.1.4 depends on CryoTanks OR KerbalAtomics-NTRsUseLF, which is not compatible with the currently installed version of KSP

This doesn't make sense as I'm running on 1.10.1. Should I manually install Cryo Tanks in this case?

Link to post
Share on other sites
3 hours ago, Exxon21 said:

Hello @Nertea I don't know if this should go here or into the Kerbal Atomics thread but whenever I try installing Kerbal Atomics it gives this error

KerbalAtomics 1:1.1.4 depends on CryoTanks OR KerbalAtomics-NTRsUseLF, which is not compatible with the currently installed version of KSP

This doesn't make sense as I'm running on 1.10.1. Should I manually install Cryo Tanks in this case?

@Exxon21, do you have a copy of your log file and screenshot of your Gamedata folder?  That is often helpful to diagnose the issue.

Link to post
Share on other sites
8 hours ago, Exxon21 said:

Hello @Nertea I don't know if this should go here or into the Kerbal Atomics thread but whenever I try installing Kerbal Atomics it gives this error

KerbalAtomics 1:1.1.4 depends on CryoTanks OR KerbalAtomics-NTRsUseLF, which is not compatible with the currently installed version of KSP

This doesn't make sense as I'm running on 1.10.1. Should I manually install Cryo Tanks in this case?

This has happened before because the metadata for the Community Resource Pack indicates that it is not compatible with newer KSP versions. I had a very quick look and it looks like the latest release version is not marked as compatible with 1.10 so the dependency chain will not resolve. Maybe @HebaruSan can comment but I think that's the issue.

Link to post
Share on other sites
Just now, Nertea said:

This has happened before because the metadata for the Community Resource Pack indicates that it is not compatible with newer KSP versions. I had a very quick look and it looks like the latest release version is not marked as compatible with 1.10 so the dependency chain will not resolve. Maybe @HebaruSan can comment but I think that's the issue.

Hi, https://github.com/BobPalmer/CommunityResourcePack/pull/249 broke CRP's versioning. @DasSkelett submitted https://github.com/BobPalmer/CommunityResourcePack/pull/252 to try to get it fixed, but @RoverDude just closed it instead. We're still trying to figure out why and what to do next.

Link to post
Share on other sites
1 minute ago, HebaruSan said:

Hi, https://github.com/BobPalmer/CommunityResourcePack/pull/249 broke CRP's versioning. @DasSkelett submitted https://github.com/BobPalmer/CommunityResourcePack/pull/252 to try to get it fixed, but @RoverDude just closed it instead. We're still trying to figure out why and what to do next.

This is because I had already done a fix that upped the max version to 1.99.99 :P

Link to post
Share on other sites
Just now, HebaruSan said:

No, that "fix" broke it, so the max version is now 1.8. Please read the text of https://github.com/BobPalmer/CommunityResourcePack/pull/252 , it is all explained there.

I read the text... and no idea why he's messing with the version vs the KSP version since the version number was moving up?  What exactly is wrong there that's breaking things?  regressing version numbers isn't a good solution

Link to post
Share on other sites
7 minutes ago, RoverDude said:

This is because I had already done a fix that upped the max version to 1.99.99 :P

But not for the current release. By bumping the version CKAN and AVC no longer consider the remote version file, because the VERSION property doesn't match anymore. So CKAN has gone back to 1.8.9 as max KSP version:
https://github.com/KSP-CKAN/CKAN-meta/commit/ccb01a95538d62c99145af0545fb4e5b19ad73ba

You have to either decrease the VERSION again, just like my PR did, or you have to do a new release. Either one, but not keep it as is.

Edited by DasSkelett
Link to post
Share on other sites
Just now, DasSkelett said:

 

But not for the current release. By bumping the version CKAN and AVC no longer consider the remote version file, because the VERSION property doesn't match anymore. So CKAN has gone back to 1.8.9 as max KSP version:
https://github.com/KSP-CKAN/CKAN-meta/commit/ccb01a95538d62c99145af0545fb4e5b19ad73ba

You have to either decrease the VERSION again, just like my PR did, or you have to do a new release. Either one, but not keep it as is.

New release it is then.

Link to post
Share on other sites
3 minutes ago, RoverDude said:

regressing version numbers isn't a good solution

It is when it's accurate; you're trying to indicate compatibility of the 1.3.0.0 release of CRP, so the VERSION property should say 1.3.0.0. Instead it was changed to 1.4.0.0 and then 1.4.1.0.

Link to post
Share on other sites
Just now, HebaruSan said:

It is when it's accurate; you're trying to indicate compatibility of the 1.3.0.0 release of CRP, so the VERSION property should say 1.3.0.0. Instead it was changed to 1.4.0.0 and then 1.4.1.0.

And you all caught me in the middle of doing releases anyway, so the 1.4.x version is in fact accurate.

 

There - release done.

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...

 

On 11/17/2020 at 12:49 AM, lookolookthefox said:

I do not seem to be able to view how much Ec/s i need to cool certain tanks. Any clue as to why? is this dependant on the Dynamic Battery Storage mod?

Sorry, need more information.Which tanks? How do you mean, view? In the part window? Somewhere else?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...