Jump to content
  • 0

Rover control help (WASD causing rotation as well as translation)


Question

I have a question about Rover controls.  Basically, whenever I use WASD to control the Rover, W not only drives the rover forward, but it also pitches it forward.  That makes control dificult on low gravity.  And if I press S, it not only reverses the wheels, but it also pitches me backwards.  

I've tried looking up some forum posts.  One suggests using IJKL, but none of those keys do anything (I checked and they are indeed mapped to translation controls).  Another post suggests switching to Docking Linear Mode.  I did that too but then WASD do nothing. 

So I'm wondering what I'm not understanding about my Rover controls and if I can find any help.

If it makes any difference, I built the Rover using the Cupola module as the root part in SPH, then loaded it into VAB and pointed it upwards, then attached rocket parts to the bottom.  So it's a rocket whose final stage is a rover, if that makes any sense.  Not sure if that is what is affecting the controls.

 

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1
7 hours ago, konokono said:

One suggests using IJKL, but none of those keys do anything (I checked and they are indeed mapped to translation controls). 

yxr241i.pngThat is strange.  If those keys show up in the relevant 'Settings' screen that you get from the main menu at game-start (shown at right) then they should operate the wheels just as well as WASD do. 

Probably something went wrong, so it might work if you recheck that the settings were stored correctly, and try again. 

If you prefer numeric keypad keys, you can select them on the same screen; maybe they will work for you.

Whether SAS is on or off, if the reaction wheels are active and have default settings, the WASD keys will rotate the ship.  You can turn the reaction wheels off if you like by right-clicking on the reaction wheel (or command pod that contains a reaction wheel) and turn it off or have the reaction wheel respond to [Edit: 'SAS Only' and not your keyboard input.]

7 hours ago, konokono said:

If it makes any difference, I built the Rover using the Cupola module

Oh, that might be the problem, if the round window on the Cupola is still pointing up when you use it for the rover. 
Rocket-style command pod have their 'forward' direction pointing up by default, so the "drive forward" command would by default activate any wheels that would move the craft toward where the top of the rocket would be, and you might not have any wheels that move the craft in that direction.

There is another option if you right-click on the Cupola to set a different control direction.

Edited by OHara
doh.
Link to post
Share on other sites
  • 1
12 hours ago, konokono said:

So I'm wondering what I'm not understanding about my Rover controls and if I can find any help.

As others have said (@N_Danger & @OHara), you have wheel controls mapped to the same keys as your reaction wheel rotation controls.  There are several options to deal with this:

  1. Set the reaction wheels to respond to 'SAS Only', as @Streetwind suggested.  This way, you can use stability assist to keep your rover somewhat level in case you drive off a rise or otherwise need some anti-flip control.
  2. Shut off the reaction wheels entirely.  Then it won't matter that the keys are double-mapped.  You can do this with action groups, if you like.
  3. Build a rover that doesn't have reaction wheels; the RoveMate probe core doesn't have any.
  4. Re-map your rover wheel controls so that they do not share keys with other controls.  I prefer to use 2-4-6-8 on the number pad, with 5 as a second brake control, but the translation controls I-J-K-L will also work if, for some reason, you do not already have them mapped as secondary wheel controls as is the default.  I prefer not to use the translation controls because for technical consistency, I expect forwards and backwards to be controlled by H-N, not I-K, but that's only a peculiarity of my preference.
  5. I suppose that you could technically remap your rotational controls instead, but no one ever seems to do this.
12 hours ago, konokono said:

If it makes any difference, I built the Rover using the Cupola module as the root part in SPH, then loaded it into VAB and pointed it upwards, then attached rocket parts to the bottom.  So it's a rocket whose final stage is a rover, if that makes any sense.  Not sure if that is what is affecting the controls.

That won't make any difference.  Assuming that you have an upgraded VAB (or are using Sandbox or Science mode), you can set action groups to toggle between reaction wheels and rover wheels so that you don't have to watch wheels spinning blindly in space while you're trying to fly it, but simply having rocket parts on your rover won't change the control scheme (after all, rockets whose final stages are rovers are the only way to get rovers to other planets--even docked rovers are part of the same vessel).

Good luck!

Link to post
Share on other sites
  • 0

If SAS is active wsad will have the reaction wheels  try to pitch or yaw at the same time as you move.

I always re-map the rover movement keys to 1,2,3 and 5 on my num pad for that reason.

You can turn off SAS if you comfortable with that.

Edited by N_Danger
Grammer
Link to post
Share on other sites
  • 0
1 hour ago, OHara said:

or have the reaction wheel respond to 'Pilot Only' and not SAS.

You want the opposite, actually. The reaction wheels should not respond to pilot input in order to fix the issue. So "SAS only" is the correct mode.

Link to post
Share on other sites
  • 0

Thanks for the advice.  Mapping the wheels control to separate keys helped.  Turning off reaction wheels also helps.

However, I did notice that initiating forward or reverse driving would *still* pitch the vehicle, even if all reaction wheels are turned off and using keys mapped only to the wheels.  The pitching is worst when starting from a stopped position.  Once the vehicle is in motion, the driving controls don't pitch the vehicle as much if at all.  Raising traction control on the wheels also stops the pitching.  So I'm starting to wonder if the unwanted pitching has to do with the physics and is therefore a flaw in my craft's design?  Attaching a picture of the vehicle for help

JrujF90.png

 

 

Edited by konokono
Link to post
Share on other sites
  • 0
1 hour ago, konokono said:

However, I did notice that initiating forward or reverse driving would *still* pitch the vehicle,

Have you ever done a wheely on a bicycle. Same thing. The wheel torque is pitching you.

I would just use the regular keys, set the wheels to SAS Only, and turn on the Stability control in the MechJeb rover window.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...